Statistics

254,885 members
132,627 posts
  • New
    robsimons78
    Newcomer - Level 1
    2021-04-28

    Hi, I've sent in a parts request for a new FireWire board for my Venice F16 mixer. Can some please come back to me? Would really appreciate getting this mixer working again

    CAS-446634-M4P1Z2 

    Many thanks

    0 74
    • robsimons78
      Dale_M I have asked the Spares Team to assist.
      • Apr 28
      • FireWire board F16
        robsimons78 Thank you. I have been contacted now. I guess before I order a new firewire card, I want to be sure it's not working 100%. I've tried on OSC High Sierra and Catalina, newest drivers, and terminal hack OK. Drivers appear fine, the FireWire lights are green, but no devices found. Do the FireWire lights need to be RED to indicate that it's faulty??
        • Apr 28
      • FireWire board F16
        DavidKnighton Hello robsimons78,
        From my experience, the LED does not change color. It is constantly illuminated during power on. The only true way to know if the firewire chip is gone is by interfacing with a firewire enabled computer running Windows 7 or Mac OS El Capitan or earlier. These are the latest known working and supported operating systems. Any other operating system is not officially supported or tested.
        • 1
        • ·
        • Apr 28
      • FireWire board F16
        robsimons78 Thanks, that's helpful. I have one more machine with a legacy OSX that I'll try. If that doesn't work then I suppose I have my answer Also, I know it's been pitched a few times before, but an updated Thunderbolt card for these mixers would be a godsend, thousands of Venice owners would jump all over it.
        • Apr 29
  • New
    Geoffwalker55
    Newcomer - Level 1
    2021-01-08

    Hi I have a midas f32 operating on windows7 using protools12 and a uad thunderbolt device somehow my pc aint seeing the mixer if i click on the midas icon i can see it anyone know how i a get rouind this issue please i would normaly take my rig to Parr Street Studios in Liverpool but thanks to covid this is not possible any help would be gratefullt welcomed

    Thank you

    Geoff

    read more...
    0 60
    • Geoffwalker55
      john0121 Hi Geoff, is this the firewire version or the USB version? Either way it would be best to fill out the tech support form via the Support button (top of page). A member of the team can then work through some troubleshooting with you. Thanks
      • Jan 10
  • New
    Janus
    Newcomer - Level 2
    2020-11-25

    Hi

    What is the normal repsonse time, when one submits a support ticket?.
    It's been over a week now.

    0 69
    • Janus
      Janus Also, would the Midas EPS1200 external PSU be suitable for a Venice F16 firewire mixer?
      • November 25, 2020
    • Janus
      DavidKnighton Hello Janus Jensen,
      Sorry to hear you case hasn't been answered. Can you tell me your case number please? It should begin with CAS-
      I'll get someone on it immediately. As for the PSU question, I would not recommend the EPS1200 for the Venice F mixer. That Power Supply was designed for the original Venice consoles, non Firewire non USB version.
      • November 25, 2020
      • New PSU
        Janus I just got the email reply i waited for.
        Thanks for the input regarding the EPS1200.
        • November 26, 2020
  • New
    thoward
    Newcomer - Level 1
    2021-05-14

    Hi
    I have a Midas Venice F32 where the power supply is making a whining noise and it is being induced in the audio busses.
    I raised a support ticket to see if a replacement PSU is available on 5th May but not had any response yet

    Ticket no CAS-450985-P9Z8V1

    Any pointers welcome

    read more...
    0 52
  • New
    matiflemita
    Newcomer - Level 1
    2020-11-10

    cuando quiero entrar a la ventana de registro de Midas, me lleva a una ventana de musictribe en cuyo listado de marcas
    a registrar no se encuentra Midas. Necesito registrar el producto antes de que vensa el plazo de 90 dias desde que la compre
    pero en la pagina no esta la posibilidad como menciono arriba. Como puedo hacer? Gracias desde ya

    read more...
    0 50
    • matiflemita
      KyleJohnson Hello Matias, Kyle here with Music Tribe. To register your product, click on the Support button at the top of this page and then select Product Registration.
      • November 10, 2020
  • New
    TurdFerguson19
    Newcomer - Level 1
    2021-01-24

    Hi everyone, I'm new to the forum but not to Midas, I have recently purchased a pristine Venice F32. The only issue is my channel #4 fader is missing ? at least the knob plus the slider, the body is still on the circuit board. Can someone point me in the right direction for a replacement fader plus the knob? 

    read more...
    0 119
    • TurdFerguson19
      Nigel67 Hi, please click on the support tab at the top of the page. In the new page that opens, scroll down, click on the spare parts tab and submit a ticket. One of my colleagues will then get back to you with pricing and availability. many thanks
      • Jan 24
  • New
    DiogoGregorio
    Newcomer - Level 1
    2021-09-12

    Good people!

    This is a long shot, lets see if anyone did or have any idea how to do this or if its possible at all.

    I have an XL4 installed in an OB van (yeah, I know) while it sounds pretty nice the dreaded Outboard Electronic module just give up on me.

    I lost the group routing capability, the aux routing is erratic and when you press 1 it turns on 13 also, our other random aux and turns off other random aux.

    All automation don't work, VCA, routing, and all kinds of momentary switches.

    My question is, is it possible to bypass the automation module, having access to the group and aux routing and not using the VCAs at all?!

    Cheers! 

     

     

     

    read more...
    0 9
    • DiogoGregorio
      Dale_M Hi there, as the XL4 is very old there is now very limited resource and support for it, however there is an excellent Facebook page with lots of Pro Users (many with XL4/H3 consoles) who are much better placed to advise you, I would suggest joining this group and adding your post, sorry we are unable to help any further: https://www.facebook.com/groups/1976275959349445
      • Sep 15
  • New
    Musiccc3000
    Newcomer - Level 1
    2021-02-09

    Im at the point of buying a Midas  Venice 16U; 

     

    The seller used it as an backup and said it turned off, then on then off (while being connected to a generator);

    I might be a easy fix or the unit might be bricked; the seller doesnt really care to invest a repair.

     

    Are parts still available and what could be a possible fix (theres no voltage on the internal PSU according to the seller)

    read more...
    0 78
  • New
    CPMixing
    Newcomer - Level 1
    2020-11-12

    Hi,

    Just yesterday I was doing some tests at my studio and decided to plug in the FW 400-800 cable from my Midas Venice F32, into my OWC TB2 Hub that has a FW 800 port. The computer would not recognize it, so I plugged directly into the iMac with a FW 800 to TB2 adapter. Same issue. I then tried on my Macbook Pro (early 2013 retina 15" with High Sierra), no device detected still. I then uninstalled the Midas drivers and re-installed, both on my iMac and Macbook. No change. I then tried shutting the computer down, then turning the Midas off and back on, then re-booting the computer. Still no device detected. I also tried all of these same things with a different cable, same issue.

    It's been a looong time since I tried the Midas as an interface and this was the result. We also have 2 Apollo 8's and since I almost never need more than 16 inputs, I don't bother to use the Midas as a Digital Interface, only to monitor and run HP mixes. Only thing I noticed as far as the FW card is concerned, is the FW 400 port is a little loose, but still makes a solid connection(from feel at least) with the cable. The leds still light up above the sample rate and clocking text.

    Do I need a new FW Card? Any other troubleshooting I could try? Any specs not mentioned are below. Thanks for the help!!

     

    Computer Specs

    21.5” iMac running Sierra OS Quad CORE i7 3.1GHz Processor 16GB RAM
    1TB SSD

    Interfaces-2x Apollo 8 Blackface 2nd Gen, Dual Core(Thunderbolt 2) -Midas Venice F32(FW 800)

    Thunderbolt Hub-OWC 12 Port Thunderbolt 2 Dock

    DAW-Pro Tools 12.6.0 

    read more...
    0 500
    • CPMixing
      DavidKnighton Hello Chris Pummill,
      Mac OS El Capitan is the latest OS that our firewire driver will support. I would suggest testing on an earlier OS, or if you have a Windows 7 machine with firewire, you can try that as well with the PC driver.
      • November 12, 2020
      • Midas Venice F32 FW Issues
        CPMixing Thanks David! Unfortunately, with our other DAWs and plugins, we can't go back OS-wise right now. It's a bit of a tricky setup because I record and mix out of the studio frequently, but we pay our bills by renting our space monthly to 10-15 different people. So any changes at all need to consider a large group of people. Worst case scenario, we just don't use the Midas as a digital interface anymore.

        Is there any way to tell if the FW card is working without reverting our computers to prior OS'?
        • November 12, 2020
      • Midas Venice F32 FW Issues
        CPMixing Also, I can't be 100% sure, but I believe I've used the Midas as an interface with the iMac and Sierra OS a few years ago with great success. Since we purchased our Apollos, I haven't bothered to use it, which is what led to the current confusion and troubleshooting. Nothing has changed on our iMac in YEARS because of potential compatibility issues and because its incredibly stable as-is.
        • November 12, 2020
    • CPMixing
      Dale_M Hi Chris, no not really as this is the only way to check the FW card is "seen" by the computer, you could try an old laptop running on an earlier Windows software but it's not guaranteed much past WIN 8 from memory, it def works on XP/Vista/Win 7/Win 8 and as my colleague David has stated on MAC up to El Capitan. It can be made to work with Sierra/High Sierra but these are unsupported workarounds, that said many users have had success -there was a KB article on it but the attachments are down at present. I think my suggestion with a laptop may be worth verifying if you can get hold of one as a starting point.
      • November 12, 2020
      • Midas Venice F32 FW Issues
        CPMixing Thanks Dale! Having read up on SIP and how it can help with newer OS's seeing the MIdas, is there any major downside to disabling it, even temporarily?
        • November 12, 2020
  • New
    mikerosen
    Newcomer - Level 1
    2021-07-20

    Hey,

    One of the channels on my Midas Venice F24 makes some ruffling noises sometimes when there is nothing connected to the input on that channel. Would appreciate it if anyone could help me with this!

     

    Thanks :)

    read more...
    0 46
    • mikerosen
      Dale_M This sounds like one of the op amps on that channel has failed, assuming you have tried a known good cable and mic from a neighbouring channel then it is likely to be faulty and require a repair, for assistance in this matter please go to the support tab above and select Service as your ticket type to inquire on a non warranty repair.
      • Jul 21
Go to page