Statistics

249,690 members
126,740 posts
  • gcvrsa
    Volunteer Moderator
    2020-06-12
    I heard there was a new firmware for the Mimiq, so today, I decided to go through my pedals and make sure everything was up to date. I have successfully updated the Mimiq and my SpectraComp, but when I attempted to follow the instructions to update the firmware in my Polytune 2, the pedal stopped working entirely. I can't get it to power on anymore, no matter what I do. I followed the instructions on the YouTube video. I plugged in the input jack, then plugged in the power, and the tuner booted up. I then held down the display button and plugged in the USB cable. Nothing seemed to happen, so I tried it again, and now the pedal doesn't seem to power up at all. Is there anything i can do to recover it? Update: SOLVED As it turns out, what happened here is that the pedal I was sold in not, in fact, a Polytune 2, it is a Polytune Classic, which someone sold to me as a Polytune 2 and shipped to me in a Polytune 2 box. The pedal wasn't dead, it was stuck in "boot mode", and by downloading the Polytune Classic, I was able to successfully update the firmware (which was actually already at the current version), and the pedal rebooted into its normal mode and is functioning properly. It took me a little while before I spotted the fact that the logo on the Polytune 2 is actually different to the logo on the Polytune Classic. I was a little worried when I bought this pedal, as it doesn't say "Polytune 2" on the front, but at the time I bought, I noted that the Polytune 2 doesn't actually say "Polytune 2" on it, it only says "Polytune". However, the logo on the Classic is left-aligned, and the logo on the Polytune 2 is centered, and that is the only apparent difference in appearance. I did not notice this when I first purchased this pedal, which I believe was over two years ago.
    read more...
    2 167
    • gcvrsa
      TC-Mike Good to hear you solved it. there should also be a FAQ about it in the FAQ section
      • June 13, 2020
    • gcvrsa
      leocoelhobass I have the same problem and I can't find the software to download, please help
      • July 30, 2020
    • gcvrsa
      gcvrsa It would appear that with the most recent update to the tc electronic website, the Polytune Classic software has been omitted. I suggest contacting tc electronic support directly, I'm sure they still have the software.
      • July 31, 2020
    • gcvrsa
      leocoelhobass I am Brazilian and do not speak English, to request support is very complicated, there is a lot of information on the form that I don’t have! help me
      • July 31, 2020
  • MrZurkon
    Newcomer - Level 1
    2020-09-14

    Hi, I have a polytune 2 mini that I got on the used market, it seems to work ok but when you click the footswitch it says BATT every 30 seconds or so, should I be worried?

    0 76
    • MrZurkon
      Nigel67 Hi, have never come across this fault before. As there is no battery inside, I am wondering whether the power supply is on the edge of working and not. I can only think that the software was copied over from its big brother and the batt message was not removed. Do you have another psu that you can try. it needs to be 9volts 100mA or more centre negative. Let me know how you get on.
      • September 14, 2020
      • Polytune2 mini BATT warning?
        MrZurkon Hi Nigel, thanks, I changed the power cable out and that seems to have cleared it.
        • 1
        • ·
        • September 14, 2020
  • MaxWhite
    Newcomer - Level 1
    2020-09-15

    Hi - do we know when Polytune Clip will be available again in the UK - I know there were some supplier probelms back in July?

    I need a new tuner and would rather wait to get what appears to be the best than settle for a lesser device if they will be available soon :-)

    Will there be both black and white models avaialble when they are back on sale?

    Many thanks!

    read more...
    1 53
    • MaxWhite
      MaxWhite I see some shops are indicating over 3 months expected wait, and others 4 or 5 weeks.
      • September 15, 2020
  • New
    dblbogy007
    Newcomer - Level 1
    2020-12-28

    Device wont come on with a battery or adapter.

    0 67
    • dblbogy007
      TC-Marcus Howdy William!
      Please be aware that the PolyTune line of pedals won't turn on unless you have an input jack inserted. This is to conserve power when pedal is unused (i.e. when there is no cable inserted).
      • December 28, 2020
  • New
    Boboji
    Newcomer - Level 2
    2020-10-29

    When I power my polytune clip on I get two arrows moving away from each other. No other function. Is there a reset to this???

    0 60
    • Boboji
      JoeRivers96 Hi Robert, unfortunately it sounds like there as an issue with your unit here. Please fill out a service request using the SUPPORT option at the top of this page.
      • October 30, 2020
  • New
    Chedmus
    Newcomer - Level 1
    2021-08-28

    Just purchased a TC Polytune 3

    Not arrived yet.

    To save me taking my pedal board appart to get acces to the power cables i'm considering using a battery with this.

    Does anybody know whether the Polytune draws power whilst connected - even when the unit is off?

    Whilst connected, how long will a standard alkaline battery last during constant use (true bypass mode)

    Cheers

     

    read more...
    0 19
    • Chedmus
      PedroRodrigues Hi Chedmus, please consider that the Polytune 3 will draw voltage even when off , it draws lower voltage but it does draw energy. Thank you
      • Aug 30
  • New
    kongo
    Newcomer - Level 1
    2021-09-17

    Hello,

    Can someone point me to the FAQ on how to get the Polytune out of boot mode? I tried to update the firmware, but it got stuck and now I can't unstick it. 

    I downloaded the "PolyTune_SWUPdater" and "setup" file, and followed all the instructions on the release notes page

    The issue seems to be that the SW Updater is designed to work in Windows XP, not Windows 10. I tried to run various compatability settings (like running the program in compatability mode for Win XP), but it doesn't let me run the SW Updater, so I can't update the firmware (and its now stuck in the boot mode).

    I read that you can run the SW Updater program from an old Windows XP computer and get it to work, but I really don't have any of those around, or know anyone who does.

    Can someone please help?

    read more...
    0 3
    • kongo
      NicJonesMT Hi Kongo.
      Could you please click Support at the top of the page, and submit a technical support ticket. From there we can then advise you further.
      • Fri at 5:20 AM
  • New
    oiamt
    Newcomer - Level 1
    2021-05-21

    I recently learned about sweetened guitar tuning (tuning each string a few cents flat to accoomodate for fretting chords etc for optimal intonation during play) and wonder if the Unitune can be used to do this (tune a string anywhere from 4 to 12 cents flat, varying by the string).

    I was able to do flat tuning with a Korg CA (essential for African instruments) but want a clip-on for guitar and am wondering which one to get. I prefer the Unitune otherwise, but am unsure about the tuning increments. It looks like a line of lights is an interval of some kind, so I wonder if it's 1 cent, or more than that, perhaps 5 cents?

    Thanks

    read more...
    0 45
  • AlanDavis
    Newcomer - Level 1
    2020-10-16

    I own a polytune clip (original silver color).  After more than 3 years, I am catching on that there is a problem with this unit.  I have an Acoustic (Taylor) guitar.

     

    1.  First of all, it is impossible to tune all strings together on a guitar.

    2. Tuning the A string, one often see's "F" when it is in tune.

     

    I like the tuner, use it in preference to any other for it's accuracy, but the functionality is somehow lacking.  It certainly is not all it's cracked up to be in the manual, etc.  

     

    I thought I would buy another to find out whether this is a real problem, or something of my own usage.   I now see a "Polytune Clip Black" on the market.  Didn't see them before.  Unfortunately it is nearly impossible to find one online---most sites say it is back ordered.  Amazon has them, but at an elevated price, indicating it may be gouging in response to a supply issue. 

    Any ideas about these issues?  

    read more...
    0 75
    • AlanDavis
      PedroRodrigues Hi Alan, thank you for your contact, can you please state if the issue that you mention on your Polytune Clip happens since you acquire the tuner or the issue is being happening more recently? Regarding your second question, please adress the information request to the respective reseller, as we do not have access to any stock information for any third party company such as resellers or distributors. As a manufacturer we do not sell directly to end users and and we have no information of any issues with distributors for any unit. Thank you
      • October 16, 2020
  • New
    Loner
    Contributor - Level 2
    2021-02-16

    I just obtained a PolyTune Clip Black, and need a quick sanity check: The instructions say that it turns off automatically after 5 minutes, but I assumed that this meant it would turn off after 5 minutes of disuse. Mine turns off after 5 minutes, even if I'm actively using it. Is this normal?

    read more...
    0 38
    • Loner
      WilliamR Hello Loner, This function would be normal. It does turn off after five minutes regardless if you are playing or not.
      • Feb 16
Go to page