Statistics

254,567 members
132,268 posts
  • bucknodules
    Newcomer - Level 1
    2020-08-11

    Does anyone know how to change the X-Touch One's shuttle wheel resolution? I'm using Studio One but I'm guessing changing resolution is similar for all DAWs. It's default is a 1 bar increment. I'm guessing there has to be a way to easily (besides changing the sysex message) increment length to 1/4 note, 1/8 note, seconds, etc.

    Thank you for your help...

    read more...
    0 65
    • bucknodules
      DavidKnighton Hi bucknodules. I would suspect this setting would be within Studio One, as the controller is simply spitting out messages, and the DAW is translating those messages. I would double up and check the Presonus forums to see if this has already been answered on their site. This link seems to have some guidance on the topic.

      https://forums.presonus.com/viewtopic.php?t=21678&p=118856
      • August 12, 2020
  • New
    killerart666
    Newcomer - Level 1
    2020-11-16

    I'm owning a X32 Rack, a X Touch and using this with Reaper.
    So my question, i have been able to connect all so that I can control Reaper with the X Touch and also control my X32.
    But finally i would also like to see X32 mix on my second screen of my mac.
    Can i use the TP-Link TL-SG105E to connect all together?
    So Cat 5 from X Touch to TP-Link, Cat 5 from X32 to TP-Link and also Cat 5 from TP-Link to Mac ?

    read more...
    0 73
    • killerart666
      RexBeckett Hi Vandamme, yes you can use an Ehernet switch to connect all the units on a single network. You would need to set each device to have a fixed (static) IP address in the same subnet. Alternatively you could use a router with the DHCP Server enabled. This would allow dynamic (DHCP issued) IP addresses.
      • November 16, 2020
      • A quick question ...
        killerart666 Hey , tried it this morning, and it works like a charm.
        Super thx for helping me out
        • November 17, 2020
  • New
    lightspur13
    Newcomer - Level 1
    2020-12-31

    When I put my X-Touch in Mackie Mode, it works fine but when I switch it over to HUI, I get nothing. I noticed that when it is in HUI mode, the scribble scripts are completely blank, no line through the center. Is there a way to do a full factory reset or am I missing something? This used to work but just stopped.

     

    Thanks

    read more...
    0 80
    • lightspur13
      DaveMorrison I suppose you could reload the most recent firmware (via MIDI).
      • December 31, 2020
      • X-Touch HUI mode not functioning.
        lightspur13 That was my first thought so I upgraded the firmware from 1.15 to 1.21 to no avail.
        • Dec 31
  • New
    RichSallnow
    Contributor - Level 2
    2021-04-04

    This is driving me nuts! Since yesterday whenever I press the record button on my X-Touch, it mutes the track on Logic Pro X. It seems like the record and mute buttons seem to have linked themselves!. I've tried unplugging all midi devices, rebooting the Mac, re-installing the 1.21 firmware, but it's still happending. Any ideas?

    read more...
    0 61
    • RichSallnow
      DaveMorrison If you haven't customized any of the buttons (or functions), go to the "Logic Pro": Control Surfaces : Setup... menu. Then delete the Mackie Control icon.
      • Apr 4
    • RichSallnow
      ChrisJanton Have you tried installing the 1.15 firmware again? From what I could see there's no reason to update to firmware 1.21.
      • Apr 5
  • BrokeHustlerz
    Newcomer - Level 1
    2020-07-16
    cant find editing software
    0 62
  • New
    Wyshwood
    Contributor - Level 1
    2021-06-24

    Many of us that use sample libraries to create tunes need a simple, reliable 2 fader usb midi cc# controller for expression and volume.  There just aren't any sensibly priced options out there, but thousands demand it.  Just check out the Spitfire audio channel to see how many would bite your hand off for a 2 x 100mm throw like this https://www.youtube.com/watch?v=RheLEzsxUvs

    read more...
    0 64
  • New
    SpockAndStepR
    Newcomer - Level 1
    2021-01-29

    can someone send me the Controller addresses for the Behringer Odyssey? I've been trying to automate some parameters in my DAW and I haven't been able to find the controller addresses in the manual.

    0 55
    • SpockAndStepR
      DavidKnighton Hello Spock,
      I'm not certain you can automate parameters on the Odyssey. It's completely analog workflow, no digital controls. What exactly are you hoping to automate with this synth?
      • Jan 29
      • Behringer Odyssey Controller addresses
        SpockAndStepR the filter frequency. I was watching a tutorial on how to route midi from FL studio to my analog synthesizer, (it worked) and while I was watching it, it said that I could "control" any parameter of an analog synth by finding out the Controller addresses... if my initial post was worded kinda weird, here's a link to the video:
        https://youtu.be/xRRaeCw7P2Y?t=111
        • Jan 29
  • New
    Brettwilliams53
    Newcomer - Level 1
    2021-06-08

    I'm looking for a control surface that controls both MIDI CC movements, such as expression, vibrato and volume on a virtual instrument (Like Spitfire's BBC CORE or Opus Composer Cloud), as well as mix control, so the faders control the main mix in my DAW? (LOGIC PRO) Not at the same time mind you, but like in two separate modes; Midi and Mix modes.

    Does the X-Touch do that? I can't seem to find a definitive answer?

    read more...
    0 37
    • Brettwilliams53
      NicJonesMT Hi BrettWilliams53.
      Based on the above it sounds like the X-Touch Compact would be what you are looking for.

      The XT Compact has a Windows (Only) Editor that will allow you to manually configure what PC/CC messages are sent by each control on the unit. There is also a MC mode built in to allow you to quickly and easily configure with your DAW.
      • Jun 8
  • asharp
    Newcomer - Level 1
    2020-11-17

    Hi,

    I'm trying to send a MIDI message to the Behringer X-Touch Mini (firmware ver 1.08) so that a button can change its state to Blinking rather than just on/off.

    If I send a velocity of 0, then the LED is off, a velocity of 1 then the LED is on, but as far as I could understand from the documentation a velocity of 2 should make the button LED blink.  I can't appear to get this last part to work.  It appears that any velocity from 1-127 only keeps the LED on.

    Any thoughts on where I might be going wrong on this?

     

    update:

    Problem solved, was sending the midi output to the wrong location.  For button 1 (G#-2) I should have been sending the signal to Ch 0, Note 0x00 with a velocity of 2 in order to get the button G#-2 to blink.

    read more...
    0 77
  • New
    ebosseck
    Newcomer - Level 1
    2021-04-20

    Hello,

    While working on a programm in order to be able to use the Behringer X-Touch Compact remotely with OBS, I noticed that when remote controling the button LEDs, the LED will not turn on if I send the message [145, 0, 1] (Note On, Channel 1, Note no. 0, velocity 1), as it should according to the quick start guide. On the other hand, when I send [145, 0, 2] (Note On, Channel 1, Note no. 0, velocity 2), the LED turns on, as it should according to the manual for velocity = 1. I was able to witness the same off-by-one error for setting the LED to blink.

    Is there a off-by-one error in the user guide or am I missing something ?

    I am using firmware 1.12 (according to X-TOUCH Editor 1.21), using the factory preset for standard midi operation. I send MIDI messages using a python wrapper for rtmidi on Windows 10.

    Greetings,

    ebosseck

    read more...
    0 69
Go to page