Statistics

294,529 members
177,634 posts
  • New
    killerart666
    Newcomer - Level 1
    2020-11-16

    I'm owning a X32 Rack, a X Touch and using this with Reaper.
    So my question, i have been able to connect all so that I can control Reaper with the X Touch and also control my X32.
    But finally i would also like to see X32 mix on my second screen of my mac.
    Can i use the TP-Link TL-SG105E to connect all together?
    So Cat 5 from X Touch to TP-Link, Cat 5 from X32 to TP-Link and also Cat 5 from TP-Link to Mac ?

    read more...
    0 77
    • killerart666
      RexBeckett Hi Vandamme, yes you can use an Ehernet switch to connect all the units on a single network. You would need to set each device to have a fixed (static) IP address in the same subnet. Alternatively you could use a router with the DHCP Server enabled. This would allow dynamic (DHCP issued) IP addresses.
      • November 16, 2020
      • A quick question ...
        killerart666 Hey , tried it this morning, and it works like a charm.
        Super thx for helping me out
        • November 17, 2020
  • New
    lightspur13
    Newcomer - Level 1
    2020-12-31

    When I put my X-Touch in Mackie Mode, it works fine but when I switch it over to HUI, I get nothing. I noticed that when it is in HUI mode, the scribble scripts are completely blank, no line through the center. Is there a way to do a full factory reset or am I missing something? This used to work but just stopped.

     

    Thanks

    read more...
    0 86
    • lightspur13
      DaveMorrison I suppose you could reload the most recent firmware (via MIDI).
      • December 31, 2020
      • X-Touch HUI mode not functioning.
        lightspur13 That was my first thought so I upgraded the firmware from 1.15 to 1.21 to no avail.
        • December 31, 2020
  • New
    RichSallnow
    Contributor - Level 2
    2021-04-04

    This is driving me nuts! Since yesterday whenever I press the record button on my X-Touch, it mutes the track on Logic Pro X. It seems like the record and mute buttons seem to have linked themselves!. I've tried unplugging all midi devices, rebooting the Mac, re-installing the 1.21 firmware, but it's still happending. Any ideas?

    read more...
    0 64
    • RichSallnow
      DaveMorrison If you haven't customized any of the buttons (or functions), go to the "Logic Pro": Control Surfaces : Setup... menu. Then delete the Mackie Control icon.
      • April 4, 2021
    • RichSallnow
      ChrisJanton Have you tried installing the 1.15 firmware again? From what I could see there's no reason to update to firmware 1.21.
      • April 5, 2021
  • BrokeHustlerz
    Newcomer - Level 1
    2020-07-16
    cant find editing software
    0 69
  • New
    Wyshwood
    Contributor - Level 1
    2021-06-24

    Many of us that use sample libraries to create tunes need a simple, reliable 2 fader usb midi cc# controller for expression and volume.  There just aren't any sensibly priced options out there, but thousands demand it.  Just check out the Spitfire audio channel to see how many would bite your hand off for a 2 x 100mm throw like this https://www.youtube.com/watch?v=RheLEzsxUvs

    read more...
    0 74
  • New
    dalejason
    Newcomer - Level 1
    2021-12-17

    Hi

    In Sept I tore down my studio for a major upgrade / redesign and I have only just completed re-fitting the furniture, cables and equipment.

    I have also upgraded the studio computer to a Dell G5 5505 Laptop. Upon connecting my X-touch, I now find that it is not detected at all by the computer. It lights up the LED on the big round jogger and the backlights on the screen light up but nothing else.

    It was working fine on my old Dell Lattitude E6330 in september.

    I can hear it connect to the computer when turned on (windows makes a sound) but it is not recognised by the X-touch editor or in Ableton. It has been safely stored and has not been turned on Since Sept, so I am not sure what the problem could be. Can anyone suggest anything I can try ?  I do not have another computer to try at the moment.

     

    Device name DESKTOP-1I3G9MG
    Processor AMD Ryzen 7 4800H with Radeon Graphics 2.90 GHz
    Installed RAM 16.0 GB (15.4 GB usable)
    Device ID 52605D1C-AC81-438C-9713-DE6D96D67AE2
    Product ID 00325-96763-21628-AAOEM
    System type 64-bit operating system, x64-based processor
    Pen and touch No pen or touch input is available for this display

    read more...
    0 35
    • dalejason
      DaveMorrison The X-touch needs the newest firmware to successfully connect to Ryzen based computers. You have to upgrade using a non-ryzen computer. Ver 1.22 https://www.behringer.com/product.html?modelCode=P0B1X
      • December 17, 2021
      • X-Touch Not Recognised Dell G5 AMD Ryzen 7 4800H with Radeon Graphics 2.90 GHz
        dalejason Ah.. ok, I did not know this, It is on FW V1.15 at the moment. I can borrow a laptop from a friend and try this. Thank you for posting, much appreciated.
        • December 19, 2021
      • X-Touch Not Recognised Dell G5 AMD Ryzen 7 4800H with Radeon Graphics 2.90 GHz
        simmonds01 Supposedly the Ryzen problem was fixed in 1.21 (according to it's release note) - no release notes in 1.22 so no idea what they are upgrading.
        • Jan 20
  • New
    SpockAndStepR
    Newcomer - Level 1
    2021-01-29

    can someone send me the Controller addresses for the Behringer Odyssey? I've been trying to automate some parameters in my DAW and I haven't been able to find the controller addresses in the manual.

    0 64
    • SpockAndStepR
      DavidKnighton Hello Spock,
      I'm not certain you can automate parameters on the Odyssey. It's completely analog workflow, no digital controls. What exactly are you hoping to automate with this synth?
      • January 29, 2021
      • Behringer Odyssey Controller addresses
        SpockAndStepR the filter frequency. I was watching a tutorial on how to route midi from FL studio to my analog synthesizer, (it worked) and while I was watching it, it said that I could "control" any parameter of an analog synth by finding out the Controller addresses... if my initial post was worded kinda weird, here's a link to the video:
        https://youtu.be/xRRaeCw7P2Y?t=111
        • January 29, 2021
  • New
    Brettwilliams53
    Newcomer - Level 1
    2021-06-08

    I'm looking for a control surface that controls both MIDI CC movements, such as expression, vibrato and volume on a virtual instrument (Like Spitfire's BBC CORE or Opus Composer Cloud), as well as mix control, so the faders control the main mix in my DAW? (LOGIC PRO) Not at the same time mind you, but like in two separate modes; Midi and Mix modes.

    Does the X-Touch do that? I can't seem to find a definitive answer?

    read more...
    0 45
    • Brettwilliams53
      NicJonesMT Hi BrettWilliams53.
      Based on the above it sounds like the X-Touch Compact would be what you are looking for.

      The XT Compact has a Windows (Only) Editor that will allow you to manually configure what PC/CC messages are sent by each control on the unit. There is also a MC mode built in to allow you to quickly and easily configure with your DAW.
      • June 8, 2021
  • New
    strober8
    Newcomer - Level 1
    2022-01-22

    After the firmware update 1.21, the X-TOUCH mini displays stopped showing any values. It is also impossible to select the connection protocol during the initial setup of the X-TOUCH (HUI or MCU) and setup brightness of displays. Returning the firmware to 1.15 and also updating to 1.22 does not give any result. I use TAC along with logic pro, macos monterey.

    Support does not give any advice, asks for video updates and other questions? how did you update, which cables did you use during the update, did you try different usb ports, etc.

    Anybody have some problems? Have ane ideas? 

    read more...
    0 35
    • strober8
      JTRACKER I guess this is the norm for this "support" forum - by this I mean no answers. Is there a "readme" document somewhere which states what updates are "expected" from the 1.21 to 1.22 change?
      • Feb 8
  • asharp
    Newcomer - Level 1
    2020-11-17

    Hi,

    I'm trying to send a MIDI message to the Behringer X-Touch Mini (firmware ver 1.08) so that a button can change its state to Blinking rather than just on/off.

    If I send a velocity of 0, then the LED is off, a velocity of 1 then the LED is on, but as far as I could understand from the documentation a velocity of 2 should make the button LED blink.  I can't appear to get this last part to work.  It appears that any velocity from 1-127 only keeps the LED on.

    Any thoughts on where I might be going wrong on this?

     

    update:

    Problem solved, was sending the midi output to the wrong location.  For button 1 (G#-2) I should have been sending the signal to Ch 0, Note 0x00 with a velocity of 2 in order to get the button G#-2 to blink.

    read more...
    0 220
Go to page