Statistics

294,530 members
177,635 posts
  • New
    ebosseck
    Newcomer - Level 1
    2021-04-20

    Hello,

    While working on a programm in order to be able to use the Behringer X-Touch Compact remotely with OBS, I noticed that when remote controling the button LEDs, the LED will not turn on if I send the message [145, 0, 1] (Note On, Channel 1, Note no. 0, velocity 1), as it should according to the quick start guide. On the other hand, when I send [145, 0, 2] (Note On, Channel 1, Note no. 0, velocity 2), the LED turns on, as it should according to the manual for velocity = 1. I was able to witness the same off-by-one error for setting the LED to blink.

    Is there a off-by-one error in the user guide or am I missing something ?

    I am using firmware 1.12 (according to X-TOUCH Editor 1.21), using the factory preset for standard midi operation. I send MIDI messages using a python wrapper for rtmidi on Windows 10.

    Greetings,

    ebosseck

    read more...
    0 89
  • New
    ebosseck
    Newcomer - Level 1
    2021-04-20

    Hi all,

    I noticed that it seems like there is no MIDI signal generated when changing layers using the layer buttons on the controler.
    Is there a way to either detect layer changes caused by the layer buttons on the controler (before another MIDI message unique to the new layer is send), or set feedback (like letting the LED of a button blink or setting the led ring behaviour) based on the active layer ?

    This would be useful in order to give visual feedback to the user on states of functions which might get changed externally (e.g. on another controler or in a GUI), if the same physical control has different functions (and therefore different states) on different layers of the controler.

    I am using firmware 1.12 (according to X-TOUCH Editor 1.21), using the factory preset for standard midi operation. I send and recieve MIDI messages using a python wrapper for rtmidi on Windows 10.

    Greetings,
    ebosseck

    read more...
    0 75
    • ebosseck
      PedroRodrigues Hi ebosseck to configure the button layers on the X-TOUCH have you tried to perform the following MIDI implementation :

      The Layer A and Layer B files assign the controls on the X-TOUCH to MIDI Commands
      Default layer files are provided on the product resources disk, or you can customize your own.

      Please note the layer files must match the map file that you load in DashBoard.
      Connect the X-TOUCH to the server.
      Launch the X-TOUCH Editor application that came with your controller.
      Click the GLOBAL tab.
      Click LOAD in the PRESETS ON COMPUTER area and click Yes.
      Select the X-TOUCH-LayerA####.bin file and click Open.
      Wait for the file to be loaded and click Close on the success dialog box.
      Click Dump A in the TO HARDWARE area.
      Click Yes to start the upload and Close on the success dialog box.
      Repeat these steps to load the X-TOUCH-LayerB####.bin file and click Dump B. In the case of this not working please submit an assistance request so we can assit you with more tools by following the link below :https://community.musictribe.com/pages/create-new-ticket?type=Technical%20Support&brand=Behringer . Thank you
      • April 21, 2021
  • New
    AcrobatStar
    Newcomer - Level 1
    2021-04-04

    Hi My Xtouch is not working .

    I upgraded to the latest firmware 1.21.   1.04

     

    Showing looking for i.p adresss.

    Is there a reset for this product

    0 93
    • AcrobatStar
      DaveMorrison Changing modes is a type of reset. It looks like your Xtouch is waiting for a IP address to be sent from a DHCP server. What mode are you in? Reloading 1.21 or Downgrading to 1.15 would be another option.
      • April 4, 2021
  • New
    jguitarz13
    Newcomer - Level 1
    2022-04-05

    Don't shoot the noob, but i recently added an XTouch-One to my setup. i run Reaper and the unit works fine I'm able to do everything I want with it however, The issue is when i play a track the audio coming out of my monitors is not in sync with the curser. i have to reboot my interface then it's fine for a a pass or two. if i stop to do any editing it goes out of sync. When it is working, the audio will randomly start to crackle and distort. I lowered the buffer rate from 512 to 256 didn't help. Maybe it should go lower to 128 not sure. 

    By the way this all goes away when i unhook the XTouch. I have no audio issues whatsoever unless i hook up the controller. 

    I have a windows system with 32gb of ram and my interface is a Tascam US-1641 I know its an older unit but it always worked with no problems. 

    Any sugestions would greatly be appreciated

    read more...
    0 20
    • jguitarz13
      NicJonesMT Hi Jguitarz13.
      I've not heard of this happening before.
      Would it be possible for you to submit a tech support ticket? Please click support at the top of the page and then scroll down to the Tech support option.
      If you coould provide as much information on your setup as possible this would be extremely helpful (For example, all devices being used, USB ports (2.0/3.0), tested with a different machine, tested with a blank project with just a click, Changed project settings (Buffer and sample rate)).
      • Apr 6
  • New
    JohanHansson
    Contributor - Level 1
    2021-12-17

    Just found that new firmware (1.10) is available for the X-Touch One, but can't find any info at all about what's new or what has been fixed. 

    Anyone? 

     

     

     

     

    2 230
    • JohanHansson
      MattKay Ditto for standard X-Touch 1.22, also recently released without a change log. I'd love to know what changed before attempting an update.
      • December 22, 2021
    • JohanHansson
      PaulJones

      What gives here? Any information on firmware 1.10? I upgraded it last night and it behaved totally differently in Reaper. I then downgraded to 1.04.

      • Jan 5
  • New
    Mumbojumbo70
    Newcomer - Level 1
    2021-01-01

    Would any body know if the Behringer Motor 61 Keyboard controller will work as a controller with Garageband on an iMac desktop, please?

    0 73
    • Mumbojumbo70
      DaveMorrison It should give you basic MIDI functionality because they are both USB class compliant. MC mode won't work because Garageband doesn't have that feature (Logic Pro does).
      • January 2, 2021
      • Behringer Motor 61 compatabiliity
        Mumbojumbo70 Thanks very much Dave. That's pretty much what I thought. I'll try running in midi mode and see if I can assign controls that way.
        • January 2, 2021
  • New
    barcslay
    Newcomer - Level 1
    2021-09-18

    Hey guys! I recently added an x-touch compact to my setup for Logic Pro X - I've had success using it, but I'd really like to be able to use rotary encoders 9-16 when in in plugin control mode. Is there a way I can do this? In the manual it says that turn is not assigned - so is there a way to activate and assign them? 

    read more...
    0 18
  • New
    MartyAtias
    Contributor - Level 2
    2021-10-28

    My X-touch with FW 1.21 works well controlling an X32 over a local network connection. And I can control an off-premises X32 remotely with the X-Edit software.

    Now I need the X-Touch to talk with X-Edit, which should work in MC /USB mode. However while the faders work, the button mapping is all over the place making it unusable. This happens in MC/USB mode even with a local X32.

    Has anyone here been able to get this to work?

    Thanks

    read more...
    0 17
  • New
    WilbertLichtenb
    Contributor - Level 2
    2021-06-25

    Why can't xtouch extender hookup to x32 rack with ethernet, 

    Xtouch can. Why did Behringer  not add that to the latest firmware upgrade?

    0 36,685
  • TheEngraver
    Newcomer - Level 1
    2020-10-02

    Hello. I am interested in purchasing a Behringer X-Touch One or X-Touch Compact. But I absolutely need to know one thing. Is it possible, in both models, to map the Faders so that they become midi controllers, instead of volume controllers? That is, can I assign a midi controller, such as CC1 (modwheel) or CC11 (expression), etc. to the Fader of the X-touch One and those of the Compact? I work with Cubase Pro 9.5 and 10.5. Thanks a lot.

    read more...
    0 788
    • TheEngraver
      leah Hello @TheEngraver ,

      If you're looking for customizable controls, you'll want to use either the X-TOUCH COMPACT or X-TOUCH MINI. Both of these devices are compatible with our X-TOUCH Editor software. The software will allow you to customize the assigned CC and PC messages that each button/fader/encoder will send out to your DAW.

      The X-TOUCH, X-TOUCH ONE, and X-TOUCH EXTENDER are not customizable and are compatible with MCU, HUI, and XCTRL protocols.

      X-TOUCH COMPACT - https://www.behringer.com/behringer/product?modelCode=P0B3L
      X-TOUCH MINI - https://www.behringer.com/behringer/product?modelCode=P0B3M

      Hope this helps!
      • October 2, 2020
      • X-touch One and Compact mapping fader
        TheEngraver Ouff.....i was hoping on the One.... Ok, many thanks! :-)
        • 1
        • ·
        • October 2, 2020
      • X-touch One and Compact mapping fader
        TheEngraver Hi Leah. So, I've been looking for products similar to X-Touch One, but none of them have the ability to map single fader to drive MIDI CCs. So I looked for products similar to the X-Touch Compact. I had found a couple, especially one (from a company I will not mention) that from the description, from the operating manual, and from the videos on youtube, allowed to configure the 9 faders in the way I need. But then several recent comments on the videos reported complaints from users that they couldn't do it. I literally collided with the technical support of this company, which showed incompetence, lack of seriousness, and unfairness, since they do not mention the fact that with the recent firmware updates, the software to map the commands no longer allows this thing. So I decided to send them to hell and only consider the X-Touch Compact. But I have to be sure to spend money having the product that meets my needs, so I ask you: can you confirm that with the Compact I can configure the faders to control all the MIDI CCs and not just the volume (in Cubase Pro 9.5 and 10.5)? Are there any problems with the latest firmware updates in this regard? And above all (since it is a product that is now a few years old), is the release of a new version of the Compact planned in a more or less short time? Thanks a lot.
        • October 15, 2020
      • X-touch One and Compact mapping fader
        TheEngraver Hi Leah. Could I please have an answer? Thanks a lot.
        • October 21, 2020
Go to page