Statistics

268,282 members
147,852 posts
  • New
    bobbyval
    Newcomer - Level 1
    2021-03-08

    THis control surface had been working seamlessly with Presonus Studio One 5 on my Macbook Pro running Mac Os Mojave. I recently purchased a Mac Mini 2018, which came with Mac Os Big Sur already installed. I have since reconnected all of my audio and midi hardware to the Mac Mini and come to find that the Xtouch Compact is no longer responding in Studio One 5. Presonus states that the issue is with Behringer and that many third party developers are having a challenging time with Big Sur compatiblity. Has anyone else seen this issue with the Xtouch Compact and Mac Os Big Sur?

    read more...
    0 89
    • bobbyval
      PedroRodrigues Hi bobbyval, please consider that when it comes to implement any of our units on MacOS11 / Big Sur, consider that, at this moment none of our units is compatible and when interfaced with this OSX version will lead to issues. and my not work.
      However, USB audio/MIDI function of our products is fully USB 2.0 compliant and should keep working under CoreAudio as before.
      • March 9, 2021
    • bobbyval
      bobbyval I have an update to this thread and issue! It is not a Behringer Xtouch problem and Big Sur, Mac Mini, etc! It is a Presonus Studio One 5 and their support of Big Sur issue, even though they have continued to deny it! Here is how I have come to this conclusion. In an attempt to reproduce the non-responsive Xtouch Compact on my system, I took the liberty of downloading Cubase 11 (which I already have a license for ) and installed it on this computer. After a few clicks in the studio setup dialog, the Xtouch Compact came to life with all faders and lights active! I wasted so much time with Presonus and them telling me quite convincingly that it was Behringer's problem.
      • March 23, 2021
  • New
    Olenga
    Newcomer - Level 2
    2021-04-09

    Hello. Is it possible to use X-touch Extender with X-touch One?

    1 68
    • Olenga
      PedroRodrigues Hi Olenga please consider that the X-TOUCH EXTENDER was designed to work and an extension of the X-TOUCH and the X-TOUCH ONE was designed to work as one fader control to offer a smaller solution to control your DAW, never the less it may be possible to implement both unit considering that you may have duplicated functionalities on each. To assist you on this matter please check this video guide present on the link below https://youtu.be/mQn0abPzrGk?t=76
      • April 26, 2021
  • New
    Ashleykeyte
    Newcomer - Level 1
    2021-08-01

    Hello!

     

    I have recently purchased a Xtouch Universal control surface. 

     

    I have managed to link the device to Cubase using Mackie controls and assign tools to the function buttons. There are issues with the transport, global view, automation and utilty buttons not doing as written. The buttons themselves show a MIDI input level when pressed. 

    I have updated the controller to the 1.21 firmware.

     

    Please help!!

     

    read more...
    0 36
    • Ashleykeyte
      DaveMorrison The X-Touch is a Mackie Control clone. Your best resource is the Cubase forums. Pretend the XTouch is a Mackie control unit and learn what a real MCU would do. Then do that to the X-Touch.
      • August 1, 2021
  • New
    JBG7
    Newcomer - Level 1
    2021-12-04

    Does anyone know how to do a factory reset on X-Touch One?

    0 13
    • JBG7
      Nigel67 Hi JBG7. There is no factory reset for the X Touch One. I can only suggest trying to upgrade the firmware again and if that does not fix your issue it could well be hardware related. I would advise then submitting a Technical Support ticket and a colleague will be able to help you further. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Technical Support tab and submit a ticket. Many thanks
      • December 4, 2021
  • New
    DovGoldman
    Newcomer - Level 1
    2021-06-30

    Hi,

    My X Touch arrived yesterday. Incredible device!

    I've succeeded in connecting it to Cubasis on my iPad (via Bluetooth Midi) and the XR18 (via Ethernet RTP Midi). 

    X Touch is running firmware 1.21  

    There doesn't seem to be a way to configure Ethernet for Xctl and Midi for DAW control. I have to turn off rhe X Touch and use either MC/Midi or Xctl/Network. 

    Am I missing something?

     

    Thanks,

    Dov

     

    read more...
    0 61
  • New
    praingeard
    Newcomer - Level 1
    2020-11-22

    Hi,

    I've just puchaged a X-Touch one and pluged it in my Asus Zephyrus G14 ZEPHYRUS-G14-GA401IU-110T.

    It's an AMD Ryzen 7 4800HS on Windows 10.

    The USB driver crashes with an error code 10.

     

    I'v seen the incompatibility in a post and a workaround for the X-Touch with the ethernet connection.

    But it does not work for the X-Touch One (no ethernet).

     

    This incompatibility is old and ther is a lot of AMD pcs out there.

    Is there some workaround ?

    It there some info on a fix release or work in progress ?

     

    Thanks for your help !

    read more...
    0 66
  • New
    AyobamiIsrael
    Newcomer - Level 1
    2021-08-18

    Hi guys, I worked on my XTouch with Daw (Magic Samplitude) some weeks ago, everything was fine. But I wanted to start a mix now and discovered that the scribble scrip, channel meter, timer (SMPTE) screen not working. Faders and other buttons worked.... every means of getting it working failed. What could have been the problem and likely solution pls?

    read more...
    0 39
    • AyobamiIsrael
      Dale_M Can you advise if the scribble strip works in normal operation outside of the DAW? Are you saying this is a hardware fault?
      • August 18, 2021
  • frank999
    Newcomer - Level 1
    2020-10-06

    how I can properly set X-TOUCH ONE on Reason 11?

    it looks not working properly, I can't move through different channels and have quickly access to volume fader control 

    0 50
  • New
    gregory6d
    Newcomer - Level 1
    2022-01-12

    Is there any option to have custom user layer on X-Touch with a X-Air mixer like in iPad remote application. Fader 1-2 Input 1-2, fader 3-4 maybe FX returns and so on? Any plans for it? It would be really great feature for X-Touch

    0 10
    • gregory6d
      KyleJohnson Hello, Kyle here with Music Tribe. No, this is not possible. You can rearrange your input channels by changing the input sources in the software, but it would not be practical for FX returns.
      • Jan 12
  • New
    mattkuto
    Newcomer - Level 1
    2021-01-06

    I recently purchased an X-Touch. It is on backorder and has not shipped yet. I had heard that the X-Touch does not work with the new Mac M1 Silicon computers. Does anyone know if it does or doesn't work? I will cancel my order and wait if it's not supported yet. If it makes a difference I use Logic in Rosetta mode. I had heard that there was a firmware update but don't know where to find it or how to install it. Any help is appreciated, thank you.

    read more...
    0 77
    • mattkuto
      PedroRodrigues Hi mattkuto,please consider that new Macs with Apple M1 (ARM-based) processors are not yet officially supported. Audio or control issues with M1 are purely Apple‘s domain or DAW related, as our devices are class compliant and do not need drivers under Mac OS. Thank you
      • January 21, 2021
      • Behringer X-Touch
        mattkuto Pedro, thank you for your reply. I actually have since received the X-Touch and am pleased to say that if you install the latest firmware update, it works fine!
        • 1
        • ·
        • January 21, 2021
Go to page