Statistics

267,754 members
147,251 posts
  • New
    Fred9002
    Newcomer - Level 1
    2021-06-03

    I have buy a beautiful used G-System an I feel very happy.

    In order to make the most of the possibilities offered by this system, I'm trying to update the old version of the firmware (V 1.02) to a  V3.0 and then to the V4.02 next.

    Unfortunately, when I connect the G-System to my PC with the USB cable, the system is not recognized:

    "device not found".

    How can I solve this problem?

    Thank you in advance for your reply

    read more...
    0 53
  • New
    bomei
    Newcomer - Level 1
    2021-01-26

    Hi, I loaded Mac Firmware fror Ditto + from TC Electronic site.

    It will not install saying "not a verified developer"

    what can I do to use the Firmware? I understand it is needed to import/export soundfiles from/to the Ditto +

     

    thanks!

    read more...
    0 115
    • bomei
      WilliamR Hello Bomei, William from music tribe here. Open a Mac app from an unidentified developer
      If you try to open an app that isn’t registered with Apple by an identified developer, you get a warning dialog.
      This doesn’t necessarily mean that something’s wrong with the app. For example, some apps were written before developer ID registration began. However, the app has not been reviewed, and macOS can’t check whether the app has been modified or broken since it was released.

      .

      To override your security settings and open the app anyway follow these steps:

      In the Finder on your Mac, locate the app you want to open.

      Don’t use Launchpad to do this. Launchpad doesn’t allow you to access the shortcut menu.

      Control-click the app icon, then choose Open from the shortcut menu.

      Click Open.

      The app is saved as an exception to your security settings, and you can open it in the future by double-clicking it just as you can any registered app.

      Note: You can also grant an exception for a blocked app by clicking the Open Anyway button in the General pane of Security & Privacy preferences. This button is available for about an hour after you try to open the app.
      • January 26, 2021
  • New
    DuaneWilson
    Newcomer - Level 1
    2021-07-06

    New member here, bought a plethora over a year ago when they first came out. I've never been able to update it, not once has it ever worked. Before I get rid of it I thought I would try here. I use an older mac book pro. Everything seems to work, the toneprint downloads and the plethora shows up on the screen. I download the firmware ok and it seems to drag and drop over the plethora with no issues. So when I power down and then power back up, nothing happens, the plethora just turns on as normal, no flashing update and when I go to ck the firmware it never changes from the original. 

    I thought well maybe this computer is too old (2013) so I did all of that on my wife's new mac desktop, this time when I dounloaded the firmware a screen came up and said unable to expand plethora x5 1 1 43.bin it is in an unsupported format so that didn't go too well. 

    I did a full reset and then tried again, no luck there either.

    No tuner, no looper. I'm out unless this gets fixed, any help is appreciated.

    read more...
    0 34
    • DuaneWilson
      Dale_M Can I ask that you raise a Support ticket above and select Technical so we can assist you?
      • July 6, 2021
  • New
    RickyMarshallKirkpatrick
    Newcomer - Level 1
    2021-08-24

    I've had my ND-1 for a long time.The delay knob has gotten super loose as far as the delay time adjustment goes.It still locks in the delay time when I move the knob to the 12 o'clock. I was wondereing where I can get it repaired. Thanks!

    0 23
    • RickyMarshallKirkpatrick
      WilliamR Hello, William from musictribe here. Please click the support link at the top of the page and create a service ticket. Someone will contact you ASAP to arrange this for you.
      • August 24, 2021
  • stribo1
    Contributor - Level 1
    2019-11-10

    Hi there. I play trumpet and saxophone in a band and was wondering if this was possible.... can I run my trumpet through the stereo input with a switch on the stage mic (toggle on and off when not playing), and run my sax through the mono input with also a switch to toggle on and off when not in use?

    Also, is the stereo signal for the 'trumpet' going to send to the board half the output strength of the mono signal? I hope this is possible - that would be really cool. As I'm sure you're aware the gain of the trumpet compared to the saxophone is significantly different hence the need to run both channels seperately into the board. 

    Any help would be greatly appreciated. Thanks very much. 

     

    read more...
    0 94
  • dubbeljoe
    Newcomer - Level 2
    2020-05-27

    Hi all,

    I just got a TCE M350 dual effect processor and it is lovely.

    Only problem I have is the software.

    How do I get a serial number for this free downloadable software?

    And why can I download it from the TCE website and there is no instruction how to get it working?

    Any ideas?

    thanks,

    William

    read more...
    1 89
  • New
    cubidj
    Newcomer - Level 1
    2021-03-31

    Hi, there's some digital effect rack similar to the D-Two Multi_tap Rhythm Delay?

    https://www.tcelectronic.com/product.html?modelCode=P0CJ6

    Thanx

    Rob

    0 73
  • ak4ray
    Newcomer - Level 2
    2020-09-29

    Viscous Vibe!

    The Plethora is awesome but it needs a univibe model real bad ;-)

    Thanks for a great product.

     

    1 68
    • ak4ray
      Nigel67 Hi Ray, many thanks for your feedback regarding future enhancement for the X5. I will pass this on to the TC design team for discussion and implementation.
      • September 28, 2020
    • ak4ray
      TC-Rasmus We're already working on getting it in there - please be patient ;)
      • September 29, 2020
      • Plethora X5 Effect request
        ak4ray Awesome, thank you all for the great products and all your hard work!
        • 1
        • ·
        • September 29, 2020
  • mingus
    Contributor - Level 2
    2019-04-20

    as title...
    Replaced HD to ssd on 2012 Mini.  installed, uninstalled, reinstalled new and old drivers, unit starts with the TC lights but 'device not found'.  I went through this years ago too but forget how I fixed it.

    0 166
    • mingus
      mingus

      forgot to add....using lightning bolt to 1394 adapter.  Been using this for years.

      • April 20, 2019
    • mingus
      TC-Claus

      Hi mingus,


      What macOS are You running ? and You have the latest version of TC Near Software ?


      All the best from


      Claus

      • August 12, 2019
  • ar
    Contributor - Level 1
    2020-01-29

    The tc2240 is no longer in production,cannot seem to get any sense out of custmer support..I need a mains transformer for it as it was switched on at 110v while the wall voltage is 220,can anybody help..long shot i know..........

    0 64
Go to page