• New
    DeejayRaulin
    Newcomer - Level 1
    2020-11-07

    Please I need help finding a new top speaker for my turbosound ip500 because it was dropped and it broke need a new replacement for it 

    1 54
    • DeejayRaulin
      RexBeckett Hi Raul, I suggest that you open a Care ticket for this. At the top of this page, click Support and then select Parts. Make sure that you enter all required (*) data before clicking Submit. The Care team will respond by email.
      • November 7, 2020
  • CarlJames
    Contributor - Level 2
    2020-07-26

    We inherited the use of some ip82 and we have also purchased some in order to

    balance the system and keep the systems intact. Used as std. upper-mid unit.

    The overall impression is a good compromise of enclosure, woofer, crossover and horn 

    dispersion, but not the tweeter which is a disappointment when compared to the rest

    of the system. We therefore have to use DSP correction files in our loudspeaker management

    adapted to various venues in order to correct for this. Otherwise, it measures reasonable,

    but sound harsh, no distinctive upper end etc. When will this unit be upgraded?

     

    read more...
    0 53
    • CarlJames
      AlexLane Hi Carl. I will forward to the relevant people. I can't give an estimate as to when updates may come but any feedback is welcome and listened to! :)
      • July 27, 2020
  • Apgilbert2
    Newcomer - Level 1
    2020-07-31

    Hey,

    Does anyone know if you can turn the reverb on the IP3000 manually instead of using the iPhone app? I went through the menu on the sub and didn't see any options to turn effects on. Maybe I'm overlooking something ?

    Thanks

    Andrew

    read more...
    0 53
    • Apgilbert2
      AlexLane I am sure this is possible, but don't have a unit to find the exact button sequence right now. Let me see if I can find out for you!
      • July 31, 2020
    • Apgilbert2
      AlexLane I feel like this is somewhere on the Process -> Input menu...
      • July 31, 2020
    • Apgilbert2
      Apgilbert2 Thanks, Alexander....I did go through the menu but didn't see. I read the instructions and it says that you can do it manually or with the app...I will check the speaker out tonight - maybe I overlooked it.
      • July 31, 2020
    • Apgilbert2
      Apgilbert2 If anyone else knows how to turn the effects on, feel free let me know what I should be looking for. Any help is appreciated!
      • July 31, 2020
  • New
    IvanAmadoFuentes
    Newcomer - Level 1
    2021-08-03

    Looking for a replacement mother board, turbosound audio was dropping, now making no noise at all, but turns on. I've called and contacted! Pls help.

    0 53
    • IvanAmadoFuentes
      Dale_M Hi there I think I have found your support request ticket on CAS-476138-V9H3R1 -I will reply to you shortly.
      • Aug 3
  • Rhapsody
    Newcomer - Level 1
    2020-09-30

    PLEASE HELP

    I own Rhapsody Music in Mankato Minn. I Sold a customer an ip1000 Turbo sound speaker system 5/26/2018. I understand it has a 10 year wrnty so I am reaching out to you to determine how to get it repaired.  I checked all connections and cables.. Top works fine but NO LOWS. I checked the low speaker itself and spkr is fine so it must be in the circuit board / amp/crossover.

    I could repair it here if I can get parts from you or I can ship it to you . If I ship it to you -do you need the entire cabinet or just the circuit board ??

    Thank you 

    Howard Mock

    Rhapsody Music

    326 Madison Ave.

    Mankato, Minn.

    507-387-2562

     

     

    read more...
    0 52
    • Rhapsody
      WilliamR Hello Howard, Please click the support link above and create a service ticket, and someone will get back to you ASAP.,
      • September 30, 2020
  • New
    Darell108
    Newcomer - Level 1
    2021-08-08

    Hi

     

    I have logged tickets with the parts team but i never get any response via email. Is there an alternative method to contact them as I am in desparate need for some replacement tweeters.

     

    Thanks

    0 51
    • Darell108
      Turbosound Hi Darell108, I'm deeply sorry for the inconvenience. Could you please send me the Case ID so we can follow up with our support/service team?

      Thank you for your patience.

      - Diego
      • Aug 8
    • Darell108
      Darell108 Hi Case number is CAS-474703-Q5G5T1 and CAS-466372-L3X4L3
      • Aug 10
  • Rhapsody
    Newcomer - Level 1
    2020-10-15

    I have an ip1000 pa system . The sub woofer is not reproducing any lows. I checked the sub speakers - OK..

    The mid/hi pack is ok .. It is definatley the sub. If you can send me the circuit board , I can replace it here.

    0 51
    • Rhapsody
      Nigel67 Hi Howard. We can definitely help you with the repair, but we need you to submit a service request ticket. One of my colleagues will then be able to advise you how we go about repairing your unit. If you can go to the Support tab at the top of the page and submit a service request ticket. Many thanks
      • October 15, 2020
  • New
    Lubtennapel
    Newcomer - Level 1
    2021-06-10

    Hi! I'm pretty new to this tribe, so maybe you guys can help me out here. My setup is 6x the Berlin 123, 8x the NuQ 118B-AN and I want to configure an array for outside somewhere next month. I tried to set it up in EASE, but there are no GLL files availible for the 118B-AN and the Berlin GLL files do not work in EASE 3. Does somebody has a solution. I want to configer the subs in the right way and I'm not certain about setting up an End-fire setup with the Bandpass Subs.

    read more...
    0 51
    • Lubtennapel
      DavidKnighton Hello Lubtennapel,
      The Berlin files are only licensed for EASE 2. They will not open in any other version of EASE. As for the NuQ118B-AN, we likely never licensed the product for use with EASE because it's not a line array element, rather it's a simple stand alone sub. The Berlin subs are going to be arrayable, and are also going to be a better match with the Berlin tops, so that would be my recommendation.
      • Jun 10
  • JonSelin
    Newcomer - Level 2
    2020-07-29

    One great feature of the iQ series is the Ultranet input.  However, if I run my iQ8 speakers via Ultranet and then want to send signal to my subwoofers - they do not seem to have an analog output for that. Given all of the DSP & connection options built in - I'd like to see this option in a Firmware update.  It's handy to be able to run a long distance with CAT5e cables alone - rather than needing to also run XLRs just for subs. (I'm aware that I can buy iQ15B or iQ18B subs and resolve it, but that's not in the budget.) 

    read more...
    0 50
    • JonSelin
      Paul_Vannatto This has been asked for a few times before. The answer has always been that it is not possible with the current DSP.
      • July 29, 2020
  • New
    Dnrbnsn2
    Newcomer - Level 1
    2021-07-28

     I blew a woofer in my iq-12, how do I go about getting a replacement?

    0 49
    • Dnrbnsn2
      DavidKnighton Hello Dnrbnsn2,
      For replacement parts, please click on the SUPPORT tab at the top of the page and submit a Spare Parts request.
      • Jul 28
Go to page