Statistics

268,279 members
147,848 posts
  • New
    AndriusLau
    Newcomer - Level 1
    2021-07-20

    Hey eveyone, my CP1A -12 volts rail stopped working because of my own fault. Do anyone have the scheme so I could try to fix it myself? 
    thanks in advance!

    Andrius.

    0 57
    • AndriusLau
      KyleJohnson Hello, Kyle here with Music Tribe. Please contact our Service team for further assistance with this issue. Click on Support, and then on Service Request to submit a case.
      • July 20, 2021
  • New
    Robertdude
    Newcomer - Level 1
    2021-03-05

    I bought a used v22 bugera. It's missing the logo plate word. Where do I find some of those.

    0 56
    • Robertdude
      ChrisEdwards1 Hi Roberdude, if not already done so please open a parts request ticket and a member of the parts team will be able to assist further on this. To do this go to support at the top of the page and scroll down to the Parts section.
      • March 4, 2021
  • New
    OlofSöderlind
    Newcomer - Level 1
    2020-11-13

    Hi !

    I can´t seem to find a program for my Behringer AX6240Z amplifier so I can go in by USB and adjust settings.

    The first download are not to be found anymore.

    There must be a way /another program to go into the AX !?

    So frustrating , I hope someone can help me. 

    Thanks

    read more...
    0 55
  • New
    Gheorghe17
    Newcomer - Level 1
    2021-04-05

    Hello,

    just got a used Lab Gruppen IP450, love this amp but the face plate ha some scratches.I need a new one and I was wondering if I can still find this kind of spare part ?

    Thank you in advance and hope for your positive reply.

    GD

    read more...
    0 55
    • Gheorghe17
      Nigel67 Hi Gheorghe, Please contact our spares team and they will be able to advise you availability and pricing. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Spares tab and submit a ticket. Many thanks
      • April 5, 2021
  • New
    MalkumGison
    Contributor - Level 2
    2020-11-19

    Question When I use the CD input using either my phone or my Ipod Touch, volume levels full up on the device and the amp the level is really low. Example, phone or Ipod Touch at full level and the amp full level. If I have the vocal channel at 4 and the guitar input at 5 or 6 the play back track is so low it is much below the other levels. The tracks are very hot tracks so it is not the track level. Is this normal or is there a problem with the amp? Any way to up the level or over ride it? 

    Question 2, Can the Microphone channel inputs (XLR/1/4) be used at the same time and not cancel out eachother? 

    read more...
    0 55
  • New
    Aqaba5
    Newcomer - Level 1
    2021-07-09

    I live near Bath uk. Where can I get a begringer amp repaired? I used Music Group Innovation in Kidderminster previously, but they don't appear to be in operation.

    thanks

    andrew

    0 54
    • Aqaba5
      DavidKnighton Hello Aqaba5,
      For any/all service requests you must submit an inquiry via the SUPPORT tab at the top of the page.
      • July 9, 2021
  • New
    scottydoodah
    Newcomer - Level 1
    2020-11-10

    how long is it taking to get somebody to reply to a service request?

    is anybody actually processing them and getting people the info of where to send something for repair?

    I've got a dead amp and need to get it in to a repair shop ASAP and nobdy is reposnding to the service request online and the local music tribe repair shop is not answering the phones

    I can literally drive it in a drop it off, but I'm assuming they have to issue an RMA first as it is under warranty being only a few months old

    read more...
    0 54
  • New
    ntinajero74
    Newcomer - Level 1
    2021-07-13

    I need help connecting my Bugera V22 Infinium to a new PS1 Power Soak I just got. The diagrams are not helping from Bugera. Does anyone have any instructions or steps to help with that?

    0 53
    • ntinajero74
      WilliamR Hello, William from musictribe here. If you are just using the internal speaker of the V22, then all you need to do is unplug the speaker cable on the back of the combo and plug it into the 8 OHM out of the PS1. Then, Get a 1/4 inch speaker cable, (not a guitar cable) and go from the speaker out of the v22 into the speaker in of the ps1. Then you should be good to go.
      • July 13, 2021
  • New
    mgraao
    Contributor - Level 2
    2021-05-11

    Greeetings!

    I would like to say it tis a pleasure to return, but not the case. Amp went poof Saturday night. Submitted support ticket, received response today. This amp is 5 years old and the support tells me that Sweetwater (people purchased from 5 years ago) will fix the problem under warranty!  I hate people who never take 2 seconds to actually read what I have sent.

     

    Can anyone please assist me with this. Thank you for your time.

     

     
     
    read more...
    0 53
    • mgraao
      DavidKnighton Hello mgraao,
      If the amp was purchased over 5 years ago, I would presume it to be out of warranty altogether. The longest warranty available for the product is 3 years with registration. You will likely need to send to an authorized service center as non warranty. I'll look into your case if I can find the ticket, but could you post the case number to be safe?
      • May 11, 2021
    • mgraao
      DavidKnighton Hello mgraao,
      I found your case and I'm very sorry to say I'm not very impressed at your profane response to our support agent. This constitutes verbal abuse. You should never speak to someone like that if they are trying to help you. If you are not satisfied with your initial response, you can convey your disdain in a professional and non-abusive manner.
      • May 11, 2021
  • New
    hiswkf
    Newcomer - Level 1
    2021-06-23

    Good morning, I was wondering if it was possible to convert an older LGFP14K from US mains to EU mains? If so, what would that entail?

    0 52
    • hiswkf
      DavidKnighton Hello hiswkf,
      Check the voltage spec on the rear panel near the mains input. If it does not specify operation up to 230V, then I would say not possible, at least not without some involved modifications.
      • June 23, 2021
Go to page