Statistics

294,534 members
177,639 posts
  • New
    tet024
    Newcomer - Level 1
    2021-09-05

    Good Morning, 

    I purchased 2 x iNuke DSP and I would like to hook them up to a DIY Home Theater Speaker.  The Idea is to use the Xover on the iNuke rather then building a passive crossover. My Question is:- Is it possible to have the woofers on Channel A with a 2 Ohm Impedance then the Tweeter @ 8ohm on Channel B ? Would that cause any issues ? Or effect Sound Output? 

     

    Regards,

    Etienne

     

    read more...
    0 33
  • New
    Parky58
    Newcomer - Level 1
    2021-08-16

    I have submitted a care ticket and now received an RMA to return for repair. I received an email requesting collection details but the email stated it does not accept direct incoming emails. Nowhere can I find who to respond to.

    I have found the Music Tribe website incredibly difficult to navigate, hence my question here. The site shows 4 support staff with telephone headsets but no number to speak to anyone.

    Can anyone advise how to contact Customer Care to relay these details?

    Thanks in advance.

    read more...
    0 32
    • Parky58
      KyleJohnson Hello, Kyle here with Music Tribe. You can reply directly to the email that you received. The system will not accept a new email from a separate thread if you try to send one in to that address, but as long as you reply directly to the email and do not alter the subject line the email will be received correctly.
      • August 16, 2021
  • New
    BTDGermany1
    Newcomer - Level 1
    2021-10-11

    Hey Team, 

    we are running in our theatre 6 IPD1200, all of them via Cat7 for Remote Control. After updating our system to MacOS Big Sur, the IntelliDrive won't let me control the remote. The IntelliDrive is crashing after starting. After checking the terminal I know now, that the IntelliDrive try to start with Python 2.7. But BigSur need Python 3.xxx, cause it is the newest one. 
    i cannot find any software for MacOS BigSur. 
    Is there any solution for this? 

    greets Marco Boulevard Theatre Germany

    read more...
    0 30
    • BTDGermany1
      BTDGermany1 Hey Guys, I really need a solution for this problem. Is there no way for a workaround or a new Mac software update?
      • October 13, 2021
  • New
    ashsmartcomm01
    Newcomer - Level 1
    2022-02-14

    Hi, 

     

    I'm looking for a distributor for the Lucia and E series amplifiers in the UK. Can Music Tribe assist? 

    I need: 

     

    Lucia 120/1-70

    Lucia 240/1-70

    Lucia 120/2 

    E10:4

    Thanks 

     

    Ash

     

    read more...
    1 30
  • New
    Benzand
    Newcomer - Level 1
    2021-10-14

    Hi there, unfortunately recently I have a problem about noise issue on my headphone amplifier powerplay xl 4700, it has a annoying high frequency noise on headphones and I checked everything from earth and cables but I realized that this problem 100% is from the xl 4700, I really appreciate it if you let me know what can I do for fix it. Thanks

    read more...
    0 30
  • New
    jdinsdale
    Newcomer - Level 1
    2021-09-24

    Hi,

    Id like to get a copy of a schematic for F1220D powered monitor.

     

    Thanks Jeff

    619-787-4381

    1 30
  • New
    HawaiianKidd75
    Newcomer - Level 1
    2021-09-09

    I have had the NX3000 for about 3 years hadn't had an issue at all.  Practiced as normal and the amp started blowing out bright white smoke.  It isn't dust related as it is in a Flight Case.  Still works ,however, I recently purchased the NX4-6000 from Sweetwater Mid July.  Second time being used was yesterday during band rehearsal and it duplicated the exact issue I experienced with the NX3000 and every channel went into Protect Mode.  Fans blew with much more force than normal operating conditions and all I had was 2 Peavy 12" Mains and a Peavey 500w Wedge.  Not nearly enough load to cause this.  Is this a defect or has anyone else ever experienced this issue. 

    read more...
    0 28
    • HawaiianKidd75
      john0121 Hi, unfortunately this sounds like a hardware fault in with the amp, please fill out the service request form via the support button at the top of the page and our team will arrange a repair with you.
      • September 10, 2021
  • New
    TobyWilson
    Newcomer - Level 1
    2021-08-22

    Hi there. Just looking for some help. I want to bridge channels A and B and also channels C and D together to effectively create a 2 channel amp (with more power). I have linked channels A & B and reversed the polarity oh channel B then connected to the +1 and +2 terminals of the speakon out for one side, then the same with channels C & D for the other side. Is this the correct way to do it?

    Also - how should I use the gain knobs on the front of the amp when in bridge mode in this way as gain knobs A and B both seem to affect the gain (same for C & D). I hope that I have explained this all ok. I am using the amp to drive 2 x Nexo PS15s in passive mode.

    Thank you for your help. If you have a manual for this amp I'd be very grateful as cannot find one online. 
    Best wishes,

    Toby

    read more...
    0 28
    • TobyWilson
      Nigel67 Hi TobyWilson. Well this has certainly perked up a few memories with some of the slightly older colleagues :). It seems as though this amplifier was an obsolete product in 2005, so its doing well. I am afraid that we do not have a manual, but three people have come up with all the answers for you. Its not pretty I am afraid, but better than nothing. Evidently, if you can find one, the 1300C manual was very similar
      • August 23, 2021
  • New
    Petethetrump
    Newcomer - Level 1
    2021-08-30

    Hi does anyone know where I can purchase a power circuit board for the Berhinger Air X 18 as ours has blown. We get 360 vaults going in and even part way across the board but then it splits and only some of the components are getting the voltage , in short it's dead . 

    read more...
    0 27
    • Petethetrump
      Dale_M Hi there if you are looking for parts simply go to the Support tab above and select Parts so the team can advise price and availability.
      • August 30, 2021
    • Petethetrump
      Petethetrump

      Nobody has replied and we really need the part or the X 18 is useless to us . I’d appreciate someone’s attention to this if possible?

      • September 2, 2021
  • New
    BFAN111
    Newcomer - Level 1
    2021-09-13

    I added another amp and wanted to change my EP2500 to bridge mode operation from stereo.

    It seems like it will not allow me to run it in Bridge mode without enabling the Low frequency filter?

    Is this correct?  I cannot use an EP2500 in bridge mode to power a subwoofer without a low frequency filter?

    read more...
    0 26
    • BFAN111
      DavidKnighton Hello BFAN111,
      No, that is not correct operation of bridge mode. According to the manual, you need only push switch 6 & 7 to the ON position to enable bridge mode. Also note that parallel mode must NOT be active, so switches 4 & 5 must be in the OFF position. The remaining switches/controls for INPUT 1 are optional. The manual does state that the the INPUT 1 options are used specifically for bridge mode operation, meaning INPUT 2 controls are N/A. This statement does not mean that the controls need to be engaged for bridge mode.
      • September 13, 2021
    • BFAN111
      DavidKnighton
      • September 13, 2021
Go to page