Statistics

260,756 members
139,385 posts
  • New
    BFAN111
    Newcomer - Level 1
    2021-09-13

    I added another amp and wanted to change my EP2500 to bridge mode operation from stereo.

    It seems like it will not allow me to run it in Bridge mode without enabling the Low frequency filter?

    Is this correct?  I cannot use an EP2500 in bridge mode to power a subwoofer without a low frequency filter?

    read more...
    0 8
    • BFAN111
      DavidKnighton Hello BFAN111,
      No, that is not correct operation of bridge mode. According to the manual, you need only push switch 6 & 7 to the ON position to enable bridge mode. Also note that parallel mode must NOT be active, so switches 4 & 5 must be in the OFF position. The remaining switches/controls for INPUT 1 are optional. The manual does state that the the INPUT 1 options are used specifically for bridge mode operation, meaning INPUT 2 controls are N/A. This statement does not mean that the controls need to be engaged for bridge mode.
      • Sep 13
    • BFAN111
      DavidKnighton
      • Sep 13
  • New
    parisdobermans3
    Newcomer - Level 1
    2021-10-21

    Does the PS-1 color the tone in any way?

     

    0 7
    • parisdobermans3
      WilliamR Hello, William from musictribe here. The PS-1 shouldn't color your tone in any way by means of the ps-1 circuitry. Any change in tone would be a result of the resonance of your cab and the volume you are playing at. All of which affect your overall guitar tone.
      • Oct 20
  • New
    alme
    Newcomer - Level 1
    2021-10-06

    i buy lab gruppen d200 ta but i have some problem to find it on network. in tesira software i don't find it also in cafe i can't find it on network. in order to control it what i need. i'm tring to link it with eternet cable to pc directly

    0 7
  • New
    djmarshallb
    Newcomer - Level 1
    2021-11-01

    I have alot of equipment as a portable dj and entertainer I have an issue I need addressed . I ordered 5 behringer amps back in 2011 along with 4 18 inch subs and 2 dual 15 inch tops and 2 single 15 inch tops. I needed as much to cover different small venues without moving equipment from my main venue gig. the larger amo rack with 4 amps in it which were 2  berhinger 3000 watt amp and 2 4000 watt amps . I used a few times with no problem, never over worked anything ad it was too much for some of the places I played. fast forward to a few years later I took the amp rack out and hooked up everything for an outside event . and about 15 minutes into playing one amp went out. I switched the amp . the next time I used the rack another amp went out. I wasn't pushing it hard or anything. I bought the 6000 watt amp and used it twice same thing . now I have 3 broken amps in my trailer that need to be repaired . they all power on but with any load they click off. usually because of the good price I just replace but as I see now I can't find your products on my supplier's website. what could the problem be? there was no moisture or over hard use. all amps were and is inside of sealed amp racks.

    read more...
    0 7
    • djmarshallb
      Paul_Vannatto Sweetwater is their new super partner for the US. You will need to contact them for product.
      • Nov 1
    • djmarshallb
      djmarshallb

      not the same as zzound though. credit check on orders payment plans. zzound didn't and offered 12 months. I stocked my business with zzound and American musical.

      • Nov 4
  • New
    DEFF123
    Newcomer - Level 1
    2021-09-22

    I have a new PPA550BT the power  box lights flicker on and off when I turn it on.  The also flicker when I turn it off.  What do I do?

    I have no  sound on my PA

    0 7
    • DEFF123
      DEFF123 What do I do?
      • Sep 22
    • DEFF123
      KyleJohnson Hello, Kyle here with Music Tribe. Please contact our tech support directly by clicking on Support and then Technical Support.
      • Sep 22
    • DEFF123
      DEFF123

      • Sep 22
  • New
    DEFF123
    Newcomer - Level 1
    2021-09-22

    The lights flicker on and off when I turn it on and when I turn it off.  What do you suggest?

    0 6
    • DEFF123
      DEFF123 I'm awaiting your answer.
      • Sep 22
    • DEFF123
      Nigel67 Hi Deff123. Unfortunately the device appears to be faulty. If you have tried another mains cable and mains socket and the LEDs are still flickering and you get no audio at all, then it needs to be serviced. You mention that the unit is new. If it is under 30 days old, then please go back to the shop that you purchased the unit from and ask for a DOA replacement. If it is over 30 days old, please send us a Technical Support ticket as mentioned by my colleague below and we will help you further. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Technical Support tab and submit a ticket.
      • Sep 22
  • New
    n8935f
    Newcomer - Level 1
    2021-11-03

    I have a speaker that is wired using an nl4 speakon. 1+ 1- is wired to bullet tweeter 2+ 2- is wired to a horn.

    my pre amplifier would be connected to amplifier.

    Bullet tweeters on input A

    Horn on Input B.

    Can nx6000d be used to power both these using 1 nl4 cable from outout a or b? 

    I have ran it this way before using another amp but cannot remmeber the make of it.

     

    if the answer is no, how do i get nx6000d to run so input a outputs on A and input B outputs on B.

    I have read the manual but cannot work it out

    read more...
    0 6
  • New
    dBzero
    Newcomer - Level 1
    2021-10-15

    I have 3 x IPD 2400 in a rack which had not been used since March 2020. When I set up last night the rack with the 3 amps tripped the circuit breaker for the ring main (32A) . I tried connecting each amp on its own but the fault persisted. Will these amps draw more current when they havn't been in use and the power supply capacitors will have discharged? I had to use the house powered speakers which is not ideal. I have used these amps in this venue many times before without any trouble. Has anyone else had this problem?

    read more...
    0 6
  • New
    sonidoduarte
    Newcomer - Level 1
    2021-11-20

    Hello, I have a sound reinforcement business in Guayaquil-Ecuador South America.  I need to buy parts to repair an FP7000 LAB GRUPPEN AMPLIFIER.  Where can I find a dealer to sell me the parts?

    Thanks

    https://www.facebook.com/pg/SonidoDuarteEc/videos/

    read more...
    0 5
    • sonidoduarte
      KyleJohnson Hello, Kyle here with Music Tribe. Please contact our Parts team. To do so, click on Support and then Spare Parts to submit a ticket.
      • Nov 21
  • New
    Rouziere
    Newcomer - Level 1
    2021-10-15

    Hello,

    I have a problem with a LAB Gruppen PLM12K44 amplifier, it doesn't light up at all.
    I bought it in 2017/2018.
    I am looking forward to hearing from you about the procedure to follow.

    I am looking forward to hearing from you.

    Adrien Rouziere

    read more...
    0 5
Go to page