Statistics

305,248 members
189,524 posts
  • New
    MondiMarku
    Newcomer - Level 1
    2021-04-08

    Hi..to by turbosounds product..its only like simple costumer..or if wee whoo need to work like dealer..too heave some %..too put torbosound first brend in my audio magazine..thenks i write from..Tirana Albania ?? thanks..

    0 103
    • MondiMarku
      Dale_M I am afraid we don't understand your post -are you looking to review a Turbosound product in your magazine?
      • April 9, 2021
  • Masterpiece01
    Newcomer - Level 1
    2020-09-22

    I just purchased the Milan15 Tops and subs. The dealer (Sweetwater) had covers for the tops, but not the subs. 

     

    Does anyone know IF there are covers for the subs? If so, how do I find them. There is no mention of accessories on the Turbosound site.

     

    Blessings.

    read more...
    0 102
  • New
    LowBee
    Newcomer - Level 1
    2021-05-09

    We have an event coming up where I need some more grunt in terms of subs

    I have a pair of iQ15B's, and EV ZXA-1's, was thinking of using the subs from my iP2000's (without the array columns)

    Thoughts on this please?

     

     

    Thanks, stay safe as we (finally) get back to live music :-)

    read more...
    0 100
    • LowBee
      GaryHiggins It will be a challenge but it may work with some careful setup and testing. The mixer may limit your ability. You will need extra busses to keep the subs separate. You didn’t say what one you use.
      • May 9, 2021
    • LowBee
      LowBee Gary, thanks.
      • May 9, 2021
    • LowBee
      LowBee I am using an X32Producer with Ethernet stage boxes, any set up advice much appreciated
      • May 9, 2021
  • New
    Paryss1
    Newcomer - Level 1
    2020-11-02

    Need help!

    What would cause my sub to stop working? Let me explain. I use my sub every week in church and have never had a problem. It's connected to another JBL spkr and you can see signal & power lights on in the back panel but no sound. I have no sound but do have signal....help!

    read more...
    0 98
    • Paryss1
      RexBeckett Hello Guy, it sounds as though there is a fault in the amplifier or driver. I suggest that you open a Care ticket.

      At the top of this page, click Support and then select Service. Make sure that you enter all required (*) data before clicking Submit. The Care team will respond by email.
      • November 2, 2020
  • Andybailey23
    Newcomer - Level 1
    2020-10-27

    I'm looking for some views and advice on weather the iQ15b would match up well with my Milan m12's. I'm looking at getting a pair of iq15b and wondered if anyone could tell me the best settings to to pair them. I prefer the iQ15b over the ml15b due to size and weight. I won't be using the ultranet features at this stage so just wanted to know what best setting to have them on inc the anti feedback etc. 
    thanks in advance 

    read more...
    1 98
  • TameraJohnson
    Newcomer - Level 1
    2020-10-14

    Hello this is Tamera Johnson. I bought a speaker from you. I have used it once and it is doing some weird things. When I attach my music to the speaker there’s a static, the music fluctuates up and down, and you can’t hear the lyrics. Could you please contact me and help me out with this problem? I tried to get on your website and it cautions me and tells me it’s an unsafe website. I’ve tried calling you and I can’t get an answer. I would really like to resolve this problem. Thank you for your understanding and help in advance. 
    Tamera Johnson

    read more...
    0 95
    • TameraJohnson
      john0121 Sounds like you might be connecting a stereo cable/source to a mono input which is causing phasing issues. If your trying to connect your phone to the speaker then you can use a 3.5mm TRS to 2 x XLR cable and connect to both inputs. This will stop your phasing issue.
      • October 14, 2020
  • New
    KieranPollard
    Newcomer - Level 1
    2021-01-30

    I have 2 ip1000s and 1 of them went into half power. To match the work up I have the gain this one up.

    ive checked to see if any drivers have blown and they have not.

    im at a loss, any help would be appreciated 

     

    0 93
    • KieranPollard
      john0121 HI Kieran, if the level has dropped significantly on one of your speakers but not the other I would first recommend swapping the source material and cables to ensure that isn't the cause of the problem. Further then that it could be a problem with the amplifier. If you submit a tech support ticket via the support button at the top of the page then we can work through some more troubleshooting with you and arrange a service if necessary. Thanks
      • February 1, 2021
  • New
    Nusty
    Newcomer - Level 1
    2021-01-10

    Hallo,

     

    gibt es auch eine normale Anleitung und nicht nur eine QuickStart Anleitung für den Turbosound iQ12?

    Wo finde ich die Software zum verbinden PC mit den Lautsprecher?

     

    Gruß Nusty

    0 93
  • JudeLeBlanc
    Contributor - Level 2
    2020-07-13
    I cannot find an archived post in the old forum about this but have seen it mentioned. My IP1000 has a crazy buzz/rattle in a certain low-mid frequency. Once I dial it out it with an EQ it sounds 'empty' with no body. I'm mixing through an MR18 for an acoustic setup. I've tried numerous things to remedy with little success. It's like the sub bass cabinet vibrates at a frequency and it rattles the column at it's mechanical connection. Help, I own two and they both do it. Any suggestions appreciated. I love the units.
    read more...
    0 92
    • JudeLeBlanc
      Goetz Hi James,
      sorry to hear that! Could you please go to "Support" and create a new ticket – my colleagues will help with a solution!
      Cheers
      Goetz
      • July 13, 2020
  • New
    Maygo
    Newcomer - Level 1
    2021-07-25

    where is the best place to source beringer replacement parts?

    0 91
Go to page