Statistics

251,052 members
128,282 posts
  • New
    CPMixing
    Newcomer - Level 1
    2020-11-12

    Hi,

    Just yesterday I was doing some tests at my studio and decided to plug in the FW 400-800 cable from my Midas Venice F32, into my OWC TB2 Hub that has a FW 800 port. The computer would not recognize it, so I plugged directly into the iMac with a FW 800 to TB2 adapter. Same issue. I then tried on my Macbook Pro (early 2013 retina 15" with High Sierra), no device detected still. I then uninstalled the Midas drivers and re-installed, both on my iMac and Macbook. No change. I then tried shutting the computer down, then turning the Midas off and back on, then re-booting the computer. Still no device detected. I also tried all of these same things with a different cable, same issue.

    It's been a looong time since I tried the Midas as an interface and this was the result. We also have 2 Apollo 8's and since I almost never need more than 16 inputs, I don't bother to use the Midas as a Digital Interface, only to monitor and run HP mixes. Only thing I noticed as far as the FW card is concerned, is the FW 400 port is a little loose, but still makes a solid connection(from feel at least) with the cable. The leds still light up above the sample rate and clocking text.

    Do I need a new FW Card? Any other troubleshooting I could try? Any specs not mentioned are below. Thanks for the help!!

     

    Computer Specs

    21.5” iMac running Sierra OS Quad CORE i7 3.1GHz Processor 16GB RAM
    1TB SSD

    Interfaces-2x Apollo 8 Blackface 2nd Gen, Dual Core(Thunderbolt 2) -Midas Venice F32(FW 800)

    Thunderbolt Hub-OWC 12 Port Thunderbolt 2 Dock

    DAW-Pro Tools 12.6.0 

    read more...
    0 424
    • CPMixing
      DavidKnighton Hello Chris Pummill,
      Mac OS El Capitan is the latest OS that our firewire driver will support. I would suggest testing on an earlier OS, or if you have a Windows 7 machine with firewire, you can try that as well with the PC driver.
      • November 12, 2020
      • Midas Venice F32 FW Issues
        CPMixing Thanks David! Unfortunately, with our other DAWs and plugins, we can't go back OS-wise right now. It's a bit of a tricky setup because I record and mix out of the studio frequently, but we pay our bills by renting our space monthly to 10-15 different people. So any changes at all need to consider a large group of people. Worst case scenario, we just don't use the Midas as a digital interface anymore.

        Is there any way to tell if the FW card is working without reverting our computers to prior OS'?
        • November 12, 2020
      • Midas Venice F32 FW Issues
        CPMixing Also, I can't be 100% sure, but I believe I've used the Midas as an interface with the iMac and Sierra OS a few years ago with great success. Since we purchased our Apollos, I haven't bothered to use it, which is what led to the current confusion and troubleshooting. Nothing has changed on our iMac in YEARS because of potential compatibility issues and because its incredibly stable as-is.
        • November 12, 2020
    • CPMixing
      Dale_M Hi Chris, no not really as this is the only way to check the FW card is "seen" by the computer, you could try an old laptop running on an earlier Windows software but it's not guaranteed much past WIN 8 from memory, it def works on XP/Vista/Win 7/Win 8 and as my colleague David has stated on MAC up to El Capitan. It can be made to work with Sierra/High Sierra but these are unsupported workarounds, that said many users have had success -there was a KB article on it but the attachments are down at present. I think my suggestion with a laptop may be worth verifying if you can get hold of one as a starting point.
      • November 12, 2020
      • Midas Venice F32 FW Issues
        CPMixing Thanks Dale! Having read up on SIP and how it can help with newer OS's seeing the MIdas, is there any major downside to disabling it, even temporarily?
        • November 12, 2020
  • New
    slowstar1
    Newcomer - Level 1
    2020-12-16

    Please, help me to order Fire Wire card for my Venice F32 mixer, it is broken and I need to replace it ASAP, your help will be much appreciated!

    Sincerelly,

    Slobodan Markovic,

    [email protected]

     

    read more...
    0 129
    • slowstar1
      Dale_M Dober dan Slobodan, you simply need to go to the above tab, hit support, +create a care ticket, then drop-down to Spares -from here simply ask for price & availability of Q09-AD600-41000 (VeniceF32 Firewire PCB T-VN214C-02) I hope this helps.
      • December 24, 2020
  • New
    Miklos
    Newcomer - Level 1
    2021-01-12

    Hi there, 

    I wrote to your service team and they suggested I should write to you intead. My Midas XL4 

    has a broken IC circuit in the motherboard, i need either a new motherboard or just another IC cucuit. 

    I Have attached a picture in hope that someone in your network can help with this as without this the console 

    will be completely worthless, and that would be really bad. 

     

    Thanks in advance 

    read more...
    0 123
    • Miklos
      Nigel67 Hi Miklos, I am going to set up a case for this. I will e-mail you in the next few hours and we can go from there.
      • Jan 12
  • New
    TurdFerguson19
    Newcomer - Level 1
    2021-01-24

    Hi everyone, I'm new to the forum but not to Midas, I have recently purchased a pristine Venice F32. The only issue is my channel #4 fader is missing ? at least the knob plus the slider, the body is still on the circuit board. Can someone point me in the right direction for a replacement fader plus the knob? 

    read more...
    0 111
    • TurdFerguson19
      Nigel67 Hi, please click on the support tab at the top of the page. In the new page that opens, scroll down, click on the spare parts tab and submit a ticket. One of my colleagues will then get back to you with pricing and availability. many thanks
      • Jan 24
  • New
    Gruohm
    Newcomer - Level 1
    2021-05-11

    Hi, 

    just installed an H3000 desk in my studio. Love the sound, love the workflow but it's a bit loud for studio use. The power supplys are in a different room but the board's fans are a bit to noisy to my ears. Heard of someone who modified or changed the console's fans to make it quieter?

    read more...
    0 90
    • Gruohm
      Dale_M Hi there, we have no information regarding this as modifying any safety feature (such as cooling) is prohibited -the Heritage range were aimed at live sound so fan noise would not have been a consideration. However, given the age it is not impossible that quieter fans are available, it may be best to speak to users on the Facebook group "Long Live Midas Analogue Consoles" as many users have flipped these consoles over to studio work. I hope this helps.
      • May 13
  • New
    Beppone
    Newcomer - Level 1
    2021-03-18

    Hi everyone, I'm using a Midas f32 mixer and I'm trying to record on a Macbook pro with M1 chip. I already tried to download midas drivers but no one works for my macbook. My macbook does not receive any information from the mixer, I think midas hasn't released current drivers yet, so If you have some solutions I would be grateful, if you haven't, I urge Midas to release new drivers!

    Thank you 

    read more...
    0 85
    • Beppone
      Nigel67 Hi Beppone, I am sorry, but Midas ceased any support for the Venice F drivers a number of years ago now. There will not be any new drivers released for the Macbook Big Sur with the M1 chip.
      • Mar 18
  • dbbattaglia
    Newcomer - Level 1
    2020-09-23

    Hello,

     

    anyone knows the procedure to setting the Multirack waves with Midas Venice F32 desk to using wawes in Live Concert?

     

    Thanks everybody for the help

    0 85
  • New
    Laumee
    Newcomer - Level 1
    2020-12-12

    Hey everyone, I have encountered a problem with my venice f24, one of the groups is not responsive when I route channels to it. I did check all the others and they are absolutely fine, just one (group 2) does not get signal into it, nothing on a meter, no output and it's been working fine the other day. Maybe anyone had this issue before? Any help would be highly appreciated.

    Thank you in advance

     

    read more...
    0 84
    • Laumee
      Dale_M Hi Matas, if you have concluded that the Group 2 is faulty and nothing will route to it like the others it would be advised to look at organising a non warranty repair via a support ticket/service request, we can then advise the best course of action.
      • December 14, 2020
  • New
    N1Ckp
    Newcomer - Level 1
    2021-04-06

    Hello. I recently purchased at Midas Vidas 320 desk and I love it. However, to improve longevity of this beauty I would like an EPS 1200 but cannot find one online. Seeking any help here if possible. Does Midas have any back stock of discontinued products they would sell ?

    Thanks,

    Nick 

    read more...
    0 80
    • N1Ckp
      Nigel67 Hi N1Ckp. Please contact our spares team and they will be able to advise on the stock availability of a psu. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Spare Parts tab and submit a ticket. The only other option would be to post on some of the Midas FB forums and see if anyone has a second hand one. Try 'Long Live Midas Analogue Consoles'. Hope this helps.
      • Apr 5
  • New
    PhilJutras
    Newcomer - Level 1
    2021-03-18

    Hey there everyone, I'm new to the forum, I have that MIDAS H-3000 which is sadly stuck in the LOCK mode.

    As soon as I press on the system button, the segment display tells me I'm in LOCK mode.
    The UP and DOWN button doesn't do anything, the confirm button either. If I press CANCEL, the LOCK disappear.

    I'll mention that the LOCK LED is lit but it's really dimmed.

    I measure the Power on the output of the 12V REG1, I have 12V.

    Something weird is that I have 11.2V on the XL Auto Central Control Panel board.

    Anyone ever experienced this problem? Would it be more related to power or maybe a logical gate?

    Thanks!

    read more...
    0 78
    • PhilJutras
      DavidKnighton Hello Phil,
      If anyone knows anything it would be Jim Sawyer at Sawyer Audio. He is quite the authority on legacy Midas consoles and may be able to help fix whatever issues you're having.
      • Mar 18
      • H3000 Issue, stuck in LOCK
        PhilJutras Thank your for the hint!
        • Mar 18
Go to page