Statistics

250,609 members
127,789 posts
  • Ferranno
    Newcomer - Level 1
    2020-09-28

    I have just purchased a BH250 to carry around and play when in hotels rooms and also in small sessions. As I need to play along to bits and pieces I get sent from fellow musicians its quite handy that the amp comes with a aux-in to connect e.g. with a phone. However I just noticed that while the aux-in is heard on speakers, its not functioning when headphones are plugged in, so you cant listen to the track on the headphones. Is this intentional? If yes. this does not make sense at least to me.

    read more...
    0 63
    • Ferranno
      TC-Claus Hi Frank ... You should be able to hear the AUX source through the headphone output! Connecting headphones will only mute the speaker output.
      • September 28, 2020
  • Deftones210
    Newcomer - Level 2
    2020-10-25

    Hello,

    I played my first gig using my brand new BXD15A combo, and it is definitely not 1,000 watts. It's nowhere near 1,000 watts.

    What do I need to do to up my wattage? Do I need to add a cabinet and use the combo as a head? This amp is barley pushing 150 watts and at an outdoor gig, that's not cutting it. 

    Please let me know how I can get the most from this amp.

    read more...
    1 59
    • Deftones210
      Dale_M Hi Martin sorry to hear of this issue, I think it would be best to submit a support ticket as this does not sound normal, please go to support/ +create a care ticket/ Technical
      • October 26, 2020
    • Deftones210
      PedroRodrigues Hi Martin, please be aware that if you have performed a wattage measurement?
      The watts are equal to amps multiplied by volts.
      If you have performed this calculation and the values are very different form the one announce on the specifications document on the picture below, this may indicate an issue on your unit and it requires to be inspected.
      In that case please follow the link below and submit an assistance request so we can assist you with more tools. https://community.musictribe.com/pages/create-new-ticket?type=service%20request
      • October 26, 2020
  • New
    absenn
    Newcomer - Level 2
    2020-11-24

    Bought a used BH800.  Amp is great!  I run it into 2 Fender Rumble 15" cabs.  However I cannot get the toneprint stuff to be accepted by the amp.

    I have watched every video I can find and the result is always the same.  The light on the amp never flashes, and the the toneprints never change.  I am using an iPhone Xr with IOS 14.2.

    The Toneprint app is v4.3.02.

    Its not a big deal if it doesn't work.  But it might be fun if it did.

    Has anyone got any ideas?

    read more...
    0 54
    • absenn
      MrSusan I'm having the same problem with a BH550 and nobody has come up with a fix yet. Are you using the Toneprints from the 'Bass Amps' section? The only one I have managed to beam successfully is a flanger, but only one of them. Have you tried a software update via your computer?
      • November 24, 2020
    • absenn
      absenn Hey J.J., thanks for the response. Yep, I am trying to transfer any of the "Bass Amps" tone prints, have yet to get any of them to transfer. When I tried a software update, it says I am running the latest version. Not a big deal because I usually run just a SansAmp as my only "effect". I'm a straight signal guy when it comes to my bass playing, but it might be fun if it worked. The used amp I bought has 2 tone prints assigned. I think TP1 is one of the Compressor settings, and TP2 is a chorus setting. I don't like either of them so I was just wanting to play a bit with the other prints available but I have a feeling this will never be fixed.
      • November 28, 2020
    • absenn
      Patlinger Hi guys, sorry for the simple question, but... Have you set the Volume on your Phone on a high level and the mute-switch is inactive also? You should hear a crazy sound very similar to a fax-machine when you try to transfer the TonePrint.
      • Jan 5
      • BH800 doesn't seem to work with Toneprint
        absenn Hi Patrick, Oh yes. I've had the phone at max volume and the mute switch off. I have tried upwards of 50 times to get a toneprint to transfer. It does not work with my combination.
        • Jan 6
    • absenn
      absenn Hi Patrick, Oh yes. I've had the phone at max volume and the mute switch off. I have tried upwards of 50 times to get a toneprint to transfer. It does not work with my combination.
      • Jan 6
    • absenn
      Patlinger Hi Absenn, you said the amp has the latest firmware installed, but have you re-installed this version anyway? Maybe the problem can be fixed with a new and proper installation. Or else can you use another instrument to do a cross-check?
      • Jan 18
  • New
    leobee
    Newcomer - Level 1
    2020-12-25

    The URL given in the manual does not lead to anywhere that has toneprints for BH250. Can anyone tell me the correct one? There are no BH250 toneprints at tcelectronic.com/bh250/toneprints, which redirects to https://tcelectronic.com/tonePrints/tonePrint-library.html . Loads of pedals there but no bass amps. 

     

     

    read more...
    0 54
  • erotte
    Contributor - Level 1
    2020-10-15

    I tried to get support information since weeks now, but the online support is an absolutely disgrace.
    Its extremely slow, hard to use and its impossible to communicate there.
    I got an email about a case which obviously needs some information from me, I have no clue what it could be.

    Whats going on there?

    read more...
    0 52
    • erotte
      JoeRivers96 Hi Eckhard, do you have a case number i can look into for you?
      • October 15, 2020
    • erotte
      erotte Thanks,

      CAS-133764-M3S9P1
      CAS-133763-H0N3Q0
      • October 15, 2020
  • New
    EdPolo
    Newcomer - Level 1
    2021-05-28

    Hi,

    I have BG250-208 and Switch-3 pedal. However, I never know which TonePort is active. Is there a way to  know when each of these slots are active? I want to load two different effects but am always able to load one in slot 2. When I activate slot ! nothing is happeneing. Mute siwtch (#3) is working fine.

    Thanks,

    Ed

    read more...
    0 52
  • New
    Rapisme
    Newcomer - Level 1
    2021-04-23

    So I recently acquired a BH 550 head and had it for 5 days. On the 1st played with issues. On the second day that's when during used it will intermittently go into protection mode then shut off then a few seconds later come back on! I did the care ticket thing but was curious if anyone may have a more pragmatic solution?

     

    Thanks,

    Rap

    read more...
    0 51
    • Rapisme
      NicJonesMT Hi Rapisme.
      Please submit a technical support ticket and we can go through some trouble shooting with.
      Simply click "SUPPORT" at the top of the page and scroll down to the Technical support option.
      • Apr 23
    • Rapisme
      Rapisme

      Hi, did that already and received an email indicating that I’ll have to proceed to an authorized service center to receive out of warranty service?

      • Apr 23
  • New
    sammys
    Newcomer - Level 1
    2021-06-24

    At 4 ohms the BH800 has a power module rating of 800W, according to the manual. I believe this is continuous/RMS? 

    But what is the wattage at 8 ohms?

    Thank you very much.

    0 50
  • mAd66
    Newcomer - Level 1
    2020-10-19
    hi. i am considering an rh750 bass amp in combination with a bc208 for my "home studio" setup. do the feet of the rh750 fit exactly into the square niche on the top of the bc208? thanks, matthew
     
    read more...
    0 48
  • JohnJarrett111
    Newcomer - Level 1
    2020-10-01

    I need a replacement front facia for my RH 750. Could you tell me how much they are and where I could purchase one.

     

    cheers

     

    John Jarrett

    0 47
    • JohnJarrett111
      john0121 Hi John, if you click the Support button at the top of the page you can fill out a spare parts request and the team will be in touch regarding price and availability.
      • October 1, 2020
Go to page