Statistics

294,585 members
177,696 posts
  • MartyJ
    Newcomer - Level 1
    2020-09-27

    Guys, it's over two months since you launched the Ditto Plus and there is still no user manual, just a minimal Quick Start Guide that doesn't contain much information. We need a proper manual, not least because Extended mode seems to be tricky.

    I am still trying to find out how to get the Ditto+ to do what I want in Extended mode.

    • On Loop 1 you have to press the footswitch exactly at the start and exactly at the end of the loop which is the normal way of working with loopers, no problem here. But after that things get complicated.
    • On Loop 2 you apparently have to press the footswitch before the end of the current Loop 1 to arm the Ditto+ to start recording Loop 2 the next time Loop 1 restarts, and you apparently have to press the footswitch before the end of the current Loop 1 to prepare the Ditto+ stop recording Loop 2 the next time Loop 1 restarts.
    • Recording an overdub seems to work differently: you still have to press the footswitch to punch in before the end of the current loop but then you have to press again after the end of the current loop to punch out, otherwise you get signal dropout.

    This is my guess after failing many, many times to make Extended mode work the way it should. At one stage I was going to send the Ditto+ back for a refund. Am I right -- is Extended mode supposed to work this way? Can we have a user manual please? The functionality of the footswitch in Extended mode is not intuitive, and as a minimum it needs to be explained properly in a user manual.

    read more...
    0 1,761
    • MartyJ
      Dale_M Hi Martin can you confirm that you actually have a Ditto Plus and latest firmware update installed?
      • September 28, 2020
    • MartyJ
      MartyJ Hi Dale
      Yes, I have a Ditto Plus. I updated the firmware to version 1.0.14 on September 13 as soon as it was released on TC's website https://www.tcelectronic.com/product.html?modelCode=P0DLQ.
      • September 28, 2020
      • Ditto+ Extended mode footswitch functionality
        Dale_M thnak you for confirming On Loop 2 you apparently have to press the footswitch before the end of the current Loop 1 to arm the Ditto+ to start recording Loop 2 the next time Loop 1 restarts, and you apparently have to press the footswitch before the end of the current Loop 1 to prepare the Ditto+ stop recording Loop 2 the next time Loop 1 restarts.

        wrong. there is no puch in or arming an overdub recording... there is a difference between normal overdub and xtended overdub:

        When xtend mode is selected and you actually xtend the base loop with an overdub recording that has x times the length of base loop , we have an assistant function called" queued overdub" where you CAN( not required) press the foot-switch to STOP the xtended overdub recording before the end of the latest xtend cycle and then it will continue to record to the end of the file and then auto-stop the overdub recording (not playback!) that is all this is not a punch in or Out or arm function, but simply a help to make sure the last overdub recording stop at the correct cycle length (multiple of recorded base loop)

        Again, you cannot arm the DItto + to auto start an overdub recording (the REC/PLAY/OD mode is fixed! and we don't have a REC/OD/PLAY mode like x2 or ditto X4 have)
        • 1
        • ·
        • September 29, 2020
      • Ditto+ Extended mode footswitch functionality
        MartyJ Hi Dale

        Thanks for replying. I have just tried ten times to loop in Extended mode doing what you describe and got ten failures. Here's what happens:

        - Laying down Loop 1 (one bar of percussion on an acoustic guitar body) is no problem. Starting and stopping recording works as it should.

        - Laying down Loop 2 (which I want to be four bars of chords) is a different story. Starting recording works fine, but when I try to stop recording Loop 2 the Ditto+ consistently waits for one more round of Loop 1 before it stops recording. I end up with five bars in Loop 2, which destroys my song structure. If I was playing a gig this would be a disaster.

        - I can't comment on how overdubbing over Loop 2 works -- I didn't get that far this time because of the above problem.

        I don't think that the problem is my footwork, I think it's the Ditto+. I currently own Digitech JamMan Stereo, Digitech Trio Plus, Xvive D3 Duet and Boss RC-300 loopers and I haven't had this kind of problem with any of those (admittedly the RC-300 is the only one that has a feature similar to the Ditto+ Extended mode where you can lay a longer loop over a shorter one and keep the loops synchronized).

        I downloaded the firmware from the TC website and updated the Ditto+ again just in case it had got corrupted the first time I updated it, but this did not help.

        The Ditto+ seems like a good concept with good sound quality at a reasonable price, but Extended mode is still not working right despite the firmware update, and Extended mode is the whole reason I bought the Ditto+.

        I'm interested to hear what your developers say. I'm also interested to see what other customers have to say when they start taking delivery of the Ditto+. I don't think I'm going to be the only person who has this problem.
        • September 29, 2020
      • Ditto+ Extended mode footswitch functionality
        MartyJ Hi again Dale

        I have now tried overdubbing on top of Loop 2. I am getting a dropout at the beginning of overdubs just like the dropout that Pete Honore was getting in the Andertons video. The difference is that Pete was getting the dropout at the beginning of Loop 2 whereas I am getting the dropout at the beginning of overdubs over the top of Loop 2.
        • September 30, 2020
    • MartyJ
      Dale_M Sorry for the delay, it might be just pressing the footswitch too late on your overdub recording in x-tend mode instead of using our "auto-queue" feature, so the pedal adds another Xtend round.

      the explanation of x-tend mode is here -is this the video you are talking about?:
      https://youtu.be/UpBjF9uXFck?t=140" target="_blank" title="https://youtu.be/UpBjF9uXFck?t=140" target="_blank" title="https://youtu.be/UpBjF9uXFck?t=140">https://youtu.be/UpBjF9uXFck?t=140">https://youtu.be/UpBjF9uXFck?t=140">https://youtu.be/UpBjF9uXFck?t=140

      To confirm correct functionality of pedal with latest 1.0.14 firmware when using Xtend mode, you could try the following:


      set ditto Plus to xtend mode
      record a 2 bar loop (once you are happy with it keep it in playback and prepare for Xtended Ovedub recording)
      start X-tended Overdub recording on one of the next loop cycles by pressing the foot switch right after loop start (pedal LED blinks at loop start to indicate loop wrap around)
      record an 8 bar overdub -> once you pass the 2 bar length of Loop 1 you should notice the first loop repeating while the recording counter moves on, extending the overall loop length as long as you continue to record your overdub
      now comes the critical part and what i think might happen in your scenario is that you stop the overdub recording a little too late on the "1" of the next bar, so the pedal thinks you want to xtend further and adds another length of the first 2 bars.

      Try instead to use our "auto queue" feature to help you stop OD recording precisely at end of the current xtended overdub recording cycle by just pressing the foot switch after bar 7 but before the end of the 8th bar and note that the OD recording won't stop but will continue recording until the very end of the 8 bars and then auto switches to playback without adding an extra cycle length of your base loop .
      • October 1, 2020
      • Ditto+ Extended mode footswitch functionality
        MartyJ Hi Dale

        Many thanks for trying to help. I had considered the possibility that I was hitting the footswitch too late to stop recording Loop 2, but I consistently record Loop 1 in time and I don't have problems hitting footswitches in time on any other loopers. The 'auto queue' feature will solve my problem stopping recording Loop 2 if I can train myself to hit the footswitch before the end of the last bar that I am recording in Loop 2, so I'm just going to have to practise doing that.

        I am still getting dropout at the start of overdubs that I lay over the top of Loop 2, though. Perhaps starting recording the overdub early (before the '1' beat of Loop 2). will eliminate this problem.

        For years I have been used to just pressing a footswitch on the '1' beat to start and stop recording loops. The Ditto+ does not to want to co-operate when I work this way, or perhaps it is just less forgiving than other loopers if you are a few microseconds out of time. I'll keep practising and see if I can get better results. And I'll wait to see how other users get on with the Ditto+ when it starts reaching the shops in greater quantities.
        • October 2, 2020
      • Ditto+ Extended mode footswitch functionality
        shutch011 Hi Marty, has there been any movement on this? I just got a ditto+ looper yesterday, and only got a chance to play with it today. The extend mode does not work at all for me. If i record loop 1 of 1 bar percussion, and then try to play over the top of it via loop 2 I am just stuck with 1 bar and it all gets messy really quickly.
        Also adding backing tracks don't seem to work, I get nothing but static when I try to play one.
        • March 3, 2021
  • dhpasta
    Newcomer - Level 1
    2020-06-13
    I was looking for way of contact with TC to share with You my opinion and few ideas on Plethora. Only working way I found is here. So, I felt in love with Plethora since first video of it. I used to be against guitar multi effects but idea of five separate effects with their own footswitches, luck of complicated routing, multiple cab and amp sims are what I expect from multi effect. Very clear displays, intuitive handling and many effects to choose from with Toneprint technology are big advantages. Technical feedback. I've got two (actually three) problems when using Plethora: 1. Tremolo - on few toneprints, especially with faster settings tremolo is changing speed randomly. It spins with set speed then speeds up for a second, gets back to set speed, speeds up again for half of second, gets back, and so on. I've done update, because I've read that it was reported earlier, but it still happens. 2. Changing boards - when I switch pedalboards and hold a note or a chord, volume rises up and lowers when next board ends loading. It's a bit disturbing because volume increase during the change is quite big. Also volume is higher when I switch on my rig and Plethora is loading. When it is ready to use overall volume is lower. 3. There is one more small thing. When I change boards with lever switch there could be a bit more time to decide which board I'd like to choose. In other words: When i switch board up, number appears on display, I read it's name and decide to change for next board, but it's too late and board starts to loading. I have to wait for loading to be ended and change to next board. That time when number and name of next board is being displayed could be a bit longer. Quick changing boards by pressing lever quickly is possible. I also found few things which in my opinion could be improved: 1. List of toneprints - I've uploaded to plethora some artist toneprints from app and created few mine. List of toneprints became a bit messy. I think that the list could be divided in sections: templates, user toneprints, stock toneprints, artist toneprints. Categories could be divided with line like between templates and stock toneprints. 2. Toneprint label - when I use stock toneprint in play mode there is label on display: TC ELECTRONIC, when it's my own toneprint there is: LOCAL USER. When I use artist toneptint there is also TC ELECTRONIC label. It would be helpful when there will be label ARTIST or artist name will appear. 3. Empty slot after deleting pedalboard - for example: I have 25 pedalboards. When I delete number 22 this slot remains empty. Then when I create new one it gets number 22. For me it would be nice to shift boards numbers after deleting one in the middle and giving last number for newly created. I know that it could be unuseful for other users, so it could be an option in settings menu like: Delete board: shift numbers/remain empty. 4. Deleting tone prints - It's more a question than an idea. Is it possible to deleted toneprint loaded to Plethora? For example: I've created toneprint and I don't need it anymore. Can I delete it from toneprints list in Plethora? I couldn't find that in app. According to FAQs in video (YouTube one with Scotty & Anders) I'm also waiting for phaser. I think it's must-have in such a device. It also would be grate to have Alter ago toneprints in Plethora! Now I have to save some money and buy drive pedal to complete my rig 'cause I sold almost all my pedals to purchase Plethora. Maybe I should try MojoMojo? :) Sorry for long post - it was supposed to be a mail :) I would be very happy if you find my feedback helpful.
    read more...
    1 1,304
    • dhpasta
      dhpasta Can I format text in post somehow?
      • June 13, 2020
      • Plethora X5 - few words of feedback
        RexBeckett The only formatting tool discovered so far is that Shift-Enter starts a new paragraph.
        • June 13, 2020
      • Plethora X5 - few words of feedback
        TC-Mike currently not that i am aware of... this is likely just temporary due to the new forum launch last night too.
        • June 13, 2020
      • Plethora X5 - few words of feedback
        TC-Mike here are screenshots on how to disable Pipeline TEMPO feature and how to assign TEMPO subdivision to MASH pressure sensor.
        • 1
        • ·
        • June 13, 2020
    • dhpasta
      TC-Mike Hi DHPasta,

      welcome onboard and thanks for the great feedback. Much appreciated . Glad to hear you like our new Plethora :-)

      We monitor this community closely for fproduct eedback and there is also a feature request post here in the TC Electronic brand tribe /Guitar & Bass forum where you can add your ideas or upvote existing feature requests
      from other users:

      You can also always send product feedback, ideas and questions to our CARE team using the "Support" tab at the top of the page or simply send me a PM…

      Latter is currently not possible unfortunately due to the transition to the new community structure, but the team is working on it.

      Regarding your issue with the tremolo changing, this is due to the Toneprint/setting you are using having the “TEMPO/BAR” feature active, which allows you to specify up to 4 tempo subdivision
      that are cycled through for the duration of a bar. This can be very useful when combined with the tap tempo feature that you can activate via SETTINGS/BOARDS/2NDARY FOTSWITCH FUNTION.

      In order to disable it on a particular toneprint you like, edit the toneprint via the app by disabling all tempo bar fields except the first one.

      P.s. alternatively you can assign the Subdivision that the toneprint uses also to the MASH switch or a connected expression pedal , so you can easily change tempos while always staying in sync with the tapped tempo. Typically you set Mash default to quarter notes,
      so the speed always snaps back to your basic tempo when footswitch is released after mashing . If you just want to switch to eg .8th or 16th notes, set all other curve points to same value.

      In order to delete a Toneprint stored in PLETHORA’s on-board library, select the toneprint you wan to delete in EDIT mode and then press and hold the TONEPRINT push encoder to get the “DELETE” option.
      Press push encoder again to confirm and execute. All on-board toneprints are also available as template via the app, so you can either start off fresh and build your own library from scratch or just edit the available
      Toneprints via the app and store them in your user library for later use and using the STORE TO PEDAL option you update the edited toneprint on the PLETHORA.

      I logged your feedback regarding memory location behavior when deleting board as a feature request. You can use the board organizer of the app to rename boards and change order too.

      The Helix Phaser, Viscous Vibe + a Looper will be available with the 1.2 firmware update scheduled for later this summer…

      What would be your top 3 feature requests for the 1.3 update?

      Best regards from the TC guitar team
      • June 13, 2020
      • Plethora X5 - few words of feedback
        dhpasta Thank you very much for quick answer Mike! I'm happy that you've found my opinion helpful.
        Thanks for solutions - I will mess with tremolo later on
        It's nice to hear that Helix Phaser will come in firmware 1.2! What would be my requests for 1.3? For sure it would be Alter Ago tonprints. I'm very curious about it and it would be good companion for phaser in more vintage tones. Secondly those cosmetic updates I've mentioned above - divided toneprints list, artist labels on effects and maybe active pedalboard number (or shorten name) visible somewhere on display. The third one - filter effect. That would fill list of effects. Kind of LPF, envelope, equalization. With companion of expression pedal that could be use as wah-wah. Also equalizer with toneprints powers could be mighty tool! Ane the forth, becasue it argues with idea of "drive of your choice" it could be booster with some eq possibilities. It could be useful for people (like me) using Plethora in 4CM with drive from amp. But I know it could be done with some addition pedal.
        • 1
        • ·
        • June 13, 2020
      • Plethora X5 - few words of feedback
        dhpasta O, and as Linux user I should upvote request for Toneprint App for unix systems
        • June 13, 2020
      • Plethora X5 - few words of feedback
        TC-Mike i pass this on - with regards to efforts of supporting an additional platform on top of MAC OSX, WINDOWS , iOS and Android versus using the time on other product features instead that's gonna be a tough one to sell ..
        • June 14, 2020
    • dhpasta
      TC-Mike Cheers, noted.
      As for the booster, you can currently also re-function your Pipeline Tremolo as a dynamic boost. Since it can boost output level by up to 9 dB, just assign output level to MASH switch and set Modulation depth to 0% , so you don't get the tremolo. If you don't want a gradual boost, just set all curve points to the same boost value
      Hyper gravity with its 3 bands can also be used to adjust the colour of your signal by using it as a dynamic EQ mapping the gain parameters of the 3 bands to the potmeters.. Try the dynaQ template as a starting point and adjust the boost/cut levels in the app to taste. You can set the X-over frequencies of the 3-bands too.
      • June 13, 2020
      • Plethora X5 - few words of feedback
        GuitarGeorge Hey There TC Mike!
        • July 1, 2020
      • Plethora X5 - few words of feedback
        GuitarGeorge I'm loving my Plethora. The only modulation pedal I can't get rid of is my Crescendo. Any chance that can be added in the next update?
        • July 1, 2020
    • dhpasta
      Bluesmanstar bank
      • May 28, 2021
    • dhpasta
      MatthewLevy

      I'm just starting my journey with the Plethora. Is there a way to delete and reorganize Boards now?

      • September 13, 2021
  • jkay898
    Newcomer - Level 1
    2020-10-10

    Hi,  I am trying to update the firmware on the Ditto Looper X2 pedal.  Some problem developed when trying to download an external file to the pedal which would not download. I attempted to update the firmware after which the pedal became non-functional in normal use.  I tried to do a factory reset - no effect and then update the firmware I follow the instructions to connect to the computer for a firmware update but can't update. Green light comes on, there seems to be some sort of registration with both teh computer (pings to indicate connection) and the download software but no update occurs and the software becomes non responsive.  The pedal won't be recognised as an external USB drive by the computer.  I'v tried two computers and all the USB drives on each. No idea what else to try....... Windows system being used. James.

    read more...
    0 1,296
    • jkay898
      PedroRodrigues Hi James please follow these steps To perform the firmware update please download the newest firmware from the “Support” page for your TC pedal.
      https://www.tcelectronic.com/Categories/Tcelectronic/Guitar/Stompboxes/DITTO-JAM-X2-LOOPER/p/P0DAT/Downloads#googtrans(en|en)
      There are updaters:
      – for Microsoft Windows (these are ZIP archives containing the firmware
      installer) and
      – for OS X (these are disk image files containing the firmware installer).

      2. Unplug all cables (including the power supply) from your TC pedal.

      3. Connect the pedal to your computer using a USB cable.

      4. Insert the DC power supply plug. The leftmost LED on your pedal should
      turn green.

      Your TC pedal will now be recognized as an updatable device.

      Applying the firmware update
      Open the firmware update file. The pedal’s current firmware will be listed,
      as well as the version contained in the updater.

      Click “Update” and let the program run. The BeatSense LED will flash red
      during the update. At some point, the update window may indicate that the
      pedal has disconnected, which is normal.

      When finished, the unit will return to the loop mode display shown prior to
      the update procedure
      • October 13, 2020
      • Ditto Looper X2 - Can't update firmware.
        jkay898 Hi Pedro, Thanks for your advice. This only seems to have worked after there was a windows update just prior to me trying it a second time. The lights and update screens seem to have worked as indicated so now its time to see if it works. Thanks again. James
        • October 14, 2020
      • Ditto Looper X2 - Can't update firmware.
        TonyJ Pedro, the MacOS version will NOT INSTALL.
        Mac OS cannot verify the developer (I think the TC package info is faulty), so I cannot get the firmware update for my Ditto X2 pedal - which is currentlybNOT WORKING either!!
        • 1
        • ·
        • September 20, 2021
    • jkay898
      jkay898 On reflection it also seems to be important that the pedal is connected to the computer BEFORE the updater is launched - but you can't read those instructions until you launch the updater. Chicken and egg.
      • October 18, 2020
    • jkay898
      kirtandiamond

      • December 12, 2021
  • yavuz
    Newcomer - Level 1
    2020-09-02

    Hi everyone, 

    I have watched the tips video of Plethora X5. There was a question there about renaming the boards.
    The question was not answered in the video. How can we rename the boards?

    Thanks

    0 1,115
    • yavuz
      Dale_M Hi Yavuz

      you can rename them in the board organizer that is part of the TonePrint app:
      -swipe board you want to change to the left to reveal the "RENAME" function of selected board.

      You can (if you wish) do this to allboards..
      you can also delete all factory content (boards, toneprints) and build your own library of custom toneprints /boards with any name you like!
      • September 2, 2020
      • Is it possible to rename the boards in Plethora X5?
        yavuz Duh Of course . I have not thought of swiping right or left. Thank you very much..
        • 1
        • ·
        • September 2, 2020
  • New
    Simon_Ford
    Newcomer - Level 2
    2021-01-28

    I very much like the Plethora X5.

    I have set up a 'Custom Mode' on my Novation Launchpad Pro Mk3 to manipulate the various CC settings available under Plethora X5 Settings>Global>MIDI>CC Table, and this works brilliantly, as documented, though I share the view of another thread here about the Looper controls.

    However, an undocumented feature is sending Program Change (PC) messages and seeing the Plethora switch to the relevantly numbered Board. Is there a way to avoid this behaviour, or do I just need to set the Plethora and Launchpad to communicate on a less commonly used MIDI Channel?

    read more...
    0 1,100
    • Simon_Ford
      WilliamR MIDI channel select -
      Select which MIDI Channel your Plethora receives and listens to
      SETTINGS > GLOBAL > MIDI > CHANNEL SELECT
      • MIDI PC –

      You can directly recall any BOARD on PLETHORA by sending it a PC (Program
      Change) message with the corresponding number
      • MIDI CC -
      Udated CC control mapping for following items
      - BOARD UP/DOWN
      - PEDAL 1 – 5 (Engage/Bypass)
      - HOT KNOBZ (Also allows remote control of parameter knobs in EDIT MODE)
      - Looper Controls
      • MIDI CC MAPPNG – For a complete mapping table of all MIDI CC controllable
      features, navigate to
      SETTINGS > GLOBAL > MIDI > CC TABLE
      The foot switches of your Plethora can now be remote controlled via Midi using CC to BYPASS and
      ENGAGE the pedals on your board.
      CC 102 = FS1
      CC 103 = FS2
      CC 104 = FS3
      CC 105 = FS4
      CC 106 = FS5
      CC Values
      0-63 = Bypass
      64-127 = Engage
      • January 28, 2021
      • Plethora X5 Undocumented MIDI responses
        Simon_Ford WilliamR, thank you for your response.
        • January 28, 2021
      • Plethora X5 Undocumented MIDI responses
        Simon_Ford I have the Plethora in the same MIDI chain as an external sound module. What took me by surprise was that sending a PC to change the instrument in the sound module also caused the Plethora board to change.
        • January 28, 2021
    • Simon_Ford
      ShaunC

      Hi William. Do you know if I can control the 2nd FSW Function with MIDI? This way I can assign a BPM to the Delay and Tap Tremolo using an external footswitch/MIDI device and save the Mash footswitches from heavy wear and tear.

      • Jul 30
  • CSurieux
    Contributor - Level 2
    2020-06-17
    Hello, I can't use it without :
    1) External clock sync on midi,
    2) Global tap tempo cross boards ( this is partly related to 1°) ,
    3) Accept external midi CC for external expression pedals,
    4) Accept external midi CC to drive some parameters,
    5) Possibility to 'invert' the expression pedal values (and the midi CC max and min) by effect in order to increase one while decreasing another (as delay and tremolo for example),
    6) Midi going also in and out from usb with a setting to fix its mode : USB, USB+DIN, DIN.
    Thanks and courage
    Best
    read more...
    2 942
    • CSurieux
      TC-Mike thx for the feedback Christian, i passed it on to the team. Support for Midi clock support was already on the list with 6 votes atm. ? Global tap tempo has been requested by other too. best regards from the Tc tribers
      • June 22, 2020
      • Plethora X5 : Request for features
        CSurieux Thanks, I received it today, very nice piece of linux .
        I also commented the expression pedal area upper.
        Best
        • 1
        • ·
        • June 22, 2020
    • CSurieux
      bigpocketmusic Hello TC Mike, please add my vote for Midi Clock support to be added. Thanks
      • July 6, 2020
    • CSurieux
      AZCoyoteGear

      Did Envelope Filter make it into the list of coming features?

      • Jul 31
  • lgpocairossi
    Newcomer - Level 1
    2020-09-09

    Hello everyone.

    I just got a dream realized recently, and just got an G-System. Since 10 years I'm a Nova System user, and decided to give me this full upgrade. I am so happy that it got very well.

    I got an used gear, and I am having some issues about connecting to nova drive. The version that shows on G-System is the V4.05 R1781.

    Actually I give to a techinician made the MIDI CABLE (following this image), but I'm almost sure that the connections are wrong. When the loop cables are connected, and midi cables are in g-system, when i connect nova drive, it doesn't shows anything on the menu. When i search on the edit options, either.

    Of course I tried to look to buy it. But I live in brazil an things here are totol hard to find and very expensive to buy. And if we import it tooks several months...

    Could you help me about build my own cable? I have no skills for reading this diagram. Would be very thankfull if you can show me the easiest (and dumbest HAHAHA) way to do it.

    Thanks to everyone!!

    read more...
    1 828
    • lgpocairossi
      DavidKnighton Hello lgpocairossi,
      Sorry for the crude diagram, but I hope this simplifies what you're trying to achieve, based on the diagram you provided.
      • September 8, 2020
    • lgpocairossi
      TC-Mike Hi lgpocairossi, i'll check with the team if we have some more info available on the Midi Y-split cable. Yoiur G-system firmware supports Nova Drive Midi ntegration.
      • September 9, 2020
    • lgpocairossi
      lgpocairossi Guys! I Really appreciate it! With this connection I could made G sys recgnize nova drive (but I did not have time to try with the guitar yet, so I don't know if there is any hum).So I have one more doubt. In the diagram that I uploaded, It shows the pin 1 of the P1 (out) connector inside a triangle. Does it means something? Like put the pin 1 with the ground wires? Thanks again!!
      • September 9, 2020
  • New
    Skibodeau
    Newcomer - Level 1
    2021-02-22

    Hi,

    I'm running the Plethora with the 4 cables method correctly set up (guitar -> Plethora L in -> Plethora fx send to amp in -> amp fx send to Plethora return -> Plethora L out to amp return).

    Whenever I make some sort of operation (changing pedalboard, swapping pedals, changing toneprint, loading pedal in a slot) while the Plethora is processing (a half second maybe?) there is a crazy volume increase as if my amp was jumping to its max volume.

    If I run the Plethora in front of the amp, issue doesn't occur. You can only hear that the unit kind of bypasses all effects for half a second.

    Issue occurs on both true bypass and buffered mode.

    Anyone else having this problem?

    Amp is an Egnater Rebel 20.

    read more...
    0 635
    • Skibodeau
      PedroRodrigues Hi Skibodeau have you confirm that you have set up your four cable on PLETHORA X5 as per picture below. Please confirm by checking the videos presnet on the link below and https://www.youtube.com/watch?v=STMU5G1gND0 https://www.youtube.com/watch?v=fY_xM8HP0SI
      • February 23, 2021
      • Plethora X5 - 4 cables method volume issue
        Skibodeau Yes that's exactly how I hooked it up, like I wrote.
        • February 23, 2021
    • Skibodeau
      Skibodeau Here, I've made a video so you can hear what happens :

      First half of video, PX5 plugged direct in front of amp. Some slight volume glitch sometimes when switching boards but not too bad.

      Second half of video, PX5 plugged 4CM. Huge volume jump whenever making operations.

      https://youtu.be/8aY51NxzZXM
      • February 23, 2021
    • Skibodeau
      Skibodeau I did a lot of tests and figured out what is happening.

      When using the 4 cable method, the PX5 mono output goes straight into the amp's fx return. In the case of my amp, this is straight into the power amp which is post master level (i.e. If I plug just my guitar straight into the amp fx return, it bypasses all controls and I have no control over volume, it is very loud).

      So when the PX5 does any kind of processing, the signal going from its effect send is cut out. Since this is the signal that is hitting the front of the amp, the amp suddenly receives signal only at its the return point. In the video I did, the amp was set to be quieter than its power amp level, which explain the volume jump. So whenever the PX5 is processing, it acts just like I was pulling out the cable from the front of the amp.

      Since the PX5 fx loop is part of boards this will always happen as it has to reset every time boards are switched. I mean, I don't think my unit is defective, it's more the way it is designed.

      There are two ways that I think this could be fixed :

      1 - That somehow, the signal would not cut out from the PX5 fx send out while it is processing

      or 2 - That the signal would be cut out from both the fx send and stereo outputs during processing so that it goes completely silent

      I have no idea if either ways are technically possible. But I'd like to be confirmed that I'm right about what's going on. I don't want to get into the process of returning the unit and wait for it to get back only to learn that it's the way it is designed and there is nothing to do.

      Thanks!
      • February 24, 2021
    • Skibodeau
      eld3rlyy Hi there,
      I was just about to post the same issue and found this post.

      I have a pedal board containing the Plethora X5
      The PX5 is wired with 4CM as mentioned above to a PRS MT15 amp.

      When switching between boards, or changing pedals/toneprints in a specific board in edit mode there is an unbearable jump in volume, similar to what OP described here.

      This happens even if an expression pedal configured as volume pedal for pedal is placed in the heel-down position which is supposed to cut down all volume.
      I have also tried using a JHS Little Amp Black Box (essentially a master volume in the loop) before the PX5 to attenuate the amp - still the same issue.

      4CM is essential to have some PX5 effects in front of the amp and some in the loop.
      This issue is very significant and may lead to hearing damage.
      Please fix it.
      • February 25, 2021
      • Plethora X5 - 4 cables method volume issue
        Skibodeau Hi eld3rlyy,

        I did some tests and here is what I believe is happening. When the PX5 is processing (switching boards, swapping pedals, etc.) the signal that goes out the fx send is temporarily cut while the signal going out the main output remains. When in 4CM, the main output is going straight in the amp fx return. In some amps, the return is after the master volume. So what I guess happens, is the amp stops receiving signal in the front preamp but keeps receiving in its fx return so it bypasses the whole preamp and let the signal flow directly in the power amp at full volume.

        I did another another video where you can hear what happens with both outputs separately when playing (main & fx send) :

        https://youtu.be/7q3YrUw5NMo

        This really needs some sort of fixing. Indeed it could lead to hearing damage (on a bigger amp this could be really nasty). This could also go really wrong on a gig. Best way to drive any soundman mad.

        I did submit an assistance request but I suggest you do it too. I guess the more people mention it, there's more chances it is taken seriously.
        • February 25, 2021
      • Plethora X5 - 4 cables method volume issue
        eld3rlyy Thanks skibodeau. That has alot of sense. Theres all sorts of weird things with 4CM on PX5, when moving the amp to standby and then turning on again sometimes it will lose the signal aswell. Switching boards/toneprints or pedals/pedal order not only increases volume but sometimes adds a pop that goes through the plethora fx chain so its high volume and also repeated by PX5 delay if its on. Ive also submitted a ticket on the issue.
        • 1
        • ·
        • February 26, 2021
  • New
    nmanning999
    Newcomer - Level 1
    2020-11-08

    Just got got a new ditto - the ditto+.

    I cannot get the pedal to store a loop I make on the pedal. It will store a pc transferred .wav. However, all my other Ditto's always store the current loop when powered down. Just using it the same way as I have on my X2 and normal ditto, and it doesn't behave the same. Am I missing something?

    I can record a loop, double tap to stop. If I either change location or power off the pedal, there is nothing left in that location

    I did flash the firmware as soon as I got the +, so it was the latest. 

    Not sure what else I can do really.

    Any ideas appreciated.

    Nick

    read more...
    0 557
    • nmanning999
      PedroRodrigues Hi Nick have you deleted the Loop before storing the new one? Have you tried to perform a factory reset on your unit?
      Please press and hold previous + next + Foot switch for 13 seconds

      Please confirm that when connecting pedal to USB (disk mode) and when you look into the track folder that there is no audio file in there.
      • November 9, 2020
      • Ditto+ won't store loops
        nmanning999 hi Pedro - the factory reset looks like it has done the trick. The pedal now stores the current loop! Thank you so much for the advice and prompt response. Regards - Nick
        • November 9, 2020
  • New
    DHSG
    Newcomer - Level 1
    2021-03-30

    I programmed my looper to change board in the Plethora. There are 5 presets in the looper and 5 boards in the Plethora for them. Preset 1 selects board 1 with MIDI PC 000, Preset 2 board 2 with PC 001 and so on. With this setup there are three problems:

    1) Board switching takes 1s which is a bit slow for some songs.

    2) Even when the same noisegate with the same settings is in both boards, it goes off when switching. This is very annoying and can cause some nasty feedback.

    3) When switching via MIDI, effect 2 gets switched on in the Plethora. This is not the case when toggling through the board via the small knob on the Plethora. Only the one MIDI PC stated above is send by the looper. 

    Are these known bugs? If yes, when will they get fixed?
    Or are there any ideas how I can solve these issues?

     

    read more...
    0 538
    • DHSG
      WilliamR Hello, William from musictribe here. CC changes turning pedals on and off within a selected board would be faster than the board changes via pc commands. The plethora was designed to be used in more of a selectable stompbox pedalboard setup, so the delay in switching the boards is normal behavior for the plethora.
      • March 30, 2021
      • Problems with Plethora X5 MIDI switching
        DHSG Dear William.
        Thanks a lot for your fast reply.

        I already assumed, that working this way was not the idea of Plethora. It's pitty, because now I will be using the same single board and the same 5 effects for all my presets and 126 boards will be unused - perhaps I can use a second one for experiments.

        Can I change the effect settings via MIDI?
        I would like to control the three settings or the toneprint like in edit mode. As far as I understand right now, I could only change the hot knobs, meaning just 3 parameters for the whole board!
        • March 30, 2021
Go to page