Statistics

228,629 members
103,537 posts
  • New
    dbmccommas1
    Newcomer - Level 1
    2020-12-20

    TC Helicon VoiceLive Rack

    Is this product atill being manufactured?

    read more...
    0 100
    • dbmccommas1
      PedroRodrigues Hi David, please be aware that the VOICELIVE RACK is discontinued for some time now. Thank you
      • December 21, 2020
      • TC Helicon VoiceLive Rack
        obrys Hi Pedro.
        Does TC Helicon voice live rack is still discontinued? I asked about it in online music shop in my country and they told me that they are able to provide new unit but I'll have to wait a few weeks.
        Does TC Helicon plan to release voice live rack 2 ?
        • 1
        • ·
        • Mar 20
    • dbmccommas1
      GillC Hi Pedro, have you ever had an issue with the older Harmony Control Guitar pedal, where all I get is this (see pic) when I connect it to my VoiceLive processor?

      I have followed religiously the set up instructions and all I get is the following on the front of the pedal. All lights illuminated in red, no ability to use the Tuner to tune my guitar, no sound through into the amp and the midi cables aren't connecting the Voice Live.

      I fear that the bank of red lights tell me something is wrong and nothing is registering at all.

      I have tried multiple 1/4 inch jack cables and two guitars, two amps and no life.

      Can you help please?



      Thanks

      Gill
      • December 22, 2020
      • TC Helicon VoiceLive Rack
        PedroRodrigues Hi Gill please try to perform a factory reset on your unit. To reset the unit, insert

        the power connector while holding the two-foot switches.
        • Jan 4
    • dbmccommas1
      GillC Hey Pedro, thanks for coming back to me - soooo helpful. I just wish it had worked. I got a flash of 2 green lights and then the unit returned to the red light formation above... Any other ideas? Thanks so much
      • Jan 8
      • TC Helicon VoiceLive Rack
        PedroRodrigues Hi GillC sorry unfortunately if you are using the correct PSU my suggesting will be to get your unit repair. For that please follow the link below to contact one of our partners to be bale to get your unit inspected https://www.tc-helicon.com/buy.html?type=POS
        • Jan 11
    • dbmccommas1
      GillC Thanks so much Pedro, I am definitely using the correct power supply. :-( I live in Cape Town, South Africa - I assume there may not be TCHelicon partner able to help in SA? I also assume it is not the cable I am using to connect my guitar - does it need to be a balanced or stereo jack cable perhaps? Thanks again so much for your assistance Gill
      • Jan 12
  • zachdighans
    Newcomer - Level 1
    2020-08-05

    Hello all,

     

    I wanted to inquire about an issue I am having with my vocal pedal... I seem to have the right power supply for it (the 12 V 400 mA) and the pedal lights up indicating that it is on... although there is no output from the pedal, and turning the mic gain knob on the left of the pedal does nothing to increase volume. This is especially noticeable when I got to record vocals via my DAW using the pedal. Could this be a power supply issue or an issue within the pedal itself? If anyone has any tips or maybe a way to use the product number to have it sent and fixed/checked out that would be so helpful. 

    thanks so much,

    Zach 

     

    read more...
    0 65
    • zachdighans
      WilliamR Hello, Sometimes issues like this can be cleared up with a firmware update. Make sure when you run the voice support 2 software that there are no web browsers open while you are running voice support 2 as it tends to interfere with the detection of the device.



      1. Download and install VoiceSupport2 software from here.



      https://www.tc-helicon.com/Categories/Tchelicon/Vocal/Apps/VOICESUPPORT-2/p/P0CMP/Downloads#googtrans(en|en)



      2. Connect the device to PC / Mac with USB and turn on the power.



      3. Start VoiceSupport2.



      4.VoiceSupport2 recognizes the device, and if there is the latest update, an update mark will be added to the device image.



      5. Select Update in the upper tab, click the latest firmware and try the update.
      • August 6, 2020
  • New
    JanFranzen
    Contributor - Level 2
    2021-01-29

    Hi Peeps,

     

    I've got a vocal preset on my Voicelive 3 with a few effects: bright plate reverb, harmony high&higher, double and european choir. And the sound coming out has got glitches here and there. Does anybody know what this is and how to get it fixed?

     

    Thanks in advance!

    read more...
    0 38
    • JanFranzen
      PedroRodrigues Hi, JanFranzen I would suggest to confirm if your unit is running the latest firmware update, please use VOICESUPPORT 2 to perform the update. Please also confirm your connection and the respective cable and consider that the unit must be connected directly to your computer via USB 2.0 port. Please also consider that the sample rate for any imported files for this unit i must be 16 bit 48KHZ.
      • Feb 2
      • Voicelive 3 vocal audio glitches
        JanFranzen Hi Pedro, thanks for your reply. Latest firmware is installed and my voicelive is connected with XLR cable to my audio interface. So all of the above is not the problem. I think maybe the amount of effects is just too much for the thing. Which would be weird, cause it is made to produce many effects at the same time.
        • Feb 2
      • Voicelive 3 vocal audio glitches
        PetGerbil Have you got the "compressor" on ? Try turning it off...Also try turning the "Gate" off.
        • 1
        • ·
        • Feb 2
  • New
    Jeffmac555
    Newcomer - Level 1
    2021-03-17

    Hello . My mic looper is buzzing a lot when using a condenser mic. When using a dynamic mic it's great . Any advice ? Thank you 

    0 35
  • New
    MattDavis
    Newcomer - Level 1
    2021-01-30

    My wife and I are career working musicians. I bought her a VLX3 for Christmas and there is intermittent bad crackling when she kicks on the harmonizer. Have dialed the gain back from 25 to 15 and still happening. I think we turned on the clip killer but it isn't clipping. She's using a Super 55 and the dynamic mic setting. Any advice? 

    read more...
    0 30
    • MattDavis
      john0121 Hi Matt, I would recommend to fill out the Tech Support form via the Support button at the top of the page. One of the team can go through some settings and troubleshooting with you and help get this resolved. Thanks
      • Feb 1
  • New
    ttsing4u
    Newcomer - Level 1
    2021-01-03

    I have a TChelicon Play Acoustic which tracks very well.

    My ExtremeLive 3 doesn't want to track regardless of using MIDI in from the keyboard, Guitar in from Guitar or Roomsense or Natural Play. Nothing seems to make it see the proper chord. It does occassionally do major chords but not well. I need help.

     

    Using Global Settings:

    I've switched from everyone, MIDI, Guitar, Autosense etc. and saved after each change and even powered off and on. I've tried some of the factory harmony settings as well as my own and they all respond the same. Not usuable live.

    I've turned OFF Natural Play Roomsense etc. and gone with the above settings to see if that was confusing it. Same result.

    read more...
    0 28
    • ttsing4u
      PedroRodrigues Hi Tom, please be aware that for the sync/backing track , you'll never get it perfect since the MET in the VL3 isn't the same as the tempo that's recorded on the track. Even if you set the tempo the same in VL3 as you know it is on the track, the two have no way to "talk" and make sure they stay in some sort of sync. You'd need MIDI clock from/to both devices for that I would suggest the use of a DAW.
      What you end up with is 2 tempos that are actually the same, but ever so slightly "off" when it comes to the beats themselves. You end up with the slight timing differences adding up over time and eventually they'll be playing on opposite down/up beats and then come back together again after more time.
      For the erase, that's common when you're using the Play button to erase.
      If you don't want the "burp" you can use the Erase button from the UTIL menu.
      The Looper level in the Mix menu affects the recorded volume of the loop, but that's global so you can't turn down one loop and then turn up the next Slot/Track.
      • Jan 4
      • Harmony NOT tracking with any setting
        ttsing4u I'm not using tracks. I was referring to using the guitar or keyboard as the source to follow (track) the chord structure for vocal harmonies. I've been watching it between songs and the song might be in A and the harmonizer sees it in which throws out horrible harmonies. Then sometimes it finds the correct key but doesn't respond to minor or major 7 chords only the major ones. I'm playing bass, wife on keyboard and even with the internal mic settings it still doesn't listen or hear the proper chords changes to keep the vocal harmonies correct.
        • Jan 4