268,842 members
148,478 posts
  • New
    Newcomer - Level 1

    Dear Behringer Support Team,

    I am a happy user of the X-Touch with X-Air mixers.

    Recently I purchased an X-Touch Extender and hoped it would indeed "extend" the X-Touch by allowing a 16 channel control alongside the X-Touch with all those nice features and colored scribble strips.

    However, the X-Touch Extender does currently not support the XCTL mode (I am using OSIMIDI to partially fill the gap). And I am wondering, how those colored scribble strips came to the product pictures as I have not found any means even by using the syssex commands from the Quick Start Guide in the Extender's "CTRL" mode.

    So I am wondering: Is a firmware update planned for the X-Touch Extender to add the XCTL protocol and to enable a "real" extension of the X-Touch towards 16 channels control with all the nice XCTL features?

    I am sure this would provide you with a huge success for this combination - including a nomination for the Grammy Awards ;-).

    Thanks for your efforts in answering.

    Best regards



    8 751,141
    • MichaelF000
      skshaw I too also want to do the same thing as Michael. When will you put out an update to add XCTL to the Extender?
      • December 5, 2020
    • MichaelF000
      JamesOLeary I have searched all over for that answer, It sounds like Behringer is okay with promoting false advertising. All of the product pages show colored scribble strips yet according to the company it's not possible. In my opinion, I think we have been duped by the developers. I don't think it would ever get to the BBB but it would help if Behringer showed some transparency by showing the actual use of the extender in conjunction with the X-Touch. Their silence to all of the posts in reference to this constantly pursued request is deafening. None of the requests in the community seem to be too outlandish, If it cannot be included in a firmware update or some USB-midi workaround then we should demand they send out refunds for false advertising. just look at any image on the internet for reference. " colors." They got our hopes up, can you imagine what a setup would look like with say 3 extenders cascaded and all the colors lit up?. At this point, they are just hoping consumers would just stop asking about it. It is clear they're not interested in problem-solving. just profits. If this it not the case... Change my mind Behringer!!!
      • March 24, 2021
    • MichaelF000
      Keksstar Behringer - where´s your long awaited answer? It´s so sad they don´t reply to this. The X-Touch Extender really needs the XCtrl protocol. It can´t be that hard for the Devs, as we´re speaking about nearly the same hardware. Just less buttons.
      I also see this as false advertisting as the functions shown are not working.
      • May 13, 2021
    • MichaelF000

      An implementation and integration of the XCtrl protocol for the X-Touch extender would be indeed a very useful feature

      • June 17, 2021
    • MichaelF000

      I also wanted to see the Xctrl mode for my x-touch extender. I first got my xtouch it works fine with my x32 rack. but after waiting for over 2 months to get my extender only to fine out it doesn't work with the x32 rack like the adds have you believe. Behringer has caused a lot of distrust on this one. Uli be a man and tell us if you plan to fix this or you going to leave

      • June 25, 2021
  • New
    Contributor - Level 2

    Why can't xtouch extender hookup to x32 rack with ethernet, 

    Xtouch can. Why did Behringer  not add that to the latest firmware upgrade?

    0 36,546
  • New
    Newcomer - Level 1

    My X-Touch One is not working on my Macbook Pro M1 with Big Sur. 


    It sends MIDI command correctly (so all buttons and the fader work) but it won't receive anything back from the platform. No LEDs will turn on, the scribble screen stays blank and most importantly, the fader is stuck at 0. 


    Are you aware of the issue, any beta firmware to download?



    0 876
    • MatteAce
      PedroRodrigues Hi Matteo, at this moment we still do not advise our customer to update to Big Sur, as we are still developing solutions for this only possible after the operating system was released and we do not have any time window for a implementation release . Thank you
      • November 26, 2020
      • X-Touch One on Apple M1/Big Sur not working
        MatteAce this is not an option, since I had to update my mbp to an M1 Mac. I don't understand why it takes so long, Big Sur has been in public beta for more than 6 months, and for devs Apple sent M1 computers for testing and development purposes?
        • 1
        • ·
        • November 30, 2020
    • MatteAce

      I have this problems also no feedback on display strips stay blank and the fader also go back to 00, how to resolve this problem, please help !

      • October 1, 2021
    • MatteAce

      I also have this problem. I had to update as I use my Mac for work. I can't use this at all at the moment. Shall I sell it? I don't know what to do.

      • December 4, 2021
  • PatrickCorrigan
    Contributor - Level 1
    The documentation shows that USB is supported in this mode. If I select MC mode I do have the USB option, and I can connect to my DAW in that mode. If I select Xctl/MC mode I only have Network and MIDI options and cannot connect to my DAW via USB. Does anyone know how to fix this? Thanks.
    0 641
    • PatrickCorrigan
      DaveMorrison In Xctl/MC Mode, The DAW is alway connected by USB; thus, there is no choice. The Xctl section has the choice of Network or MIDI DIN to connect to the mixer.
      • June 30, 2020
      • X-Touch No USB option in Xctl/MC Mode
        PatrickCorrigan MC is how I'm connecting to the DAW over USB. Xctl connects to my XR18. As I said, if I select MC only, I have a USB option, which connects to my DAW. If I select Xctl/MC, I only have Network and MIDI options, and I cannot communicate with my DAW via USB.
        • June 30, 2020
    • PatrickCorrigan
      DaveMorrison I under standyour connection scheme and it is correct. If the system is working correctly in Xctl/MC mode, your DAW is supposed to connect using MC protocol over USB. The transport buttons will control the DAW and the faders change depending on SMPTE/beats button. If it's not working, something is wrong with your X-Touch.
      When you're in Xctl/MC mode can your computer see the USB device (you can check in "system report")?
      • June 30, 2020
    • PatrickCorrigan
      ChrisJanton Have you pressed the "SMPTE/BEATS" button on the right of the display? That switches from XCTL to MCU
      • July 17, 2020
  • romainr
    Newcomer - Level 1
    I just bought an xtouch controller, everything works but the faders do not line up. When starting LogicPro, some go to 0, and others go to -10db (while the software is indeed at 0). Is there a software or a manipulation that allows to calibrate them?
    thank you in advance
    0 607
  • TheEngraver
    Newcomer - Level 1

    Hello. I am interested in purchasing a Behringer X-Touch One or X-Touch Compact. But I absolutely need to know one thing. Is it possible, in both models, to map the Faders so that they become midi controllers, instead of volume controllers? That is, can I assign a midi controller, such as CC1 (modwheel) or CC11 (expression), etc. to the Fader of the X-touch One and those of the Compact? I work with Cubase Pro 9.5 and 10.5. Thanks a lot.

    0 555
    • TheEngraver
      leah Hello @TheEngraver ,

      If you're looking for customizable controls, you'll want to use either the X-TOUCH COMPACT or X-TOUCH MINI. Both of these devices are compatible with our X-TOUCH Editor software. The software will allow you to customize the assigned CC and PC messages that each button/fader/encoder will send out to your DAW.

      The X-TOUCH, X-TOUCH ONE, and X-TOUCH EXTENDER are not customizable and are compatible with MCU, HUI, and XCTRL protocols.

      X-TOUCH MINI -

      Hope this helps!
      • October 2, 2020
      • X-touch One and Compact mapping fader
        TheEngraver Ouff.....i was hoping on the One.... Ok, many thanks! :-)
        • 1
        • ·
        • October 2, 2020
      • X-touch One and Compact mapping fader
        TheEngraver Hi Leah. So, I've been looking for products similar to X-Touch One, but none of them have the ability to map single fader to drive MIDI CCs. So I looked for products similar to the X-Touch Compact. I had found a couple, especially one (from a company I will not mention) that from the description, from the operating manual, and from the videos on youtube, allowed to configure the 9 faders in the way I need. But then several recent comments on the videos reported complaints from users that they couldn't do it. I literally collided with the technical support of this company, which showed incompetence, lack of seriousness, and unfairness, since they do not mention the fact that with the recent firmware updates, the software to map the commands no longer allows this thing. So I decided to send them to hell and only consider the X-Touch Compact. But I have to be sure to spend money having the product that meets my needs, so I ask you: can you confirm that with the Compact I can configure the faders to control all the MIDI CCs and not just the volume (in Cubase Pro 9.5 and 10.5)? Are there any problems with the latest firmware updates in this regard? And above all (since it is a product that is now a few years old), is the release of a new version of the Compact planned in a more or less short time? Thanks a lot.
        • October 15, 2020
      • X-touch One and Compact mapping fader
        TheEngraver Hi Leah. Could I please have an answer? Thanks a lot.
        • October 21, 2020
  • New
    Newcomer - Level 1

    Hello, I recently purchaed an X Touch One, and according to the instructions, I should be able to use a standard midi sustain pedal as a record-toggle footswitch with Logic Pro X. However, when I plug a pedal into the jack on the back of the unit and press the footswitch, the unit seems to get confused. It gets stuck in a glitchy recording loop inside Logic Pro, and the lights on the X Touch One go all haywire. The only remedy is to power off the unit and unplug the footswitch.

    I've tried using two different footswtiches, both standard 1/4" midi sustain pedals, and the unit exhibits the same behavoir, no matter which one is connected. Please note, I'm running the X Touch One firmware to the latest version (v.1.08) and using the X Touch One in the Logic configuration.

    Am I missing something? Is there anything specific I need to do inside Logic to properly set up the unit so it recognizes the record-toggle command doesn't get confused? Or do I have a defective unit.


    Dan B.

    0 510
    • danbaileyak
      PedroRodrigues Hi danbaileyak, I believe you have the unit on MC mode to operate with LOGIC have you tried to set up the unit in MIDI mode to control your pedal.
      If you are using the X-TOUCH ONE in a MIDI mode, select it in your DAW as a MIDI controller. Please confirm with your DAW’s MIDI Learn functions, and you will be able to map each button and feature of the X-TOUCH ONE to a function and control on your DAW.
      Please assign the unit to MIDI mode and please confirm that you have assigned the following message for your pedal as per below :
      MIDI Send CC
      Foot Switch: Control Change 64 (push: value 127, release: value 0)
      MIDI Send Note
      Foot Switch: Control Change 64 (push: value 127, release: value 0)
      I hope this helps
      • January 29, 2021
    • danbaileyak
      danbaileyak Thank you for getting back to me. I am currently using the X Touch One in LOGIC Mode. I prefer to use it this way, so that I don't have to reassign all of the buttons on the unit. By default, in Logic Mode, Pedal A is set to "Play or Stop," but as you saw in my video, this doesn't seem to work correctly. If I plug the footswitch into a different midi interface, I can get it to work just fine, so that's why I'm wondering if there's something wrong with my X Touch One, or if it simply doesn't work properly with the sustain pedal footswitch.
      • January 29, 2021
      • X Touch One Footswitch Problem
        PedroRodrigues Hi danbaileyak, form your description it seem that this is a matter that is related with your DAW MIDI implementation, as you stated the unit work with the Pedal work just not the way you wish to implement. I this case I would suggest to search for information on LOGIC support. Thank you
        • February 2, 2021
  • New
    Newcomer - Level 1

    Hello everyone,

    is it possible to change the scribble strips by using the xTouch in xCtrl mode while mixing a bus, so I can see the name of the input?
    Sometimes it's hard to keep track of which channel you are mixing for.

    So instead of showing the "sends mode" for each channel

    the name is shown (like viewing the main mix)

    0 477
  • New
    Newcomer - Level 1

    I am trying to find out a way to change the footswitch function to punch in/punch out.

    Behringer has a program that allows this for the regular X Touch, but it seems there isn't one for the X Touch One.

    I haven't found any documentation for this, can anyone help me?

    0 342
    • Robbinsegg1
      WilliamR 1. The device ID for x-touch one is 0x41
      2. Make sure the x-touch one is in MIDI or CC mode, otherwise it will behave like a Mackie unit with emulation of the 8 fader blocks
      Protocol in MIDI/CC mode:
      X-Touch-one MIDI mode implementation:
      Buttons (standard MIDI mode):
      - Note on #0..34 (push: velocity 127, release: velocity 0)
      Buttons (MIDI CC mode):
      - CC #0..34 (push: value 127, release: value 0)
      Button Leds:
      - Note on #0..34 (velocity 0..63: off, velocity 64: flash, velocity
      65..127: on)
      - CC #0..34 (value 0..63: off, value 64: flash, value 65..127: on)
      - Control change 70 (receive and transmit)
      Fader Touch:
      - Note on #110 (touch: velocity 127, release: velocity 0)
      - absolute mode: Control change 80 (value 0..127)
      - relative mode: Control change 80 (increment: value 65, decrement: value 1)
      Encoder Ring:
      - Control change 80 (value 0..127)
      Jog Wheel:
      - Control change 88 (turn CW: value 65, CCW: value 1)
      Meter Leds:
      - Control change 90 (value 0..127)
      Foot Switch:
      - Control change 64 (push: velocity 127, release: velocity 0)
      - sysex (hex) F0 00 20 32 41 4C 00 cc c1 .. c14 F7
        - cc: bits 0-2: backlight color (black, red, green, yellow, blue, magenta, cyan, white)
        - cc: bit 4: invert upper half of LCD
        - cc: bit 5: invert lower half of LCD
        - c1..c14: ascii characters (1..7: upper half, 8..14: lower half)
      Segment Displays:
      - sysex (hex) F0 00 20 32 41 37 s1 .. s12 d1 d2 F7
        - s1..s12: segment data (bit 0: segment a, .. bit 6: segment g)
        - d1: dots for displays 1..7 (bit 0: display 1, .. bit 6: display 7)
        - d2: dots for displays 8..12 (bit 0: display 8, .. bit 4: display 12)
      • February 19, 2021
    • Robbinsegg1
      Robbinsegg1 I thank you for replying. Sadly I’m not savvy on how to implement all of this info you’ve kindly supplied. The unit works as normal except for the footswitch, as far as I can tell. The way it behaves when the pedal is pressed is it goes into a rapid play stop, play stop, over and over. The only way to stop it is to unplug the pedal. I Logic Pro I tried to learn the pedal for record Toggle, but the same thing happens, just flashing repeated rapid record/stop instead.
      • February 19, 2021
  • DNovin
    Newcomer - Level 1

    Hi everyone,  

    I apologize if this has already been answered, but I searched and didn't see an answer.  

    I have the XTouch One, and I'm having a GREAT time with it.  However there is a feature I thought would be automatic that doesn't seem to exist, or I simply don't know how to configure it.

    When I use the Channel buttons on the XTouch One, it moves and controls the tracks in the mixer without issue.  However, if i select a track in Reaper, I was expecting the XTouch One to "jump" to that track, but it does not.  This seems like an oversight, or something that is "Wrong" in my eyes.  Having only one fader, it makes sense that the XT1 would jump to the selected track to help with workflow.

    Is there a setting I'm missing, or something I haven't done correctly to make this happen?


    0 311
Go to page