Statistics

229,583 members
104,650 posts
  • New
    davenov41
    Newcomer - Level 1
    2020-12-21

    Help! I've owned the TC Flashback II for a few months now and am loving it. Earlier this year I updated the firmware to use the tap tempo function and that was working fine. I came back to my pedal after a month off or so, and now for some reason, when engaged, I can only hear the delay output, and not the attack of the note itself. What I've done so far to troubleshoot: 

     

    - Pulled the pedal off the pedal board and isolated it as the only pedal in the signal chain between the guitar and the amp

    - Tried multiple different amps

    - Tried multiple different guitars

    - Verified that input is going into the pedal through MONO and exiting through MONO

    - Verified that true bypass and kill/dry dipswitches are set correctly (set to true bypass and off respectively, both oriented left)

    What are suggestions for next steps? Thank you!

    Dave

    read more...
    1 106
    • davenov41
      NicJonesMT Hi Dave.
      I'm Nic from the UK tech support team.
      Just to let you know I have picked up your Tech Support ticket and will be contacting you shortly.
      • December 23, 2020
      • TC Flashback II- only hearing delay, no dry?
        davenov41 Hi Nic- thanks so much for your reply. I received your email regarding my support ticket... I wasn't able to find a way to reply to the ticket from within the care portal, so I simply replied to the email. Please let me know if there's a better way to contact you! Thanks again for your help. Dave
        • December 23, 2020
    • davenov41
      TC-Mike Please check that the Kill dry switch is not set to "ON" . the dip switches can be reached by removing the back cover and more info on the positions /settings can be found in the manual. the second dip switch switches between "true-and buffered bypass" -Buffered bypass will retain the Delay repeats when pedal is bypassed
      • Jan 4
  • Nyfolk
    Newcomer - Level 1
    2020-06-23
    I have purchased another used M5000. When the unit is turned on, there is a message of "Serial Information Mismatch". I have tried to make contact at TC or Music Tribe to no avail. I would really hate to see this unit wind up as a door stop. Can someone direct me to someone who can get me a repair code? Thnak you!
    read more...
    0 101
    • Nyfolk
      RexBeckett I suggest that you open a Care ticket. At the top of this page, click Support -> Care -> Create a Care Ticket and select Type: Technical Support. Make sure that you enter all required (*) data before clicking Submit.
      • June 23, 2020
      • M5000 Serial Information Mismatch
        Nyfolk Good morning Rex, I have tried to do this already. The drop down menu does not include the M5000. Thank you!
        • June 23, 2020
      • M5000 Serial Information Mismatch
        Nyfolk I have followed the path to creating a care ticket. When I arrive at the request for model name, the M5000 is not listed. I do realize that this is a legacy product. Is there an email or phone number that I could reach out to discuss the issue and get resolution? I have had this issue many years ago and TC resolved this easily with a repair code. Thank you!
        • June 23, 2020
      • M5000 Serial Information Mismatch
        RexBeckett The usual solution for this is to use the model number of a similar product. Explain the reason in the problem description.

        The Care ticket is currently the only way to request technical support. Once the ticket is open, you should get a response by email. Keep watch on your email spam/junk folder.
        • June 23, 2020
    • Nyfolk
      Nigel67 Hi Nyfolk, if M5000 doesn't appear in the Product drop down, I would suggest choosing another TC Electronic product in the same category or as close as you can, and then put M5000 Help required in the Description and also Subject. If you want to reply on here with the case number, then I can pick up the case in the morning and assign it to the relevant person. Many thanks
      • June 23, 2020
      • M5000 Serial Information Mismatch
        Nyfolk Nigel, I have created a care ticket. The number is CAS-114126-V5B7Y8. Thank you!
        • June 23, 2020
      • M5000 Serial Information Mismatch
        Nigel67 I have your ticket and will pass it on to someone who can help.
        • June 24, 2020
      • M5000 Serial Information Mismatch
        slaterweezer Hi Nigel, I have the same issue today! If there is anyway at all you can help I would most appreciate it! My case number is: CAS-118452-P7M5G1
        • 1
        • ·
        • July 8, 2020
      • M5000 Serial Information Mismatch
        Nigel67 Hi slaterweezer, I have picked up your case. I think it is the same issue as Nyfolk which means having to change the internal battery. I will confirm this with a colleague in the morning and e-mail you back.
        • July 8, 2020
  • marvin54321
    Newcomer - Level 1
    2020-10-01

    Hi,

    is it possible to connect an external expression pedal to the "TC Electronic Flashback 2 Delay" and control the delay speed ?

    I use a tap tempo pedal in the "Stereo IN" jack, but an expression pedal connected with a TRS cable does not work. 

    Thanks

    read more...
    0 71
    • marvin54321
      WilliamR Hello Marvin, The Flashback 2 does not support an expression pedal. All expression functions are controlled in the mash button. The flashback 2X4 does support external expression pedals.
      • October 1, 2020
  • janmarchal
    Newcomer - Level 1
    2020-10-03

    I love the Flashback 2 delay, I bought it when it was updated with tap tempo. I also found the blinking led very useful, to always know in what tempo the pedal is. After a few months, I now want to experiment with the Mash and bought an external tap tempo. But when I enable the Mash, the led stops blinking! Why? TC, can you please do an update to have the blinking led in combination with Mash? That would be amazing. 

    read more...
    0 65
    • janmarchal
      PedroRodrigues Hi Jan Marchal Before anything I would suggest to update your pedal to FW version 1.2 (build 1222) this adds on your Flashback 2 a new optional tap tempo mode that retains true stereo operation and doesn’t need an external Tap tempo switch.
      Please follow the link below to access all the resources for this operation https://www.tcelectronic.com/tcelectronic/product?modelCode=P0CKR
      • October 5, 2020
    • janmarchal
      janmarchal Dear Pedro, thanks for your quick reply! Yes, i updated the firmware and i loved the internal tap tempo option and also the blinking led that shows the tempo. But now i want to use Mash (by adding an external tap tempo, i don’t use the stereo), but when I enable Mash the led stops blinking. Do you know if it’s possible to use Mash while having the blinking led? It would be great if the blinking led was an option that user can put on or off, not depending on using Mash. I hope this makes sense ;)
      • October 5, 2020
  • New
    BrandonBunn
    Newcomer - Level 1
    2020-11-02

    I can send artist toneprints to my pedal, but I am unable to edit anything in the library. It says that toneprint is not connected to the internet. It just says build 0007 - ac8eb647. I am using a Dell laptop with A HOF2 Reverb. When I originally purchased the pedal in February I was able to completely edit each preset.

    read more...
    0 63
  • Wreford
    Newcomer - Level 1
    2020-09-22

    I am not if this the correct area for this discussion but I have recently bought the TC electronics hall of fame 2 reverb pedal but there is no sound coming through at all. I was using a modular synth with sound out put through the pedal. The pedal peers on,  The red light comes on, the mash light comes on but no sound coming through. I have used other pedals the same way and these have worked fine. Is something I am missing with this particular pedal?

    read more...
    0 51
    • Wreford
      JasonB81 Hello John - If you have tried your other pedals with this same configuration and they work but your HOF2 does not - can you please click the support button above and create a support ticket? Someone from support will be able to follow up with you on the issue. Thank you for contacting us.
      • September 22, 2020
    • Wreford
      TC-Mike HI John, in general you need to attenuate your signal when going from your modular outputs to guitar pedals that is made to be operated at instrument level. the voltage of the audio signal that a modular synth outputs can be up to 10 times of line level (1vline level vs 10v modular) and pedals are just not able to handle this. When passing through filters and other modules the voltage lowers of course, but for trouble free operation and flexible integration of guitar pedals into your modular rig, you are well advised toconsider a module that handles level conversion for you (like an insert loop/amplifier moduler for guitar pedals) i can recommend the industrial electronics "black locust" module for flexibility as it has FX send /returns + dry/wet mix like on a mixer and supports 4 pedals. :-)
      https://www.thomann.de/gb/industrial_music_electronics_black_locust.htm
      There are also more cost effective solutions available from other manufacturers.
      • September 30, 2020
  • New
    maniatis1717a
    Newcomer - Level 1
    2020-11-23

    Hi .In the section  '' suggested solution ''  for Tc electronic Flashback 2 delay pedal, the answer to the question ''Why do the parameters reset when I try to save my edited Toneprint? '',  has a text and two pictures. The promblem is that the pictures are not visible.. so i can not understand  exactly the solution that is given. Is  there  a way to fix this .  Thank you

     

    read more...
    0 51
    • maniatis1717a
      ChrisEdwards1 Hi George, thank you for bringing this to our attention. I will look into getting the Article update and the pictures reimplemented. For the time being please see below, I hope this helps
      • November 23, 2020
    • maniatis1717a
      maniatis1717a thank you
      • November 23, 2020
  • Vittoriovibe
    Newcomer - Level 1
    2020-06-25
    Hi community, I purchased the flashback 2 x4 but I can't find the manual of the new toneprint editor because I can't understand how to save my presets on the PC and also I can't understand some parameters that are in the editor. finally, I couldn't even get the looper to work with the effects inserted, it only works without delay. Thanks for the help
    read more...
    0 49
    • Vittoriovibe
      Nigel67 Hi Vittoriovibe, please find the link below to the Editor Manual https://mediadl.musictribe.com/download/software/tcelectronic/tc-electronic-toneprint-editor-manual-english.pdf
      • June 25, 2020
    • Vittoriovibe
      Vittoriovibe Thanks a lot but the link it's the old editor, the new maybe still has not been released! You have a New flashback? Because the new manual of flashback 2 x4 it is not exhaustive and I was unable to solve the loop problem
      • June 26, 2020
    • Vittoriovibe
      Nigel67 Hi Vittoriovibe. The updated manual for the toneprint editor hasn't been finalised yet. A colleague will raise the question with the relevant team. I have put links below to TC You Tube videos which should help you in using your unit, including the toneprint editor. There are also many other videos buy other musicians that may help you as well if you make a search on the internet.
      https://www.youtube.com/watch?v=XJelHAoGTII
      https://www.youtube.com/watch?v=TmS2BBMU48A
      https://www.youtube.com/watch?v=SfIN63YMipw
      https://www.youtube.com/watch?time_continue=5&v=xBi9ikO6mT8&feature=emb_logo
      • June 29, 2020
    • Vittoriovibe
      Nigel67 Hi Vittoriovibe. The updated manual for the toneprint editor hasn't been finalised yet. A colleague will raise the question with the relevant team. I have put links below to TC You Tube videos which should help you in using your unit, including the toneprint editor. There are also many other videos buy other musicians that may help you as well if you make a search on the internet.
      https://www.youtube.com/watch?v=XJelHAoGTII
      https://www.youtube.com/watch?v=TmS2BBMU48A
      https://www.youtube.com/watch?v=SfIN63YMipw
      https://www.youtube.com/watch?time_continue=5&v=xBi9ikO6mT8&feature=emb_logo
      • June 29, 2020
    • Vittoriovibe
      fyxgy My M2000 has a dead battery
      • October 14, 2020
      • Help for new Editor flashback 2 x4
        Nigel67 Hi Mike, the battery inside is a LITHIUM BAT.. 3V/200mA. CR2032RV (Diameter 20mm x 3.2mm). It will require soldering into the pcb. If you want to send the unit in for repair, please go to the support tab at the top of the page and select the service option. You will fill out a form and a colleague will get back to you regarding servicing your unit. Many thanks
        • October 19, 2020
  • AhmadAk
    Newcomer - Level 1
    2020-07-10
    Hey there! Can anyone help me to know what is the last update for tc electronic system 6000 the black one not MKII?
    0 49
    • AhmadAk
      WilliamR The MKII Upgrade is recommended for all SYSTEM 6000 users as software release 5 will be the last for the original platform. System 6000 software, including system upgrades and new algorithms will only apply to SYSTEM 6000 MKII moving forward
      • July 16, 2020
    • AhmadAk
      WilliamR https://www.tcelectronic.com/tcelectronic/product?modelCode=P0CJW
      • July 16, 2020
  • TCsucks1
    Newcomer - Level 1
    2020-08-30

    I just got the Flashback 2. I programmed and stored a TonePrint but have found that if I leave the TonePrint to use a different delay type, when I go back to my stored TonePrint the settings are off because it now responds to where the knobs are physically set based on tweaking I did on the other delay type.

    Hopefully I'm doing something wrong because I was under the impression that stored TonePrints were like presets in that, once selected, would recall ALL programmed settings regardless of where the knobs are physically set.

     

    read more...
    0 47
    • TCsucks1
      Nigel67 The potentiometer (knob) values are not part of the Toneprint. They are mapped, however the the current parameter value/position of the toneprint that you have loaded in is not. The position that the pots are set to is what they will operate at.
      • September 2, 2020
      • Flashback 2 TonePrint problem
        Gegatso I'm having basically the same issue. New Flashback 2, using a Mac, Catalina 10.15.7. I made and saved a toneprint at my computer. Went to the amp and plugged up. Played around with some settings while NOT on bank 3 where my toneprint was saved. I went to use my pattern and It was still playing the pattern set by the dials. Am I doing something wrong? It seems too easy, but sometimes simplicity is when the problems creep in. Remember that it is my first day with the pedal, but I followed every step and it all seemed to work. The software showed all my settings right where I had the knobs set for my perfect sound. Much thanks in advance!
        • November 8, 2020
Go to page