Statistics

250,738 members
127,934 posts
  • New
    DougB
    Newcomer - Level 1
    2021-02-15

    The mimiq is fantastic with a mono input and stereo output to two separate amps.  Love it.    But I have a truly stereo pedal board.  For example, I have a Flashback II stereo delay and a stereo chorus before the Mimiq.  If I have a nice ping pong delay or a lush stereo chorus heading into the mimiq in stereo, the effects get mashed up and lost in the Mimiq.  What are the best recommendations for using stereo inputs to the mimiq?  How is it supposed to work - ie - what's the purpose served by stereo inputs.  Am I missing something? Should I focus on keeping it in the mono chain before the stereo effects? 

    read more...
    0 60
    • DougB
      PedroRodrigues Hi,DougB Please consider that the audio inputs on this pedal are standard 1/4" jacks (mono/TS), please connect your guitar to the mono audio input on the right side of your pedal using a regular 1/4" instrument cable, never the less the pedal also accepts stereo signals using a pair of 1/4" TS cables.
      • Feb 16
      • Mimiq - with stereo IN ????  What's the purpose?
        DougB Yes - that's my question. If I come out of a stereo chorus pedal - with a lush interesting stereo chorus on L+R and then go into the Mimiq with 2 x 1/4" cables, the Mimiq squishes the chorus channels together ruining the effect. I'm trying to think of an application where you'd put the Mimiq in the middle of a stereo chain and can't think of one. It seems that it should ONLY be a mono in, stereo out device. What am I missing?
        • 1
        • ·
        • Feb 16
      • Mimiq - with stereo IN ????  What's the purpose?
        PedroRodrigues Hi DougB as I mentioned above if you connect your guitar only to the mono audio input on the right side of your pedal using a regular 1/4" instrument cable you will have a mono signal arriving to the pedal. The pedal offers stereo and mono input
        • Feb 17
    • DougB
      drnct I'm a Hall of Fame 2 owner with the same question. What is the best way to use a stereo reverb or delay pedal with the MIMIQ? How is the stereo input (or output!) of the MIMIQ (not mono input) best used in this situation?
      • May 5
  • New
    marvinholdman
    Contributor - Level 1
    2021-07-26

    I have one of the first TC Helicon Play Acoustic you could get in the USA. So new, in fact, they didn't even label the buttons correctly! That said, it hit the ground running with me and has made this working musician thousands of dollars. I've loved it's simplicity (I ditchted the mixing board for it!). I don't use nearly all the features. In fact, I only use it to route and sweeten me and my guitar. It has been a workhorse and has never let me down. Lately though, towards the end of the night, I swear it starts adding a bit of far off background vocals to the signal. At first, I thought it was patrons singing along, then I notice no one is singing. I've had a few folks ask me about it and frankly I am a bit puzzled. See, I don't use any of the harmony capabilities of this unit. Just straight up guitar, with some body rez and a little reverb on the voice. That is all. So... I wondered if anyone else has ever noticed any mysterious "voices" in the output of their Acoustic Play? It is very subtle. Just enough to make me question my sanity. Anyone?

    read more...
    0 59
    • marvinholdman
      PedroRodrigues Hi marvinholdman that may be caused by the two Roomsense Microphones.
      If you are using RoomSense to listen for Key information, make sure it’s close to whichever instrument is play
      You can use the RoomSense LoCut parameter to “roll off” undesirable frequencies from your mix.
      In some circumstances, the low frequencies “in the room” – such as bass or kick drum – can cause the RoomSense microphones to become muddy sounding.
      The built-in high-pass filter allows you to reduce this kind of “rumble”.
      You will be able to Control the RoomSense level in the mix section, default OFF.
      • Jul 28
    • marvinholdman
      Cryms0nX I own one of these and I can honestly say I've thought I was hearing things sometimes, i've definitely heard it, but for me it's nothing specific triggering it. It just happens sometimes. The only way I could describe it is as if the natural overtones and harmonics are being picked up by the microphone and getting fedback into the mix, being then further amplified, and creating that illusion. At those moments I even double check for the little blue led, which is off... It's not an issue that bothers me, but i've definitely come across it in the past.
      • Aug 1
  • New
    bloodtohead
    Newcomer - Level 1
    2021-02-05

    I purchased a vicious vibe pedal off of eBay. Programming it to my guitar doesn't seem to make much difference. Once I beam the sound to the pickup the stumble turns red after it says it worked. Shouldn't it turn green if it was a successful beam. Please let me know if it is working correctly or it may be not working right. 

    read more...
    0 48
    • bloodtohead
      ChrisEdwards1 Hi bloodtohead, yes that would be correct. If at any point during the beaming process the LED flashes red this means the process has failed. Here are a few things you may want to try:

      Ensure the pedal is on the latest firmware version, firmware updates will be available from the product page on the website.
      If you are currently using a phone to beam the Toneprint try attempting this from the Toneprint editor for PC and MAC and see if it works this way.
      If using a guitar or bass with active pickups ensure your tone knob is turned all the way down (so that the treble is completely rolled off). The preamp in active pickups can introduce a slight bit of distortion to the beamed signal, which can cause the beaming process to fail.
      • Feb 7
    • bloodtohead
      TC-Mike red Led indicates that transfer didn't work. Please make also sure that there are no active FX prior to VV pedal, as this will alter the beaming file unreadable . Can you confirm that you have selected a TP slot when beaming?
      • Feb 8
  • New
    SCDamon
    Newcomer - Level 1
    2021-06-29

    I desperately need to turn global key off. I have cycled through the setup menu without finding it. My first day with this unit, all presets are locked on C major. Help!

    0 47
  • New
    BHShooter1
    Newcomer - Level 1
    2021-07-02

    I bought a TC Helicon Harmony G-XT a few months ago.  During my last recording sessions it worked fine.  After writing new songs to record I hooked up the rig and now signal from the microhone to the mixer.  I thought it might be the guitar needed to be hooked up to activate the mic.  The guitar plays through to the mixer, but still no mic. 

     

    Is there some setting that I am missing that is keeping the mic from working?  Does the mic input just stop working?  I have replaced both XLR cables with new ones and still no signal to the mixer.  What am I missing?

    read more...
    0 47
    • BHShooter1
      NicJonesMT Hi BHShooter1.
      Sorry to hear you are having issues.
      I think the best option would be to submit a tech support ticket and a member of the team will be able to advise you further.
      If you could provide the following information in your Ticket it would help to Speed things along.

      • Can you please detail any other devices that are being used in conjunction and exactly how these are connected to your device? This includes Microphones, Mixers, Computers ETC.
      • Can you please detail how parameters on the device are set?
      • What firmware are you using and have you tried reflashing?
      • Have you tested the device using an alternative audio source?
      • Do you have access to alternative cables?
      • Have you tested the device with an alternative power source?
      • Can you confirm the specifications of the power cable you are using?
      • Are any LED’s or lights on the device lit up or behaving erratically?
      • Do you have a similar device that you can compare the behaviours of?
      • Can you please provide me with a detailed description of how the device is behaving and any other trouble shooting steps that you have undertaken?
      • Is the Issue Intermittent or constant? If it is intermittent is there a specific setting that needs to be used to cause the issue?
      • Jul 3
Go to page