Statistics

249,484 members
126,494 posts
  • New
    YaizaCuenca
    Newcomer - Level 1
    2020-12-12

    Hi there! Anybody knows how to restore the fabric values of this relic? Thanks!!?

    0 45
  • New
    maniatis1717a
    Newcomer - Level 1
    2020-11-23
    • maniatis1717a
      leah Hello George, I've visited the article you've linked and it does show the images. Please try visiting the link again. If you are unable to see the images, here they are as well. (The image with the graph is the first one in the article.)
      • November 24, 2020
    • maniatis1717a
      maniatis1717a Hi Leah.The images are still invisible ,but its ok , you solve my promblem with the images you send ,.Thank you very much for your time
      • November 25, 2020
  • New
    Wllywurld
    Newcomer - Level 1
    2020-11-18

    Hello Tribers-

    Anybody out here in BugeraVille have a problem with the FSB104 footswitch. It is the footswitch for the 333XL Infinium Amp model.

    The pins do not line up in accodance to plug at back of amp.

    0 159
    • Wllywurld
      RexBeckett Hello Rod, it looks to me that the plug has been damaged. It should have five pins and a plastic guide (see attached). I suggest that you contact your supplier.
      • November 21, 2020
  • New
    gregoryerba
    Newcomer - Level 1
    2020-11-14

    I am utterly disgusted with your company. It took over a month, endless emails, forums, and re-sending information I provided multiple times to multiple people, before I finally got Musictribe to get warranty service to me, and then you give me a service center that is backlogged for TWO MONTHS in Digitron Electronics. It should be noted that the folks at Digitron are as frustrated with your lack of communication as I am.

     
    After making a VIDEO of the problem that you requested, you didn’t even get that right in the warranty repair you sent to Digitron. I personally drove TWO HOURS one way to deliver the unit, as I cannot afford to ship such a heavy unit anywhere. 
     
    You sent me a DEFECTIVE Turbosound Ip3000, and I have been OUT OF WORK as a solo musician who plays private engagements as a result, and now I find out it will be at least TWO MORE MONTHS before my unit is repaired, through NO FAULT OF MY OWN?!!!
     
    You all out to be ashamed of yourselves. As far as I’m concerned, you should have sent a new unit to me altogether. Your lack of quality control & customer service has been DEVASTATING to me professionally. I am out well over $1,000 in the defective unit, and way beyond that in the lost wages of cancelled gigs as a result of your incompetence. 
     
    I will be making a point to let as many of my colleagues in the greater Los Angeles area know how I’ve been disregarded by Musictribe, as well as on your forums. I have all the documentation. Shame on you. 
     
                -Beyond disappointed. Devastated.
     
                Greg Erba. (323)385-6184
                                17812 Elizabeth Lake Road
                                93532
     
     
    read more...
    0 38
    • gregoryerba
      john0121 Hi Gregory, sorry to hear about the experience you've had with your IP3000 and arranging a repair with us. Could you please let me know the case number (format CAS-XXXXX-XXXXX) you have been arranging this on and I'll have a look if there is anymore can be done here.
      • November 15, 2020
      • Disgusted with your customer service. Defective Turbosound IP3000
        gregoryerba CAS-149861-F7V8G8
        • November 15, 2020
      • Disgusted with your customer service. Defective Turbosound IP3000
        john0121 Thanks for the information, I'll escalate this to a colleague who can advise further.
        • November 16, 2020
  • gregoryerba
    Newcomer - Level 1
    2020-10-21

    For several weeks I have been attapting to contact Musictribe to have my warranty fufilled on a faulty Turbosound IP3000 I purchased from Musictribe through ebay.

    Upon the first use of this product it was faulty. Very low output, and extremely nasally, as if the tweeters were blown. I have had to cancel multiple gigs and have lost work as a solo acoustic artist as a result of this hassle.

    I attempted to get a response trhough the Musictribe website as suggested by the return message through my ebay purchase. It is not working properly. I have also emailed Musictribe to ask for personbal assistance and have recieved no response in over two weeks. 

    This is extremely frustrating. I have spent well over a thousand dollars on this refurbished speaker system and it is useless. 

    My warranty number is #184170689796

    I need to know what will be done at this point to have the 10 year warranty fufilled as promised when I purchased this product. 

     

                                                  Greg Erba (323)385-6184

     

     

    read more...
    0 66
    • gregoryerba
      gregoryerba What do I have to do to get someone from musictribe to contact me back at this point? The website is extremely slow & buggy in trying to follow through with the warranty. I have a useless Turbosound IP3000 and am a working musician losing work because of this.
      • October 21, 2020
    • gregoryerba
      AlexLane Hi Gregory,

      You need to submit a CARE ticket for this, click SUPPORT at the top of the page, select SERVICE, then fill out the required details and one of the team will respond within 24 hours.

      Apologies for the frustration, rest assured the care team will help you out.

      Any issues with the ticket submission, please let me know and I can investigate.

      My email is [email protected] if you want to contact me directly.
      • October 21, 2020
      • I need immediate assistance in having this faulty Turbosound IP3000 replaced with the 10 year warranty!!!!  Extremely poor customer service so far, very frustrated.
        gregoryerba I am utterly disgusted with your company. It took over a month, endless emails, forums, and re-sending information I provided multiple times to multiple people, before I finally got Musictribe to get warranty service to me, and then you give me a service center that is backlogged for TWO MONTHS in Digitron Electronics. It should be noted that the folks at Digitron are as frustrated with your lack of communication as I am.

        After making a VIDEO of the problem that you requested, you didn’t even get that right in the warranty repair you sent to Digitron. I personally drove TWO HOURS one way to deliver the unit, as I cannot afford to ship such a heavy unit anywhere.

        You sent me a DEFECTIVE Turbosound Ip3000, and I have been OUT OF WORK as a solo musician who plays private engagements as a result, and now I find out it will be at least TWO MORE MONTHS before my unit is repaired, through NO FAULT OF MY OWN?!!!

        You all out to be ashamed of yourselves. As far as I’m concerned, you should have sent a new unit to me altogether. Your lack of quality control & customer service has been DEVASTATING to me professionally. I am out well over $1,000 in the defective unit, and way beyond that in the lost wages of cancelled gigs as a result of your incompetence.

        I will be making a point to let as many of my colleagues in the greater Los Angeles area know how I’ve been disregarded by Musictribe, as well as on your forums. I have all the documentation. Shame on you.

        -Beyond disappointed.

        Greg Erba. (323)385-6184
        17812 Elizabeth Lake Rd
        Lake Hughes, CA
        93532
        • November 13, 2020
  • ThomasPF
    Newcomer - Level 1
    2020-10-19
    I have a problem I hope you can help me with.  I am loving jamming with my lead guitarist and when we play live together, I use TC helicon for amazing vocal harmonies.   In JK right now I am plugging my guitar cable and mike xlr cable into TC helicon and then two appropriate cables into my Focusrite audio interface...but it doesn't work while jamming or when we try to record. Can you help?
     
    read more...
    0 68
    • ThomasPF
      Nigel67 Hi Thomas, please can you advise which TC Helicon device you are using. And are you getting signal into the Focusrite audio interface, it should have some sort of monitoring feature that you can listen to to see if you are getting audio into it.
      • October 19, 2020
      • JamKazam & TC Helicon
        ThomasPF Hi Nigel--Thanks so much for responding to my inquiry I have the TC Helicon Play Acoustic model. I cannot hear the harmonies at all on my end. The monitor dial on my Focusrite is turned all the way up. My guitarist hears the harmonies faintly on his end.
        • 1
        • ·
        • October 20, 2020
      • JamKazam & TC Helicon
        Nigel67 Hi Thomas, can I confirm that the TC gain set up has been done per the manual. Is the input signal LED lighting green when you sing and play the guitar through the unit? Are you able to plug the outputs of the TC directly into an amp to check the levels you are getting out the TC device or even plug some headphones into it to check that you can clearly hear the audio? You haven't mentioned which Focusrite you are using, but the ones I have seen, have a direct monitor switch for headphones so that you can hear the audio directly off the gain pots. Can you check this and see what the audio sounds like? What settings do you have the input gain on the focusrite set to? Are you using balanced output XLRs to balanced input XLRs between the two units? Any conversion connectors or if you are using jacks to the input of the focusrite, they are TRA and not TS jacks?
        • October 22, 2020
  • avalleara
    Newcomer - Level 1
    2020-10-05

    Hi all, I bought a Midas M32 Live from eBay seller Musictribe with a 10 year warranty. I bought it to donate to a church. The console arrived, and when plugged in the main screen does not turn on. Does anyone have any suggestion on what I should do next please? I am not a musician and have never had equipment like this. Thank you in advance. 

    read more...
    0 202
    • avalleara
      Cinsound Quickest fix is connect it to a tablet or comp to see it’s features. There is a display screen brightness control.
      Try a firmware update weather needed or not to see if that resets.
      Last unwanted option is to send to be repaired
      • October 4, 2020
      • Black screen on Midas M32 Live
        avalleara Hi Nic, thank you very much for the prompt response, I am going to try and connect it to see how I can change the brightness setting to see if it’s that. I appreciate it.
        • October 4, 2020
    • avalleara
      DavidKnighton Hello Alexis Vallejos,
      I received a similar inquiry via our support system earlier, so I suspect both are related. There is no brightness setting that would dim the screen completely. Even at the lowest setting, the GUI is still visible, so I doubt the iPad method will work. Also, the iPad app does not offer brightness control for the hardware. I would suspect the LCD screen cable is unplugged or damaged. The rest of the console appears to be booting, so it's not a boot problem or PSU problem. Please find my email and reply at your earliest convenience.
      • October 5, 2020
  • vincenzokeez
    Newcomer - Level 1
    2020-09-21

    Why is the overload light always on. Just got this new and I am so pissed!!!!

     

    Any help please. Annoyed I just can't speak to a bloody tech advisor on the phone!

     

     

    0 66
    • vincenzokeez
      RexBeckett I suggest that you open a Care ticket for technical support. At the top of this page, click Support -> Create a Care Ticket and select Type: Technical Support. Make sure that you enter all required (*) data before clicking Submit. The Care team will respond by email.
      • September 21, 2020
  • whatsleft
    Newcomer - Level 1
    2020-08-22

    pic of serial number ans date code on ultrafex ii model 3100 (new old stock

    0 95
    • whatsleft
      john0121 Hi whatsleft, sorry for the frustration your having with the registration. Can you let me know what case this relates to please?
      • August 24, 2020
      • here's the stinking picture you behringer people wanted about my warranty registration
        Phoebetay Hi John, I have been trying to register my mixer online for the whole night. Not sure if that has gone through as I done it over and over again, it didn’t indicate whether the registration is successful. Can you pls help me to check?
        • Feb 27
      • here's the stinking picture you behringer people wanted about my warranty registration
        john0121 Sure, I'll drop you a message.
        • Feb 28
Go to page