Statistics

208,479 members
80,680 posts
  • Klauzix
    Newcomer - Level 1
    2020-10-22

    How can I get in touch with somebody?

    My preamp didn't work so I figured it was the tube. How do you see if it's broken?

     

    read more...
    0 41
    • Klauzix
      RexBeckett The best thing to do is to open a Care ticket: At the top of this page, click Support and then select Technical Support. Make sure that you enter all required (*) data before clicking Submit. The Care team will respond by email.
      • October 22, 2020
      • I need tech support?
        JMaxfield77583 or, since this is a forum, you could have answered their question directly. It' snot like troub;eshooting a tube amp is a trade secret. These things have been around for a cover a century...
        • October 22, 2020
      • I need tech support?
        Paul_Vannatto But not very many of us have been around for a century (hint, hint)...
        • December 16, 2020
    • Klauzix
      JMaxfield77583 Tube Tester... but it would be faster to swap it. If you amp has a reverb circuit, swap the tube for the reverb out with the preamp tube. If the reverb goes wonky but your front end works, then you found the problem. Be aware, if your reverb uses a lower gain tube (12AY7 or 12AU7) it will not make the same amount of gain as before... but it will be markedly better than if you have a blown tube.

      Also... if you tap on the tube when it's warm and it jungles then one of the elements has fried... just replace it with the same tube type.

      It never hurts to have two or three 12AX7s, a 12AUY and 12AY7 on hand... as well as matched pairs of 6L6, 6V6, EL34 & EL84 power tubes on hand. If your amp is tube rectified you can keep rectifier tubes or swap to yellow jacket solid state replacements on hand (or both). Spare parts are basically a must with tube amps... if you're mid-performance and one goes out... you need to be able to fix it.

      Cheers!
      • October 22, 2020
    • Klauzix
      Klauzix I don't know why. This is the weirding thing ever.
      I put the pre-amp back together to do some tests to see if the tube was indeed damages.

      Plot twist. Everything worked. Nothing wrong anymore.

      Now i'm super confused. It didn't work at all before i took it apart. And i didn't do anything but take out and in again the tube...
      • October 23, 2020
    • Klauzix
      Hawke77 May have just been a dirty tube socket.
      • October 28, 2020
    • Klauzix
      Dale_M Hi Klaus its not impossible that the tube was not seated correctly, or possibly had some oxidisation present on the legs which removing and refitting has removed. If it fails again replace with a new one and if still faulty there is possibly a dry solder joint on the socket.
      • November 4, 2020
  • cubbymcbride
    Newcomer - Level 1
    2020-10-09

    I ordered a Bugera T50 Infinium from Musician's Friend. I was stoked to receive my amp however, when I opened the box which was BRAND NEW from BUGERA the amp was busted to all hell. Different knobs where busted off at the base of the pot. The literally powerswitches were busted of causing me to not even be able to turn the amp on. I have to say I am extremely disappointed, frustrated and beyond pissed that Bugera's QC would tank it with an amp this badly. I waited 2 months to get this amp from a backorder and to top it off it was a birthday present. My first interaction with Bugera is not off to a great start.

    read more...
    0 20
    • cubbymcbride
      cubbymcbride Pics for reference
      • October 9, 2020
    • cubbymcbride
      cubbymcbride
      • October 9, 2020
    • cubbymcbride
      KyleJohnson Hi Caleb, Kyle here with Music Tribe. Wow, I can understand your frustration, that is in pretty rough shape. If you just received it from Musicians Friend, I definitely recommend you contact them to process an exchange. If you are outside of the MF exchange period, please submit a service ticket by clicking the Support link at the top of this page.
      • October 9, 2020
      • MY AMP CAME BROKEN FROM BUGERA
        cubbymcbride Hey Kyle, I did and they are sending me a label. I just wanted you all to be aware of the condition in which it was received brand new in. I understand things slip through the cracks but this was unacceptable.
        • October 9, 2020
      • MY AMP CAME BROKEN FROM BUGERA
        KyleJohnson Thank you for bringing this to our attention.
        • October 9, 2020
    • cubbymcbride
      DavidKnighton Hello Caleb McBride,
      I myself had a similar experience with Musician's Friend back in 2009 when I ordered a Line6 Head and Cabinet. The Head was fine, but the cabinet came with a huge crack down the side. This was most likely due to mishandling in warehousing/shipping. I was frustrated as well, because it took another 4 weeks before I could start playing. I would think something similar happened here, because it looks as though the unit was dropped on it's face. The weight of the internal components can destroy the unit from the inside if dropped from even just a few feet. It is unfortunate, but this is the woe of our shipping industry, and it happens with every product manufacturer. I know it can be frustrating, but please don't lose faith in the brand.
      • October 13, 2020
  • GeorgeKlongland
    Newcomer - Level 1
    2020-09-29

    I bought the foot switch specified on the back of the amp and the connector is different.

    The amp has a big connector and the foot switch has a small connector.

    The part number is the exact part number called for. 

    So is there a replacement connector that I can wire in ? Or and adapter ?

    read more...
    0 42
    • GeorgeKlongland
      GeorgeKlongland
      • September 28, 2020
    • GeorgeKlongland
      GeorgeKlongland
      • September 28, 2020
    • GeorgeKlongland
      john0121 Sorry for the problem you've encountered here, can you please submit a technical support case via the "Support" button at the top of the page and we can get this looked into/resolved.
      • September 28, 2020
    • GeorgeKlongland
      GeorgeKlongland Can someone, anyone just get me a wiring diagram for the connector for the footswitch on the back of a 6262 infinium?
      • October 15, 2020
    • GeorgeKlongland
      GeorgeKlongland Can someone, anyone get me a wiring diagram for the footswitch connector on a 6262 infinium? I bought a new 5 pin din cable and need to know which pin is which to wire it .
      • October 15, 2020
      • Bugera 6262 Infinium
        JMaxfield77583 Google is your friend Bro! All of the Bugera schematics (except for the TriRec or the Magician - which never saw production) can be found online.
        • October 22, 2020
  • EmanVeg27
    Newcomer - Level 2
    2020-08-24

    Hello, I have a bugera infinium 333xl 212, I bought it at the end of February, and since June I have the following problem, it tells me that valve # 3 fails. I contacted the seller, they did technical service, they replaced valve No. 3 They replaced all of them, but the problem continues. The moment they returned it to me, I tried it and it worked well for 3 or 4 hours, I turned it off, the next day I tried it and led # 3 came on again ... At one point, led # 4 came on, inclusive, and even standby blinked, the amp completely shut down and didn't turn back on, they fixed it, it worked again, and the same problem again after a few hours. I'm starting to get disappointed because I can't enjoy the amp. Did the same thing happen to someone?

    read more...
    0 15
    • EmanVeg27
      Nigel67 Hi. I am sorry that you are still experiencing an issue with your unit. It may be an issue with the device that holds the valve. Where are you based? I would suggest that you go to the support tab at the top of the page and submit a Service ticket. We can then get your unit to one of our service centres and give it a thorough test. Make sure you write on the case that a repair has been performed, but failed virtually straight away. Can I also confirm that you purchased the unit brand new in february? many thanks
      • August 25, 2020
    • EmanVeg27
      EmanVeg27 Hi Nigel, thanks for responding. That's right, buy exactly on 02/28 of this year. In June this problem started. It was heard like a tap and then led n came on. 3. I have already created the ticket: CAS-130446-N2Y4X1. The owner who sold the house serviced it 3 times and the problem continues.
      • August 25, 2020
    • EmanVeg27
      Nigel67 I just looked at the case. It is with our Vegas office. This unit, if the serial number is correct was manufactured in 2011, so very much out of warranty. I do not know who the nearest service centre is in Argentina but whoever handles your case will be able to advise you further. With your unit being this old, it could well be the device that holds the valves or possibly other components starting to fail because of age.
      • August 25, 2020
    • EmanVeg27
      EmanVeg27 Thanks again for answering, most likely if it is an old unit, unfortunately this is my first experience with these equipment, hopefully there is a solution, the company that distributes in Argentina is TEVELAM, today the retailer contacted them and coordinated the shipment to their location .
      • August 25, 2020
    • EmanVeg27
      JMaxfield77583 Bias Circuit is failing. I have a TriRec that did the same thing. If you know how to use a bias meter, and a multimeter you can figure out what's causing the problem pretty quickly. The schematics are online with test points. If your issue is like mine, it could be the rectifier circuit or the autobias circuit. The Infinium amps are cathode biased - aka self biasing - but do not always work right because they may be set from the factory out of tolerance. You'll want to figure out the correct plate voltage, then set it for 60%-65% bias current based on the expected power output of the tube your using. There again... with a cathode biased (self adjusting) amp this may require some fine tuning of the components themselves. For example, if the factory installed a 47 ohm bias resistor but it has a +/-10% variance in actual value, you could be off as much as 10% of the target... which would result in burning up tubes and other board mounted components. You might have to do some shopping around to find better quality components and then have them soldered on. The circuit designs are sound, but the component quality used in these amps is total garbage... that's why they have so many warranty claims.

      WORD OF CAUTION: If you are not experienced working on electronics, or high voltage... DO NOT try this yourself. You could kill yourself.
      • October 22, 2020
      • Bugera 333 xl infinium 212 combo
        EmanVeg27 Hi John, thank you very much for answering. Two months ago I sent the team to the headquarters in Argentina, TEVELAM. Apparently they found the fault in the valve plug and a part of the plate, they were going to test it for a few days to see if it didn't fail again, then they would send it back. Hopefully it was fixed ... Thanks again for replying. Greetings
        • October 23, 2020
  • Bugera
    Triber Moderator
    2020-07-17
    We’re bringing new features to the Bugera website to make it an even better experience! Visit https://www.bugera-amps.com today! #Bugera #NewWebsiteFeatures
    0 28
    • Bugera
      JL1103 I need some help selecting speakers for my BTX3600 and can't find anyone to ask. Can you help me ?
      • July 20, 2020
    • Bugera
      WilliamR Sure, what would you like to know?
      • July 24, 2020
  • Stephane666
    Newcomer - Level 1
    2020-06-22
    I need a power transormater for bugera 333XLinfinum you ave this
    0 67
    • Stephane666
      SethMusicTribe The part number your looking for is Z65-94063-02070. Simply start a case for spare parts! Let me know if you have any problems doing so and I will assist you.
      • June 22, 2020
      • Parts
        Stephane666 Thanks allot
        • June 22, 2020
      • Parts
        Stephane666 Were am start a case end were is the spare part in the cite ?? Sorry for my inglish am franch canadian
        • June 22, 2020
      • Parts
        RexBeckett At the top of this page, click Support -> Care -> Create a Care Ticket and select Type: Spare Parts. Make sure that you enter all required (*) data before clicking Submit.
        • June 23, 2020
    • Stephane666
      Stephane666 I ave do thath end now am wait? Somme pepole talk to me?
      • June 23, 2020
      • Parts
        RexBeckett Watch your email - including the spam/junk folder - for a response.
        • June 23, 2020
    • Stephane666
      Stephane666 !
      • June 23, 2020
    • Stephane666
      SethMusicTribe I have your email! I have contacted our part department and they will be reaching out to you very soon!
      • June 23, 2020
      • Parts
        Stephane666 Thanks alots ????????????????
        • June 23, 2020
      • Parts
        Stephane666 Sorry wrong caracter !!!!!!
        • June 23, 2020