Statistics

250,243 members
127,372 posts
  • RayMontreal
    Contributor - Level 2
    2019-11-11

    Hi everyone,

    I hope this video helps to explain my problem, struggling to find the right words in english

     

    https://vimeo.com/372529561 

     

    got a MIdas MR18, I'm trying to use it in Ableton via TouchOSC, to control faders and mute buttons

    Now I'm on a Mac and I tried Osculator, I got everything to work except, for the life of me, I can't get any of my movements from ableton or the mixer to reflect on the TouchOSC.

    Ableton talks fine to the mixer, I just can’t figure out how to send it out to the iPad’s TouchOSC. ,

    My knowledge is limited on OSC and I can’t figure it out (I’m pretty good with technology in general).

    I made a map to kinda show my problem:  

     

    Screen Shot 2019-11-11 at 3.48.22 PM.pngScreen Shot 2019-11-11 at 7.04.25 PM.pngScreen Shot 2019-11-11 at 7.04.34 PM.png

    I need help. LOL

     

    Sorry for the poor English as I am French speaking in Montreal Canada,

     

    Thank you for taking the time to read this very long message!

    read more...
    0 319
    • RayMontreal
      KenMitchell

      Hi @RayMontreal , 


       


      Looks like a fun project.  I love the graphic with the orange arrow and the matching orange text explaining the problem.  Well done.   However, I suspect the problem is actually above it with the connection between the mixer and Osculator.   In order to get feedback back from the MR18, Osculator has to listen for those messages as well as periodically re-subscribe to updates.   A couple of years ago a developed a utility called XAirRemote to serve as a bridge between OSC clients (TouchOSC, Lemur, etc) and the XAir/MAir mixers.  I hadn't thought about it but Osculator should be able to be used as a client as well.  


       


      Here's a link to the utility: https://sites.google.com/site/xairutilities/XAirRemote-1_2-OSX.zip?attredirects=0&d=1


       


      In your setup, you'll want to set it up between Osculator and the MR18. 


       


      Let me know what questions you have about the setup. 


       


      Ken

      • November 11, 2019
    • RayMontreal
      RayMontreal

      Well, first of all a very big thank you for replying to my message!


      The MR18 is currently being kept alive with an OSC Message (/xremote) tied to the Beat, so as long as Ableton is playing, the MR18 is alive and also in Ableton, if I move a fader, it does reflect it on the MR-18,


      so that part works! it's just not also being sent to the iPad...


      I want to duplicate the backmapping in Osculator so that it sends it also to the iPad, I just don't know how to get Osculator "talking" to MR-18 AND iPad at the same time. that Ð (and L and 1-16 in Osculator) is super confusing to me and I don't know how to deal with it.


      Having Osculator in there is already a big move for me as I prefer having a very bare minimum of apps open during shows...


      will definitely try your app, thank you!


      but if it's job is to keep MR18 awake, I am already doing that in Osculator and that is working.


      Best,


       


      Ray


       

      • November 11, 2019
    • RayMontreal
      RayMontreal

      my ini file looks like this:


      1 0 0 1 0
      1 16 17 17 18 21 40 45 46 49 51 54 0
      <92.168.0.123>
      <192.168.0.105>
      <192.168.0.182>
      <8000>
      <8000>
      #EOF


      but the MR18 listens to 10024 not 10023 like the XR18, so I think it might be the reason I'm getting a tail like;


       


      OSC Controller at IP <192.168.0.105>, receives on port <8000>, sends to port <8000>


        Listening for OSC Controller on <192.168.0.182>:<8000>


        Flags: verbose: 1, delay: 0ms, Transport: 0, Master: 1, Sync: 0


        Map (min/max): Ch 1/16, Aux 17/17, FxR 18/21, Bus 40/45, FxS 46/49, DCA 51/54, Bus Offset 0


       


      *******************************************************************************************


        Start of Log data:


       


      ->X,    8 B: /info~~~


      XAirConnect: Error sending data to XAir


       


       


       

      • November 11, 2019
    • RayMontreal
      KenMitchell

      Hi Ray, 


       


      The XR18 also uses 10024. 10023 is what the X32 uses. 


       


      Remove the "<" and ">" from the IP addresses and ports in your ini file.  


       


      You've also got <92.168.0.123> which I suspect should be 192.168.0.123.


       


      Ken

      • November 11, 2019
    • RayMontreal
      RayMontreal

      correctly writing my ini file made your app work,


      your app now logs correctly but I dont know what that brings to the table,


      in the tail I see both ipad and mr18 messages show up in the log


      but when I start osculator, it says port 8000 already being used error.


       


      I will NOT give up, my brain is struggling, but there has got to be a way to make all this work! haha

      • November 11, 2019
  • ecarballo
    Contributor - Level 1
    2019-10-28

    Hola buenas tardes quisiera que me ayudaran a recomendar una pagina web donde pueda encontrar un repuesto para MIDAS M32 el numero de parte es P0B31 o con quien me podria contactar para la compra

    -------------------------------------------------------------

    Hello, good afternoon, I would like you to help me recommend a website where I can find a spare part for MIDAS M32, the part number is P0B31 or with whom you could contact me for the purchaseREPUESTO MIDAS M32.jpegWhatsApp Image 2019-10-16 at 10.57.41 AM(1).jpegWhatsApp Image 2019-10-16 at 10.57.41 AM(2).jpegWhatsApp Image 2019-10-16 at 10.57.41 AM.jpeg

    REPUESTO MIDAS M32.jpeg
    read more...
    0 293
  • NelsonVega
    Contributor - Level 1
    2019-07-23

    when trying to update pro2. this error appears. Which may be? error #52 - Failed security check ... thanksWhatsApp Image 2019-07-22 at 13.21.02.jpeg

    read more...
    0 334
    • NelsonVega
      ChaseMcKnight

      Hi @NelsonVega 

      Typically this is due to a corrupt firmware, likely it just downloaded incorrectly. Try downloading the update file again from the website and if you can connect to the internet via landline, even better. 

      Re-format your USB drive (FAT or FAT32) and create a folder '  DL2Upgrades ' - then place the unzipped .tar file in the folder and try upgrading the console firmware again. 

      Let me know if you have any other issues.

      • July 25, 2019
  • garypegb
    Contributor - Level 2
    2019-05-29

    Is the Heritage-D a real thing?

     

    IMG_0259.JPG

    read more...
    0 1,981
Go to page