268,227 members
147,783 posts
  • New
    Newcomer - Level 1

    Hello! Trying to record loops/ vocals from my voicelive touch 2 into Ableton Live via the USB connection. As shown in the photo, Ableton is picking up the device as a Midi input, but when I hit the record button, no audio is recorded.  I'm a total noob to Ableton and recording and fooling with this and trying to research the issue is really throwing off my creative process and bumming me out.


    Can I record using this USB connection directly into my PC? or do I need to invest in an interface to be able to get my vocals into Ableton? Thanks in advance!

    0 4
  • New
    Newcomer - Level 1

    why the device show no power,led light is off ,after I put in the batteries?it show no working...

    0 4
  • New
    Newcomer - Level 1


    I recently just noticed after turning on my pc that the icons on the goxlr don't appear anymore. also the second and fourth one in the row seem to be dimmer in lighting. 

    I've been trying to figure out why they aren't working.

    Before I noticed that they weren't working, pressing the mute buttons didn't bring the faders down or anything, a pop up message in windows came up saying something about "usb...".

    I restarted my pc, but that didn't fix the issue either. i unplugged / replugged the usb cable from the goxlr and everything started to work again. This is where i noticed the icons weren't working

    i believe prior to this a message on the goxlr app said update failed?, yet there aren't any updates when i go and check

    Thank you for taking the time to read this.

    0 6
  • New
    Newcomer - Level 1


    i have just rebooted PC, (Restartet everything)

    And now, GOxlrMini doesn't work, when i try connect. To my PC

    idk what im doink wronk, when its pluggin and configurating, its creating DriverError, i tried everything, also searched on google no help, try restartet my PC, no work. 

    Unplugged and plugged USB didnt work.

    Updated, DRIVER, tryid to find error, with Window Error Finder.

    No help...

    Can somebody help me out 



    Best Regards. Adam  



    1 10
    • Lind
      WilliamR Hello, William from musictribe here.

      Have you tried to manually update the driver? The issues you've described are usually related to driver configuration and the resolution is to manually install the driver. I've attached a copy of the driver. Please do a manual install and test your device again. Please run the installation twice, the first uninstalls the driver and the second reinstalls it.

      Has your GoXLR or computer also gone through any recent updates? If so, Windows may have disabled your inputs/outputs. Update to the latest driver or reinstall the driver. I've attached a file for the download. Go to Playback/Recording Devices, and re-enable the device.

      Go XLR basic troubleshooting:
      Try a different USB port/cable. Works best on 2.0 or 3.1 ports. 3.0 gets glitchy
      Update BIOS
      Check sound privacy settings
      Manually install/update driver

      If the audio cut outs are stutter-like, generally speaking - audio stutters happen from:
      - Using a USB 3.0 port instead of a USB 2.0.
      - Being plugged into a USB extender/hub.
      - Being plugged into a part of the computer that is already maxing out its bandwidth.
      - Having out of date BIOS.
      - Having a bad USB cable.
      - Being plugged into the wrong type of connection.
      • Jan 12
  • New
    Newcomer - Level 1

    I purchased the tc helicon talk box synth and the stomp switch stop working. What are my remedies for replacement or repair?

    0 10
    • ESharp
      Nigel67 Hi ESharp. The unit will require repair as replacement is usually only if the product fails within the first 30 days. First of all, please contact the seller and they should help you out. If there are any issues, please raise a Service Ticket and the Service Team will be able to help you further. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Service tab and submit a ticket. Many thanks
      • Jan 5
  • New
    Newcomer - Level 1
    Connecting Play Acoustic to VoiceSupport2. What's the trick? Tried 2 PCs and a Mac. Tried 3 USB cords. Tried powering on and off in every imaginable sequence. Searches on TC Helicon refers me to a video from 2012 based on Vista that is zero help. Please tell me there is a simple setting that I am missing. I would like to not have to return this thing.
    May be an image of text that says 'VoieSupport2 Presets Devices [ම] TIT Scan Disconnect Update MIDI Devices Device Scan There turned MIDI capable devices available to VoiceSupport. Make sure your device is and properly connected. For more information on diagnosing connection problems click the 'More Info' button. Ok More Info... MyOffinT-He My Offline TC-Helicon Devices Nothing NothnCo Connected'
    0 13
    • whodatpat
      WilliamR One thing you want to make sure of is that all your web browsers are closed while hooking up your device. Also, be sure to plug directly into the USB port and not a USB hub.
      • December 21, 2021
    • whodatpat
      kenloebel As a newbie, I am excited to get to use the product ( Play Acoustic) but am disenfranchised with the overload of brands, unorganized data, and lack of a simplified Start-up approach. With multi synth, a company I own, and a new looper, this Play Acoustic and other responsibiloities, I have no desire to search and navigate a rabit hole - it seems I got a great product with a website in need of simplification, organization and customer experience corrections.
      • December 23, 2021
  • New
    Newcomer - Level 1

    can anyone solve this? I'm having trouble connecting my voicelive touch2

    1 16
  • New
    Newcomer - Level 1



    I have just installed VoiceSupport 2 on a windows vista computer, but as soon I start the program, I get a message about "unable to establish an internet connection". The internet works fine, so what is the problem?

    0 17
  • New
    Newcomer - Level 1



    ich wundere mich das es nach wie vor nicht die möglichkeit gibt, die aufgenommenen Samples direkt umzubenennen. Wenn ich etwas einspreche und das 4-5 mal, weil mir die vorherigen Aufnahmen nicht passen, muss ich jedes mal mühsam die richtige Datei aus dem Ordner suchen und dann umbenen.

    Es wäre echt hilfreich und würde einges an Zeit sparen, das endgültige Audio, welches nun auf einer der Samplertaste liegt direkt mit einem "Rechtsklick->Umbenen" auf das Audio neu zu benennen, sodass ich den Rest den ich nicht mehr haben will einfach nur noch aus dem Ordener löschen kann ohne ausversehen die Datei, welche ich behalten möchte mit zu entfernen.

    Ist dies bezüglich ein Softwareupdate in Aussicht?


    0 11
  • New
    Newcomer - Level 1

    Some one Help me plz I need firmware of Play acoustic I Need it back :(

    0 14
    • poptechanon9
      thisisjust9 I have the same problem. Have you find any solution? My unit now is bricked/useless. Connecting the unit to VoiceSupport 2 (Mac version) shows the unit is now Blue (VoiceLive Play) not the actual Black one (VoiceLive Play Acoustic).

      And, one more thing, I wonder whether this MusicTribe forum really represents TC Helicon? This forum has the lowest and slowest response, and not even from TC Helicon Tech team. Such a disappointment for a big name such as TC Helicon.

      Anyway, I certainly hope, anyone here can help us to solve this VoiceLive Play weird problem.

      Thank you.
      • December 26, 2021
Go to page