Statistics

250,514 members
127,680 posts
  • New
    Jeff22
    Newcomer - Level 1
    2021-09-08

    Good morning everyone I have a Bugera 333 just wondering how do I order parts on this site?

    Don't know what the board is called but it's for you plug the main power cord in it is a small circuit board with the fuse and the off and on switch. I hope the image helps me identify this board and where I can get one thanks in advance everyone

    read more...
    0 12
  • New
    KrynolKrynolowski
    Newcomer - Level 1
    2021-08-18

    Hello,

    I've recently bought a used Bugera amplifier. After I plugged it in, it turned out that the LED at the front keeps flashing with more or less one second intervals. At the back, there is also a LED which signals the need to change tubes. I replaced both tubes for the ELECTRO-HARMONIX EL84 model. But after all that, nothing changed.

    What can I do to fix this? I have an electronics degree so I can measure or replace any electronic elements. Unfortunately, I don't specialise in tube amplifiers which is why I'm asking for your help.

    Thanks

    read more...
    0 26
    • KrynolKrynolowski
      Dale_M Sorry to hear this, if you have changed both valves were they both new or old ones you had lying around? If new then this sounds like a genuine fault, we would advise you go to the support tab above and create a Service ticket so we can try and organise a repair.
      • Aug 18
    • KrynolKrynolowski
      KrynolKrynolowski

      Both valves I used were brand new. I already have the service ticket. But I can also try to fix this problem myself, I would just need specific instructions.

      • Aug 19
      •  Bugera V22 Infinium - problem
        Dale_M I am afraid we cannot legally offer that type of support due to the danger of electrocution, if you do wish to pursue a repair please follow up on your ticket.
        • Aug 19
  • New
    sidereal9
    Newcomer - Level 1
    2021-07-08

    Not sure what this white paste is. But I've had two amps lose massive amounts of volume and low end while plugged into this unit.  Now I have to replace two amps due to this product 

    0 57
    • sidereal9
      WilliamR Hello, William from musictribe here, I'm sorry about the issues you are having. Can you click on the support link above and create a tech support ticket? Someone will get back to you asap.
      • Jul 8
    • sidereal9
      DavidKnighton That white stuff is probably either lubricant and/or thermal conductive paste.
      • Jul 9
  • New
    mikemelton2002
    Newcomer - Level 1
    2021-06-17

    II recently purchased a Bugera 333xl Infinium head but it did not come with the foot switch. The jack at the back of the head says "FSB104 Only" (picture posted), but it appears there are two different sizes of the FSB104 foot switch. My question(s) is/are; 1) which is the right foot switch, and 2) how can I purchase the right foot switch? I'm in Colorado, USA, if that helps locating a dealer or another solution.

    Thanks!

    read more...
    0 46
  • New
    KrishnaphatM
    Newcomer - Level 1
    2021-04-19

    Hi All 
     
    My amps ( Bugera 333XL ) have seriously noise when rotate on knobs Master and Treble and sometimes they are not working I think they should replace the new one. Master : 250K Treble : 50K but the pots are not like standard alpha 9 mm or the other amps use.  The shaft of Bugera pot is too long.


    read more...
    0 121
    • KrishnaphatM
      Dale_M Thank you for your post, we do not recommend that users repair their own product as it voids any warranty. If you wish to buy spares please raise a spares ticket from the support tab above.
      • Apr 19
      • My Bugera 333XL Master and Treble pots are not working
        KrishnaphatM I had open a ticket to purchase the parts on Apr 16, 2021 Ticket Number: CAS-444348-J4N9F9 and have no any respond back to me till now.
        • Apr 21
  • New
    Behringer
    Triber Moderator
    2021-01-22
  • Klauzix
    Newcomer - Level 1
    2020-10-22

    How can I get in touch with somebody?

    My preamp didn't work so I figured it was the tube. How do you see if it's broken?

     

    read more...
    0 120
    • Klauzix
      RexBeckett The best thing to do is to open a Care ticket: At the top of this page, click Support and then select Technical Support. Make sure that you enter all required (*) data before clicking Submit. The Care team will respond by email.
      • October 22, 2020
      • I need tech support?
        JMaxfield77583 or, since this is a forum, you could have answered their question directly. It' snot like troub;eshooting a tube amp is a trade secret. These things have been around for a cover a century...
        • October 22, 2020
      • I need tech support?
        Paul_Vannatto But not very many of us have been around for a century (hint, hint)...
        • December 16, 2020
    • Klauzix
      JMaxfield77583 Tube Tester... but it would be faster to swap it. If you amp has a reverb circuit, swap the tube for the reverb out with the preamp tube. If the reverb goes wonky but your front end works, then you found the problem. Be aware, if your reverb uses a lower gain tube (12AY7 or 12AU7) it will not make the same amount of gain as before... but it will be markedly better than if you have a blown tube.

      Also... if you tap on the tube when it's warm and it jungles then one of the elements has fried... just replace it with the same tube type.

      It never hurts to have two or three 12AX7s, a 12AUY and 12AY7 on hand... as well as matched pairs of 6L6, 6V6, EL34 & EL84 power tubes on hand. If your amp is tube rectified you can keep rectifier tubes or swap to yellow jacket solid state replacements on hand (or both). Spare parts are basically a must with tube amps... if you're mid-performance and one goes out... you need to be able to fix it.

      Cheers!
      • October 22, 2020
    • Klauzix
      Klauzix I don't know why. This is the weirding thing ever.
      I put the pre-amp back together to do some tests to see if the tube was indeed damages.

      Plot twist. Everything worked. Nothing wrong anymore.

      Now i'm super confused. It didn't work at all before i took it apart. And i didn't do anything but take out and in again the tube...
      • October 23, 2020
    • Klauzix
      Hawke77 May have just been a dirty tube socket.
      • October 28, 2020
    • Klauzix
      Dale_M Hi Klaus its not impossible that the tube was not seated correctly, or possibly had some oxidisation present on the legs which removing and refitting has removed. If it fails again replace with a new one and if still faulty there is possibly a dry solder joint on the socket.
      • November 4, 2020
  • cubbymcbride
    Newcomer - Level 1
    2020-10-09

    I ordered a Bugera T50 Infinium from Musician's Friend. I was stoked to receive my amp however, when I opened the box which was BRAND NEW from BUGERA the amp was busted to all hell. Different knobs where busted off at the base of the pot. The literally powerswitches were busted of causing me to not even be able to turn the amp on. I have to say I am extremely disappointed, frustrated and beyond pissed that Bugera's QC would tank it with an amp this badly. I waited 2 months to get this amp from a backorder and to top it off it was a birthday present. My first interaction with Bugera is not off to a great start.

    read more...
    0 116
    • cubbymcbride
      cubbymcbride Pics for reference
      • October 9, 2020
    • cubbymcbride
      cubbymcbride
      • October 9, 2020
    • cubbymcbride
      KyleJohnson Hi Caleb, Kyle here with Music Tribe. Wow, I can understand your frustration, that is in pretty rough shape. If you just received it from Musicians Friend, I definitely recommend you contact them to process an exchange. If you are outside of the MF exchange period, please submit a service ticket by clicking the Support link at the top of this page.
      • October 9, 2020
      • MY AMP CAME BROKEN FROM BUGERA
        cubbymcbride Hey Kyle, I did and they are sending me a label. I just wanted you all to be aware of the condition in which it was received brand new in. I understand things slip through the cracks but this was unacceptable.
        • October 9, 2020
      • MY AMP CAME BROKEN FROM BUGERA
        KyleJohnson Thank you for bringing this to our attention.
        • October 9, 2020
    • cubbymcbride
      DavidKnighton Hello Caleb McBride,
      I myself had a similar experience with Musician's Friend back in 2009 when I ordered a Line6 Head and Cabinet. The Head was fine, but the cabinet came with a huge crack down the side. This was most likely due to mishandling in warehousing/shipping. I was frustrated as well, because it took another 4 weeks before I could start playing. I would think something similar happened here, because it looks as though the unit was dropped on it's face. The weight of the internal components can destroy the unit from the inside if dropped from even just a few feet. It is unfortunate, but this is the woe of our shipping industry, and it happens with every product manufacturer. I know it can be frustrating, but please don't lose faith in the brand.
      • October 13, 2020
  • GeorgeKlongland
    Newcomer - Level 1
    2020-09-29

    I bought the foot switch specified on the back of the amp and the connector is different.

    The amp has a big connector and the foot switch has a small connector.

    The part number is the exact part number called for. 

    So is there a replacement connector that I can wire in ? Or and adapter ?

    read more...
    0 180
    • GeorgeKlongland
      GeorgeKlongland
      • September 28, 2020
    • GeorgeKlongland
      GeorgeKlongland
      • September 28, 2020
    • GeorgeKlongland
      john0121 Sorry for the problem you've encountered here, can you please submit a technical support case via the "Support" button at the top of the page and we can get this looked into/resolved.
      • September 28, 2020
    • GeorgeKlongland
      GeorgeKlongland Can someone, anyone just get me a wiring diagram for the connector for the footswitch on the back of a 6262 infinium?
      • October 15, 2020
    • GeorgeKlongland
      GeorgeKlongland Can someone, anyone get me a wiring diagram for the footswitch connector on a 6262 infinium? I bought a new 5 pin din cable and need to know which pin is which to wire it .
      • October 15, 2020
      • Bugera 6262 Infinium
        JMaxfield77583 Google is your friend Bro! All of the Bugera schematics (except for the TriRec or the Magician - which never saw production) can be found online.
        • October 22, 2020
  • ScatPack2020
    Newcomer - Level 1
    2020-08-12

    This is a pic of the head

    0 75
    • ScatPack2020
      DanielPaine wonderful - I like the cobwebs. Authentic
      • August 18, 2020
    • ScatPack2020
      ScatPack2020 Yea I just got it I’m trying to find replacement knobs or the actual pits for this amp head it was given to me
      • August 18, 2020
Go to page