Statistics

254,387 members
132,070 posts
  • New
    D3r1vat1v3
    Newcomer - Level 1
    2021-09-28

    Hello

    Switched on My Tc-Helicon 3 Extreme the other day and found it would not boot up and the screen was Blue with a white square within it. Anyone out there know how to fix this issue, as it is completely unuseable.

    thanks in advance

    Mike

    read more...
    0 15
    • D3r1vat1v3
      Nigel67 Hi Mike. Our technical team will be able to advise you further on what the problem may be and how to fix it, or whether the unit needs to go off for repair. You will need to send in a ticket to them. To do this, click on the support tab at the top of the page. A new window will open. Scroll down and click on the Service tab and submit a ticket. Many thanks
      • Sep 29
    • D3r1vat1v3
      D3r1vat1v3

      Hi Nigel
      Thanks for the message. I did open up a ticket after I had no response from the company I purchased my unit from, I have owned the pedal less than a year , was working fine, then switched on at a gig and was greeted with the blue screen-white square issue , and no response from it. The response from Music Tribe was they would not service it as I bought it from a unauthorised dealer. I chose that model expecting reliability as I gig a lot, and now have an expensive Door Stop. I hate to think how much it may cost me to repair what is probably a simple solution, but sadly I did not get it from Music Tribe.
      Regards Mike

      • Sep 30
    • D3r1vat1v3
      D3r1vat1v3

      Hi, Is there anyone on the Community had Problems like I have with their Voicelive 3 Extreme (Blank Blue screen with White square) and can offer solutions, or indeed repair it for me, as Music Tribe refuse to assist. thanks in advance, Mike

      • Oct 2
  • New
    captainflab
    Newcomer - Level 1
    2021-08-02

    I just bought a Duplicator. TC Helicon's own documentation says that it can do octave up or down, but when I tried it out, I only got the octave down. How do I get the octave up instead? Does it need a firmware update to make that happen?

    0 47
    • captainflab
      ChrisEdwards1 Hi captainflab, The Duplicator octave function is dependent on the preset that's currently loaded. The pedal should come from the factory pre-installed with the up and down, however, this can vary. You can change this within the Voicesupport 2 application, if you do not yet have a copy of this it can be downloaded from the downloads center below:

      https://www.tc-helicon.com/downloads.html
      • Aug 4
  • New
    mururoaman
    Newcomer - Level 1
    2021-06-19

    Hello I'am looking for the TC helicon Voicelive Rack MIDI System exclusive.

    I cannot find the codes of the Sysex for Voivelive Rack

    Thank's

    Muru

    read more...
    0 58
  • New
    T260
    Newcomer - Level 1
    2021-05-23

    Hi,

    It would appear artist Tov Lo uses some version of the Voice Live for her shows (or at least used to), however I've never seen any mention of this. Be nice to know how she uses it and the presets, does anyone out there have any info? Perhaps I'm wrong, if not it would seem like a very good artist endosrsement.

    Thanks!

    read more...
    0 43
  • New
    DanLewis
    Newcomer - Level 1
    2021-05-04
    Was hoping you could help me with my Mic Mechanic. Something seems to have gone wrong during the firmware update process. Now, the pedal doesn't work and VoiceSupport2 doesn't recognise it as a TCH device. 
     
    Please advise. Thanks!
    read more...
    0 53
  • New
    LuisFerreira
    Newcomer - Level 1
    2021-05-04

    Hello,

    Last year I created a ticket about the issue I'm facing with my TC-Helicon VoiceLive play. Until now no answer from the support.

    I have performed all kinds of reset to the device explained in the manual (full reset etc....)  , installed the latest firmware etc... nothing solved .

    The issue is the LCD screen display the information of the patch goes reverse and can not be readable from time to time, power off the unit and power up again solve the issue until after a few minutes (30m or 1h or so ) the LCD display goes reverse again.

    Can someone help me on that ?  Anyone had this issue? 

    In attach a picture of the issue.

    Thanks for the support

    read more...
    0 81
    • LuisFerreira
      DavidKnighton Hello LuisFerreira,
      Sorry to hear you haven't been in touch. Quite often if you don't hear from us, it's because your email server spammed our reply. Always check spam/junk inbox when expecting a reply. I would say this issue likely needs to be examined. Go ahead and click the SUPPORT tab and submit a TECH SUPPORT inquiry. Once submitted, you should get an automatic reply with a case number that begins with CAS-xxxxxx-xxxxxx. Provide me with that case number and I'll see to it that someone responds.
      • May 4
    • LuisFerreira
      LuisFerreira Hi David , thanks for your reply, I have create a new ticket "Ticket Number: CAS-450888-X7V5L3". Sometime was not correct on my last ticket request as this time. I get a message with ticket number that I did not happen on the other request. Thanks for your support. Regards - Luis
      • May 5
  • New
    bongnp
    Newcomer - Level 1
    2021-04-19

    The BLUE TC Helicon C1 Pitch Correction pedal

    I just bought 3 of these for my 4-pc rock band. My guitar goes through all of the pedals for pitch correction to my guitar. While playing live all the voices sound SUPER processed and doubled. I'm not looking for 'hard tune' or gender. I'm just looking for some subtle pitch correction for our 3 hour shows, which are very physically taxing. I have the correction knob up about 20% to keep some pitch correction, but it still sounds WAY too processed and double for a live rock band (KISS Tribute). Does anyone have suggestions? If it can't be tweaked, I might have to return them...

    read more...
    0 61
    • bongnp
      WilliamR Could you click on the support link above and create a tech support ticket? You can put attention to William Reichling. If you can provide an audio clip of the tone that would be helpful too.
      • Apr 19
    • bongnp
      kiskadar69 1. "I'm just looking for some subtle pitch correction": I think the guitar signal should not go through the C1s and the C1s should be set to CH mode.

      2. If the problem is not solved, the Cs1 knobs should be calibrated:
      https://www.youtube.com/watch?v=HcLi6wfBkwQ
      • Apr 20
  • New
    Muso2
    Newcomer - Level 1
    2021-04-08

    I can't get vocal or guitar to work?

     

    What software settings do I need to do and which socket should I plug into my fishman loudbox performer?

    0 72
    • Muso2
      PedroRodrigues Hi Muso to be possible to assist you with more resources please follow the link below and submit a assistance case directly with our support team . https://community.musictribe.com/pages/create-new-ticket?type=Technical%20Support&brand=TCHelicon
      • Apr 9
    • Muso2
      Muso2 Hi,

      I’m confused how to set up VL3extreme. The equipment I currently have is Taylor 714ce acoustic electric guitar, shure 57beta mic, VL3E and Fishman loudbox performer.

      I want to be able to play mic and guitar through the vl3e. Is it possible to run it all through my fishman amp or do I need to buy a mixer and speakers? Where do I connect it through fishman if this is possible.

       What gear would you recommend I get if fishman option not possible. I want to get voice and guitar working for VL3Extreme, 

      Thanks in advance
      • Apr 9
    • Muso2
      PetGerbil Can you plug acoustic guitar and mic into vl3, take the main XLR outputs from Vl3 into the mic and guitar inputs on the Fishman amp and set the Vl3 to "Dual Mono" outputs.? (making sure there's no "phantom power" on the Fishmans inputs.)
      • Apr 9
  • New
    jackL
    Newcomer - Level 1
    2021-04-01

    The connected software shows that the device is GTX, and it shows "it is in use" and the firmware cannot be upgraded. Could you please give me a copy of the firmware of the machine?

    0 61
  • New
    CoryDumont
    Newcomer - Level 1
    2021-03-14

    I was at rehearsal last week and decided to plug in my phone to the aux jack to run through a song. Seemed to work fine but now the unit seems to have an j thermal mic issue or something. If nothing is plugged into the aux jack(even just a cable with nothing in the other end) then the unit picks up every sound ( pressing buttons, touching the machine at all) very loud and clearly with a slight delay. The k my way I have found to remedy this is to just leave an 1/8" cable plugged into the aux port. This seems like a very strange issue, I'm wondering if anyone else has come across it. Thanks! Cory

    read more...
    0 65
    • CoryDumont
      PedroRodrigues Hi CoryDumont this may be related to the RoomSense being active, as this tool controls the two onboard microphones on the unit and in some cases can cause similar issues as the ones you just mention. Can you please press MIX and turn the ROOMSENSE level all the way OFF and see if the issue is still present?
      If the steps above, do not resolve this matter have you tried to perform a factory reset to your unit?
      To perform a factory reset hold down “Store” and “Back” during power up.
      Thank you
      • Mar 14
Go to page