Statistics

224,440 members
98,776 posts
  • New
    AcrobatStar
    Newcomer - Level 1
    2021-04-04

    Hi My Xtouch is not working .

    I upgraded to the latest firmware 1.21.   1.04

     

    Showing looking for i.p adresss.

    Is there a reset for this product

    0 7
    • AcrobatStar
      DaveMorrison Changing modes is a type of reset. It looks like your Xtouch is waiting for a IP address to be sent from a DHCP server. What mode are you in? Reloading 1.21 or Downgrading to 1.15 would be another option.
      • Apr 4
  • New
    Djs58
    Newcomer - Level 1
    2020-12-27

    Hello I wonder if you can help. I have a brand new x-Touch and am having very intermittent success getting the item to connect properly in Logic. Sometimes it works, sometimes it just has a blank screens, sometimes half the controls work, the rest don't. I've just updated to 1.21 and now it doesn't work at all. I can see it connected in Control/Setup (as Mackie Control) and the yellow ! goes as it sees the machine but no faders react, screens stay blank. Please help! Thanks

    read more...
    0 36
  • New
    Izio72
    Newcomer - Level 1
    2020-12-14

    Salve,please have you keep spare parts for Behringer BCR2000?

    This is the potentiometer with switch of the Bcr 2000. I am attaching pictures. If you also have a knob, you can add it to your purchase. I think the pot is 19/20Kohm, diameter 6mm and height 25mm: But surely you will have a pattern with part serial number.

    Thanks

    Fabrizio Danieli

    read more...
    0 30
    • Izio72
      Nigel67 Hi Fabrizio, for spare parts, please go to the support tab at the top of the page, scroll down to the bottom of the new page that opens and submit a spares ticket via the spares tab. A colleague will then be able to get back to you with pricing and availability. Many thanks
      • December 14, 2020
      • Spare parts Bcr2000
        Izio72 Done, very thanks!
        • 1
        • ·
        • December 15, 2020
  • New
    lpagross
    Newcomer - Level 1
    2020-12-14

    I'm on a Mac. It appears that the Windows editor for the X-Touch Mini has been uploaded twice instead of the Mac editor. Can anyone confirm that there isn't a Mac editor or upload the Mac editor? Thanks,

    Gordon

    0 24
    • lpagross
      DaveMorrison As far as I remember, there has never been an editor for Mac. There are lots of "Music Tribe" windows apps that have no Mac equivalents.
      • December 14, 2020
      • X-Touch Mini editor
        lpagross Oh well, thanks for letting me know.
        • December 14, 2020
  • New
    Brunoph
    Newcomer - Level 1
    2020-11-12

    Hello friends! I have the following problem: the power board of my BCF2000 is burning fuses and won't turn on anymore ... Where can I buy another board, or get it fixed? I tried to get the service manual, but Behringer does not provide it ... And there is no authorized assistance in Brazil .... Does anyone have experience with this equipment? If I knew the voltages coming out of the board, I would be able to fix it ... Thanks in advance!

    read more...
    0 31
  • vincenttessier
    Newcomer - Level 1
    2020-07-24

    Hello all,

     

    I just received my brand new Berhinger X Touch One, that I will use with my macbook pro and Cubase 10.5 Elements. I updated the firmware to 1.07 and followed the step to set it up, (clicked on STOP + the knob to select Cubase as a DAW + then in Cubase did the proper set-up, see screen attached) it worked well for 10mn but then i started to have some issues. Basically the controls don't respond when I press them, but when I press play on my keyboard bar space, the controller is responding and I can see the music play, the timer / bars moving, if i click on a track, the fader moves etc but again, not the other way around, when I want to use the controller to change things in Cubase, it doesn't respond.

     

    I am not so sure about the Generic Control section, isn't it redundant woth the Mackie control section?

    Also, I changed the USB cable, i'm not using the one that was coming with the controller, I don't think that changes anything as to me a USB cable is a USB cable, right? Or do I have to use the one provided?

     

     

    Thanks!

    read more...
    0 44
  • Oskarchu2010
    Newcomer - Level 1
    2020-06-21
    I was chosen DCPH connect in Xtouch but it keeps waiting. And can’t connect to XR18.
    0 40
    • Oskarchu2010
      GaryHiggins What are your cable interconnections from XR to Xtouch, using a router also?
      • June 21, 2020
      • How can I connect Xtouch and XR18
        Oskarchu2010 I was use Cat 5e cable and without router
        • June 21, 2020
    • Oskarchu2010
      GaryHiggins Do you have the switch in the ethernet poistion? It's likely you need to connect the XR to access point FIRST to make changes to the mixer LAN settings (I would try using DHCP server mode). You need to be connected to the XR and then make your settings changes to LAN and save (or apply). If not the changes you may have thought you made might not have been saved. Once you save the settings, then switch to the Ethernet switch position. Try that and see if you have any luck!
      • June 21, 2020
    • Oskarchu2010
      NicJonesMT Hi Oskarchu,

      Hi GM Audio
      We actually have a video on our KB channel on setting X-Touch and XR18 (In Wlan mode). What I would recommend is to check out the video and then apply the relative steps (Mainly the X-Touch setup) to your system.



      https://www.youtube.com/watch?v=B8lh9xggqi4
      • June 24, 2020
  • bschmidt
    Contributor - Level 1
    2019-08-16

    Hi All, I've been a Behringer fan and user for years and stepped up to buying the x-Touch. Cubase Pro 10 recognizes the x-Touch in all three aspects of Studio setup (see images) but nothing works - actions in cubase don't register in x-touch, and moving sliders in x-touch have no effect in Cubase:

    MIDI Input Output.JPGMIDI Port Setup.JPGVST Quick Controls.JPGAny suggestions on next steps would be greatly appreciated

    Thank you, b 

    read more...
    0 182
    • bschmidt
      Kinghuru

      Hi... I don't know if it will help you but I had to put my XTouch on Mackie Control (MC) setting... I found that HUI does not work... 


      You do this by holding the channel 1 select button down while you power on the device... then dial the first dial to MC... then dial the second dial to USB... 


      Then you press the select button again to reset the XTouch... 


      Hope this helps...

      • October 4, 2019
    • bschmidt
      PSimon

      Hi,


      beside Kingurus answer you also have to tell Cubase, that you're using a Mackie Control Unit. Do this in the studio setup (see your first screenshot). Add a new controller by pressing the little plus-symbol in the upper left corner of the window. Be aware that you add a Mackie control unit and that your device is turned on. On the  right side of this screen select x-touch as midi in and out device. Unselect x-touch as midi device on the other control devices (your 2nd and 3rd screenshot) or simply delete these controls as you don't need them really. Click apply, your x-touch should work now.


      Greetings


       


       


       


       


       

      • December 29, 2019