Statistics

289,850 members
172,414 posts
  • New
    markusraivisto
    Newcomer - Level 1
    2020-12-08

    I bought the pedal and was satisfied, but playing with the LP mode, the looper, made me confused.

    Pressing it once activates the red flash indicating the first loop is recording, pressing it again saves it and starts playing it from the start. Easy and logical.

    However, what made me confused, is that the very first step on the pedal button comes in to the recording creating a little gap to the start. Therefore, if I assume my first loop starts from the pressing of the button, and start playing on the very same moment, I assume wrong - there is a half-second pause instead of my first notes.

    Fault or feature?

    read more...
    0 121
    • markusraivisto
      PedroRodrigues Hi Markus, please be aware that to record Loops you should set the Delay type selector to LP.
      Make sure the pedal is in bypass mode (i.e., the LED should be off).
      Feel the groove and prepare for recording.
      Then tap the pedal’s footswitch to start your recording and play.
      The pedal’s LED flashes red.
      To stop recording, press the footswitch again. Alter Ego Delay immediately switches to playback mode and starts playing the loop. In playback mode, the LED is green.
      To overdub your recording, press the switch once more. The LED now blinks.
      To delete all recordings, double-tap the footswitch.
      • December 8, 2020
      • TC Electronics Alter Ego Delay
        markusraivisto Thankyou, but what is in your reply that adds to my description of use?
        • 1
        • ·
        • December 8, 2020
      • TC Electronics Alter Ego Delay
        PedroRodrigues Hi Markus, can you confirm that the pedal is in bypass mode when that happens?
        • December 8, 2020
      • TC Electronics Alter Ego Delay
        markusraivisto Can't confirm. How can you tell it's in bypass mode? EDIT: The led should be off. I'll check it! But how can you turn it in to bypass mode, if it's not?
        • 1
        • ·
        • December 9, 2020
      • TC Electronics Alter Ego Delay
        PedroRodrigues Hi, Markus, to do that you need to disconnect the pedal and turn it on its back. Unscrew the back plate of the pedal and look for the two-small dip-switches in the upper left corner.
        The upper DIP switch (the one closer to the power in jack), switches between True Bypass mode (default) and Buffered Bypass mode.
        Set the DIP switch to the desired position as you can see on the image
        When finished please remount the back-plate
        • 1
        • ·
        • December 10, 2020
  • New
    Adrione61
    Newcomer - Level 1
    2020-11-23

    Hi all

    Does anyone know the polarity of the ext. power?

    I have a generic power supply but I don't know if positive is in the center or not; living in italy is very diffult ti find an original one

     

    Many thanx

     

     

    read more...
    0 239
    • Adrione61
      Adrione61 oh, damned T9 ....
      • November 23, 2020
    • Adrione61
      RexBeckett Hi Adriano, the power connector is a 3.5mm TS jack with tip positive. It will work with a supply of 8-32 Volts dc at very low current. Use 24-32V if you want to run it at pro signal levels (max 14dBm).
      • November 23, 2020
  • New
    maniatis1717a
    Newcomer - Level 1
    2020-11-23

    Hi .In the section  '' suggested solution ''  for Tc electronic Flashback 2 delay pedal, the answer to the question ''Why do the parameters reset when I try to save my edited Toneprint? '',  has a text and two pictures. The promblem is that the pictures are not visible.. so i can not understand  exactly the solution that is given. Is  there  a way to fix this .  Thank you

     

    read more...
    0 72
    • maniatis1717a
      ChrisEdwards1 Hi George, thank you for bringing this to our attention. I will look into getting the Article update and the pictures reimplemented. For the time being please see below, I hope this helps
      • November 23, 2020
    • maniatis1717a
      maniatis1717a thank you
      • November 23, 2020
  • New
    SaxmanVince
    Newcomer - Level 1
    2020-11-05

    Tc Electronic M-one/M-one XL/Voiceworks Replacement Rotary Encoder 7E34000301 Where can I find this part..?

    0 228
    • SaxmanVince
      JasonB81 Hello - please click above under support and make a parts case and we can get that sorted out for you. Thank you for reaching out.
      • November 5, 2020
  • zsairbedroomstudio
    Newcomer - Level 1
    2020-10-07

    Hello Everyone!

    I've bought a TC Electronic M3000 in a hungarian shop via internet and I have a dispute with them because I think they have sent a used, damaged one instead of a brand new, factory sealed one. They have sent it in not the original box of M3000 but a completely different kind of equipment and the box hasn't contained any owners' manual and other documents. (I have a TC Electronic 96K Finalizer...I've bought it an other shop and came in its original box with these kinds of documents). My M3000 hasn't got its own display saver clingfilm and has some raw cosmetic wears. The equipment has got a little label with this text 'Audiotest OK, ANBOR'. Does this little label use to be found on every M3000, or is it a label sticked by other person, for example in a service?

    Can you tell me the proper year, when has this M3000 been made? The serial number is 1823167.

    TC Item number is: 820088011

     

    Thank you very much!

    Best wishes (Andrew from Hungary)

    read more...
    0 65
    • zsairbedroomstudio
      PedroRodrigues Hi Andrew Zsolt, please be aware that as you know the M3000 is a older unit manufactured a few years ago, so the date of manufacturing will not be recent. The sticker that says audiotest ok is a official factory testing validation that is done at the factory and it look legitimate. On the other had as I'm sure you are aware this is a commercial relationship between yourself and the store and we cannot intervene, we in fact are the manufacturer but we cannot guide the commercial interactions in the market of shops and reseller as they are responsible for there own actions and interactions. In the end if you feel that this unit is not up to your standard you can always return the unit and request a return.Thank you
      • October 7, 2020
    • zsairbedroomstudio
      zsairbedroomstudio Dear Pedro Rodrigues! Thank you for your fast reply and the informations. My argument with the shop will be ended soon, because the hungarian seller will take back the used, not factory sealed, damaged (and maybe repaired) M3000 from me the original buying price (356.900HUF) and they will send a new after paying the difference the new purchase price and the old buying price. (115.000HUF) I hope everything will be OK. Best Wishes: Andrew
      • October 8, 2020
  • PYRALIS
    Newcomer - Level 1
    2020-10-05

    The D button on my Nova System is broken, I live in the countryside and apparently no one know how to repair/ replace. Who can I send my Nova System yo so it can be repaired? It doesn't click, or spin it just hangs.

    0 149
    • PYRALIS
      DaveMorrison If you fill out a support ticket, you can get it fixed. Use the "Support" menu at the top of this page and fill out the all of the required info. Your response will be in an email so check your spam folder.
      • October 5, 2020
      • Nova System D button is broken
        PYRALIS I’ve already done that.
        • October 5, 2020
      • Nova System D button is broken
        john0121 Have you not received a response yet? what's your case number? I'll give the right team a nudge for you.
        • October 5, 2020
  • Malkout
    Newcomer - Level 1
    2020-10-01

    Hi,

    I need a new cable (GPIO connection) of the tc electronic clarity M which is already included in the box.

     

    where can i buy it


    please contact me directly at my email 

     

    thank you

    read more...
    0 81
    • Malkout
      Nigel67 Hi Mahdi. Please go to the support tab at the top of the page and submit a support ticket to the spares department and one of my colleagues will get back to you with pricing and availability. Many thanks.
      • September 30, 2020
  • IanKlausing
    Newcomer - Level 1
    2020-09-10

    After a little over a year of my ditto being an absolute staple on my board, today it just didnt want to work. I used it last night, went to record a loop this morning, red light came on, hit the playback button, it turned green but no playback. I unplugged the power source and checked all the cables and such, now it's just strobing green and red nonstop! This is devastating to me cause I love it so much I was just wondering if theres anything i can do? Are these serviceable? I'd have no clue where to start on diagnosing the issue. I have a hard time believing it's just broken, I'm hoping its something stupid like some kind of reset or maybe theres a way of reading a fault code via the USB,  idk I'm probably just SOL but still. This pedal has not given me any problems using it almost every day for a year and it just doesnt make sense for it to overnight just crap out when it isnt even on. 

    read more...
    0 123
    • IanKlausing
      john0121 Sorry for the problem with your Ditto pedal, please click the submit button at the top of the page and fill out the service request form. A member of the team will be able to help then with some troubleshooting and a repair if needs be.
      • September 10, 2020
  • the3nooges
    Newcomer - Level 1
    2020-09-09
    OK, I really love this Plethora thing; I rate it 10/10, but even so, here's my wish list:
     
    1. Spark Boost
    2. Bigger text in various areas
    3. Asks for save/no save when exiting Edit mode
    4. Board name displayed while in Play mode
    5. When leaning on the Board switch, I want to scroll through the boards one after the other, rather than having to hit the switch over and over again for each next board (Basically, it would duplicate the existing function of "triple-tapping" switch 1 or 2, and both methods would need the "lean on it to scroll" function).

    Overall, an excellent product, and I'm really excited to see what's coming up.  Thanks for the excellent work, TC.

    read more...
    3 105
    • the3nooges
      john0121 Thanks for the feedback. I'll pass this along to the dev team for consideration.
      • September 9, 2020
    • the3nooges
      snaarman Also: can you map or limit the expression pedal movement. That would be great..
      • September 10, 2020
      • Plethora Feature Request - 5 Items
        TC-Mike thx for the feedback, glad to hear you enjoy your Plethora ..control range of the Expression pedal can be customized for each FX slot via the Toneprint app and the Expression pedal can control up to 3 parameters for each pedal, each with it's own programmable parameter value curve.
        Pipeline tremolo allows to boost signal by up to 9 dB and can be programmed to emulate a booster. your other feature requests were already requested by other customers too and are already logged . i added your up-vote
        • 1
        • ·
        • September 11, 2020
    • the3nooges
      the3nooges But what would be really cool is if I could rename the function. In other words, the display would show something like the graphic above. Below "Hypergravity" would be the intended use of the pedal; in this case, it would be used as simply a transparent boost with no compression, just some gain. And right above the words "TC Electronic", maybe a bit more detail (say, "0 to +20dB).
      • September 11, 2020
    • the3nooges
      MikeL YES. Being able to name (in large font) your pedals would be great. For example: I have one slapback delay a one 400ms delay. Labeling them SLAP and ECHO would allow me to see which is which from a standing position.
      • September 23, 2020
      • Plethora Feature Request - 5 Items
        MikeL Yes, great idea! And very user friendly!!
        • November 7, 2020
  • Nistico
    Newcomer - Level 1
    2020-09-09

    Does any one tried this out? When is not playing or recording is true byepass, and it's OK BUT, and it's A Big BUT, when recording, playing or doing anything after created the first record, it's a Huge tone sucker!!! I know that it's buffered when playing or recording but this was not happening with the old dittos... Does any one from tc can explain this to me? And a way to solve this? Other else I will return the item and ask for a refund from thoumann. Best regards everyone

     

    read more...
    0 137
    • Nistico
      Nigel67 Hi Nistico, please could you provide me with information on your set up as this is not an issue that has been reported before. If you could put together a drawing of your setup / connections that would be even better. Many thanks
      • September 14, 2020
    • Nistico
      TC-Mike Yes, we need more info about your setup. Any chance you are using Fuzz pedals in your signal chain?
      • September 14, 2020
    • Nistico
      Nistico Hi Mike and Turner. Tks for answer. I don't have any fuzz pedal.Tbe screamer and Ocd going into AMT F1 preamp than tc flashback and reverb into AMT Pangea cp-100 (impulse response loader)than ditto+ Once again.WWhen is on but no recorded loops its OK but when I press the record the sound drops about 30% of the original gain, even with the volume on ditto at max. I triedto upgrade the firmwareon tc website,it's not solve the problem and creates a new one. Now, with the ditto+ completely empty, I start to record and a few seconds later a message shows up at the screen " 4 minutes left" I just don't know what's happenin. II wwill ssend bback tto tthoumann and the will send to you to checkit out. I really would like to have the ditto + in my board but not like that. If you can explainwhats ha penned,and will work properly, I will buy it again. Best regards
      • September 14, 2020
      • Ditto+ problem?!!
        Nistico Sorry about the misspellings. JJust a thiny keyboard on the cell phone
        • September 14, 2020
    • Nistico
      Nistico I again guys, I have some news. I did again the firmware update and the 60min loop came back!II I can't explain that. The second information tha I would like to share is that I change the order of the ditto+ in the chain, I put it Before the AMT pagea cp-100 (impulse response loader)and works fine,no signal loss.. I assume that is note a problem with ditto+,may be with the impedance change after de pangea.For live and pratics its OK because the signal goes true the impulse response after the ditto+ but to export the files from the ditto+ to the computer I will not have the impulse response filter in the records.II can live with that.TThank you so much for the help,yyour qquestions aabout tthe cchain let me tink about tthe order I alread call thoumann and explain.II will keep te ditto,anyway its a fantasticllooper . Best regards for all
      • September 15, 2020
Go to page