Statistics

241,180 members
117,431 posts
  • New
    marvinholdman
    Contributor - Level 1
    2021-07-26

    I have one of the first TC Helicon Play Acoustic you could get in the USA. So new, in fact, they didn't even label the buttons correctly! That said, it hit the ground running with me and has made this working musician thousands of dollars. I've loved it's simplicity (I ditchted the mixing board for it!). I don't use nearly all the features. In fact, I only use it to route and sweeten me and my guitar. It has been a workhorse and has never let me down. Lately though, towards the end of the night, I swear it starts adding a bit of far off background vocals to the signal. At first, I thought it was patrons singing along, then I notice no one is singing. I've had a few folks ask me about it and frankly I am a bit puzzled. See, I don't use any of the harmony capabilities of this unit. Just straight up guitar, with some body rez and a little reverb on the voice. That is all. So... I wondered if anyone else has ever noticed any mysterious "voices" in the output of their Acoustic Play? It is very subtle. Just enough to make me question my sanity. Anyone?

    read more...
    0 0
  • New
    tranix
    Newcomer - Level 2
    2020-12-31

    I have a problem with vacuum tube preamp v2200 with a left side eq not working out well, with a little bit of hiss. I have sent in three care tickets now, I believe, in the last two months. I have purchased the unit last May,  I believe that it is still under warranty. The product is registered with Behringer.  I requested technical support and service, but no one has responded to my care tickets. The ticket keeps saying as status, "problem solved." But the problem is not solved because I have not been contacted yet. Please, someone at Behringer, look into this and help me. I am a big fan of your products and own several of your synthesizers and a few effects units as well. I have uploaded a screen shot of two of the care tickets that I sent in. Thanks.

    Sincerely  Mark Wasson

    read more...
    0 35
    • tranix
      ChrisEdwards1 Hi Mark, upon checking your cases I can see a response to both was sent on 22/12/2020 and 30/11/2020. It is highly likely these could have routed to your spam/junk folder or even been blocked by your email provider. I would recommend checking these locations and I will also request my colleagues resend their emails.
      • December 31, 2020
      • Behringer not responding to my technical and or sevice care tickets request. Have sent in three so far. No response.
        tranix Hello sir. Thank you so much for getting back to me. I have checked my email spam folder and nothing arrived from your tech response. However about a year ago I had another problem and your customer support was able to contact me through the same email that I used this time [email protected] I can't understand why it is not working this time. Could you send to your department another email to contact me with at [email protected] Is there any way update my information with another email address? Thanks. Love your products, your my favorite audio company. I have like seven of your synthesizers and five audio effects units. I continue to buy your products.
        • Jan 2
    • tranix
      tranix I have gone into my profile and tried to change my email address to be contacted. Still, the website will not allow me to save my new email address for your department to respond to my service request—any help. Suppose I open a new account with another email address. Is there any way to transfer my registrations over of my products and care tickets to a new account? Thanks.
      • Jan 2
      • Behringer not responding to my technical and or sevice care tickets request. Have sent in three so far. No response.
        ChrisEdwards1 Hi Mark, thanks for the follow up. Just to confirm my colleague resent his response on the 31/12/2020 this was not received also?
        • Jan 3
      • Behringer not responding to my technical and or sevice care tickets request. Have sent in three so far. No response.
        tranix Yes it was not received on my [email protected] email. Sorry for slow response sir.
        • Jan 11
      • Behringer not responding to my technical and or sevice care tickets request. Have sent in three so far. No response.
        tranix In the message you replied to me on December 31st, I was notified through my email account that there was a reply to my question from the music tribe. Your message you sent to me on January 3rd did not notify me on my email account this time. I was expecting a notification to my email from your next reply. That is why my slow response. But I decided to check today on music tribe, and I see you replied to me on January 3rd. What should I do? Open a new account with a different email? Thank you so much!
        • Jan 11