Statistics

289,809 members
172,366 posts
  • New
    acabrecords
    Newcomer - Level 1
    2022-06-09

    Hi everyone! 
    so just wanna say I really love the poly D! The tones that can come out of this beauty is insane!

    The only problem I have is there's a couples of keys (A2,A#2,B2) that are making a weird sticky sound when i press them a bit harder, like a physical sticking plastic sound! So i thought oh maybe i got a bad unit so I ordered a second one, which to my dismay, does the same thing but just on different keys this time. 

    it doesn't affect the sound in anyway but at a 1000$ CAD I would have liked to see a better quality control!

    Im hesitating about my next move, do I send them back to amazon and hope that the third one is gonna be ok? Is it worth it or they all do that? 


    View Video
    read more...
    0 10
    • acabrecords
      NicJonesMT Hi Acabrecords.
      Is this happening just on these specific keys or on all?
      There is a small rubber bump stop underneath the keys with an air pocket in. If you push the keys with some force it causes the pop noise, as the air is released.
      Can you please click support at the top of the page, and provide a short video of the noise you are getting. From there we can then try to determine if it is the bump stop or something else that you are getting.
      • Jun 10
      • Poly D sticky key sounds
        acabrecords Hi Nick! So on the first unit it was the key mentioned above and on the second it’s B3, C3 and D3.
        • Jun 10
      • Poly D sticky key sounds
        acabrecords i did posted a video on the post but when i get home ill take another one and send it to support! Thanks
        • 1
        • ·
        • Jun 10
  • New
    EdwardJonathanBlakeley
    Newcomer - Level 1
    2021-01-24
    1 98
  • New
    Tinkertra1n
    Newcomer - Level 1
    2020-11-28

    Hi,

    I've noticed that the decay does not behave as expected when setting the decay curve to +50% (255). At the end of the decay period there is an extra hump right before the envelope enters the sustain phase. Can someone else confirm this? Is it a bug or is it just my DeepMind 12 that is acting up?

    Steps to reproduce:
    1. Create a default program
    2. Set VCA sustain to 0
    3. Set VCA decay curve to 50% (255)
    4. Play a note and let it decay fully.

    I've attached an audio example.

    read more...
    0 151