Statistics

293,637 members
176,662 posts
  • New
    Dmeek
    Newcomer - Level 1
    2021-12-11

    Hi! One week ago today I received a X-touch. it seems great except the faders don't go to zero. I looked at the firmware and it is version 1.21, and I imagine it's something software related but don't know how to fix it. I sent a message last week when I set up my account and received no response... having this thing in front of me not working right it's seriously bumming out the new purchase excitement. I'm using it with reaper if that helps at all (v6.42) Please help! Thanks


    View Video
    read more...
    0 21
  • New
    Edmond
    Newcomer - Level 1
    2021-08-11

    Hi All,

    I bought xTouch recently and connected Pro Tools by HUI. BUT I found that TRACK button can't press it. AND Signal METER is missing. How can I do? When I connect Pro Tools's setup, HUI PRO is missing.

    Thanks ALL!!!

    0 83
    • Edmond
      NicJonesMT Hi Edmond.
      Please note that the X-touch will behave differently with each DAW. It is down to how the DAW developers have integrated the HUI and MCU protocol.

      With your Issue, Could you please submit a support ticket (Click support at the top of the page) and confirm the following:

      How is the XT connected to your computer?
      How do you have the XT configured in Pro Tools (Please provide a screenshot)?
      Have you tested the unit with an alternative DAW (For example Reaper using the MCU protocol)?
      What firmware is the XT using?
      • August 11, 2021
    • Edmond
      Edmond

      Hi Nic,
      I submitted a support ticket. Thanks for your help! I hope it can solve my problem.

      • August 12, 2021
  • New
    danbaileyak
    Newcomer - Level 1
    2021-01-29

    Hello, I recently purchaed an X Touch One, and according to the instructions, I should be able to use a standard midi sustain pedal as a record-toggle footswitch with Logic Pro X. However, when I plug a pedal into the jack on the back of the unit and press the footswitch, the unit seems to get confused. It gets stuck in a glitchy recording loop inside Logic Pro, and the lights on the X Touch One go all haywire. The only remedy is to power off the unit and unplug the footswitch.

    I've tried using two different footswtiches, both standard 1/4" midi sustain pedals, and the unit exhibits the same behavoir, no matter which one is connected. Please note, I'm running the X Touch One firmware to the latest version (v.1.08) and using the X Touch One in the Logic configuration.

    Am I missing something? Is there anything specific I need to do inside Logic to properly set up the unit so it recognizes the record-toggle command doesn't get confused? Or do I have a defective unit.

    Thanks,

    Dan B.

    read more...
    0 760
    • danbaileyak
      PedroRodrigues Hi danbaileyak, I believe you have the unit on MC mode to operate with LOGIC have you tried to set up the unit in MIDI mode to control your pedal.
      If you are using the X-TOUCH ONE in a MIDI mode, select it in your DAW as a MIDI controller. Please confirm with your DAW’s MIDI Learn functions, and you will be able to map each button and feature of the X-TOUCH ONE to a function and control on your DAW.
      Please assign the unit to MIDI mode and please confirm that you have assigned the following message for your pedal as per below :
      MIDI Send CC
      Foot Switch: Control Change 64 (push: value 127, release: value 0)
      MIDI Send Note
      Foot Switch: Control Change 64 (push: value 127, release: value 0)
      I hope this helps
      • January 29, 2021
    • danbaileyak
      danbaileyak Thank you for getting back to me. I am currently using the X Touch One in LOGIC Mode. I prefer to use it this way, so that I don't have to reassign all of the buttons on the unit. By default, in Logic Mode, Pedal A is set to "Play or Stop," but as you saw in my video, this doesn't seem to work correctly. If I plug the footswitch into a different midi interface, I can get it to work just fine, so that's why I'm wondering if there's something wrong with my X Touch One, or if it simply doesn't work properly with the sustain pedal footswitch.
      • January 29, 2021
      • X Touch One Footswitch Problem
        PedroRodrigues Hi danbaileyak, form your description it seem that this is a matter that is related with your DAW MIDI implementation, as you stated the unit work with the Pedal work just not the way you wish to implement. I this case I would suggest to search for information on LOGIC support. Thank you
        • February 2, 2021