Statistics

242,817 members
119,208 posts
  • New
    davenov41
    Newcomer - Level 1
    2020-12-21

    Help! I've owned the TC Flashback II for a few months now and am loving it. Earlier this year I updated the firmware to use the tap tempo function and that was working fine. I came back to my pedal after a month off or so, and now for some reason, when engaged, I can only hear the delay output, and not the attack of the note itself. What I've done so far to troubleshoot: 

     

    - Pulled the pedal off the pedal board and isolated it as the only pedal in the signal chain between the guitar and the amp

    - Tried multiple different amps

    - Tried multiple different guitars

    - Verified that input is going into the pedal through MONO and exiting through MONO

    - Verified that true bypass and kill/dry dipswitches are set correctly (set to true bypass and off respectively, both oriented left)

    What are suggestions for next steps? Thank you!

    Dave

    read more...
    1 141
    • davenov41
      NicJonesMT Hi Dave.
      I'm Nic from the UK tech support team.
      Just to let you know I have picked up your Tech Support ticket and will be contacting you shortly.
      • December 23, 2020
      • TC Flashback II- only hearing delay, no dry?
        davenov41 Hi Nic- thanks so much for your reply. I received your email regarding my support ticket... I wasn't able to find a way to reply to the ticket from within the care portal, so I simply replied to the email. Please let me know if there's a better way to contact you! Thanks again for your help. Dave
        • December 23, 2020
    • davenov41
      TC-Mike Please check that the Kill dry switch is not set to "ON" . the dip switches can be reached by removing the back cover and more info on the positions /settings can be found in the manual. the second dip switch switches between "true-and buffered bypass" -Buffered bypass will retain the Delay repeats when pedal is bypassed
      • Jan 4