Statistics

269,007 members
148,664 posts
  • New
    Whodunit
    Newcomer - Level 1
    2022-01-20

    Hi guys, 

    Just got used a TC Electronic - Nova Drive.

    I really like a couple of the setting the previous owner has programmed.

    How can I see the parameters so I can recreate and archive the settings, before I strat tweeking?

     

    Thanks Mike

    read more...
    0 9
  • New
    Mikey333
    Newcomer - Level 1
    2022-01-18

    A couple years ago I called TC Helicon for help setting up my Play Acoustic, a fine unit, but a real bear to set up. They helped a lot getting my rig running.
    Today I return to TC Helicon for help and see four people with headset Phone microphones/earpieces at the top of the page BUT NOT ONE SINGLE PHONE NUMBER FOR ANYONE TO CALL, as I did last time.
    Does this mean we are now only helping each other on a forum? No more live chat with a tech there? Is this a cost-cutting move?
    I'm now really doubting TC Helicon's sincerity at helping its customers.

    read more...
    1 10
    • Mikey333
      Nigel67 Hi Mikey333. I am sorry, but there is no telephone support at the present time. You can however contact our Technical Support Team through our Care Portal ticketing system, where they will help you through any questions that you have. To contact the Tech Team, please click on the Support tab at the top of the page. In the new page that opens, scroll down and click on the Technical Support tab. Fill out the ticket and a colleague will come back to you with an answer. Many thanks
      • Tue at 11:14 PM
  • New
    Mikey333
    Newcomer - Level 1
    2022-01-18

    How is it possible my Play Acoustic vocal AND guitar are mixed together on the VOCAL output? Is there a setting I need to undo?
    I have seperate inputs to both vocal and guitar - plus seperate outputs for both to my PA. Yet when I shut off the guitar I still clearly hear it in the vocal channel.
    I'm trying to add a new Fender Smolder pedal to my pedalboard and finding, though tat pedal works fine straight into an amp or my PA, it is NOT working fine (half strength) when put before the Play Acoustic or after it!
    I'm about to give up and pull my guiter entirely from my Play Acoustic and just use it for vocals.

    read more...
    0 5
  • New
    sachin1
    Newcomer - Level 1
    2022-01-18

    With settings Tweed and Clean there is no noise...but swtching to BRIT or Calif using hi gain gives conitnous strong Hum/Rustle noise... While changing in MOD switch click /clip sound comes from speaker...kindly suggest a solution...

    0 6
  • New
    B5215
    Newcomer - Level 1
    2022-01-17

    I have a Morningstar MC3 plus BluGuitar mercury and a plethora figured out the BluGuitar ok but cannot seem to get the plethora to work. Just want to switch boards. Played around and can make it switch with the 3 BluGuitar setting I have but it's switching the wrong boards? How do I for example say when I press button A on the MC3 I want board number 22 and button B I want board 11 for example. I thought about moving the boards to the slots I seem to be able to switch but don't think you can move the boards around. I think just to control Boards is a pc change and should be easy? Don't need to control the individual pedals as I guess if they are on when I return to the board it will still be on.  Please help I have spend 2 weeks off and on and getting nowhere.

    read more...
    0 5
  • New
    shawnthesheepy
    Newcomer - Level 1
    2022-01-12

    I recently bought the Sub n Up octaver and was excited to try the Toneprint editor - succesfully making my own Toneprints but when I try to store it in the pedal, it always reverts back to the default Toneprint. I even tried beaming them in via my phone but it was the same. Any ideas?

    read more...
    0 15
  • New
    s199
    Newcomer - Level 1
    2022-01-11

    Hi i was using the looper and thought i had deleted the loop and went back into the voice section but it appears the loop was still running. I am now not able to use any of the switches or knobs on the unit. i can scoll the presets using the arrows.

    i have turned the unit off and on but still cant use any of the switches or knobs.

    i have updated the firmware but still no resolution to the issue.

    Can you please help

    Thanks Stephen

    read more...
    0 2
    • s199
      s199 Can anyone help with this issue all of the knobs and foot switches and controller knob is frozen which means i cant factory reset the machine as i cannot select the options in the maintenance screen. i have deleted all of the presets and restarted but it doesnt fix it nor does downloading the firmware. Not sure what to do now?.
      • Wed at 2:10 PM
  • New
    baweems
    Newcomer - Level 1
    2022-01-06

    Computer recognizes both, but neither show up in the app no matter what.

    0 10
  • New
    Dkoky
    Newcomer - Level 1
    2022-01-03

    Can anyone please confirm if i can connect a Xynyx 802 directly to a Eurolive B213D?

    1 11
    • Dkoky
      Nigel67 Hi Dkoky. I am sorry, but I do not recognise the Eurolive B213D (could one of the numbers be wrong?), but as long as the speaker is active, i.e contains an amplifier, then you will be able to connect the Xenyx 802 to it. The Xenyx does not have a built in amplifier.
      • Jan 3
  • New
    Nandopr81
    Newcomer - Level 1
    2022-01-02

    Good Morning everyone and happy new year!!!Well the question is...Can i use my Bugera 6262 Infinium with the Ps1 powersoak?I know that the Ps1 it's a 100w Max power attenuator and the 6262 it's a 120w amp but,i've heard something about the real power of the 6262 it's 85 R.M.S Watts and could fits perfectly with the Ps1 powersoak so...Can anybody tell my something about this?

    read more...
    0 5
Go to page