Statistics

267,754 members
147,251 posts
  • klapklapklap
    Contributor - Level 1
    2019-12-16

    Hello,
    I need one information about Alter Ego X4 and I don't know where to ask, so. ❤
    Is Behringer FCV100 compatible expression pedal with Alter Ego X4.

    Thank You ?
    Martin

    read more...
    0 95
    • klapklapklap
      TC-Samuel

      Hi Martin
      Glad you found us
      The Behringer FCV100 is a volume pedal as far as I can tell. You need a dedicated expression pedal as they will have different potentiometer values or a combined option. I haven't tried Behringers FC600. That might work, but if you have the option where you live, you can go down to a store and hook up your X4 to any expression pedal you like and open up the toneprint editor. There you'll see a graph showing the exact range of the potentiometer specific expression pedal you're looking at. They can be quite different. I now it's a bit geeky, but we can't help it


      Hope you find something and have tons of fun with it.

      Cheers
      Sam

      • December 17, 2019
  • bpmben
    Contributor - Level 1
    2019-12-16

    Just got a BC208 and it buzzes on the top speaker. My Music tribe case number is 01040995. Help please!

    0 77
    • bpmben
      TC-Samuel

      Hi bpmben
      If you have an open support ticket, I promise you the great guys in support will get back to you as soon as they can
      Cheers,
      Samuel

      • December 17, 2019
  • lifeforcer
    Contributor - Level 1
    2019-12-15

    When I power up the D Two switches back from user to factory presets every time. Not sure why

    0 121
  • Eb1
    Contributor - Level 1
    2019-12-14

    I am returning 4 TC Pedals I bought just two weeks ago from the GC promotion. The Nether, Surfer, HoneyPot Fuzz, and the Swell Pedal.  All of these pedals were pretty much abismal in sound quality, and sounded different each time I would use them. 
    I understan they are a consumer line of stomp boxes, but I believer I can get better results by buying the components to build these myself. Sorry, TC, but IMO you failed on this line of products.

    read more...
    0 111
    • Eb1
      TC-Samuel

      Hi @Eb1 
      I'm very sorry to hear that. If you think they sound awful that is totally legit, but I assure you they should sound the same everytime you use them! I hope you find some pedals that better suit your taste
      Cheers,
      Samuel

      • December 15, 2019
  • rjferretti
    Contributor - Level 1
    2019-12-13

    Just got the HOF 2 and Flashback 2 today. Right away I noticed the selector knob on the HOF is very firm and exact when turning but the selector knob on the Flashback feels mushy and has a lot of play in between options. Is this normal or should I return it and get another one?

    Thanks

    read more...
    0 117
    • rjferretti
      TC-Rasmus

      Hi Rjferetti
      The two knobs should feel almost exactly the same, with "a little play" in between options, and a quick snap when you select a mode. It might be that the HOF2 just needs some turning, or you may try to pull off the knob and reinsert it. If this doesn't work, and you still think it is an issue, then report back to us here 

      Hope this helps

      • December 15, 2019
  • yann_
    Regular Contributor - Level 1
    2019-12-11

    I've saved up a little bit of money for these units 
    at the moment i've got the tc-8210 the dvr-25 and the tc-1210. can't afford the tc-2290 yet anyway.
    I'm pretty amazed by the sound of the reverbs. really like it better than pretty much most reverb vst's
    I hope these will be supported for ages to work... 
    And the drivers being updated for the years coming...
    Please don't let us users who always put trust in this brand down. I'm still a konnekt-48 user i also got the Clarity and some other outboard fx's from tc... I always loved the brand for making top quality gear. 

    There is one thing I was curious about, as u can use multiple vst's of a certain unit how do you go from using the hardware from one vst to another..?  

    read more...
    0 120
    • yann_
      TC-Samuel

      Hi @yann_ So happy you like them! The controller automatically detects which instance of the plugin you are using. The link icon in the lower left corner of the plugin interface will turn from yellow to green when you select the window and you'll see the controller change values.
      Hope they'll bring you tons of joy in the years to come
      Cheers,
      Sam

      • January 8, 2020
  • stevetrembley
    Contributor - Level 2
    2019-12-09

    You open a ticket. You get one response. You reply. You get "we haven't heard from you". Has happened twice now. Where the hell are you Jason Brewer? You need to be fired. This is utter nonsense. Absolutely useless support system. I've never seen such ridiculous lack of support ever. It's like the entire support system is run by idiots.

     

    read more...
    1 227
    • stevetrembley
      TC-Kristian

      Hey @stevetrembley 


      Sorry to hear about your experience.
      Can i ask you for your care ticket number? I'll pass it on to a support colleague.


      In the meantime, here are some tips you can try if you haven't already.


      1) Have you tried to do a memory reset (press and hold Loop 1 switch for 13 seconds until LED blinks orange)?
      2) Which version number are you running? The advice above won't work if by any chance you still have the original build 35 firmware. ---< Connect your X4 via USB to computer and take a look at the Ditto partition for "about.txt" file which contains firmware number.
      3) Have you tried updating to latest build 91 beta? if not I'll send you a download link.


      After that, connect your pedal to your computer via USB, but don’t connect the power supply.


      Hold down the far left footswitch while inserting the power supply. KEEP THE SWITCH PRESSED DOWN UNTIL ALL LIGHTS TURN SOLID GREEN.


      Open the firmware update application and in the drop-down menu select DITTO BOOT.


      Click the UPDATE button.


      Once the update has reached 100% and the LEDs have changed you can disconnect your pedal.


      4) If your unit cannot be set to boot mode it means the memory card is shot and needs to be serviced --> If thats the case, it seems you have a unit from the first batch and needs to be exchanged - your exchange unit will come with a new updated memory card.


      - Kristian

      • December 10, 2019
    • stevetrembley
      stevetrembley

      Here's the deal. I've udated the firmware and it seems to operate with fewer glitches, but why did I recieve a "new" unit last month with firmware from 2017? If I did receive an old stock unit with older, now updated components, I need to know this before it's too late to return. It's a simple question and Jason can't seem to answer this question. Weeks have gone by with 2 sporadic replies that don't come close to a relevant, "hey I read your email" response. Very frustrating. 


      1. Serial number 14307305. Someone please tell me the date of manufacture on this unit.


      2. Someone please tell me if this unit is older stock, now updated with a more current, trouble free design or components/memory card.


      3. Do all the new units still come with the two year old Version:1.0.00 BUILD 35 firmware?


      I've only got another couple weeks to determine this so I can get a refund and then a more current X4.

      • December 11, 2019
    • stevetrembley
      stevetrembley

      My original ignored case number was Case: 01031637. Since I received no replies, I opened another ticket Case: 01036840

      • December 11, 2019
    • stevetrembley
      stevetrembley

      And because their email support system is absolutely USELESS, they have closed my most recent case number. I swear, this is the worst customer service ever.


       

      • December 12, 2019
    • stevetrembley
      TC-Kristian

      Dear @stevetrembley 


      I am deeply sorry to hear about your issues - this shouldn't happen.


      I have contacted the head of the support department and they will resolve this promptly.


      Sincerely, Kristian


       


       


       

      • December 12, 2019
  • chrismilne
    Contributor - Level 3
    2019-12-09

    This worked fine last night on my project in studio one with a Mac Mini.  Today, just dashes.  Says not connected.  I've tried through a hub and direct to a usb port.  I've used the hardware less than 5 times.  Please help.  I tried to reinstall the drivers already.

    read more...
    0 152
    • chrismilne
      chrismilne

      It's just a bad idea that you can't use the software without the hardware, I'm stuck not being able to use this. 

      • December 10, 2019
    • chrismilne
      TC-Rasmus

      Hey Chris

      It sounds like it could be a hardware problem. Maybe try the unit on another computer - and tell us if that works?

      • December 10, 2019
    • chrismilne
      chrismilne

      I went through the hassle last night of installing Boot Camp, my daw, plugins etc on my mac under windows....and strangely it seemed to work there.   So that is the same unit, on the same mac mini (but under windows/bootcamp), even on the same USB hub.


      I went back to the mac and used an app cleaner to delete everything, deleted all the instances of the plugin in the vst/3 folders...reinstalled and no change.   Anything else on a mac i need to clean out to really remove it from the OS?  I don't know enough about mac's to find it...i thought it was just supposed to work...they say.


       

      • December 10, 2019
    • chrismilne
      TC-Rasmus

      It should work though.
      Nice of you to check by going through all that work

      Maybe send us some info on the OS you're using right now and some specs on your computer, and we'll look into it?

      • December 11, 2019
  • Caught exception: Specified column "user_id" is not in the row
  • TopherConner
    Contributor - Level 1
    2019-12-04

    I just got the Hall of Fame 2 in the mail. I plugged it in, the red light comes on but no sound comes through. I turn the pedal off, I can hear my guitar. Turn the pedal back on, the light shows the pedal in on, but I have no sound. Any ideas??

    read more...
    0 157
    • TopherConner
      macfilipe

      Which setting do you have it on? IIRC, toneprint slot 3 comes preloaded with a toneprint that cuts off your sound until you use the MASH switch. Is it also cutting off on the named presets, such as the Hall / Plate / etc?

      • December 4, 2019
    • TopherConner
      TC-Samuel

      Hi TopherConner,


      Have you gotten it to work?


      Can you check which preset you are on?


      As Macfilipe said TP slot 3 turns the pedal into a faux volume pedal. So you can only hear your guitar when the MASH switch is engaged.

      • December 5, 2019
Go to page