Statistics

260,195 members
138,697 posts
  • New
    EuanRichard
    Newcomer - Level 1
    2021-11-05

    Hi, I just have a quick and simple question - will there be any more updates to the Plethora X5?

    I've seen hundreds of recent posts clamouring for more frequent updates - as originally promised to customers as part of their purchase - that would continue to turn the Plethora into a true "Multi-FX" pedal. However I can't find any communication at all on this issue, and no updates for over a year now.

    Is there any roadmap or timeline here, or have the promises been abandoned?

    Thanks

    read more...
    2 17
    • EuanRichard
      CSurieux I fear it's dead for more important updates :(
      • Nov 5
    • EuanRichard
      BibsJ I am editing my post to echo the OP. It would be nice to know. Either way it's a good device if you can find one used for a decent price.
      • Nov 5
    • EuanRichard
      BibsJ Hi TC Folks, any updates?
      • Nov 14
    • EuanRichard
      EuanRichard

      Yes please, TC.

      I love TC Electronics gear and have spent hundreds over the years... but if promises get broken like this, and worst off you won't even reply honestly to the question... all I can do is throw it all in the bin, and advise everyone never to buy anything TC again.

      • Nov 14
    • EuanRichard
      John-PierreConq

      No updates for over a year and no responses to any emails in just as long. I'd say they've abandoned this project already.

      • Nov 15
  • New
    Virtanen
    Newcomer - Level 1
    2021-11-05

    Hi,

    What are the supported PCMCIA cards for System 6000? 

    0 1
    • Virtanen
      PedroRodrigues Hi Virtanen, thank you for your post, SYSTEM 6000 will work with a variety of PCMCIA CARDS but we advise to use a brand called PRETEC . Than you
      • Nov 5
  • New
    paul510
    Newcomer - Level 1
    2021-11-04

    Hi, my bh250 owner amp has stopped working. All the other features (TonePrint, DI, eq and tuner) function, but I have nothing out of the Speakon connector. I unplugged it and removed the cover, then looked under the heat sink at the power chip. Oh my god! There is charting on the underside of the aluminium heat sink that looks like the components next to it have exploded. The heat compound has dried up, and it looks like this is what caused the problem. Is there any way to get a replacement board?

    read more...
    0 5
  • New
    quadrifoglio
    Newcomer - Level 1
    2021-11-03

    After clicking on Buy Now button the PayPal small windows appears for a second, then dissapears and then nothing happens.

    Tried few browsers and computers. Any help with this? Thanks...

    0 14
    • quadrifoglio
      NicJonesMT Hi Quadrifoglio.
      Can you confirm the browsers you are using and if you have cleared your Cache?
      Are you using any Adblockers?
      • Nov 3
  • New
    Dylandylan
    Newcomer - Level 1
    2021-11-02

    Hi! I have a Shaker pedal, and I've misplaced the oversized screw that secures the bottom of the enclosure. Is there any way to order a replacement? Thanks!

    0 5
    • Dylandylan
      Nigel67 Hi Dylandylan. Please send a ticket to our spares team and they will be able to advise availability and pricing. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Spare Parts tab and submit a ticket. Many thanks
      • Nov 1
  • New
    LukeAnderson
    Newcomer - Level 1
    2021-10-31

    I turn it on and it lights up a weird set of lights and does not play. It's stuck in this mode. Clip light, TubeDrive Light, E and A tuner lights, Flat tuner light and Power light are all lit solid. No sound.

    0 1
    • LukeAnderson
      Nigel67 Hi LukeAnderson. Please fill out a Technical Support ticket and we will be able to assist you in getting your unit repaired. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Technical Support tab and submit a ticket. Many thanks
      • Oct 31
  • New
    PatrickTR1
    Newcomer - Level 1
    2021-10-30

    Hi - can you take a look at this short vid and tell me what is wrong with my setup

    It's a Windows 10 64 bit set up - the software is all up to date.

    I have reinstalled the latest firmware to the Pletora unit & and I have re-downloaded the latest Toneprint software.  

    https://www.screencast.com/t/wkRqaC80BJ

    Any thoughts much appreciated.

    Thanks.

    Patrick.

    read more...
    0 12
    • PatrickTR1
      NicJonesMT Hi PatrickTR1. Thank you for the video, I've watched it and think the best option would be to submit a tech support ticket (Click Support at the top of the page).

      Can you please provide the following in your ticket (Along with your video link) and we can then hit the ground running to try and get this sorted.

      1 - Please confirm the exact Toneprint app version you are using .
      2 - Please confirm the Firmware version on the Plethora (we need the version number).
      3 - Can you confirm the Windows Build and Version you are using (Found in "About your PC").
      4 - Please check all drivers and bios for your computer are up to date.
      5 - Have you tested on an alternative computer.
      6 - How are you connecting the Plethora to your computer.
      7 - If using USB, please confirm if you have tried connecting to a USB 2.0 Port directly to your computers Motherboard (Avoid any Hubs and adapters where possible).
      8 - Have you performed a Factory Reset.
      • Oct 31
      • Struggling when creating a new board on TC Electronic Plethora X5
        PatrickTR1 Ok thanks Nic - I'll do that.
        • Oct 31
  • New
    kstolting
    Contributor - Level 1
    2021-10-28

     

    Hi

     

    I am aware that Pace iLOK has issues with Monterey. The current version of Finalizer crashes as soon as it's opened. Here's the iniatial part of the Crash Report. 

     

    Translated Report (Full Report Below)
    -------------------------------------

    Process: Finalizer [6897]
    Path: /Applications/Finalizer.app/Contents/MacOS/Finalizer
    Identifier: com.tcelectronic.Finalizer
    Version: 1.0.1 (1.0.1)
    Code Type: X86-64 (Native)
    Parent Process: launchd [1]
    User ID: 501

    Date/Time: 2021-10-28 11:29:48.3236 -0500
    OS Version: macOS 12.0.1 (21A559)
    Report Version: 12
    Bridge OS Version: 6.0 (19P548)
    Anonymous UUID: A8046853-FA96-EAED-E18D-8993D73BE607


    Time Awake Since Boot: 18000 seconds

    System Integrity Protection: enabled

    Crashed Thread: 0 Dispatch queue: com.apple.main-thread

    Exception Type: EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000
    Exception Codes: 0x0000000000000001, 0x0000000000000000
    Exception Note: EXC_CORPSE_NOTIFY

    Termination Reason: Namespace SIGNAL, Code 11 Segmentation fault: 11
    Terminating Process: exc handler [6897]

    VM Region Info: 0 is not in any region. Bytes before following region: 4411924480
    REGION TYPE START - END [ VSIZE] PRT/MAX SHRMOD REGION DETAIL
    UNUSED SPACE AT START
    --->
    __TEXT 106f8a000-108408000 [ 20.5M] r-x/rwx SM=COW ...cOS/Finalizer

    Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
    0 ??? 0x0 ???
    1 dyld 0x10a9bfb49 invocation function for block in dyld4::Loader::findAndRunAllInitializers(dyld4::RuntimeState&) const + 182
    2 dyld 0x10a9e60ff invocation function for block in dyld3::MachOAnalyzer::forEachInitializer(Diagnostics&, dyld3::MachOAnalyzer::VMAddrConverter const&, void (unsigned int) block_pointer, void const*) const + 129
    3 dyld 0x10a9dd893 invocation function for block in dyld3::MachOFile::forEachSection(void (dyld3::MachOFile::SectionInfo const&, bool, bool&) block_pointer) const + 566
    4 dyld 0x10a9acd91 dyld3::MachOFile::forEachLoadCommand(Diagnostics&, void (load_command const*, bool&) block_pointer) const + 129
    5 dyld 0x10a9dd61b dyld3::MachOFile::forEachSection(void (dyld3::MachOFile::SectionInfo const&, bool, bool&) block_pointer) const + 179
    6 dyld 0x10a9e5b30 dyld3::MachOAnalyzer::forEachInitializerPointerSection(Diagnostics&, void (unsigned int, unsigned int, unsigned char const*, bool&) block_pointer) const + 118
    7 dyld 0x10a9e5da2 dyld3::MachOAnalyzer::forEachInitializer(Diagnostics&, dyld3::MachOAnalyzer::VMAddrConverter const&, void (unsigned int) block_pointer, void const*) const + 386
    8 dyld 0x10a9bfa7c dyld4::Loader::findAndRunAllInitializers(dyld4::RuntimeState&) const + 144
    9 dyld 0x10a9bfc08 dyld4::Loader::runInitializersBottomUp(dyld4::RuntimeState&, dyld3::Array<dyld4::Loader const*>&) const + 178
    10 dyld 0x10a9bfcac dyld4::Loader::runInitializersBottomUpPlusUpwardLinks(dyld4::RuntimeState&) const + 108
    11 dyld 0x10a9d332e dyld4::APIs::runAllInitializersForMain() + 222
    12 dyld 0x10a9b1358 dyld4::prepare(dyld4::APIs&, dyld3::MachOAnalyzer const*) + 3438
    13 dyld 0x10a9b04b4 start + 388


    Thread 0 crashed with X86 Thread State (64-bit):
    rax: 0xfffffffffffff008 rbx: 0x00007ff7b8f71ef8 rcx: 0x0000000108565000 rdx: 0x0000000000000100
    rdi: 0x0000000108565180 rsi: 0x00007ff7b8f71ef8 rbp: 0x00007ff7b8f71fa0 rsp: 0x00007ff7b8f71ee8
    r8: 0x00007ff84e9344f0 r9: 0x0000000000000000 r10: 0x0000000106f8a000 r11: 0x000000010a9e607e
    r12: 0x0000000000000001 r13: 0x0000000106f8a918 r14: 0x0000000108565a80 r15: 0x0000000108564040
    rip: 0x0000000000000000 rfl: 0x0000000000010202 cr2: 0x0000000000000000

    Logical CPU: 0
    Error Code: 0x00000014 (no mapping for user instruction read)
    Trap Number: 14


    Binary Images:
    0x0 - 0xffffffffffffffff ??? (*) <00000000-0000-0000-0000-000000000000> ???
    0x10a9ab000 - 0x10aa16fff dyld (*) <1a6ae033-9438-33c0-8077-988fd885250a> /usr/lib/dyld

    External Modification Summary:
    Calls made by other processes targeting this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
    Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
    Calls made by all processes on this machine:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0

    VM Region Summary:
    ReadOnly portion of Libraries: Total=1.0G resident=0K(0%) swapped_out_or_unallocated=1.0G(100%)
    Writable regions: Total=530.6M written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=530.6M(100%)

    VIRTUAL REGION
    REGION TYPE SIZE COUNT (non-coalesced)
    =========== ======= =======
    Kernel Alloc Once 8K 1
    MALLOC 137.2M 11
    MALLOC guard page 24K 5
    MALLOC_NANO (reserved) 384.0M 1 reserved VM address space (unallocated)
    STACK GUARD 56.0M 1
    Stack 8192K 1
    VM_ALLOCATE 8K 2
    __DATA 26.3M 340
    __DATA_CONST 19.4M 209
    __DATA_DIRTY 798K 125
    __FONT_DATA 4K 1
    __LINKEDIT 636.4M 8
    __OBJC_RO 81.5M 1
    __OBJC_RW 3120K 2
    __TEXT 365.7M 357
    __UNICODE 588K 1
    dyld private memory 1028K 2
    shared memory 8K 1
    =========== ======= =======
    TOTAL 1.7G 1069
    TOTAL, minus reserved VM space 1.3G 1069

    read more...
    0 116
    • kstolting
      PedroRodrigues Hi kstolting, thank you for your post, if you have a MAC M1 running macOS 12.0.1 you will require to install ROSETTA 2 to allow your MAC M1 to interface with App's designed to interact with Intel Mac processors such as FINALIZER. Thank you
      • Oct 29
    • kstolting
      ajamillion This doesn't work on M1Pro, there isn't even an option to load with rosetta. PLEASE update this app already!
      • Nov 28
  • New
    Whyde
    Newcomer - Level 1
    2021-10-27

    Brand new pedal - will not store/save loops on the first 2 tracks.  From 3 on it saves them. Defective??

    0 7
    • Whyde
      NicJonesMT Hi Whyde.
      If possible could you please submit a technical support ticket (Click support at the top of the page).
      We can then gather some more information from you to help look for a resolution.
      • Oct 27
  • New
    Leonex91
    Newcomer - Level 1
    2021-10-26

    Hi,

    Ditto stereo looper: It remains a bit difficult for me to do the "double tap" in order to stop the loop. Is there a way to set the stomp so that with only one tap the loop can be stopped? (it does not matter if i give up the overdub function)

    Thank you for your support 

    read more...
    0 8
    • Leonex91
      NicJonesMT Hi Leonex91.
      It is possible to change how the pedal functions when you tap the switch, but unfortunately this does not change the double tap to stop function.

      Please see page 13 of the user manual for steps on how to switch the operation mode.
      • Oct 27
    • Leonex91
      NicJonesMT
      • Oct 27
Go to page