Statistics

229,577 members
104,644 posts
  • New
    Livesound702
    Newcomer - Level 1
    2021-05-12

    What is the crossover frequency between the 8" and the compression driver?

    0 5
    • Livesound702
      NicJonesMT Hi Livesound702.
      I'm not too sure off the top of my head but if you submit a tech support ticket, one of the team who deal with Loudspeakers will be able to advise you further.
      • May 14
  • New
    LowBee
    Newcomer - Level 1
    2021-05-09

    We have an event coming up where I need some more grunt in terms of subs

    I have a pair of iQ15B's, and EV ZXA-1's, was thinking of using the subs from my iP2000's (without the array columns)

    Thoughts on this please?

     

     

    Thanks, stay safe as we (finally) get back to live music :-)

    read more...
    0 20
    • LowBee
      GaryHiggins It will be a challenge but it may work with some careful setup and testing. The mixer may limit your ability. You will need extra busses to keep the subs separate. You didn’t say what one you use.
      • May 9
    • LowBee
      LowBee Gary, thanks.
      • May 9
    • LowBee
      LowBee I am using an X32Producer with Ethernet stage boxes, any set up advice much appreciated
      • May 9
  • New
    toddyboy020
    Newcomer - Level 1
    2021-04-29

    When I plug in my 2 x turbo sound iX12, the Bluetooth screen just flashes blue...

     

    nothing works at all apart from a regular blue flashing light on both speakers.

     

    any ideas anyone?

    0 12
    • toddyboy020
      DavidKnighton Hello toddyboy020,
      I suggest clicking the SUPPORT tab at the top of the page and submitting a technical support inquiry. Flashing LED or LCD is the type of behavior that would indicate a power issue.
      • Apr 29
  • New
    KevinPeters
    Newcomer - Level 1
    2021-04-26

    Hi All,  To better cover some of the rooms my band is playing and to not have to push our current system as hard I went from 2 iq12's and 2 iq18b's to 4 iq12's (still with 2 subs).  I have K&M bars that will allow me to place 2 iq12's on a single pole and I plan to run 2 on each side of the stage.  The K&M bars allow for adjustment of the distance between the high packs which brings me to my question.  How far apart should I space the top speakers?  I have 2 likely scenarios, 1 is smaller rooms where with the coverage patterns i will likely leave the speakers straight forward, and wider areas where I will likely splay them - is there a difference in distance when doing that?

    Thanks!

     

    Kevin

    read more...
    0 15
    • KevinPeters
      DavidKnighton Hello KevinPeters,
      when placing two point source speakers side by side, you can encounter a phenomenon called "comb filtering". It would be a good idea to read up on this topic, as it can have an adverse effect on your sound. Understanding the effects of comb filtering will help you with placement. It won't be as big of a issue when the speakers are splayed at an angle from each other, but when both are forward facing, that's where you will want to play with the placement a bit more. Also you might want to be careful putting too much weight on a single subwoofer pole cup. I'm not sure it was meant to take more weight than a single loudspeaker.
      • Apr 26
      • iQ12 multiple high pack configurations
        LowBee David, jumping on the back of this question. Would it reduce Com Filtering if I placed the mid/top cabs one on top of the other, one inverted so the high range horns are close to each other?
        • May 11
  • New
    MarcelNYC
    Contributor - Level 2
    2021-04-13

    I'm not near my iQ PA system and was thinking of buying a couple of supplemental side speakers for an outdoor show. They're Milan speakers which don't have Ultranet. Instead of running very long XLR cables to these speakers I was wondering if the iQ speakers converts the Ultranet digital audio input then sends them out via one of the analog outputs?

    Thanks,
    Marcel

    read more...
    0 21
  • New
    Hrl21
    Newcomer - Level 1
    2021-04-12

    Tengo Turbosound ix12 que se escucha bajito. Cual puede ser posible causa del defecto? Gracias!!

    0 7,340
    • Hrl21
      KyleJohnson Hello, Kyle here from Music Tribe. For technical support I recommend you click on the Support link at the top of the community page and then submit a Technical support ticket.
      • Apr 12
  • New
    MondiMarku
    Newcomer - Level 1
    2021-04-08

    Hi..to by turbosounds product..its only like simple costumer..or if wee whoo need to work like dealer..too heave some %..too put torbosound first brend in my audio magazine..thenks i write from..Tirana Albania ?? thanks..

    0 24
    • MondiMarku
      Dale_M I am afraid we don't understand your post -are you looking to review a Turbosound product in your magazine?
      • Apr 9
  • New
    OliS
    Newcomer - Level 1
    2021-04-08

    Hey together, 

    is there anybody who can repair my IP2000 Subwoover? Maybe, near Frankfurt? It worked fine for years, but suddenly its completely dead. Changed fuse already.....

    Any ideas? 

    Oli

    0 19
    • OliS
      DavidKnighton Hello OliS,
      Not sure exactly, but if you click the SUPPORT tab at the top of the page you can submit a SERVICE REQUEST ticket and someone should be able to give you the information you need. Also if it's under warranty, then you'll need the RMA to have it serviced.
      • Apr 8
  • New
    davisdc50
    Newcomer - Level 1
    2021-04-08

    I ordered a pair of IQ15's from Thomann. I received one of them today and it doesn't work.  It powers up and all the menu functions work but I cannot get any sound.   I've tried ultranet from my XR18 on numerous channels, XLR from my XR18 to "local" on the speaker and even a mic straight in to both channels on the speaker and there's no output.   I have a signal light, so it's not the source input.    And I can plug the xlr into one of my other speakers and it works.   Gain control is up.   Send it back or am I doing something wrong?   Help!

    read more...
    0 28
    • davisdc50
      GaryHiggins Double check all the menu’s again. There are at least 2 places that effect volume, gain is but 1. Those menu’s and controls are not so intuitive. It could be defective but maybe it’s just finding the right spot.
      • Apr 8
    • davisdc50
      Dale_M Hi if Gary's advise does not work and this is new you should contact the seller as it will be DOA within 30 days.
      • Apr 8
    • davisdc50
      davisdc50 Thomann sent me the European version. I'm in the US. DOH. RMA requested.
      • Apr 8
      • Brand new IQ15 doesn’t work!!!
        DavidKnighton Hello David,
        You're not the first to encounter this. Many N. American folks order from Thomann only to find that they only sell products that fit the Euro electrical grid. This is why it is important to purchase items from your regional distributor and not from overseas distributors.
        • Apr 8
  • New
    gr8shirt
    Newcomer - Level 1
    2021-04-02

    is there ANY information on when they will be filling orders in on these for the US market? i have been on order for 6 weeks and no information anywhere to be found. 

    0 30
    • gr8shirt
      Dale_M Hi there, can I ask that you go to the Support tab above and sent this request as a Pre Sales ticket as that particular team are not involved in the Music Tribe Community page, someone will pick your ticket up and advise direct to you. Many thanks.
      • Apr 3
    • gr8shirt
      gr8shirt ANYONE else having this problem with a back order??
      • Apr 3
    • gr8shirt
      asui yes I am
      • May 3
Go to page