Statistics

254,563 members
132,264 posts
  • New
    Babber
    Newcomer - Level 1
    2021-03-29

    What Behringer passive speakers are a good match for the Behringer KM750 amp? I've been looking at the VP1220 and B212XL. Would either of these 2 speakers work well with the KM750? 

    Our venue is a small church of about 40 to 70 people in a room that can hold a maximum of 70 people.

    The intruments we use are: Electric drums, bass, electric and accoustic guitars, piano, keyboard, and 3 vocal mics.

    Any help here would be greatly appreciated.

     

     

    read more...
    0 85
    • Babber
      DavidKnighton Hello Babber,
      The KM750 is 200 W per channel at 8 Ohm. Both the 212XL and the VP1220 are 800 W peak, so I wouldn't recommend the KM750 unless you run the amp in bridge mode, then you can push 750 W at 8 Ohms, which would be adequate.
      • Mar 31
  • New
    jeffwoods
    Newcomer - Level 1
    2021-03-25

    My ip500 v2 is powering down after only 1 hour of being powered up.

    any one have any suggestions what could be going on. 

    it just shuts off all by itself.

    0 58
    • jeffwoods
      Dale_M Hi there can you advise if the unit is getting hot at all before shutdown? It may be wise to go to the support tab at the top of the page and raise a Technical support ticket so we can help you.
      • Apr 9
      • ip500 shutting down after 1 hour power up
        jeffwoods Thanks, the MusicTribe team got me fixed up with the correct part.
        • Apr 9
  • New
    danjamowf
    Newcomer - Level 1
    2021-03-18

    Had an outside gig powered by clients generator and I suspect the voltage dipped or spiked. The LEDs show the music input but no sound. Is there anything I can do on my end, or is it fried? :( The firmware is up to date.

    Thanks

    0 67
    • danjamowf
      RexBeckett Hi danjamowf, it seems likely that the IQ12 power supply was damaged. I suggest that you open a Care ticket.

      At the top of this page, click Support then scroll down the new page and select Service. Make sure that you enter all required (*) data before clicking Submit. The Care team will respond by email.
      • Mar 18
  • New
    davisdc50
    Newcomer - Level 1
    2021-03-15

    Can you run ultranet to the iQ15's and use the crossover to send XLR to another brand sub? 

    0 77
  • New
    MichaelHutton
    Contributor - Level 2
    2021-03-12

    I am using my iQ8's and 15B in our small studio/rehearsal place and want to set up the speakers with XLR connections from our analog rehearsal mixer and Ultranet to the X32 in the control room used for recording.  I had all the speaker inputs set to 'Auto' but the X32 was not turned on at the time as I understood the iQ speakers would 'Auto' to XLR when no Ultranet signal was detectedwhich is what I want for general use for other users.  Only I use the X32 when recording so when I turn on the X32 I expected the Ultranet connection to take priortity.  This set up is to make it compatible for both the analog desk and the digital desk without the others having to change the input selection on the back of each speaker (which means pulling them all out to access the back panel) Is this not how the 'Auto' input should work or am I missing something.  To avoid the hiss and use XLR I had to switch the inputs to analog and then turn the speakers off and on again before they stopped hissing.  Any advice would be appreciated

     

    Many Thanks

     

    Mick

    read more...
    0 57
    • MichaelHutton
      GaryHiggins I believe you can only connect to one or the other, digital via the ultranet or analog via the xlr not both (physicaly connected) at once. I also believe the auto is only for eq not for the analog/digital connectors.
      • Mar 13
  • New
    Johniewhite
    Newcomer - Level 1
    2021-03-08

    Hi. I'm confused with using my Milan sub.

    I connect from my mixer into the sub and then from the thru output up to the tops.

    The confusion comes from the Milan's signal led. I rarely see it working! It only shows a signal when the mixer output is high AND the milan output level is high. Oh, it sounds great but it's too loud for some of the venues I play!

    My experience and expectations would be that the speaker would display a signal received via the led and then you'd turn it up to suit the venue. Or you'd set the speaker level high and then control the overall volume from the mixer, however this could add unwanted noise.

    I thought the idea of a signal led is to display that the speaker is receiving a safe level before it would clip or trip the limiter. At the same time it would also ensure you're not introducing noise.

    I tried by having the mixer turned up fully but it still wouldn't show a signal until I turned up the speaker to almost full volume as well.

    I've followed the manual but it offers no explanation.

    With lockdown coming to an end and gigs starting up again, I was hoping I could use the milan with a bit more confidence.

    If you could reassure and help, it'd be great, thanks.

     

    read more...
    0 61
  • New
    ThumpGC
    Newcomer - Level 2
    2021-03-07

    only used 8 times, purchased 10/2019. 1 works fine, however, while working to get sound check, discovered this new powered speaker high end was not working, turned off then back on, 3 times, waiting 15 seconds, still no high end only low end, all powers on but NO high end... very frustrating and disappointed, I certainly HAD confidence in Behringer products....I paid good money for those....they shouldn't be working lime throw-away speakers.....they should last lo get than that

    ...

    read more...
    0 49
    • ThumpGC
      KyleJohnson Hello, Kyle here with Music Tribe. Sorry to hear about the trouble you are having with your product. Could you please contact our Service team directly by clicking on the Support link at the top of the page?
      • Mar 7
  • New
    deborahkay2
    Newcomer - Level 1
    2021-03-02

    Can the battery be replaced?  I was going to open up the back of the speaker and read that it shouldn't be opened, so I didn't.  

    We love the speaker but must have it plugged in to use.  

    0 49
    • deborahkay2
      KyleJohnson Hello, Kyle here with Music Tribe. Please contact us directly through the Support link at the top of the page so we can advise you.
      • Mar 2
  • New
    mgpaco951
    Newcomer - Level 1
    2021-02-27

    Hello I bought a Behringer MPA200BT on 4/10/18 but the battery doesn’t charge anymore where can I buy a replacement battery, please help

    0 200
    • mgpaco951
      Nigel67 Hi, Please contact our spares department and they will be able to quote you for a replacement battery. This can be done by clicking on the support tab at the top of the page. This will open a new window. Scroll down and click on the Spares tab and submit a ticket. Many thanks
      • Feb 27
    • mgpaco951
      JasonMaier Fire hazard.... I too purchased one of these early model MPA200BT. My battery also went bad around the same time. But instead of it just going dead it leaked battery acid all over the circuit board, destroying the unit. I filled out the 3 year warranty as soon as I got the unit. Unfortunately Behringer claims that this is not covered under the warranty period. I find this kind of behavior by a reputable company unacceptable. When I opened the MPA200BT the acid had shorted the battery wiring and was visibly burnt black and hot. I'm glad my house did not burn down. Long story short Bheringer will not honor their warranty and will not stand behind their products.
      • Jun 30
  • New
    RobertHatfield
    Newcomer - Level 1
    2021-02-18

    Hi I have a behringer mpa200bt speaker that is asking for a code it will not let me access anything on it I have never put a code on it where do I find the code or how can I bypass it 

    0 58
    • RobertHatfield
      PedroRodrigues Hi RobertHatfield please input PIN code: 0000, this will work if effectively no other pin code was set up. Thank you
      • Feb 19
Go to page