Statistics

251,052 members
128,282 posts
  • New
    DiogoGregorio
    Newcomer - Level 1
    2021-09-12

    Good people!

    This is a long shot, lets see if anyone did or have any idea how to do this or if its possible at all.

    I have an XL4 installed in an OB van (yeah, I know) while it sounds pretty nice the dreaded Outboard Electronic module just give up on me.

    I lost the group routing capability, the aux routing is erratic and when you press 1 it turns on 13 also, our other random aux and turns off other random aux.

    All automation don't work, VCA, routing, and all kinds of momentary switches.

    My question is, is it possible to bypass the automation module, having access to the group and aux routing and not using the VCAs at all?!

    Cheers! 

     

     

     

    read more...
    0 5
    • DiogoGregorio
      Dale_M Hi there, as the XL4 is very old there is now very limited resource and support for it, however there is an excellent Facebook page with lots of Pro Users (many with XL4/H3 consoles) who are much better placed to advise you, I would suggest joining this group and adding your post, sorry we are unable to help any further: https://www.facebook.com/groups/1976275959349445
      • Sep 15
  • New
    vassallo90
    Newcomer - Level 1
    2021-08-30

    hey iv just bought a Midas f32 and noticed it's pre fader. Is there a Mod to fix to Post Fader?

    And who is available to do this working in Melbourne Australia?

     

    regards 

    0 17
    • vassallo90
      Dale_M There is a mod that can be done but we advise an official Midas repair centre perform it. For more info please submit a Technical ticket from the Support tab above.
      • Aug 30
  • New
    mikerosen
    Newcomer - Level 1
    2021-07-20

    Hey,

    One of the channels on my Midas Venice F24 makes some ruffling noises sometimes when there is nothing connected to the input on that channel. Would appreciate it if anyone could help me with this!

     

    Thanks :)

    read more...
    0 43
    • mikerosen
      Dale_M This sounds like one of the op amps on that channel has failed, assuming you have tried a known good cable and mic from a neighbouring channel then it is likely to be faulty and require a repair, for assistance in this matter please go to the support tab above and select Service as your ticket type to inquire on a non warranty repair.
      • Jul 21
  • New
    MSTK
    Newcomer - Level 1
    2021-06-07

    Hi!
    A bought a F24 and everything was working and it connect to Midas FW Control Panel.
    When I came home in my studio to set it up I get "No device found". Tried different macs but no luck. Then I see that i have put the FW cable upside down. Cant believe that it ´s possible to do without force and how a could do that. Google it and found out that I probable have burned the FW board :( Have u heard about this situation before? Last Monday I contacted Support/Spear part and ask if u got a new FW board that I can install, have received a support ticket but no answer yet, how long is it usually take?
    Really hope u can help me cos right now i`m really sad and angry at myself.
    Best Regards

    /D

    read more...
    0 45
    • MSTK
      Nigel67 Hi MSTK. Can you send me your ticket number and I will check why it hasn't been replied to yet.
      • Jun 7
      • Midas Venice F24
        MSTK Thanks for reply Nigel! I have send u a PM!
        • 1
        • ·
        • Jun 8
  • New
    thoward
    Newcomer - Level 1
    2021-05-14

    Hi
    I have a Midas Venice F32 where the power supply is making a whining noise and it is being induced in the audio busses.
    I raised a support ticket to see if a replacement PSU is available on 5th May but not had any response yet

    Ticket no CAS-450985-P9Z8V1

    Any pointers welcome

    read more...
    0 46
  • New
    Gruohm
    Newcomer - Level 1
    2021-05-11

    Hi, 

    just installed an H3000 desk in my studio. Love the sound, love the workflow but it's a bit loud for studio use. The power supplys are in a different room but the board's fans are a bit to noisy to my ears. Heard of someone who modified or changed the console's fans to make it quieter?

    read more...
    0 90
    • Gruohm
      Dale_M Hi there, we have no information regarding this as modifying any safety feature (such as cooling) is prohibited -the Heritage range were aimed at live sound so fan noise would not have been a consideration. However, given the age it is not impossible that quieter fans are available, it may be best to speak to users on the Facebook group "Long Live Midas Analogue Consoles" as many users have flipped these consoles over to studio work. I hope this helps.
      • May 13
  • New
    RLND
    Newcomer - Level 1
    2021-05-02

    Hi there,

     

    I have owned a Venice 32F for over six years and have it running on a Windows 7 (32 bit) system with a Sinux FWB3414G firewire PCI-e card. It has been working like a charm since day one.

    I have now put together a new PC because the old one is on its way out. It has a Windows 10 Pro (64 bit) system and I got a new fire wire PCI-e card by Star-Tech (2 Port PCI Express FireWire Card - PCIe 1394a FireWire Adapter).

    I installed the drivers, the card is being recognised by Windows but when I fire up my Venice it is not recognised (I have installed the drivers for the Midas console).

    I then tried my old firfewire PCI-e card (Sinux) and it does recognise the console but when I started REAPER the first time and set the sound device to the Midas console Windows popped up a blue window with an error code and restarted Windows.

    I tried it a few more times also with another audio program and the PC would just restart.

     

    1. Does anyone know what could be the issue? (Start Tech had drivers to install, Sinux had no drivers to install).

    2. Can anyone recommend a firewire card they know is working with Windows 10 (ideally available in Australia)

     

     

    Cheers, RLND

    read more...
    0 61
    • RLND
      Nigel67 Hi RLND, I think your problem is more to do with the driver. Unfortunately Midas support for the Venice F ceased a number of years ago now and there was never a driver released for Windows 10. There are many posts on forums asking if anyone has made the Windows 7 driver work successfully with Windows 10. The only time that I have seen a person answer with a successful outcome was this one, however I have never had anyone else verify it. The post went as follows; 'Downloaded the Win 7 driver. Then right click the .exe file and switch compatibility to Win 7 so now the driver runs in Win 10, thinking its Win 7'. I hope this works for you. If not, then I can only suggest that you search on the internet to see if you can find someone else who has managed to get the driver working. Many thanks
      • May 2
    • RLND
      RLND Thanks a lot Nigel,
      • May 4
    • RLND
      RLND ... I tried your tip with the Star-Tech card and it recognises now the console, however, when I start Reaper and switch to ASIO Midas the same scenario happens - blue screen and PC restarts. Meanwhile I read on another forum that there is a difference with different chip sets on firewire cards re Win 10 - some work with Win 10 and some don't. I'll do some further research. Cheers, Roland
      • May 4
  • New
    robsimons78
    Newcomer - Level 1
    2021-04-28

    Hi, I've sent in a parts request for a new FireWire board for my Venice F16 mixer. Can some please come back to me? Would really appreciate getting this mixer working again

    CAS-446634-M4P1Z2 

    Many thanks

    0 71
    • robsimons78
      Dale_M I have asked the Spares Team to assist.
      • Apr 28
      • FireWire board F16
        robsimons78 Thank you. I have been contacted now. I guess before I order a new firewire card, I want to be sure it's not working 100%. I've tried on OSC High Sierra and Catalina, newest drivers, and terminal hack OK. Drivers appear fine, the FireWire lights are green, but no devices found. Do the FireWire lights need to be RED to indicate that it's faulty??
        • Apr 28
      • FireWire board F16
        DavidKnighton Hello robsimons78,
        From my experience, the LED does not change color. It is constantly illuminated during power on. The only true way to know if the firewire chip is gone is by interfacing with a firewire enabled computer running Windows 7 or Mac OS El Capitan or earlier. These are the latest known working and supported operating systems. Any other operating system is not officially supported or tested.
        • 1
        • ·
        • Apr 28
      • FireWire board F16
        robsimons78 Thanks, that's helpful. I have one more machine with a legacy OSX that I'll try. If that doesn't work then I suppose I have my answer Also, I know it's been pitched a few times before, but an updated Thunderbolt card for these mixers would be a godsend, thousands of Venice owners would jump all over it.
        • Apr 29
  • New
    N1Ckp
    Newcomer - Level 1
    2021-04-06

    Hello. I recently purchased at Midas Vidas 320 desk and I love it. However, to improve longevity of this beauty I would like an EPS 1200 but cannot find one online. Seeking any help here if possible. Does Midas have any back stock of discontinued products they would sell ?

    Thanks,

    Nick 

    read more...
    0 80
    • N1Ckp
      Nigel67 Hi N1Ckp. Please contact our spares team and they will be able to advise on the stock availability of a psu. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Spare Parts tab and submit a ticket. The only other option would be to post on some of the Midas FB forums and see if anyone has a second hand one. Try 'Long Live Midas Analogue Consoles'. Hope this helps.
      • Apr 5
  • New
    Beppone
    Newcomer - Level 1
    2021-03-18

    Hi everyone, I'm using a Midas f32 mixer and I'm trying to record on a Macbook pro with M1 chip. I already tried to download midas drivers but no one works for my macbook. My macbook does not receive any information from the mixer, I think midas hasn't released current drivers yet, so If you have some solutions I would be grateful, if you haven't, I urge Midas to release new drivers!

    Thank you 

    read more...
    0 85
    • Beppone
      Nigel67 Hi Beppone, I am sorry, but Midas ceased any support for the Venice F drivers a number of years ago now. There will not be any new drivers released for the Macbook Big Sur with the M1 chip.
      • Mar 18
Go to page