298,817 members
182,483 posts
  • New
    Newcomer - Level 1

    Hello, I appear to have lost the windows USB driver for my RD 8.

    It is not recognized in FL Studio 12 as a midi device. I can't perform any software upgrade either. It can't find a device.

    Please someone to help me??


    0 125
    • Serge1961
      NicJonesMT Hi Serge1961.
      Have you recently used the Zadig driver to update the unit?
      Sometimes the Zadig Driver can take priority of the unit and stop it connecting.
      Can you please uninstall the Zadig driver and also go to C:\Program Files and C:\Windows\System32\drivers and ensure that any remaining files for the RD-8/Zadig are removed.
      Once completed power cycle the computer and then reconnect the RD08. It should hopefully reconnect and allow you to use in your DAW.

      If the above doesnt work please click Support at the top of the page, scroll down and submit a technical support ticket.
      • August 11, 2021
    • Serge1961
      alanmoores I was having an issue with "USB Device Not Recognised" for my Behringer XR18 on one of my Windows PCs today. I uninstalled the Windows Update "KB5004331" and now all works again - perhaps this is impacting your device too?
      • August 11, 2021
  • New
    Newcomer - Level 1

    Anyone else had this issue? I get no sound out of the hi tom, whether I'm using mains or the dedicated output. Switching to Hi Conga gives no sound as well.

    0 49
    • ZodiacSF1969
      Nigel67 Hi ZodiacSF1969, please contact our Service Department and they will be able to arrange a repair for you. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Service tab and submit a ticket. A colleague will then get back to you with an RMA number and advise the local service centre to you.
      • July 26, 2021
  • New
    Newcomer - Level 1

    When is the release in the USA for the RD8 Mk2?

    0 108
  • New
    Newcomer - Level 1

    hello, yesterday I bought RD-8, tried to update, but failed, downloaded the program Zadig 2.5, but I accidentally changed the drivers on the RD-8 itself, and now it says "No device detected" in SYNTHTRIBE V2.5.3, after that I tried to install 1.3.5, I succeeded, they advised me to find SYNTHTRIBE V2.0 on the Internet, but I could not find the version under SYNTHTRIBE V2.5.3

    0 116
    • Inkub
      Inkub tried to roll back the driver on the drum machine, did not help, rolled Windows back to the PC, did not help
      • June 20, 2021
    • Inkub
      ChrisEdwards1 Hi Inkub, if you have not yet done so I would recommend submitting a technical support ticket so we may gain a better understanding of your setup. To do this please go to support at the top of the page, scroll down to technical support and fill in the form.
      • June 21, 2021
    • Inkub
      No1sketchie I had similar problems. my solution was that windows doesn't like a huge list of USB devices. , I used a tool called USBDeview to find the cache and deleted all of those in the list it generates. (it doesn't delete the drivers but just the prefetch data cache) reboot and then RD-8 should show up in the Synthtribe welcome screen. ? HTH
      • June 23, 2021
    • Inkub
      bernyboss SYNTHTRIBE v. 2.5.7 disponibile! (anche x RD-8 MKII)
      New SYNTHTRIBE version available 2.5.7! (RD-8 MKII is here)
      • December 28, 2021
  • New
    Newcomer - Level 1

    Lo and behold, I power it on, all semms to work, connect usb cable to my rd-8. launch latest synthtool on mac, alerted firmware update required, it bricked it AGAIN. Same usb cable and computer I updated my td-3 with. I am so displeased, seems like behringer had my rd-8 for months, to not replace the defective component or just replace the unit. I am NOT happy.

    0 74
    • heyvirgil
      NicJonesMT Hi Hey Virgil.
      Please submit a Technical Support ticket and provide your previous case number. We can then look into this for you.
      • June 18, 2021
      • just got my rd-8 back from behringer service because of firmware update bricking it
        heyvirgil send me a new damn machine
        • June 18, 2021
      • just got my rd-8 back from behringer service because of firmware update bricking it
        heyvirgil I submitted a ticket
        • June 18, 2021
      • just got my rd-8 back from behringer service because of firmware update bricking it
        heyvirgil I don't want to spend the time and expense to ship to you again, I have used this unit successfully a total of 2 hours since purchase, the vast majority of ownership has been spent at service or bricked.
        • June 18, 2021
      • just got my rd-8 back from behringer service because of firmware update bricking it
        heyvirgil Also, why can't I modify a request ticket once I have created it? Your support site sucks so bad.
        • 1
        • ·
        • June 18, 2021
  • New
    Newcomer - Level 1
    Hi there,
    So, I've had my RD-8 for a few months, got the hang of the sequencer apart from one bug that I can't seem to fix.. here goes...
    I program ptns 5 6 7 8, no problem, I can switch between them playing live with no problem.
    I program them into a simple song to play in the following seq... 5 5 6 6 7 7 8 8 and repeat.
    I check the programming by scrolling through each the song to check each should playing twice. All good so far.
    When I play the song it starts fine, playing 5 5 6 6 7 7 8 8, then the problem starts when it repeats..
    So, from the beginning it plays as follows..
    5 5 6 6 7 7 8 8 (repeat here)
    8 5 6 6 7 7 8 8
    8 5 6 6 7 7 8 8..
    This happens whether playing in INT or MIDI sync modes. The seq shows correctly as I programmed it in Synthtribe software.
    I've deleted the song and started from scratch and I get the same issue.
    I'm running the latest OS as from yesterday, still the same issue.
    Anyone else had similar issue and solved it?
    Cheers anyone,
    0 74
  • New
    Newcomer - Level 1

    Where can I buy replacements parts, especially wiring harness, for the beringer hds240usb electric drum set?

    0 78
    • Laugustejr1
      KyleJohnson Hello, Kyle here with Music Tribe. Spare parts can be ordered from us if you click on the Support link at the top of the page and then click Spare Parts to submit a ticket.
      • June 15, 2021
  • New
    Newcomer - Level 1

    Buenas tardes

    Tengo la batería behringer hds110usb, y lamentablemente se me rompió el brazo que soporta el hit-hat y el mismo platillo hit-hat, es posible conseguir repuesto de esto mismo. Quedo atento a sus comentarios




    0 96
    • Saul79
      Nigel67 Hi Saul79. Please can you send us a spares request ticket and one of my colleagues in that team will send you availability and pricing. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Spare Parts tab and submit a ticket. A colleague will then get back to you. Many thanks
      • May 2, 2021
  • New
    Contributor - Level 1

    RD-8 has been off with power unplugged for a couple of weeks and now, when I turned it back on, I have no audio coming out of my desktop via usb. I can select an instrument and tap the "TRIGGER" button and hear an output into the headphones, but still cannot hear anything through the computer.

    I've rebooted my computer and done a factory reset on the RD-8.... Still nothing.....

    I tried the bass drum out to my interface as well as the Mono out and nothing.....

    I do get a notification sound from my computer when I disconect the USB cable and also when I turn the RD-8 on and off.

    Other than that I get nothing?????


    Please help!


    0 94
    • NealS_Munson
      JoeRivers96 Hi Neal, Are you using the original power supply? Sometimes this affects the audio output if a third party power supply is used. Please also try a factory reset:

      Press the Settings button.
      Hold Tap/Hold and press step key 16. The display will read Wait.
      When the display reads Done, power cycle the RD-8 to complete the procedure.
      • March 22, 2021
    • NealS_Munson
      graesserph Not exactly sure what you mean with "I have no audio coming out of my desktop via usb". Please take note that the RD-8 does not at all pass any audio through USB. You can send and receive MIDI through USB, but not audio, as the RD-8 is no audio interface...that's what its specification says.
      The the RD-8 has only analog audio outputs, the main mono out jack, the individual mono out jacks, and the headphone out jack. This is it. As far as my understanding goes, the RD-8 will never pass audio through USB.
      • March 24, 2021
  • New
    Newcomer - Level 1

    As the title suggests, my RD-8 suddenly, while playing on it, turned off and I have not yet been able to power it on again. Only the signal light flashes shortly, but nothing else happens.

    Also tried connecting it over USB, but the RD-8 isn't recognized. 

    I was running OS 2.0.6 as far as I remember.

    Anyone had the same issues/any advice?

    1 117
    • Sebastian95515
      dafraludom I have the same issue - lodged a Care Ticket.
      • March 20, 2021
    • Sebastian95515
      dafraludom Sorry, but unit still dead and no joy from care ticket response - looks like I have a door stop.
      • March 29, 2021
Go to page