Statistics

284,944 members
166,810 posts
  • New
    atouchofmusic
    Newcomer - Level 1
    2021-12-21

    Hello

    I have new lap top with Monterey OS. Logic latest version. 

    My X-touch control surface do not work properly. Communciation seems to be only one way from X-touch to Software.

    Information from Logic are not reaching X-touch (display does not show anything, feader position does not update and so on).

    Any one can tell me where is the issue?

     

     

    read more...
    0 19
    • atouchofmusic
      DaveMorrison I often have to restart my X-Touch so I can both send and receive data. Sometimes I have to delete the control surfaces (Mackie) profile (Icon???) when I can't connect.
      I'm running Monterey with the latest version Logic. I'm running an intel machine though.
      • December 21, 2021
  • New
    dooft12
    Newcomer - Level 1
    2021-12-18

    Hi, need some help on how to factory reset my X Touch. 

    Seen on internet about the method to reset X Touch Compact, but the full size X touch dont have the layer button as the X touch compact. 

    Thanks in advance.

    D

    1 115
  • New
    JohanHansson
    Contributor - Level 1
    2021-12-17

    Just found that new firmware (1.10) is available for the X-Touch One, but can't find any info at all about what's new or what has been fixed. 

    Anyone? 

     

     

     

     

    2 138
    • JohanHansson
      MattKay Ditto for standard X-Touch 1.22, also recently released without a change log. I'd love to know what changed before attempting an update.
      • December 22, 2021
    • JohanHansson
      PaulJones

      What gives here? Any information on firmware 1.10? I upgraded it last night and it behaved totally differently in Reaper. I then downgraded to 1.04.

      • Jan 5
  • New
    dalejason
    Newcomer - Level 1
    2021-12-17

    Hi

    In Sept I tore down my studio for a major upgrade / redesign and I have only just completed re-fitting the furniture, cables and equipment.

    I have also upgraded the studio computer to a Dell G5 5505 Laptop. Upon connecting my X-touch, I now find that it is not detected at all by the computer. It lights up the LED on the big round jogger and the backlights on the screen light up but nothing else.

    It was working fine on my old Dell Lattitude E6330 in september.

    I can hear it connect to the computer when turned on (windows makes a sound) but it is not recognised by the X-touch editor or in Ableton. It has been safely stored and has not been turned on Since Sept, so I am not sure what the problem could be. Can anyone suggest anything I can try ?  I do not have another computer to try at the moment.

     

    Device name DESKTOP-1I3G9MG
    Processor AMD Ryzen 7 4800H with Radeon Graphics 2.90 GHz
    Installed RAM 16.0 GB (15.4 GB usable)
    Device ID 52605D1C-AC81-438C-9713-DE6D96D67AE2
    Product ID 00325-96763-21628-AAOEM
    System type 64-bit operating system, x64-based processor
    Pen and touch No pen or touch input is available for this display

    read more...
    0 30
    • dalejason
      DaveMorrison The X-touch needs the newest firmware to successfully connect to Ryzen based computers. You have to upgrade using a non-ryzen computer. Ver 1.22 https://www.behringer.com/product.html?modelCode=P0B1X
      • December 17, 2021
      • X-Touch Not Recognised Dell G5 AMD Ryzen 7 4800H with Radeon Graphics 2.90 GHz
        dalejason Ah.. ok, I did not know this, It is on FW V1.15 at the moment. I can borrow a laptop from a friend and try this. Thank you for posting, much appreciated.
        • December 19, 2021
      • X-Touch Not Recognised Dell G5 AMD Ryzen 7 4800H with Radeon Graphics 2.90 GHz
        simmonds01 Supposedly the Ryzen problem was fixed in 1.21 (according to it's release note) - no release notes in 1.22 so no idea what they are upgrading.
        • Jan 20
  • New
    andrewthiriot
    Newcomer - Level 1
    2021-12-11

    Hi,

    I’d like to use my Behringer BCF2000, with Logic Pro in a very simplified way:

    I’d like to simply use 3 faders to control different automation such as modulation, expression, vibrato for the active track.

    How could I do that (or is it even possible)?

    I have been through a tutorial and I can see how, in Mode 1, I can control certain automation with the controls for each channel. But in that case the one fader on the BCF2000 for the active channel will be controlling that channels fader volume only.

    Ideally I wouldn’t even have it set up in Mode 1 to be able to control everything - but just simply assign a few faders to a few specific midi channels.

    The main three faders would be programmed to control midi channels: CC1, CC11, CC21.

    Thanks for reading and for any help! :) 

    read more...
    0 18
  • New
    JBG7
    Newcomer - Level 1
    2021-12-04

    Does anyone know how to do a factory reset on X-Touch One?

    0 19
    • JBG7
      Nigel67 Hi JBG7. There is no factory reset for the X Touch One. I can only suggest trying to upgrade the firmware again and if that does not fix your issue it could well be hardware related. I would advise then submitting a Technical Support ticket and a colleague will be able to help you further. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Technical Support tab and submit a ticket. Many thanks
      • December 4, 2021
  • New
    myeckwaters
    Newcomer - Level 1
    2021-11-30

    Howdy

    I recently picked up an X-Touch One for use in Cakewalk. It worked for a few days and then stopped. Now when I plug it into the USB the system reads "Unknown USB Device (Set Address Failed)".

    I am using a fairly new PC with Win 10 and an AMD Ryzen 5 cpu.

    I brought it in to work and hooked it up to my work PC and it seemed to be OK. MidiOx was able to talk to it and I was able to update the firmware (V1.08). But on my actual system at home, no joy.

    Any suggestions?

    read more...
    0 25
    • myeckwaters
      cwadams Other than the reported issue with Ryzen, check your version of Windows 10. I just got an X-Touch, and the computer would not recognize it until I manually updated the computer to Win10 version 21H2.
      • Jan 11
  • New
    billyg
    Newcomer - Level 1
    2021-11-19

    I am new here and hoping some of you can help me with thoughts/advise on using the X-Touch (8 fader) controller with Reaper. I am considering buying this controller. I am running the latest version of Reaper on a Mac Mini that is running the latest (Monterey) OS. I've heard rumers of the faders being very loud when running automation. Is there a Reaper overlay for the 8 channel X-Touch? I saw a video showing an overlay for the X-Touch One and the setup looked very simple. Are there any issues I should be concerned with? Thanks!

    read more...
    0 17
    • billyg
      NicJonesMT Hi BillyG.
      Unfortunately the overlays are for the XT1 only, however there are a few third party companies that sell these for the full size model.

      With regard to Fader noise, Personally I dont think they are that loud. There is a motorised noise however i dont find it obtrusive or distracting.

      The best thing I can recommend would possible be to look on youtube at user reviews or people actually using the controller.
      • November 21, 2021
  • New
    MartyAtias
    Contributor - Level 2
    2021-10-28

    My X-touch with FW 1.21 works well controlling an X32 over a local network connection. And I can control an off-premises X32 remotely with the X-Edit software.

    Now I need the X-Touch to talk with X-Edit, which should work in MC /USB mode. However while the faders work, the button mapping is all over the place making it unusable. This happens in MC/USB mode even with a local X32.

    Has anyone here been able to get this to work?

    Thanks

    read more...
    0 13
  • New
    JackDarling
    Contributor - Level 1
    2021-10-26

    I recently got an X-Touch One to use with Logic Pro X. When I first plugged it in everything was working well, except that the fader wasn't controlling the selected track. After doing some research, I found out that there was new firmware to fix that. I updated and that solved the original issue, but know the Pan Knob doesn't seem to functino at all. None of the indicator lights will turn on and it won't control panning on the active channel.

    Does anyone have any insight about what might be happening here?

    Thanks!

    read more...
    0 257
    • JackDarling
      PedroRodrigues Hi JackDarling, thank you fo r your post, in this case I would suggest to check the video guide present on the link below: https://www.youtube.com/watch?v=SOHi26sqOks Thank you
      • October 30, 2021
      • X-Touch One - Pan Knob not working in Logic Pro X
        JackDarling Thanks Pedro, I followed the manufacturer's instructions to set up the device properly. As I said, panning was working until I updated the firmware (which I had to do to fix another feature that wasn't working).
        • November 2, 2021
    • JackDarling
      Yzzman1

      Hi - I am a working composer and I was pissed (understatement) when I started to have this exact issue intermittently after updating Logic. You'll notice when the Pan controls stop working in Pan/Surround mode on the Xtouch - the l/r pan stereo lights are also not illuminated. What I found that solves the problem - at least until it happens again - is to unplug the USB cable (or cables in the case of having an extender or multiple extenders) and plug it back in after a few seconds. Then delete the control surfaces from Logic and reinstall them via controller setup. If you don't unplug the USB cables and plug them back in - this method does NOT work. You have to unplug the USB cables

      • Jan 11
    • JackDarling
      imrank79

      Press the bank button either left or right 3-4 times and it will come back to Pan

      • Mar 22
Go to page