Statistics

254,618 members
132,321 posts
  • New
    jeremycables
    Newcomer - Level 1
    2021-04-16

    I have a X Touch and the Ethernet Port is not working to be able to connect to our XR18. I updated it to the newest firmware after we discovered that it wasn't working. The activity light blinks on for a brief second after plugging in a cable and then immediately turns back off.

     

    Any ideas?

    read more...
    0 56
    • jeremycables
      DavidKnighton Hello jeremycables,
      Please click on the SUPPORT tab and enter a TECH SUPPORT ticket into our system. This item may require service.
      • Apr 17
      • X Touch Ethernet not Working
        jeremycables I have done that. Waiting on a response.
        • Apr 19
  • New
    LittleBearNoise
    Newcomer - Level 2
    2021-04-14

    Hi, I have a couple of questions, I use Cubase Pro 10.5 and the full version of XTouch:

    1. Does the Xtouch editor work with XTouch or only X-touch One / compact etc? 

    2. How do I activate the use of the footswitch (1/4") to punch in/out? In other responses it has been noted that other units (one / compact) need to be placed into midi mode in order to work. This would remove the normal cubase compatibility functions under the MC protocol which I wish to retain. 

    3. When selecting a bank of 8 channels which are not displayed on-screen (if there are a large number of channels) using the fader bank function on the XTouch, the screen in Cubase does not follow the selection of the next bank without pressing the select button for the last channel in the new bank of 8. When it is pressed the next bank of 8 channels come in to view. Is there a way to edit the function of the XTouch so that the view in Cubase follows the selection of the new bank on the XTouch?

    4. When scrolling through the plug in list using the rotary encoder (plug-in button selected) the list jumps through plug-ins in groups of 4 or 5, this means that many plugins are not selectable from the XTouch plug in settings. Is there a way to make the encoder scroll through the plugins one by one?

    5. The Xtouch One has overlay templates showing the different button assignments for different DAWs is this available for the XTouch?

    Kind regards

     

    read more...
    0 65
    • LittleBearNoise
      DaveMorrison For Questions 1-4: The X-Touch is not programmable. It's a clone of a Mackie Control (plus a mode to connect to X/M mixers). The buttons and controls have fixed MIDI note/controller assignments and can't be changed. The DAW, in your cases Cubase, has to act on the information that it receives (and also sends). Everything is controlled/configured by Cubase. You'll probably have better luck by going to the Cubase forum and search for MCU.
      Question 5. Yes, templates have been made by third party suppliers. There are links to them somewhere in the bowels of this forum. I haven't had any luck searching for them (it's one of the many problems with this forum/site/disaster area ; ) ).
      • Apr 14
  • New
    caferrer
    Newcomer - Level 1
    2021-04-12

    I have a problem. Just got a brand new X-Touch with a brand new HP Envy completely updated and I cannot even see the X-Touch as a Midi input. Therefore, I could not update the firmware because it is not seen by the program. However, it is weird that I can see it in the Device manager under audio devices. Any help would be greatly appreciated.

    read more...
    0 59
    • caferrer
      gethindavies The same thing has happened to me. Bought brand new off of Thomman a few weeks back and the LCD won't show anything at all. There is nothing online to help. I'm completely stuck!
      • Apr 12
      • X-Touch with Windows 10 - not working
        caferrer Thank you for replying. I hope someone out here can help us.
        • Apr 12
    • caferrer
      caferrer Please, anyone help !! we are totally stuck. I will reward anyone who can get this problem solved.
      • May 8
    • caferrer
      ChrisEdwards1 Hi caferrer, I can see you have also submitted a case for this query which I have picked up and will respond to today. Please keep an eye on your spam/junk folders for my response. I will also go ahead and add any details for your post to your case I think may help.
      • May 8
  • New
    Olenga
    Newcomer - Level 2
    2021-04-09

    Hello. Is it possible to use X-touch Extender with X-touch One?

    1 67
    • Olenga
      PedroRodrigues Hi Olenga please consider that the X-TOUCH EXTENDER was designed to work and an extension of the X-TOUCH and the X-TOUCH ONE was designed to work as one fader control to offer a smaller solution to control your DAW, never the less it may be possible to implement both unit considering that you may have duplicated functionalities on each. To assist you on this matter please check this video guide present on the link below https://youtu.be/mQn0abPzrGk?t=76
      • Apr 26
  • New
    AcrobatStar
    Newcomer - Level 1
    2021-04-07

    Hi just purchase xtouch ( 8 channel ). I have upgraded to the latest version of Cubase 11 pro and updated the firmware to the latest one on the website. 1.2.1.

     

    Alot of the buttons are not working.

    Click track button

    Had to program it using function keys.

    Utility save , undo

    marker track

    midi track, input, audio track, aux , busses, ouyputs, user buttons all not working

    solo button not working

    drop button not working

     

    Is there a new firmware update being created so this product will actually work with daw programs

     

     

    read more...
    0 78
    • AcrobatStar
      DaveMorrison Unless you have a Ryzen processor, there seems to be no reason to upgrade to 1.21. I haven't yet because all the posts on this forum have been negative regarding 1.21. Of course that means nothing and I really ought to try. I'm still sticking with 1.15 though. The X-touch is a clone of the Mackie Control and it works very well (at least in Logic Pro). However, all the functionality is provided by the host DAW. MCU mode generally has more support than HUI. I bet the Cubase forum will provide you more information on Mackie Control support than this site.
      • Apr 7
  • New
    RichSallnow
    Contributor - Level 2
    2021-04-04

    This is driving me nuts! Since yesterday whenever I press the record button on my X-Touch, it mutes the track on Logic Pro X. It seems like the record and mute buttons seem to have linked themselves!. I've tried unplugging all midi devices, rebooting the Mac, re-installing the 1.21 firmware, but it's still happending. Any ideas?

    read more...
    0 61
    • RichSallnow
      DaveMorrison If you haven't customized any of the buttons (or functions), go to the "Logic Pro": Control Surfaces : Setup... menu. Then delete the Mackie Control icon.
      • Apr 4
    • RichSallnow
      ChrisJanton Have you tried installing the 1.15 firmware again? From what I could see there's no reason to update to firmware 1.21.
      • Apr 5
  • New
    LittleSharkStudios
    Newcomer - Level 1
    2021-04-02

    Hello,

    I've got an X-Touch and an X-Touch Extender both in HUI mode.

    When I push the "PAN/SURROUND" button on the X-Touch, pans for stereo tracks of the X-Touch change their side (left to right or right to left) but NOT on the Extender! Everything else is getting the right commands (like when I solo a track on the X-Touch the other tracks go muted on the X-Touch and on the Extender as well, same for "FADER BANK" button the tracks are well routed on the X-Touch and the Extender channels), the only thing that doesn't work is the PAN/SURROUND button that doesn't send the command to the Extender. What am I missing?

    Thanks for the help.

    read more...
    0 81
  • New
    EmotiveSigns
    Newcomer - Level 1
    2021-03-30

    Hi - 

    I have been using logic pro for years. For musical input I use a MK-425C keyboard which has worked perfectly. Recently I bought a x-touch and since adding that when I press a key on the keyboard strange behaviour occurs, such as it triggers a different layout, rather than playing the notes. 

    Can anyone help explain this problem and possibly help me fix it?

    Thanks in advance,

    Charles

    read more...
    0 63
    • EmotiveSigns
      NicJonesMT Hi Charles. Ideally it would be easier to help if I could see how you have both devices setup and configured in Logic.
      Could you please submit a tech support ticket (Click support above) and provide some screen shots of your setup?
      • Mar 30
  • New
    EmotiveSigns
    Newcomer - Level 1
    2021-03-30

    Hi

    I've recently got an X-touch which i'm loving. This maybe my misunderstanding but I'm assuming the modify buttons work the same as the keys on the keyboard. However when I press and hold the option key, and click on a track I would assume it would allow me to drag and copy that section to another track. However it seems only to grag and move instead. I've played about with all the buttons and they don't seem to behaviour in that way. 

    Should I be able to use these buttons instead of the keys on the keyboard. If so what am I doing wrong?

    Any help would be gratefully appreciated,

    Thanks in advance,

    Charles

    read more...
    0 58
  • New
    BenH
    Newcomer - Level 1
    2021-03-16

    Hi,

    Can the X-Touch select which side the X-Touch Extender is on?

    It seems by default to cascade to the right.  Can it be switched so that the Extender flows from the left side, so that track 1 is on the Extender, and Track 9 is on the X-Touch, and plug-in parameters flow similarly?

     

    Thanks

    Ben

    read more...
    0 60
    • BenH
      NicJonesMT Hi Ben.
      It is dependent on how you setup your control surfaces in your DAW.
      So for example if you are using Cubase, you need to set the Extender as the 1st device.

      Some DAW's also have a "Channel Offset" Option which you can use aswell, but this is DAW dependent.

      What I would recommend is contacting the DAW developer to see if they can assist you with any additional settings.
      • Mar 16
Go to page