Statistics

254,455 members
132,142 posts
  • Pavel1
    Contributor - Level 1
    2020-03-14

    Hi, I have a problem stopped working Display on M-ONE XL. Illuminates but does not show anything can it be fixed somehow? Or the only chance is to buy a new one ??? Thank you for info Pavel

    0 113
    • Pavel1
      RexBeckett

      @Pavel1 


      Hellp Pavel, welcome to the community.


       


      I suggest that you raise a Care ticket for Service Repair explaining your problem. This is done by clicking on Support at the top of the page and then clicking the Create a Care Ticket button. This is only possible if you have completed all the required fields in your profile. Make sure that you fill-in every required field on the Care form.

      • March 14, 2020
  • AndersonGuerra
    Contributor - Level 1
    2020-03-10

    Hello fellows...1st post around here...

    I have a TC Finalizer Wizard Series 48k and the display backlight is not working anymore, the display itself is working.

    I had a tech to look around and see if it was something visible like a missing voltage or bad cap.

    he could not find anything. any tips on fixing this or where to buy a new display?

    Cheers, Anderson.

     

     

     

     

     

     

    read more...
    0 90
    • AndersonGuerra
      PedroRodrigues

      Hello Anderson


      In that case please enter the SOFTWARE BOOT menu, by keeping HELP button pressed at power on. Dial option to INFO and press OK to check the application software. If corrupted; load the application software again.


      I hope it helps...


      All the best


      Pedro


       

      • May 13, 2020
  • Beefboy
    Contributor - Level 1
    2020-02-27

    I'm looking at a tc 1280 digital delay that displays "error" across the screen when it's turned on. Does anyone know what would cause it to say this? The user manual has error codes and their description, but nothing for an "error" being displayed. Please help

    read more...
    0 91
  • Uglebobruker
    Contributor - Level 1
    2020-02-24

    Hi, 

    Our café has a xo24, which I've got working again. Only thing is I don't understand why I only get signal out on channel 3, although channel 1 and 2 also are connected to an amplifier. I also need to turn the crossover for channel 3 on, although the HP and LP are completely off. I've checked channel trim on all channels, and don't quite understand how channel 3 routes to channel 1 and 2.

    Thanks in advance.

    This is the route

    Input channel a on, routing channel 3 on, crossover channel 3 on, output channel 3 on. 

    read more...
    0 59
  • PeterStedt
    Contributor - Level 2
    2020-01-31

    Hi.  I am using the Limiter -14 for Spotify but in the prepare section its Another specification, its -17 How can that be? At the same time down in the lower right of the Windows it says Output Loudnes -14
    What does Prepared mean, i do not quite follow. I tried  to upload a pic but the file was to big.  All the best! Peter Stedt

    Sweden

    F754B70A-E690-42C3-844D-891C5C094B2F.png
    read more...
    0 190
    • PeterStedt
      PeterStedt

      hi is there anyone here who is working with Finalizer var could lead me to someone who do? all the best! Peter 2029-02-08

      • February 8, 2020
    • PeterStedt
      PeterStedt

      Hi I have got an reply in my mailbox BUT , the links do not go to the Soarer (Contributor - Level 1) or the other one, why is that? This community is very hard to understand, really! Hi PeterStedt, Soarer (Contributor - Level 1) posted a new reply in Effects and Signal Processors on 2020-02-09 11:33 AM: Re: Finalizer loudness I use the Finalizer every day in my hardware setup so more like a master bus compressor and not as a mastering unit. But I'm wondering why you set the limiter so low? There's no auto gain

      • February 9, 2020
  • ar
    Contributor - Level 1
    2020-01-29

    The tc2240 is no longer in production,cannot seem to get any sense out of custmer support..I need a mains transformer for it as it was switched on at 110v while the wall voltage is 220,can anybody help..long shot i know..........

    0 64
  • amathie
    Contributor - Level 1
    2020-01-24

    I've been using my TC System 6000 Mk1 with Icon software, as for my purposes, I didn't want the extra clutter and expense of the Icon hardware controller and the rack mounted CPU unit that it needs to run.

    Whilst discussing upgrading my MK1 mainframe to a MK2, I've just learnt that the Icon software is only 32 bit and wont therefore run on the current MacOS.

    Please could a TC representative confirm whether or not TC are withdrawing support for ICON software for the Mk 1 and the Mk 2.

    If this was the case, I would feel this was an unreasonable step.

    read more...
    0 132
  • crispernaki
    Contributor - Level 1
    2020-01-18

    Howdy:

    I have a SpectraDrive, and I loved the compression so much, I picked up a SpectraComp so I could dig down into the settings and creat my own TonePrints.

    No matter what I do on the SpectraComp, I can't get rid of what sounds like clipping when plucking the strings agressively. There is no clipping when the SpectraComp is bypassed. There is no clipping when using the SpectraDrive ever.

    When comparing the two, I'm using the same amp, bass, cables, and power supply. Only swapping between the two pedals, and only using one pedal at a time. Tried almost all of the TonePrints.

    Have any of you had this issue? Is there a perhaps a problem with this particular SpectraComp? I submitted a support ticket, and am waiting to hear back, but it seemed like a good idea to ask around.

    cb

    read more...
    0 112
    • crispernaki
      TC-Rasmus

      Hi Crispernaki


       


      I figure that you're using the right power supply for the pedal right? It might be, that the SpectraComp somehow came loaded with at TonePrint that distorts the signal. It does not usually come with that, but it might have been beamed in at the factory. 


      Please try to beam some of the TC TonePrints into the pedal via your Bass, and see if that changes anything for you. The Comp in SpectraDrive is based on SpectraComp, so they should definitely sound almost the same.



      Have a crack at it, and let me know if it works

      • January 20, 2020
  • Lydfabrikken
    Contributor - Level 1
    2020-01-13

    Does anybody know how to restore passwords for M6000 licenses?

    As I have changed battery in one of my mainframes, I have lost my license codes.

    Please help!

    Kind regards

    Anders

    0 161
    • Lydfabrikken
      TC-Claus

      Hi Lydfabrikken,


      Please send me Your Mainframe serial and Restore Key in a PM


      All the best from


      Claus

      • January 12, 2020
    • Lydfabrikken
      MartinSeiferth

      Hi,


       I have the same problem. I use the M6000 on an OB Van and lost the license after changing the battery. 


      unfortunatly I got no answer from [email protected] 


      hope you can help me


       


      martin

      • January 27, 2020
  • CEB
    Contributor - Level 1
    2020-01-08

    Hi I have a TC 6000 MK2, it says that the license have been destroyed and that we need to phone to get our license back. We are on a big show right now and we need our broadcast bundle. Can we call and give you the SN and get our license back??

    read more...
    0 152
    • CEB
      TC-Mike

      Hi CEB,


      the support phone lines are unfortunately not available any longer and you have file a support request via the Community interface -> click on SUPPORT tab at the top of the page and then on "create ticket".


      Best regards,


      Mike

      • January 8, 2020
    • CEB
      PedroRodrigues

      Hi CEB


      That is a unfortunately situation, but it happens and we will be here to help you resolve this matter.


      What you need to do first is to replace the 3 V  battery present on the Main Frame of your TC 6000 MKII.


      It is adviseble that the battery exchange is performed by someone who is confortable soldering or by a techician.


      Please see the link below to acess our network of partners and service centers:


      https://www.tcelectronic.com/brand/tcelectronic/store-finder?division=ENTE&isoCode=GB&type=POS#googtrans(en|en)


      After the battery is replaced you should power the unit on, please do power off the unit in any ocasion, then submit a request via via the Community interface -> click on SUPPORT tab at the top of the page and then on "create ticket".


      Provide the serial number for your Main Frame and the 16 digit restore present on your screen and we will reactivate your unit in no time.


      Please adress the assitance request submitted in my name so I can  deal with your request ASAP.


      Best Regards


      Pedro Rodrigues


       

      • January 8, 2020
    • CEB
      QQ8472626 我的也是这样的问题,已经申请了,请您查看下信息。谢谢
      • Mar 4
Go to page