Statistics

270,121 members
149,910 posts
  • New
    EuanRichard
    Newcomer - Level 1
    2021-11-05

    Hi, I just have a quick and simple question - will there be any more updates to the Plethora X5?

    I've seen hundreds of recent posts clamouring for more frequent updates - as originally promised to customers as part of their purchase - that would continue to turn the Plethora into a true "Multi-FX" pedal. However I can't find any communication at all on this issue, and no updates for over a year now.

    Is there any roadmap or timeline here, or have the promises been abandoned?

    Thanks

    read more...
    2 23
    • EuanRichard
      CSurieux I fear it's dead for more important updates :(
      • November 5, 2021
    • EuanRichard
      BibsJ I am editing my post to echo the OP. It would be nice to know. Either way it's a good device if you can find one used for a decent price.
      • November 5, 2021
    • EuanRichard
      BibsJ Hi TC Folks, any updates?
      • November 14, 2021
    • EuanRichard
      EuanRichard

      Yes please, TC.

      I love TC Electronics gear and have spent hundreds over the years... but if promises get broken like this, and worst off you won't even reply honestly to the question... all I can do is throw it all in the bin, and advise everyone never to buy anything TC again.

      • November 14, 2021
    • EuanRichard
      John-PierreConq

      No updates for over a year and no responses to any emails in just as long. I'd say they've abandoned this project already.

      • November 15, 2021
  • New
    Virtanen
    Newcomer - Level 1
    2021-11-05

    Hi,

    What are the supported PCMCIA cards for System 6000? 

    0 4
    • Virtanen
      PedroRodrigues Hi Virtanen, thank you for your post, SYSTEM 6000 will work with a variety of PCMCIA CARDS but we advise to use a brand called PRETEC . Than you
      • November 5, 2021
  • New
    PatrickTR1
    Newcomer - Level 1
    2021-10-30

    Hi - can you take a look at this short vid and tell me what is wrong with my setup

    It's a Windows 10 64 bit set up - the software is all up to date.

    I have reinstalled the latest firmware to the Pletora unit & and I have re-downloaded the latest Toneprint software.  

    https://www.screencast.com/t/wkRqaC80BJ

    Any thoughts much appreciated.

    Thanks.

    Patrick.

    read more...
    0 19
    • PatrickTR1
      NicJonesMT Hi PatrickTR1. Thank you for the video, I've watched it and think the best option would be to submit a tech support ticket (Click Support at the top of the page).

      Can you please provide the following in your ticket (Along with your video link) and we can then hit the ground running to try and get this sorted.

      1 - Please confirm the exact Toneprint app version you are using .
      2 - Please confirm the Firmware version on the Plethora (we need the version number).
      3 - Can you confirm the Windows Build and Version you are using (Found in "About your PC").
      4 - Please check all drivers and bios for your computer are up to date.
      5 - Have you tested on an alternative computer.
      6 - How are you connecting the Plethora to your computer.
      7 - If using USB, please confirm if you have tried connecting to a USB 2.0 Port directly to your computers Motherboard (Avoid any Hubs and adapters where possible).
      8 - Have you performed a Factory Reset.
      • October 31, 2021
      • Struggling when creating a new board on TC Electronic Plethora X5
        PatrickTR1 Ok thanks Nic - I'll do that.
        • October 31, 2021
  • New
    fx2tz1209
    Newcomer - Level 1
    2021-10-24

    Hi,

    i would like to work with my old M2000 via sysex commands.  However, the only documention on that topic, available from TC, is for the M3000.

    https://mediadl.musictribe.com/download/software/tcelectronic/tc_electronic_m3000_midi_sysex_specifications.pdf

    I would be interrested in how the implementation for the two units differs.

    Example preset request to the M3000 (from the PDF above)
    0xF0       Sysex start
    0x00       TC Electronics ID
    0x20
    0x1F
    0x00       Device ID (can be set on the unit itself)
    0x42       M3000 model ID
    0x45       SYXTYPE_PRESETREQUEST
    [0x00 | 0x01 | 0x02]        Single engine 1, Single engine 2, Dual
    <Preset MSB>                preset number
    <Preset LSB>
    0x0F   Sysex end

    Considering the sysex request :
    1. Can i assume that the request from the M3000 will also work with an M2000, since both units are very similar ?
    2. I don't know about the model ID of the M2000, which has to be put into the request code (see above).
        Does anybody has this information ?
    3. Same questions 1,2 for the TC Reverb 4000


    I would very much appreciate any info!

    Thanks, Frank

    read more...
    0 14
    • fx2tz1209
      PedroRodrigues Hi fx2tz1209 the information on this matter was provided via the case you have submitted directly to us, if you require any more assistance on this matter please reply to my last E-mail sent on this case . Thank you
      • October 28, 2021
  • New
    oldale
    Contributor - Level 1
    2021-10-08

    Where can I download the G-System Editor software?

    0 13
  • New
    kennew
    Newcomer - Level 1
    2021-10-08

    The mono input on my Flashback 1 is intermittently cutting out.  How do I send it in for service?  Or is it even worth doing that?   Service charges can often rival the cost of replacement.  Thanks

    0 7
  • New
    JohnWashington21
    Newcomer - Level 1
    2021-10-05

    Anyone help please. 

    I have a brand new Dunlop X 8 volume/expression pedal but when I use it in expression mode I simply cannot use it to alter an effect level from 0 (heel down) to say 50 (toe down). 

    I have calibrated the pedal (in fact tried manual and automatic) and I know for certain that I am assigned the exp pedal correctly on the board and parameter I want to affect -- in this case the reverb effect level. 

    On the dunlop pedal there are switches/level controls inside but I've tried every combination possible and I simply cannot get it working. I know it's connected correctly. 

    please help before it gets sold 

    read more...
    0 13
    • JohnWashington21
      PedroRodrigues Hi JohnWashington21, thank you for your post, please consider that there is an expression modifier for each TonePrint which can be selected when assigning the EXP in the setting menu of the PLETHORA X5.
      This expression modifier is fully mappable in the TonePrint App including end-points, direction of travel, taper and up to 3 parameters simultaneously.
      Please take in to account that this is a slow process to implement
      Please follow the link below to access a video that mentions this on minute 22:11
      https://youtube/FJvbOLWiYpQ
      Thank you
      • October 6, 2021
  • New
    Picksmore
    Newcomer - Level 1
    2021-10-02

    Any chance of adding a polyphonic tuner to the X5?  The chromatic is great but having a polyphonic display option would be even better.  Even if it was only displayed on one 'module window', it'd be a nice option to have.  

    1 8
    • Picksmore
      PedroRodrigues Hi Picksmore, thank you for your post, please consider that adding a Polyphonic Tuner on the X5 would impact the amount of DSP resources available for other FX, so the Dev. Team deliberately chosen to add a very basic light tuner that will not require an extra pedal slots and can run alongside the five TonePrint effect slots.
      • October 6, 2021
  • New
    Warrioremg
    Newcomer - Level 1
    2021-09-29

    Hello, I've bought used Delay FB mini 1 and it doesn't have a dry signal. I've tried to switch kill dry by using Toneprint (version 4.4.18 for PC) templates, but it did nothing. Any suggestions?

    0 29
    • Warrioremg
      PedroRodrigues Hi Warrioremg,Please consider that the FX Level pot on your pedal is an analogue pot that mixes the wet signal with the dry after the wet signal has been converted back to analogue. With that in mind we can't do any clever digital trickery to the wet signal like turn it all the way up or all the way down when you are using the loop mode, because the pot is analogue. Because the looper is 100% wet and has no dry signal, this means that the FX level pot controls the overall output of the entire signal therefore not providing a dry signal.
      • October 3, 2021
  • New
    Sassy1Nabors
    Newcomer - Level 1
    2021-09-26

    I am using a G-System , Plethora x5 and a Riverside via midi and it wont work.A conflick with the Riverside and the X5 CC 102 cuts off the riverside. I fixed that with the riverside by cutting off the CC midi in.I cant cut off midi patch change off on the X5 and a full second changging boards is not an option.The g system is fantastic but for a main controler send the same data to ever external device.Something has to give.Im sure everyone with a g system would like to see it be able to use more than one midi chanel or X5 with a program change on/off.

    read more...
    0 31
    • Sassy1Nabors
      PedroRodrigues Hi, Sassy1Nabors please consider that to set up the G-SYSTEM and the Plethora X5 you must use a specifically-designed Y-Cable, for the G-System and Plethora X5 to communicate via MIDI Sysex messages.
      With the Y-cable installed, the G-System will still be able to talk to the Plethora X5 and separates the message traffic between the G-System and the Plethora X5 from the traffic between the G-System and any other unit. Thank you
      • September 27, 2021
    • Sassy1Nabors
      Sassy1Nabors I have that cable witch end goes where ?
      • September 27, 2021
    • Sassy1Nabors
      Sassy1Nabors Well i tried that cable . Same problem .
      • September 27, 2021
      • MIDI a problem !
        PedroRodrigues Hi Sassy1Nabors, please confirm that your Y cable as the same specifications as the one posted above. Nevertheless if that is the case please submit an assistance request directly to our Tech Support by hitting support on the top of the page. Thank you
        • September 28, 2021
    • Sassy1Nabors
      Sassy1Nabors I got the cable from TC.If I turn the patch change off on the G-system it wont control the strymon so i keep it on but the plethora changes boards with a 1 second gap it needs a (patch change on/off) .I want to control the X5 with CC# messages only. Adding the (patch change on/off) would be a good additive to the next update.
      • September 28, 2021
    • Sassy1Nabors
      Sassy1Nabors I found a solution! MIDI patch change messages go from 1-128 on the X5 so I went to bank 26-1 on the G-system witch is out of range for the X5. I have banks 26-39 on G-system and the Riverside has 300 patches so should not be a problem. Thanks for your help.
      • September 28, 2021
Go to page