299,155 members
182,868 posts
  • New
    Newcomer - Level 1

    I have used the EHX Iron Lung Vocoder in the past as a 'talkbox' kind of effect with my Kemper Profiler.
    I put the EHX in the effects loop of the Kemper and then just engage the effects loop when I want to use the harmonizer.

    I'm now trying to switch to the TC Talkbox Synth and hook it up the same way; but it appears that only the un-affected signal passes thru the 1/4" output and using the XLR output into the return of the Kemper doesn't work.

    Is there no way to set it up in this manner?
    It has to send the effected signal to the XLR output into a PA only?

    0 85
    • JimRodgers
      WilliamR Hello Jim, The talkbox synth effect is designed to only come out of the xlr out of the pedal and guitar thru of the 1/4 inch. There really isn't a convenient way to seamlessly integrate it in the effects loop of your kemper the way you are describing.
      • August 17, 2021
  • New
    Newcomer - Level 1

    What is the power input for Perform VG?


    0 72
  • New
    Newcomer - Level 1

    I just bought a Perform V about a week ago.  After hooking it up, there is a ground hum (about 80 hertz) coming out of it that I can't get rid of.   Here are a few notes about the setup:


    Shure ULXD24/KSM9 > Perform V > Mixer (input>onboard compressor>onboard EQ).


    1.  The input is all the way down and distorts if I turn up the gain at all.  I've trimmed down the gain coming out of the wireless receiver and it is working ok as far as input/distortion.

    2.  I've swapped out the mic cables and checked wiring to make sure it isn't a problem with the cables.  Same result with all cables.

    3.  It seems to be slightly less prevalent after a reset of the unit.  As soon any presets are loaded, it gets worse.  This is the case even without the preset being selected or HIT being on.  

    4.  In order to get the mic up to an acceptable level on our sound system, we have to turn up the gain/fader which in turn amplifies the hum.  

    5.  The firmware is updated to the most current version.  


    Can anyone help?  Could this be a line/mic level signal problem?  It's a pretty neat little unit and I want to use it, but the hum makes it useless.

    0 68
    • jeaves726
      PedroRodrigues Hi jeaves726 thank you for your contact, I would suggest to confirm that you have the 48V (Phantom Power) activated and also confirming the type Mic control is set up on this unit . On another point it may be useful to test a wired microphone with this unit to confirm that the input is operating correctly and the wireless signal is not causing any issues on any signal stage specially on the Roomsense onboard microphone. For last as a general check please confirm that all your cables are in good conditions and that you are using the supplied PSU.
      • July 28, 2021
    • jeaves726
      jeaves726 It's amazing how little info is out there on this unit. I was able to figure it out though. If you are an end user, I would be careful about the trouble shooting given here. Phantom power was absolutely wrong for the setup I detailed in the original comment. Most of the rest didn't apply.

      Ultimately, I was able to figure it out. The unit is not equipped to accept a line level signal (as I suspected). I switched the ULXD receiver to mic level and started adjusting the gain on the unit. There is no option to pad or switch the Perform V so if you don't have a mic level signal, you are out of options.
      • July 30, 2021
  • New
    Newcomer - Level 1

    Hallo ich suche verzweifelt einen Weg Backingtracks per Midi zu starten. Ich benutze das tc helicon voicelive 3 extrem. 

    Auch wenn ich den Start auf ein Taste lege, die sonst über Midi steuerbar ist, verliert diese Taste ihre Midi Fähigkeit. 

    Meine Host App ist songbook+ auf dem iPad. 


    Hello I am desperately looking for a way to start backing tracks via midi. I use the tc helicon voicelive 3 extreme.

    Even if I put the "start" on a key that is otherwise controllable via midi, this button loses its midi capability.

    My host app is songbook+ on the iPad.


    0 108
    • SHML18
      TC Helicon Hi SMHL18. If you need assistance with your TC Helicon products, the fastest and most effective way to directly reach our technical support team is at:

      - Diego
      • July 23, 2021
    • SHML18
      PedroRodrigues Hi SHML18, please consider that the below works successfully when triggering VL3X from Linkesoft Songbook via iRig MIDI2 interface.
      I hope this helps.
      Triggering commands are entered on the Songbook edit page which operates in chord pro hence {} brackets.

      {midi:CC32.# PC#}
      Where CC32 is the bank number and PC is the program preset

      Bank 0 runs from 1 - 128
      Bank 1 runs from 129 - 256
      Bank 2 runs from 257 - 384
      Bank 3 runs from 385 - 513 Note VL3x only has 500 presets

      Also note midi starts at 0 and not 1
      This is important when you want a particular preset. The PC entered needs to be -1 from the preset you want

      Example for preset 1
      {midi:CC32.0 PC0}

      Example for preset 129
      {midi:CC32.1 PC0}

      Example for preset 257
      {midi:CC32.2 PC0}

      Example for preset 385
      {midi:CC32.3 PC0}

      Calculating presets:
      If you want preset 208 on the VL3x
      208 - 129 (which is starting number in the bank 208 falls into) = 79
      So syntax would be {midi:CC32.1 PC79}

      If you want preset 494 on the VL3x
      494 - 385 which is starting number in the bank 385 falls into) = 109
      So syntax would be {midi:CC32.3 PC109}

      Its worth again noting on the VL3x the preset needs to be active to be selected. If there's nothing on preset 498 then the VL3x does not change when command is sent from the page on songbook you have chosen.
      • July 28, 2021
    • SHML18

      Hi, Mr. Rodrigues,

      I already understand the way to send midi commands from my app to the vlx3 and it works for functions like Chorus or Echo.
      Unfortunately there is no midi command to start the playback of a backing track via a midi command sended from the host app,
      to start a playback on vl3x in sync with the Text-Scrolling on the host app!? Is there a workaround? Is it possible to start
      the playback automatically while opening a preset initiated by the host app? (I know how to select a preset on the vlx3 via the app!)
      Best regards

      • July 28, 2021
  • New
    Newcomer - Level 1

    I have a TC Helicon Voicelive play unit that seems to have a short in the footswitch. i need it fixed as soon as possible be fore my next gig,

    0 57
    • Tonyvnacil
      Nigel67 Hi Tony, please send us a Service Ticket and we will raise an RMA for repair. This can be done by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Service tab and submit a ticket. A colleague will then get back to you with an RMA number and advise the local service centre to you. If it is urgent I would suggest calling the Repair Centre that they tell you to send the unit to and ask if they can turn it around quickly for you.
      • July 19, 2021
  • New
    Newcomer - Level 1

    I bought a TC Helicon Harmony G-XT a few months ago.  During my last recording sessions it worked fine.  After writing new songs to record I hooked up the rig and now signal from the microhone to the mixer.  I thought it might be the guitar needed to be hooked up to activate the mic.  The guitar plays through to the mixer, but still no mic. 


    Is there some setting that I am missing that is keeping the mic from working?  Does the mic input just stop working?  I have replaced both XLR cables with new ones and still no signal to the mixer.  What am I missing?

    0 103
    • BHShooter1
      NicJonesMT Hi BHShooter1.
      Sorry to hear you are having issues.
      I think the best option would be to submit a tech support ticket and a member of the team will be able to advise you further.
      If you could provide the following information in your Ticket it would help to Speed things along.

      • Can you please detail any other devices that are being used in conjunction and exactly how these are connected to your device? This includes Microphones, Mixers, Computers ETC.
      • Can you please detail how parameters on the device are set?
      • What firmware are you using and have you tried reflashing?
      • Have you tested the device using an alternative audio source?
      • Do you have access to alternative cables?
      • Have you tested the device with an alternative power source?
      • Can you confirm the specifications of the power cable you are using?
      • Are any LED’s or lights on the device lit up or behaving erratically?
      • Do you have a similar device that you can compare the behaviours of?
      • Can you please provide me with a detailed description of how the device is behaving and any other trouble shooting steps that you have undertaken?
      • Is the Issue Intermittent or constant? If it is intermittent is there a specific setting that needs to be used to cause the issue?
      • July 3, 2021
  • New
    Newcomer - Level 1

    I desperately need to turn global key off. I have cycled through the setup menu without finding it. My first day with this unit, all presets are locked on C major. Help!

    0 67
  • New
    Contributor - Level 2

    I am so [email protected]#$ pissed off at this thing right now. I've read the manual in excrutiating detail and CAN NOT record over a previsouly recorded sequence. I have tried everything I can think of. Hit the RECORD button, let it RECORD over the SEQUENCE, hit the STOP button. I go to track view and make sure all the SEQ marks are missing. I"ve tried saving it and not saving but no matter each time I end the recording/Sequence/Backtrack. Then I switch to a new track and right back to the one I was working on and there are the same old SEQ marks that I just saw were deleted when I recorded over them. And can anyome tell me what a category TC-Helicon claims a VL3X is? What a STUPID way of referencing. Why don't they just have VL3X in the product category. Sorry, I'm just really PO right now. Any help would be appreciated. 

    0 70
  • New
    Contributor - Level 3

    Okay, I got that loops and tracks are separate things. But if I have a loop assigned to a footswitch, why can't I select that footswitch from within the track? Will the loop just not play?

    0 50
    • Cstotland
      PetGerbil I'm just guessing, as I've only got the VL3 which doesn't have backing tracks...but, I believe you can only have one or the other. Loops or Backing tracks. not both. I assume it would double the machines required processing power to handle it.
      • June 28, 2021
  • New
    Newcomer - Level 1

    The lights come on and the unit seems to be working but I get no sound or effects. NOTHING!!!

    0 59
    • johnnysecho47
      WilliamR Hello, William from music tribe here. Please click on the support tab above to submit a support ticket and a specialist will get in touch with you asap.
      • June 22, 2021
Go to page