Midas

Midas

Brand

Midas

260,836 members
139,474 posts
  • New
    Vettes73
    Newcomer - Level 1
    2021-12-05

    I cannot figure out how to patch/configure the talk function on my Midas Pro1.

    It will be used FOH and mixing monitors from FOH.

    Thank you in advance.

    0 0
  • New
    Benjazz31
    Newcomer - Level 1
    2021-12-02
    hello, 

    I am using MR18 as sound card with Studio One 5 on Lenovo Ideapad Y500 Gtm650 laptop with Win10 Ltsc I7 16GB Ram processor.
    I performed the latest MR18 firmware updates.
    During the mixing / mastering phases I increase the buffers to a maximum of 2048 when I use a lot of plugins.
    when reading I have a lot of dropouts which make work impossible.
    With Asio4all and the integrated sound card no problem with the same session.

    What is the problem?
    read more...
    0 12
    • Benjazz31
      Paul_Vannatto The ASIO4ALL is the problem. Uninstall it and install the MR18 USB Audio Drivers Version 5.12.0 found here
      https://www.midasconsoles.com/product.html?modelCode=P0C8H
      under the Software section (on right)
      • Thu at 7:47 AM
    • Benjazz31
      Benjazz31 Hi Paul Thank. The problem is not with Asio4all. without much conviction I followed your procedure but the problem does not come from there. I'm afraid the driver is limited to working with 2048 samples and 44.1kHz. I hadn't noticed this problem on my other i5 24gb ram pc from my Home Studio. I also have a UMC 404HD which also does not have this problem like the Asio4all. I had a Focursite which did not even manage 2048 samples. The problem appeared since the update of Firmware 1.18 and driver 5.12.0. Studio One doesn't want the MR18 at 2048 Samples and crashes the Daw, even 1024 looks problematic.
      • Fri at 10:05 AM
    • Benjazz31
      Benjazz31 Hi Paul Thank. The problem is not with Asio4all. without much conviction I followed your procedure but the problem does not come from there. I'm afraid the driver is limited to working with 2048 samples and 44.1kHz. I hadn't noticed this problem on my other i5 24gb ram pc from my Home Studio. I also have a UMC 404HD which also does not have this problem like the Asio4all. I had a Focursite which did not even manage 2048 samples. The problem appeared since the update of Firmware 1.18 and driver 5.12.0. Studio One doesn't want the MR18 at 2048 Samples and crashes the Daw, even 1024 looks problematic.
      • Fri at 10:08 AM
    • Benjazz31
      Paul_Vannatto Try Reaper (at Reaper.fm)
      • Fri at 10:17 AM
    • Benjazz31
      Benjazz31

      Paul, you are on the wrong path, but thank you for your help.
      The problem comes from Driver 5.12.0. I have the same identical cloned system on another ssd with the 4.59 driver. I had not performed the 5.12.0 upgrade. Everything works smoothly. I uninstalled the 5.12 driver on the system and installed 4.59 and there everything worDuring a mixing session with all the active plugins, the driver does not follow. Even on a much lighter session. 3 tracks, 3 plugins cuts and cracks were heard a bit. the cpu load oscillated strongly for no reason. With the buffer set to 2048 Studio One 5 did not start. I had to turn off the power to the MR18 to get out of this crash which froze Win10.ks normally again. I think the 5.12 driver increases the CPU load too much.
      To complete this diagnostic I should check on my other home studio PC but clearly the 5.12 driver makes the system unstable on my laptop. So everything works for me with Firmware 1.18, MR PC Edit 1.7 and Asio driver 4.59.

      • 19 hours ago
  • New
    Vettes73
    Newcomer - Level 1
    2021-12-02

    How to setup a Midas DL16 to work with a Midas Pro1?

    0 0
    • Vettes73
      Paul_Vannatto The DL16 won't work with the Pro1, since the DL16 works only at 44K and 48K, while the Pro1 only works at 96K.
      • Thu at 8:14 AM
  • New
    Stijn3000
    Newcomer - Level 1
    2021-12-01

    Dear Midas,

    I don't know where else to write you about this, so I'm just dropping it here. Perhaps someone reading it can shoot the feature request upstairs.

    I recently bought the Midas M32R Live, and I'm learning to use the machine right now. Overall I'm quite happy, but I am missing one important thing, and since the M32R is advertised as to be future proof constructed, I thought I'd submit this feature request for inclusion in future firmware updates.

    I'm a sound artist and electro acoustic composer. I frequently work in multichannel setups, with a lot of different speakers. So when I see aux outs, I immediately think I can put a speaker out on that. Giving me a total of 14 possible analog outputs from the desk itself. However, I now have found out I can only put a speaker delay on the XLR outputs, which is a bit of a bummer. It would be really handy if I could also put a speaker delay - to compensate for distance - on the aux outputs as well. Since the M32R live is digital mixer with endless routing possibilities, I would like to request the next firmware update to incorporate speaker delays on the analog aux outputs as well. Since you already have the code installed for the xlr outputs, I wouldn't think it would be too difficult to also make this accessible for the aux outputs. For people like me, and probably many others, this would be extremely handy.

    kind regards
    Stijn

    read more...
    0 5
    • Stijn3000
      Paul_Vannatto This has been requested numerous times in the past. Unfortunately, the M32/X32 DSP engine is pretty well maxed out and adding more delays is not possible. Since the Routing Out 1-16 can have delays (total of 16), you could get a stagebox (such as the Behringer SD8) to access all 16 XLR outputs. If you need more than that, I would suggest you consider getting the Wing instead.
      • Wed at 6:52 AM
  • New
    tpmagee
    Newcomer - Level 2
    2021-11-30

    Hi all,

    I've got an M32 surface with 2 DL153 IO boxes.
    I need to add an M32C to the set up.
    would it work using the A and B AES50 connections on the C going to the 2nd AES50 connections on the DL boxes?

    0 2
    • tpmagee
      Nigel67 The DL153 boxes do not work in the same manner as the DL16 / DL32 in that they cannot be connected in series. They require their own dedicated AES50 port. The only way that this will work, is to put one DL153 on each mixer, and connect an AES50 port together on each mixer. For example, connect an AES50 cable between Port A on both mixers, and then connect the DL153's to Port B AES50s on each mixer. You will the use the AES50 line between the two mixers to send the inputs between them.
      • Tue at 10:36 PM
    • tpmagee
      tpmagee

      Hi Nigel,
      Thanks for the quick response!

      • Wed at 6:41 AM
  • New
    babyfood
    Newcomer - Level 1
    2021-11-30

    Any HD-96 users? Anyone having any issues?

    0 3
  • New
    Midas12
    Newcomer - Level 1
    2021-11-30

    Music Tribe censors out members posts when they don't like what you have to say.

    1 16
  • New
    Midas12
    Newcomer - Level 1
    2021-11-30

    You have lost all credibility with me. No response. I have many Verona modules that need repair. I would advise any person in buying gear to stay away from the Music Tribe. Horribly managed.

    1 15
  • New
    an2nyrobles
    Newcomer - Level 1
    2021-11-29

    Hi Guys!

    this is my first post here.

    I would like to ask if how long midas service center can repair/replace parts? 

    1. Just serviced my m32 today and they dont know when the mcu will be available. 

    2. One friend is currently waiting for m32 mcu replacement for 2 months

    3. other friend is waiting for months as well for Dl32 repair. 

    December is the most awaited months in 1 year to make profit but our equipment is not yet ready and waiting for repair. 

    Thank you in advance!

    Anthony

    read more...
    0 7
    • an2nyrobles
      Midas12 Good luck buddy. Service has had my Midas Verona since April of this year. I have not gotten a single reply from Esteban the service manager in over 7 months. I've opened case after case. I also have several other units that need repair too.
      • Tue at 11:27 AM
  • New
    RichHartfield
    Newcomer - Level 1
    2021-11-27

    Hi. I’m having trouble diagnosing a really strange fault.

    My setup:

    M32r connected to DL32 via aes50A ports. All inputs on the DL32 arrive on the correct channels on the M32. But channels 17-24 are behaving strangely. Sometimes when I switch phantom power on or off on one of these channels, it can cause a surge through some of the other surrounding channels between 17-24, disrupting their gain permanently, and turning off their phantom power. Sometimes when I turn phantom power on or off on one of these channels, it doesn’t even get a response from the dl32. Turning up the gain knob on channel 24 on the desk, also caused the surrounding channels to take a dramatic drop in signal level and lose phantom power.

    I’ve factory reset the console, and updated it to the latest firmware. I’ve also tried different cat5 cables.

    Any ideas? Any advice would be greatly appreciated!

    Thanks!

    read more...
    0 6
    • RichHartfield
      Paul_Vannatto Are the firmware of both M32R and DL32 up to date? Is the AES50 synchronisation solid green between the console and stagebox?
      • Nov 27
Go to page