Products

289,064 members
171,529 posts
  • New
    Agus84
    Newcomer - Level 1
    2022-06-27

    Can you guys help me, to find where I can get spare parts for loud speaker Turbosound,. I have a problem with the spare parts,Thank you for those who want to share the sales link 

    0 2
    • Agus84
      djtetei If you have a faulty PCB component, I doubt you will be able to get the specific component from MusicTribe, because, as far as I know, they will only sell you the whole PCB. You can try opening a support ticket or you can try outsourcing the required component from a donor PCB.
      • 3 hours ago
  • New
    edemmiller
    Newcomer - Level 1
    2022-06-27

    Hi guys!
    Recently (never before) I have the problem that the tuner stops my signal even if it's off.
    (sidenote: tuning works fine, no problem with it)
    All my gear (amp, guitar, cables, power supply) seem OK.
    When I remove the tuner from the signal chain everything works fine.
    What do you think? 

    read more...
    0 2
    • edemmiller
      PedroRodrigues Hi edemmiller, thank you for your post, in this case I would suggest confirming that your Polytune 3 is connected directly to a PSU that offers a 9 V DC, positive centre negative,>100 mA.
      It is also vital that you confirm that you are using a 1x ¼ " TS, unbalanced, mono cable on the input
      It may also be advisable to attempt to update you pedal by following the guidance below.

      Download the newest firmware from the link below.

      https://www.tcelectronic.com/tcelectronic/product?modelCode=P0CM0

      There are updaters for:

      -Microsoft Windows (these are ZIP archives containing the firmware installer)

      -OS X (these are disk image files containing the firmware installer).

      • Unplug all cables (including the power supply) from your TC pedal.
      • Connect the pedal to your computer using a USB cable.
      • Press and hold the footswitch on your TC pedal. If your TC pedal has more than one footswitch, press and hold the leftmost footswitch.
      • Insert the DC power supply plug.
      • The LED on your pedal should turn green. If your TC pedal has more than one LED, the left most LED should turn green. This indicates that the pedal is ready to receive the software update.
      • Release the footswitch. Applying the firmware update
      • Quit all MIDI-related applications (e.g., your DAW) on your computer and launch the firmware updater you have downloaded from the link above
      • In the firmware updater app, select your TC pedal from the drop-down list under the “STEP1” heading
      . • When the “Update” button under the “STEP2” heading turns green, click it.
      • The updated firmware will now be transferred to your TC pedal.
      Wait for the progress bar to reach 100%.
      When the update procedure is complete, the pedal will automatically restart.

      Thank you
      • 4 hours ago
    • edemmiller
      edemmiller Hi Pedro!
      Ok, I will have a try with the firmware update.
      But I'm sure that the power supply is fine.
      As I mentioned I have never had this problem before while I have been using this power supply
      (mooer macro power s8) with the polytune 3 for a couple of months.
      Also I'm using the same cables as I have used before (when there was no problem with the tuner).
      • 4 hours ago
      • Polytune 3
        PedroRodrigues Hi edemmiller, please ponder that in some cases when using a PSU that does not offers the exact features the pedal requires, 9 V DC, positive centre negative,>100 mA, the pedal may deteriorate over time, therefore what you are describing may happen. I hope this helps
        • 4 hours ago
  • New
    Leedubs
    Newcomer - Level 1
    2022-06-26

    I have 2 IP3000 speakers. One of them would not power up. I thought it may be a fuse so I changed the fuse and it still will not power up. The light panel remains dark. Are there steps in changing the fuse that I may hve ignored? I popped the fuse out and put another one in. Any guidance would be apprecciated.

    read more...
    0 1
    • Leedubs
      djtetei Sadly, as with many other products made by MusicTribe conglomerate, there's no troubleshooting procedure specified in Turbosound IP3000 user manual. Therefore, you have three options: open a technical support case on MusicTribe community, contact the dealer/retailer from which you bought the speakers and enquire about repair options under warranty or not, or troubleshoot the issue yourself. Get inside the box and check if the mains power reach the speakers power supply and further down the line.
      • 7 hours ago
    • Leedubs
      Nigel67 Hi Leedubs. As djtetei has mentioned above, the only troubleshooting you should do is changing the mains cable and mains sockets. If it isn't one of those, then open a Technical Support ticket. If your speaker is still under warranty, then you shouldn't go inside it as this would void any warranty, and if parts are required to repair the unit then this could be saving you money. We also advise that only our trained partners or authorised service centres repair the units as there could be some parts of the circuitry that could cause injury if touched while the speaker is powered, or further damage to the electronics could be caused leading to higher repair costs. To raise a ticket, click on the support tab at the top of the page. A new window will open. Scroll down and click on the Technical Support tab and submit a ticket. Many thanks
      • 6 hours ago
  • New
    PhatBa55
    Newcomer - Level 1
    2022-06-25

    I've owned by Veyron since 2017 and up until last night it's been amazing.  I fired up the amp to start practicing for church this coming weekend and there was no sound output.  Checked with 2 basses, multiple instrument cables, headphones there's zero output from the instrument.  Successfully tested output from the FX Return so the cables/basses are all good so it's either something with the instrument jack itself or something in the preamp?  It's so strange as for the last year the amp hasn't left my house or even moved.  Has anyone had this experience and were you able to resolve it?

    read more...
    0 5
  • New
    Caught exception: Specified column "user_id" is not in the row
  • New
    simi1947
    Newcomer - Level 1
    2022-06-25

    Hi, my Ditto+ is approaching full... how can I back-up my loops to Mac and also update software, please?

    0 4
    • simi1947
      ChrisEdwards1 Hi simi1947, backing up your loops is a simple procedure. All you will need to do is connect the DITTO+ to your Mac with the included USB cable and then power it on, once done it will be seen as a external hard drive by your Mac similar to a USB Stick. Once this is done it is just a case of dragging and dropping the folders from the DITTO+ Drive to an alternative folder on your Mac.

      Once you have backed them up to your Mac you can eject and disconnect the DITTO+, you may also want to carry out a factory reset to ensure all files backed up are fully removed and you have full memory again. You can do this by pressing and holding in the 'left' + 'right' buttons along with the footswitch, connect the power whilst holding these three switches in and maintain for 13 seconds. After 13 seconds you will see the pedal factory reset and reboot.

      With regards to the firmware update, instructions on how to do this can be found within the firmware release notes, both the firmware release notes and update are can be found under the "Software" tab on the product page linked below:

      https://www.tcelectronic.com/product.html?modelCode=P0DLQ
      • Jun 25
    • simi1947
      simi1947 Thanks Chris - will do...
      • Jun 25
  • New
    grok
    Newcomer - Level 1
    2022-06-25

    I recently purchased a used BG250 and at the time it was working correctly. However, yesterday i tried to use it and the power comes on but there is no sound at all and the buttons (mute, etc) and tuner do not register or work. I tried to connect via USB to no avail - I thought it may need a firmware update. I downloaded the Update package but it does not find the amp. Please help, what should i do?

    read more...
    0 3
  • New
    Stubedo
    Newcomer - Level 1
    2022-06-24

    Hi, can anyone help, I have the A-440 tone coming out of the synth, but can't get a sound from the oscillators. Never had this problem before,had the synth for a year and a half?..

    0 15
    • Stubedo
      PedroRodrigues Hi Stubedo, thank you for your post, in this case I would suggest performing a the full calibration process for you Model D, for that please follow the link below to access the full guide for this process:https://wsi.li/dl/gSWYhHea8zpCPqDzy/ Thank you
      • Jun 26
    • Stubedo
      Stubedo This looks like a scammers site,,,The link above?
      • Jun 26
  • New
    Marce1
    Newcomer - Level 1
    2022-06-24

    Good afternoon will the behringher x2442 usb work all 16 channel faders and subgroups with the master fader with the DAW

    PROTOOLS , WHICH DRIVER IS BEST TO USE WITH THE BEHRINGER X2442 USB WITH THE DAW PROTOOLS

    0 11
    • Marce1
      djtetei Behringer x2442 usb audio interface can only be used to send stereo track audio from computer to the mixer's main mix bus and to send the main mix output to the computer. Its audio interface is not multichannel and do not have controller functionality. However, you can use the x2442usb direct output jacks (post eq and post fader) to send their mono tracjs to a multichannel audio interface, if need be.
      • Jun 24
    • Marce1
      Marce1

      Thank you very much djtetei. Marcello gabriels.

      • Jun 24
  • New
    Aliennation
    Newcomer - Level 1
    2022-06-24

    More than 10 requests sent for service on a dead Tannoy Mini Live only 18 months purchase. Never any receipt or reply from this company. 0/10 for service.

    0 8
    • Aliennation
      djtetei I wonder where did you bought this speaker from? Was it an official Tannoy dealer / partner? Send it back to were you bought it, asking for repair or replacement. Alternatively, try to repair it yourself, because, truth be told, Music Tribe conglomerate is not the one worth buying products from, unless you know how to service them yourself. They are so inept in refusing to share the service manuals for their products, claiming that they can only share with service partners, to avoid injuries or mishandling. Even their community moderators don't have a clue about the products their employees sell, especially on the technical issues. They behave just like some robots, asking you to open countless cases on the product support page and no one ever bother to reply in a reasonable timeframe. I own many pieces of equipment from Pioneer, Allen Heath, Denon and JBL and these brands, especially Pioneer, will never ever refuse to share the service manuals, service parts list or any other information you request as a customer and user of their products. That's why these true brands are who they are and deserve to be where they are - at the top of the product quality, customer service and piece of mind for many years.
      • Jun 24
    • Aliennation
      ChrisEdwards1 Hi Aliennation, I am sorry to read about your experience. I have checked your account in our system and only see 2 cases have been submitted under the email address linked to the account, both of these are product registrations. There are no service or technical related cases submitted, however, upon review of your proof of purchase submitted for the registration of the Live Mini I see this was purchased via Amazon.

      Amazon are classed as a Super Partner, Super Partners are now responsible for all warranty/service related issues for products they sell. As your unit is still under warranty if you contact Amazon directly they will be able to assist you further.
      • Jun 24
Go to page