TC Electronic

TC Electronic

Brand

TC Electronic

208,481 members
80,682 posts
  • New
    tonyg0508
    Newcomer - Level 1
    2021-01-06

    I have downloaded the latest firmware update for the X5. The new pedals, looper etc have all appeared as expected. However the triple tap to activate the tuner and the board up/down controls appear to no longer work even though they are selected in the global settings. Anyone else have this problem and found a solution?

    read more...
    0 18
    • tonyg0508
      WilliamR Hello Tony, With the latest firmware update, you have to go into your global settings and turn that feature back on. This is bypassed in the new update.
      • Jan 6
    • tonyg0508
      tonyg0508 Hi William. Thanks for the reply. I had the feature turned on in settings but still no luck after re-installing the update. I have created a support ticket and sent a video showing the problem. Thanks again
      • Jan 8
    • tonyg0508
      WilliamR Have you tried doing a factory reset after the update yet? I just tested it out on mines and it is working.
      • Jan 8
    • tonyg0508
      tonyg0508 Hi William. Thanks again for the suggestion. I just tried a factory reset but unfortunately it didn't solve the problem so I then tried cycling the power after the reset but still no luck.
      • Jan 8
    • tonyg0508
      tonyg0508 Hi William. I seem to have solved this by accident. The speed of the triple tap seems to be the issue. You need to triple tap VERY quickly (difficult to do with your foot). Even a very slightly slower tap and it does not work. Thanks very much for your suggestions. Best wishes. Tony
      • Jan 11
  • New
    ChristianMonhei
    Newcomer - Level 1
    2021-01-06

    Hello, when i choose the option delay for a Hot Knob for the Delay effect, the knob works counterclock wise ( the bpm goes from 3000 Bpm fully left and 30 Bpm fully right) is this a normal behavior ? 

    Cheers from Belgium

    0 10
    • ChristianMonhei
      DavidKnighton Hello Christian,
      When you think about it, 3000BPM is a really short delay time, and 30BPM is really long. So the knob turns from left to right - short to long. By turning clockwise, you're "increasing" the delay time.
      • Jan 6
      • Plethora Hot Knobz
        ChristianMonhei Hello David, you are right, this make sense, but it is not very intuitive when you are in Bpm mode. Thank you
        • Jan 7
  • New
    jeremeikun
    Newcomer - Level 1
    2021-01-06

    I use my Polytune mini 2 for my bass guitar. It works great except for the lowest strings on my 5 string (tuned to drop G). Trying to tune the drop G seems to engage the polyphonic tuning feature, potentially from all the overtones generated from the bass string?

    At the moment I tune my lowest string at the 12th fret harmonic but it gets tedious after a while.

    I believe being able to disable the polyphonic tuning feature could help me but I'm not sure.

    Thanks for your help

    read more...
    0 10
    • jeremeikun
      PedroRodrigues Hi Paul , As you know by now, PolyTune 2 Mini is a polyphonic tuner, you can strum your instrument, and PolyTune 2 Mini will analyse and display the tuning of all strings.
      It is not possible to activate or deactivate the polyphonic tuning mode you just struck and it works, the strings that are in tune will be represented by two green LEDs. Strings that need tuning are represented by two red LEDs below (flat) or above (sharp) the middle row.
      • Jan 6
  • New
    davidmachac11
    Newcomer - Level 1
    2021-01-05

    Hi recently I found out that my tc electronic t2 guitar pedal is not working. Do you know if the service is for free and to whom should I write to? thank you

     

    0 5
    • davidmachac11
      WilliamR Hello David, Please contact us by submitting a Care Ticket. Click on the Support link at the top of this page. On the Support page, scroll down to the bottom and click on Technical Support to get started.
      • Jan 5
  • New
    Azarazu
    Newcomer - Level 1
    2021-01-05

    Hello,
    I recently got a TC Electronic Plethora X5 and I'm loving it. I played with it for some time and now decided to tweak some of the settings on my computer... and I couldn't be more dissapointed.

    First: the user manual for the Toneprint app doesn't even mention the plethora, the plethora itself comes with quick start guide and no detailed manual. Why?

    Second: the toneprint app seems to be completely unprepared for interacting with plethora, I have the boards tab, that I can use for renaming and reordering the boards, which I will use for reordering the boards if I want it or not, because if you are past the first 10 or 15 boards every single click will reorder the board you clicked to a random spot in the first 10. It cannot do anything else, or I'm completely missing something. Can I delete, duplicate, create new board in the toneprint app? Most importantly: can I edit the board I have created? Can I at least edit the effect in realtime and tweak the settings to see what works? The toneprint app seems to completely not utilise the fact that the communication with the Plethora is two way. It works on the single fx pedals, so I really expected it here.

    I'm frustrated and extremely dissapointed :(

     

    Running plethora at build 1.2.18, Toneprint app at 4.4.03, and mac on catalina 10.15.7


    View Video
    read more...
    1 19
    • Azarazu
      StaceyBaum I feel your pain Maciej. I also struggled with the reording of the boards on my Mac. When I used the app on my iPad I found it was less touchy. This forum is a great spot to voice your concerns, suggestions and questions. They do listen and want to help.
      • Jan 5
    • Azarazu
      WilliamR Hello Maciej, I highly recommend watching the plethora tutorial videos by Pedal Platform. They are very helpful.
      • Jan 5
      • Am I missing something, or the Toneprint app is the worst (with the Plethora X5)
        Azarazu Thanks, I will check it out
        • Jan 5
      • Am I missing something, or the Toneprint app is the worst (with the Plethora X5)
        Azarazu Now I understand. I'm still unhappy with board management in the app and limited communication from the plethora to the app, but at least I understood the basics of how to really program that thing.


        TC - you should hire Philippe from Pedal Platform to do some official tutorials for you.
        • 1
        • ·
        • Jan 5
    • Azarazu
  • New
    Shamusotoole
    Newcomer - Level 1
    2021-01-04

    Hi Fam.  

    I bought a Flashback 2 with the aim of mono input, external tap, and stereo out.

    I've been trying to play with the settings and can't seem to set it up this way.

    The goal was for this stereo output to go into a hof2 stereo verb, but I'm not winning this one. 

    Any tips, suggestions etc?  

    Cheers all

    read more...
    0 17
    • Shamusotoole
      TC-Marcus Howdy!
      According to the manual https://www.tcelectronic.com/product.html?modelCode=P0CKR "Documentation -> Manual" this is not possible, see the attached crop out.

      You can, however, switch the behavior of the footswitch from being MASH to being tap tempo, thus sacrificing MASH functionality, of course. Check this video https://www.youtube.com/watch?v=FCHVsmpxYJc. At around 3.00 the mono/stereo output stuff is explained too. Using the built in tap tempo, you can have tap tempo and stereo out.
      Read the video description for an explanation on how to do the FWupdate

      You also need the latest TonePrint app which can be found here https://www.tcelectronic.com/tonePrints.html

      Let me know how it turns out!
      • Jan 4
    • Shamusotoole
      Shamusotoole Thanks for that. I had read that but wasn’t sure if there may have been another firmware release that enabled this. I have multiple tap delays and need the external tap to sync them.

      Anyone else found a work around?
      • Jan 4
      • TC Electronics Flashback 2 - external tap + Stereo out?
        TC-Marcus There is no workaround, as stated in the manual, other than using the built in tap tempo, sorry.
        • Jan 4
  • New
    dsmmrm
    Contributor - Level 2
    2021-01-04

    My new ditto plus mutes the signal when you press record. It still records though, as you can find out when you stop recording and play back starts. at that point there is no sound from the input jack going into the signal. Hitting record to do an overdub does not play any guitar signal to the output jack. if you stop the loop there is still no sound going from the input to the output jack. Deleting the loop immediately restores the guitar signal. I can hear what sounds like a faint relay clicking inside the unit when I switch from a loop location that has a loop to one that does not.

    read more...
    0 20
    • dsmmrm
      dsmmrm PS. I have the latest firmware and reloaded it just to be sure.
      • Jan 4
    • dsmmrm
      PedroRodrigues Hi, I would suggest performing a factory reset followed by a firmware update to the latest version 1.0.14
      This version will Improved footswitch handling in x-tended overdub mode for better timing x-tended overdub recording starts on down-press.
      To perform a factory reset please press and hold previous + next + Foot switch for 13 seconds.

      To update your unit please follow the steps below

      1. Power off pedal
      2. Plug in USB between pedal and pc (or mac)
      3. Hold down the foot switch (and keep holding it)
      4. Power on pedal
      5. Display should show "boot mode" and the currently installed version number
      6. Run the firmware update
      7.
      It is, unfortunately, not uncommon for the firmware updater to show "update failed", even when successful.

      You can, however, verify the install worked by going back to boot mode and then checking if the version number is as expected (Step 1 to 5 above).

      Extend mode is one of the new features for Ditto+, it means that the initial recording will be extended such that you can for example have a ground rhythm that you want to record some leads over.
      To go to Extended mode please go to an empty track and hold down left and right (first "back level" will be displayed, keep holding, then "extend lp" will be displayed
      Press left for yes, right for no, to toggle extend mode on or off (default) respectively

      To use backing tracks please simply connect to pedal via usb and you can drag and drop your files in and out of the pedal

      Only wav files are supported, in these formats
      • PCM mono 16bit @ 44.1kHz
      • PCM stereo 16bit @ 44.1kHz
      • PCM mono 24bit @ 44.1kHz
      • PCM stereo 24Bit @ 44.1kHz
      • PCM mono 32bit @ 44.1kHz
      • PCM stereo 32bit @ 44.1kHz
      • Float mono 32bit @ 44.1kHz
      • Float stereo 32bit @ 44.1kHz
      I hope this helps
      • Jan 5
      • ditto plus mutes while recording and when a loop is present.
        dsmmrm reloaded firmware. confirmed 1.0.14. did the reset you described. no change.
        • 1
        • ·
        • Jan 5
      • ditto plus mutes while recording and when a loop is present.
        PedroRodrigues Hi dsmmrm can you confirm that the file you are suing reflects the list of Wave files supported stated above?
        • Jan 6
    • dsmmrm
      dsmmrm I am not using an imported wav. I'm just trying to use the looper in a live setting. whatever it records is the format I'm using
      • Jan 6
      • ditto plus mutes while recording and when a loop is present.
        PedroRodrigues Can you please confirm that you are using t a 9 V / ≥100 mA PSU?
        • 1
        • ·
        • Jan 7
      • ditto plus mutes while recording and when a loop is present.
        dsmmrm yes,l i am.
        • Jan 7
    • dsmmrm
      TC-Marcus Hey there!
      Sorry for the late reply!
      Ahh, that's a bummer. Sounds like a faulty unit to me! I would suggest returning it for a new one.
      Let me know how it turns out with the new one.
      • Jan 11
  • New
    begmas2000
    Newcomer - Level 1
    2021-01-04

    Just got the pedal, learning how to use for now! But I think I miss something comparing apps (both win and android) with screenshots on the web. What app should I use to be able to see those dynamic response curves for compressor? Cannot find them in neither latest windows or android apps

    read more...
    0 53
    • begmas2000
      TC-Mike The Graphs only show when you actually change related parameters like Threshold etc via app interface or when using the physical knobs on the pedal while connected to app
      • Jan 4
    • begmas2000
      begmas2000 This is what I see, The circle on knob range graph moves when I rotate knobs, but no dynamic response graphs shown on neither tab! How can I see the top two graphs from the first screenshot?
      • Jan 4
  • New
    MiroslavHemela
    Newcomer - Level 1
    2021-01-03

    Hellou.. My Tc Nova System power supply is death. Little trafo is burned... Any suggestions for new or used in funcion, power supply? I am from Serbia, its hard to buy this item in my country. Thanks.

    0 9
    • MiroslavHemela
      Nigel67 Hi Miroslav. Have you tried contacting our spares team? If you click on the Support tab at the top of the page and then click on the parts tab towards the bottom, you will be able to submit a ticket and request pricing and availability for a new power supply.
      • Jan 3
      • Tc Nova System Power Supply Death
        MiroslavHemela I did that just now. Thanks
        • 1
        • ·
        • Jan 3
  • New
    ttsing4u
    Newcomer - Level 1
    2021-01-03

    I have a TChelicon Play Acoustic which tracks very well.

    My ExtremeLive 3 doesn't want to track regardless of using MIDI in from the keyboard, Guitar in from Guitar or Roomsense or Natural Play. Nothing seems to make it see the proper chord. It does occassionally do major chords but not well. I need help.

     

    Using Global Settings:

    I've switched from everyone, MIDI, Guitar, Autosense etc. and saved after each change and even powered off and on. I've tried some of the factory harmony settings as well as my own and they all respond the same. Not usuable live.

    I've turned OFF Natural Play Roomsense etc. and gone with the above settings to see if that was confusing it. Same result.

    read more...
    0 4
    • ttsing4u
      PedroRodrigues Hi Tom, please be aware that for the sync/backing track , you'll never get it perfect since the MET in the VL3 isn't the same as the tempo that's recorded on the track. Even if you set the tempo the same in VL3 as you know it is on the track, the two have no way to "talk" and make sure they stay in some sort of sync. You'd need MIDI clock from/to both devices for that I would suggest the use of a DAW.
      What you end up with is 2 tempos that are actually the same, but ever so slightly "off" when it comes to the beats themselves. You end up with the slight timing differences adding up over time and eventually they'll be playing on opposite down/up beats and then come back together again after more time.
      For the erase, that's common when you're using the Play button to erase.
      If you don't want the "burp" you can use the Erase button from the UTIL menu.
      The Looper level in the Mix menu affects the recorded volume of the loop, but that's global so you can't turn down one loop and then turn up the next Slot/Track.
      • Jan 4
      • Harmony NOT tracking with any setting
        ttsing4u I'm not using tracks. I was referring to using the guitar or keyboard as the source to follow (track) the chord structure for vocal harmonies. I've been watching it between songs and the song might be in A and the harmonizer sees it in which throws out horrible harmonies. Then sometimes it finds the correct key but doesn't respond to minor or major 7 chords only the major ones. I'm playing bass, wife on keyboard and even with the internal mic settings it still doesn't listen or hear the proper chords changes to keep the vocal harmonies correct.
        • Jan 4
Go to page