TC Electronic

TC Electronic

Brand

TC Electronic

269,959 members
149,732 posts
  • New
    dave50
    Newcomer - Level 1
    2021-12-17

    When I have my body rez in mute mode to switch instruments it works fine on all instruments except for my Guild acoustic jumbo Jr bass it pops when pluging in. Does anyone have an idea what might cause this? maybe a ground issue 

    thanks 

    Dave

    read more...
    0 9
    • dave50
      WilliamR Please be sure you are using a 1/4 inch TS cable and not a balanced trs cable. Your guild bass probably has an active pickup with a TRS jack that is used to turn the battery of your bass on and off. If you use a balanced cable it may cause the issue you are describing.
      • December 21, 2021
    • dave50
      dave50

      I am using a TS cable and I forgot to mention when using my boss Tu2 tuner it does not pop

      • December 22, 2021
  • New
    Beep2458
    Newcomer - Level 1
    2021-12-16

    Hi I bought 4 licences of VSS3.

    No email and licences recieved... 

    I all ready complain two times on this portal. No help rom your side.

    Pleas send me those licences and invoice ASAP...!

    ilok:lukasmoudry


    View Attachment
    read more...
    0 4
  • New
    DukeVanAwe
    Newcomer - Level 1
    2021-12-15

    The screen corresponding to the 5th pedal (last screen) is always white no matter what I do. It does this from start-up until I turn it off. It didn't always do this. Worked as expected for a while. Yesterday I turned the pedal on and there was nothing on screen except white. I tried a factory reset and also I updated the firmware to plethoraX5_1_2_18 but that did not work.

    The pedal is not unde warranty since I bought it from another person.

    Is there a way to fix this? Thanks!

    read more...
    0 20
    • DukeVanAwe
      Nigel67 Hi DukeVanAwe. The displays are individual items, so there is a possibility that the cable connecting the display to the main pcb has become dislodged. The display could also have failed and need replacing, but there is no way to test this apart from swapping a good one with the bad one. We would advise that this is done by a trained technician as further damage could be caused when swapping the LCDs over. If you do intend doing this yourself, please make sure that the power supply is disconnected before entering the unit. Spare parts can be purchased from the Spares Team. They can be contacted by clicking on the support tab at the top of the page. A new window will open. Scroll down and click on the Spare Parts tab and submit a ticket. We do advise that repairs are carried out at one of our repair centres and the unit can be booked in with them by sending a ticket to our Service Team - same as spare parts but click on Service Department. Many thanks
      • December 15, 2021
  • New
    SmashAshby
    Contributor - Level 1
    2021-12-15

    Hi, Wondering if it is possible to place the Plethora X5 FX loop "before" the Stereo Input.

    If so, my signal chain would be:

    Guitar -> FX Loop Input,  Plethora X5 Effects -> FX Loop Out -> Analogue FX with Stereo Outputs -> Stereo Input -> Plethora X5 Effects -> Stereo Output -> Amp L & Amp R.

    See Attached Diagram.

    NB - it would also work if the Effects, and FX loop could be placed "after" the Stereo Output...

     

     

     

    read more...
    3 15
    • SmashAshby
      MaximeG YES please !!! It does seem like a huge limitation to have a stereo effect processor with stereo in and out, but mono FX return !
      • December 26, 2021
    • SmashAshby
      scattitude I am guessing this is not possible based on the design, which I assume controls all signal routing after the A to D conversion at the inputs; and that the loop-out jack needs to see a signal connected to the Plethora input. I get that you are trying to keep the Plethora entirely out of the signal path using the loop feature, but you would probably need to do this with an external loop box. The only other method that would simulate your desired connections would be a pedalboard setup that had no assigned effects - all bypassed.
      • Jan 2
  • New
    BilltheCat
    Newcomer - Level 1
    2021-12-14

    It's been almost a month since I sent it in. I resubbmitted it 10 days after the first try because I hought it got lost. The ticket checker just says "In Progress".

    0 24
    • BilltheCat
      KyleJohnson Hello, Kyle here with Music Tribe. If you can provide the case number I would be happy to look into it for you.
      • December 14, 2021
      • Can I get an update on my warranty/product registration?
        BilltheCat Case number is still CAS-505202-J3B2Y5.
        • December 17, 2021
  • New
    fraz60
    Newcomer - Level 1
    2021-12-13

    I am an endorsee and I see that a lot of things have changed. How can I get in contact with you?

    0 9
  • New
    nlsrecordingstudio
    Newcomer - Level 1
    2021-12-08

    Dear Support

    Can you give me a hands up where you are in migrating the VST3 / AU plugins to run natively on Apple Silicon. I'm not intressted in rosetta2 (that works for now). But as upcoming DAWs are running natively on M1(x) those plugins are needed.

     

    read more...
    0 27
  • New
    madman171
    Newcomer - Level 1
    2021-12-07

    Hello Musictribe and tc electronic team,

    can you tell me if the System6000 Licences execept the System6000 Integrator are running with an MKI System?

     

     

     

    0 10
  • New
    paul510
    Newcomer - Level 1
    2021-12-06

    I contacted the help desk in order to obtain a replacement power amp for for my BH250, and recieved an invoice indicating the parts that I needed, but so far (4 weeks later) nobody has picked up the phone in order for me to actually order the parts. I have left messages on their answerphone, but I've heard nothing.

    Does anybody actually work there?

     

     


    View Attachment
    read more...
    0 14
  • New
    Oelmen
    Newcomer - Level 1
    2021-12-06

    Hey! I'm really having trouble figuring this out and haven't found articles online related to it. I play e-bass and a Moog synth bass on stage and I need them both to be heard from my bass cab and run via a single cord for the sound guy. For this purpose, I was dreaming about running my e-bass to the "Input" of the amp, and running the Moog synth bass to the insert / effect loop so it would bypass the preamp of the amp. So far I ger both inputs working indivitually but once the effect loop jack is plugged in, the "Input" jack cuts off and signal from it is no longer heard. What might I be missing here?  Thanks!

    read more...
    0 9
    • Oelmen
      TC-Mike Hi Oelmen,

      The FX Loop of the RH750 is serial like on most other amps too and this cannot be changed.
      What you can do is either use an A/B switching box to toggle between Bass and Synth input source or use a small mixer in front of your BH 750 in case you want to layer your Moog with your E bass.
      There are also A/B Y switching boxes with a parallel path available to switch or layer input sources.

      best regards, Mike
      • December 9, 2021
Go to page