TC Helicon

TC Helicon

Brand

TC Helicon

260,696 members
139,320 posts
  • sdrummato
    Contributor - Level 1
    2019-06-29

    Hello eveyone, i just noticed a funny (yet frustrating) fact. I massively use loops in my sets, and I both use the looper integrated in the play Acoustic and another looper, the boss rc 30. Now, I noticed today that the play Acoustic looper kinda ruins the guitar sound, it's like it's filtered and is obviously different from the one i hear when i play, also it's completely different from the sound i get on the rc30, which is identical to the sound i hear. How is this possible? It's funny cause I didn't notice that before, but i need to understand it cause i need them both in my live sets. Thanks to anyone who is willing to help!

    read more...
    0 172
    • sdrummato
      TCH-Rob

      The first thing I'd check is whether you have the speaker sim enabled on page 3 of the setup menu. This is designed to make your guitar sound like it's coming out of an electric guitar cab, which will colour your sound. Also double check that guitar amp fx are set to off. If neither of these solves the issue, it could be an issue with your setup. What does your signal flow look like? What order are your effects pedals in currently?


      Hope this helps!

      • July 2, 2019
  • TomHigginsom
    Contributor - Level 1
    2019-06-28

    Hi,

    Anyone has a good advice?
    I bougth this unit a year ago, and now when I am IMG_20190628_150208.jpgswitching on, it turns off and on again, then shows the window message as on the pic.

    What should I do?

    IMG_20190628_150208.jpg
    read more...
    0 404
    • TomHigginsom
      TCH-Spencer

      Hey @TomHigginsom,
      Please get in contact with our support team, they'll be able to troubleshoot with you and discuss repairs if necessary.  Good luck!

      • June 28, 2019
    • TomHigginsom
      lana22

      Chuck the device and find a different f/x processor from a different company.

      It appears there is no fix for this and Music Tribe has scrubbed all the old forum posts about it.

      From my experience with my VoiceTouch 2, this blue/white screen issue is a random occurance. For me, it self-resolved, and now it's happened again and I can't fix it. 

      • July 8, 2019
    • TomHigginsom
      DennisDubeau

      A very lucky guess is that it looks like a contrast misadjustment... If the unit is out of warranty and if it was very impractical to have it serviced by a certified TC Helicon tech.. Before using the unit as a paper weight, I'd open the unit and try to locate a small potentiometer very close to the display.. I'd turn it a very slight bit, power up carefully and see if anything improves at all...


       


      Good luck.


       


      PS: I am a tech myself but in no way connected to TC Helicon other than owning a unit myself. No issues so far.

      • August 1, 2019
    • TomHigginsom
      PureWinter

      Hi Tom,


      I have been gigging with VL3x for about 3 years now and this has happened to me twice. It's probably that the SD card become unseated. Fortunatly during rehersal or sound check. So the show went on. 


      If you unit is out of warrenty and you are somewhat of a handy person there are many video's online that can show you how to fix it. 


      video link of many.  blob:https://www.youtube.com/71fe5c17-c850-4251-a5ed-1e2b70a3d62a


      I have done it twice. I love my unit but this seems to be a common problem that TC Helicon should be addressing when if they ever update the unit. I hope they do because I'd love them to add midi mix control and more I.O. options. Non the less it has been working great for me so far.


      Good luck.


       


       


       


       

      • August 1, 2019
  • PictureMeFree
    Contributor - Level 1
    2019-06-27

    Hi,

    when I power in my vl3x, the input meters show maxed out to the red even though nothing is plugged in. I tried plugging in a mic and a guitar- no change. Rebooted to factory settings- no change.

    unit has been kept in pristine studio condition, and is completely unusable at the moment. Any help would be appreciated! 

     

     

     

     

    read more...
    1 250
    • PictureMeFree
      TCH-Spencer

      Hey @PictureMeFree,
      Since the factory reset had no effect, there may be something physically wrong with your unit.  Please get in contact with our support team, they'll be able to troubleshoot further with you and discuss repairs if necessary.  Good luck!

      • June 28, 2019
    • PictureMeFree
      Chrodrig

      Did they ever solve this issue? I have the exact same problem. 

      • August 7, 2019
  • ToddPlesko
    Contributor - Level 2
    2019-06-26

    Hi, I have a need to enter bypass mode using Midi.  I use midi for many functions on the VL2, all using PC messages.  The manual indicates bypass can be enabled using CC#114.  I have tried multiple controllers, I know the unit is receiving the message (PC messages work fine and I can visually see the Midi indicator on the VL2 when I send the CC#114 message), so I am at a loss as to why it is not entering bypass mode.  I have tinkered with the CC Channel in setup (I am unsure exactly what that is and why it is different form the Midi Channel).

    Any idea why the 114 CC message is not turning on bypass mode?

    Thanks in advance!

    read more...
    0 178
    • ToddPlesko
      TCH-Spencer

      Hey @ToddPlesko,
      You've found a bug!  Well kind of... The good news is that CC 114 actually is working and is toggling the Bypass mode as it should, the bad news is that the footswitch LED isn't being toggled with the Bypass mode.  So you're right that the footswitch isn't lighting up or turning off with this CC, but if you listen to the VL2's output it actually is toggling Bypass.  Cheers!

      • June 27, 2019
  • DanielThompson
    Contributor - Level 2
    2019-06-11

    So if a teenager wanted to start beatboxing and looping in a live situation like for a school dance or gathering of friends. what TCH product(s) should I recommend? I've already told him about your amazing iPhone apps, but those are little hard to master in a live situation, I think. What else do you have?

    read more...
    0 219
    • DanielThompson
      TCH-Paula

      Hi you have a couple of options! If you're looking for something really simple, then the Ditto Mic Looper is for you. If you're up for something that will give you a vocal effect or a kick or a snare built in, then go for Perform VE. I hope this helps! 



       


       
      • June 13, 2019
  • JohnShelley
    Contributor - Level 2
    2019-06-05

    I don't understand why this is not an easy answer to find.  I just hit "Backup All" in VoiceSupport2 which is hooked up to my VL3x... Where does the backup file go????

    0 331
    • JohnShelley
      TCH-Spencer

      Hey @JohnShelley,
      In VoiceSupport 2 you'll find created backups in the "Presets" tab under "Backups" on the left.backups.png


      You can also use the "Import" and "Export" buttons in the top-right to manage backups.


      These backups also exist as pairs of files on your computer.  On a Windows machine they live in "C:\Users\[Username]\AppData\Roaming\TC-Helicon\VoiceSupport 2\VoiceLive Play GTX\data" and each backup is a pair of files - a ".tch" file and a ".xml" file together create a backup.  The files are pretty useless outside of VoiceSupport 2, but nevertheless that's where they are.  Cheers!

      • June 20, 2019
  • deanzey
    Contributor - Level 1
    2019-06-03

    Hi. Just bought the C1 voicetone pedal. Red light keeps going off and on and the effect keeps turning itself off and on. Do I have a faulty pedal?

    0 279
    • deanzey
    • deanzey
      TCH-Spencer

      Hey @deanzey,
      Please ensure that the "Mic Control" button on the side of the pedal is turned off (pressed out).  If it's on and you aren't using a MP-75 or MCA100, then it's very likely your pedal will be confused and think that you're using a remote button to toggle the pedal when you really are not.  Cheers!

      • June 20, 2019
  • vavaenvivo
    Contributor - Level 1
    2019-06-02

    Hi All,

    I have a VoiceLive 3 Extreme adn I've been trying to import backing tracks for a few hours now. I save the tracks as .wav files, made them 24bit at 48000, but when I try to import the track into the VL3X, only the USB drive is reognized and NOT the files. The files don't even show up. What am I doing wrong here? I have a gig in two weeks and really need to make sure the unit works and the set is fluid!

    Many Thanks!

    read more...
    0 259
    • vavaenvivo
      TCH-Spencer

      Hey @vavaenvivo,
      Backing tracks on your USB drive should live on the root of the drive, as in not in any folders.  Loops however should be in a "VL3_Loops" folder, and recordings direct to the drive will end up in a "VL3_Recordings" folder.  So hopefully your backing tracks are on the root of your flash drive.
      Also, "The internal audio file format of VL3X for Backing Tracks is 16 bit resolution and 48 kHz sampling rate" (from page 75 of the manual).  The VoiceLive should do the conversion from your 24 bit to its internal 16 bit, but if you have the ability to export your tracks at 16 bits that might be better.
      There's also the issue that some USB thumb drives just straight up don't work with the VoiceLive 3.  If possible, please try using a different drive.

      • June 6, 2019
  • MokePerry
    Contributor - Level 2
    2019-06-02

    I would like to advance through my programmed 'Steps' via midi, just like I could with a foot-switch connected to the Pedal input on the hardware. I can only find a Midi option for selecting a particular 'step', but not a 'next' option. Does this really not exist?

    I can recreate all of the functions that I used with the foot-switch except this one??? I don't want to run another cord out to my pedalboard for a switch to advance through 'steps', when I have spare switches on my midi controller

    read more...
    0 246
    • MokePerry
      TCH-Spencer

      Hey @MokePerry,
      Unfortunately there is no "Next Step" option, you need to explicitly state which Step you want to change to.


      CC 115 = Step
      Value represents Step Number, but starting at an index of 0, so “0” = Step 1, “1” = Step 2, etc.
      So sending a CC#115 with a value of 1 will take you to the second Step in your current Preset.

      • June 6, 2019
  • Vedran
    Contributor - Level 2
    2019-05-27

    Hi,
    we have a project that would include TC-Helicon Blender in several packages but we need it fully functional on Raspberry Pi (Linux).

    Do you plan to release Linux drivers for it?

    It would mean us a lot, and we would be able to make our project come true with your product which solves a lot of pain we had to make this possible! With your device we would only need Raspberry Pi and Blender to make it possible!

    Please if there's a way, tell us how we can help!

    Best regards,
    Vedran

    read more...
    0 658
    • Vedran
      Vedran

      Also, I've tried it on Windows 10 with your drivers, and while it should work as ASIO device, in software I've tried it didn't work at all.


       


      Tried: 


      - vMix


      - OBS x64


      - Audacity

      • May 27, 2019
    • Vedran
      Roblof

      The blender is core audio compliant so it should work on linux without any 3’rd party drivers.

      • May 29, 2019
    • Vedran
      Vedran

      Hi,


      I've tried it on Linux, but while it gets recognized by it, I can't use it in any software.


      TC-Helicon says that they don't support Blender for Linux, and that they don't even think about doing a support for that case... 


      Can anyone else test this out and for sure say that it works for them?


      @Roblof  ?


      Thanks!

      • May 30, 2019
    • Vedran
      antonyudin

      There is a way to make the tc-helicon Blender work on Linux, but it is not the most convenient one.
      If you were to plug-in the device into a Windows box first, let the driver initialize the device, then unplug the USB cable and plug it into a Linux box, you will get 12 input channels in Ardour and a playback back to the Blender working perfectly fine.


      It looks like the only part that is missing is just the initial handshake between the driver and the device.

      • May 10, 2020
Go to page