Turbosound

Turbosound

Brand

Turbosound

293,847 members
176,890 posts
  • JulienRutyna
    Contributor - Level 1
    2019-06-11

    Bonjour,

    Je possède depuis 1 an 2 ip3000, j'ai deja eu 2 retour de garantie car une colonne s'est arreté d'un coup en pleine soirée. L'ecran reste allumé, les fonctions sont accessible mais aucun son ne sort.
    Aujourd'hui j'ai encore un probleme avec des coupures de son de 2 secondes toutes les 3 minutes sur une colonne.
    Je ne comprend pas cette enorme manque de fiabilité pour une marque comme Turbosound surtout que je fais attention a mes volumes d'entrée , j'ai lu sur les forums que c'est un soucis recurrent sur ce modele. Que puis je faire pour ne plus avoir de soucis car j'aime beaucoup ce modele qd il fonctionne.
    Merci beaucoup

    read more...
    0 160
  • Dae_dalus82
    Contributor - Level 1
    2019-06-10

    I own 2 15 inch siena tsp152-ans.  I was going to buy a pair of 12 in loudspeakers but before i do i was wondering the differences between the siena, nuQ, and athens product lines.  The athens have different dispersion options but other than that i am unsure what their main selling points are.  If i go by frequency response and max spl then the sienas are the best bet.  The other two lines are more expensive and i wonder why that is?  Thanks for any help anyone can provide.

    read more...
    0 275
    • Dae_dalus82
      GaryHiggins

      @Dae_dalus82 I cant speak to all the exact differences but when I looked (at turbosound in general) a while back, some models that had the ultranet port, did not include an ethercon port with it. I know the enclosre on some models differed in materials used and would suspect the speakers and perhaps the on board amps are different in some key ways.

      • June 16, 2019
  • robykock
    Contributor - Level 2
    2019-05-23

    Hi I am helping a customer but not sure the proper mounts to use for the IP300 to hang them or suspend them from wall.  What is best practice for doing this?

    Robert

    [email protected]

    0 142
  • JasonChambers
    Contributor - Level 2
    2019-05-20

    I have 2 IQ15's that are less than a year old and really haven't had much use.

    At Saturday's show one of them after being powered on for about 3 minute and without any load shows "over temp" on the display and stops audio output.

     

    Contacted the point of sale and it's a 4-6 week turnaround for repair, which is very disappointing indeed.

     

    Anyone else had this issue?

    read more...
    0 266
Go to page