Contributor - Level 2

VoiceLive selecting the wrong Preset

I am sending MIDI messages from my Yamaha MOTIF XF8 Workstation Keyboard to a TC Helicon VoiceLive Rack via MIDI during live performances. I am editing my MIDI sequences in Cubase and downloading them to the MOTIF for for each song. When I start the MOTIF's sequencer to begin playing a song,  MIDI messages, ie: i.e.: CC 0 (BankSelect MSB), CC 32 (BankSelect LSB) and CC 115 (Control 115) are sent to the VoiceLive Rack to select the correct Preset for that song.  What I am finding is that in about 1 in 10 songs, the VoiceLive will select the wrong Preset, which can result in difficulty and embarrassment for the singer. Originally I put the MIDI messages for the VoiceLive at the first beat of the first bar of each sequence, but then I started encountering this problem. So, I've been putting the MIDI messages on the second beat of the first bar with no other MIDI events in that bar to see if that would fix it, however the problem still persists. Has anyone got any suggestions as to how I can ensure that the VoiceLive selects the right patch 100% of the time, instead of 90% of the time? I can email a example midi file which contains a typical guide track for the Voicelive as they appear in the MIDI sequences to somebody if that helps.

synthmax Contributor - Level 2 2019-09-04

2019-09-04

VoiceLive selecting the wrong Preset

I am sending MIDI messages from my Yamaha MOTIF XF8 Workstation Keyboard to a TC Helicon VoiceLive Rack via MIDI during live performances. I am editing my MIDI sequences in Cubase and downloading them to the MOTIF for for each song. When I start the MOTIF's sequencer to begin playing a song,  MIDI messages, ie: i.e.: CC 0 (BankSelect MSB), CC 32 (BankSelect LSB) and CC 115 (Control 115) are sent to the VoiceLive Rack to select the correct Preset for that song.  What I am finding is that in about 1 in 10 songs, the VoiceLive will select the wrong Preset, which can result in difficulty and embarrassment for the singer. Originally I put the MIDI messages for the VoiceLive at the first beat of the first bar of each sequence, but then I started encountering this problem. So, I've been putting the MIDI messages on the second beat of the first bar with no other MIDI events in that bar to see if that would fix it, however the problem still persists. Has anyone got any suggestions as to how I can ensure that the VoiceLive selects the right patch 100% of the time, instead of 90% of the time? I can email a example midi file which contains a typical guide track for the Voicelive as they appear in the MIDI sequences to somebody if that helps.

  • 0 Kudos
  • 6 Replies
  • Reply
Triber Moderator

Re: VoiceLive selecting the wrong Preset

Hey @synthmax,
That sounds very bizzare indeed, I haven't heard of this before.  If you could please share the offending MIDI file by uploading it to a Cloud platform (like Dropbox or Google Drive) I'd be happy to try it out with a VoiceLive Rack here and see if it triggers the wrong preset at times.

Testing engineer at TC Helicon, MUSIC Tribe. Our Support Team is always available for more urgent assistance.
Contributor - Level 2

Re: VoiceLive selecting the wrong Preset

Hello there TCH Spencer,

Thanks for getting back to me. Please find above the Dropbox link for the sample file. The problem is very random. You can send this file to the Voicelive thirty times and it will randomly select the incorrect patch once. My lead vocalist thinks it's end of the world. :\  Looking forward to hearing back about this. Many thanks.

 

 

 

 

Triber Moderator

Re: VoiceLive selecting the wrong Preset

Hi again @synthmax,
Thanks for sharing your MIDI file!  I was able to import that into Reaper and send it to a VoiceLive Rack via 5-pin MIDI out of my interface.  This is an article I wrote a while ago about changes presets via MIDI on VoiceLive 3, and the same info applies to the VoiceLive Rack, so this is what I'm basing my preset-changing knowledge on.  I inspected your file and it all looks correct to me, sending CC 32 to select your bank, a Program Change to specify a preset, and CC 115 to specify the Step of that preset.  I automated your provided MIDI commands a few dozen times and it always selected preset 259 without fail for me... So I still want to refrain from taking the easy way out and blaming the Motif but I will say I wasn't able to recreate your issue with that file here in my setup.  Is it possible for you to further debug the Motif though by plugging its MIDI output into an interface and monitoring its messages on a computer?  If you use an app like MIDI-OX you can monitor your keyboard's output and know for sure that it's consistently sending the same messages every time.

I also forgot to ask which firmware build your VoiceLive Rack is running?  When you boot it up the splash screen will show you "Build __". I'm currently on build 26 which is the latest firmware.

Testing engineer at TC Helicon, MUSIC Tribe. Our Support Team is always available for more urgent assistance.
Contributor - Level 2

VoiceLive selecting the wrong Preset

Hello there TCH-Spencer,

Thanks for getting back to me about this issue. Yeah, I thought my MIDI files are o.k. too. 

Unfortunately there is no build of MIDI-OX for MacOS available. I tried to monitor the MIDI output from the MOTIF on my Mac using MidiPipe, but I wasn’t able to see any messages coming through. This could be something to do with the software configuration of my Mac or the Steinberg UR22mkII that I had the MIDI out plugged into. Either way, I don’t want to spend any more time on that as I am confident that the MOTIF is transmitting the MIDI messages o.k.

I can confirm my Voicelive is running Build Version 1.0.09 Build 26.

Could the problem be that the software or firmware on the VoiceLive is corrupt? Is there a way of reinstalling the firmware? Should I try a Global Reset?

The other thing that I thought might be worth a try is using a brand new MIDI cable between the MOTIF and the VoiceLive. I will give that a shot.

I would appreciate any further thoughts you might have on this matter and my ideas on how to fix this issue.

Best,
Grant

Triber Moderator

Re: VoiceLive selecting the wrong Preset

It's possible the firmware is corrupt, but very unlikely that the only indication of this would be in changing presets.  If it were corrupt you'd likely see issues all over the place, changing parameters, audio glitches, sometimes not even booting properly.  But yeah it's worth a global reset, at the very least to rule out corruption.  Be sure to back up your presets in VoiceSupport 2 first, then go ahead and perform a factory reset:

Power up the unit, then when the first text is displayed on screen, hold "µMod", "Delay", "Reverb", and "Tone". Continue to hold until the reset prompt is displayed.

Then after the reset you can connected it to VoiceSupport again, you might need to re-update your firmware to 26, and of course load your backed up presets back onto the unit.  Good luck!

Testing engineer at TC Helicon, MUSIC Tribe. Our Support Team is always available for more urgent assistance.
Highlighted
Rising Star - Level 2

Re: VoiceLive selecting the wrong Preset

@synthmax 

FYI.  MIDIMonitor is a good open source MIDI monitor for MacOS